]> git.pld-linux.org Git - packages/xpra.git/commitdiff
handle $CC with spaces
authorElan Ruusamäe <glen@delfi.ee>
Mon, 30 Dec 2013 20:32:48 +0000 (22:32 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 30 Dec 2013 20:32:48 +0000 (22:32 +0200)
setup-cc-ccache.patch [new file with mode: 0644]
xpra.spec

diff --git a/setup-cc-ccache.patch b/setup-cc-ccache.patch
new file mode 100644 (file)
index 0000000..7c9c0df
--- /dev/null
@@ -0,0 +1,15 @@
+allow spaces in $CC env
+
+inspired from https://codereview.chromium.org/14813020/
+--- xpra-0.10.10/setup.py~     2013-12-19 11:14:12.000000000 +0200
++++ xpra-0.10.10/setup.py      2013-12-30 20:14:28.220987556 +0200
+@@ -284,7 +284,8 @@
+ def get_gcc_version():
+     global GCC_VERSION
+     if len(GCC_VERSION)==0:
+-        cmd = [os.environ.get("CC", "gcc"), "-v"]
++        cc = os.environ.get('CC', 'gcc').split()
++        cmd = cc + ['-v']
+         proc = subprocess.Popen(cmd, stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.STDOUT)
+         output, _ = proc.communicate()
+         status = proc.wait()
index 7de91328f0ebc49c44506e3078ce5efb367326a3..aa3a2850ec12adec68333f1392eee78885c54960 100644 (file)
--- a/xpra.spec
+++ b/xpra.spec
@@ -23,6 +23,7 @@ License:      GPL v2+
 Group:         X11/Applications/Networking
 Source0:       http://xpra.org/src/%{name}-%{version}.tar.xz
 # Source0-md5: deb60252055062214f558155efc3714a
+Patch0:                setup-cc-ccache.patch
 URL:           http://xpra.org/
 BuildRequires: OpenGL-devel
 BuildRequires: ffmpeg-devel
@@ -75,6 +76,7 @@ W uproszczeniu xpra to "screen" dla zdalnych aplikacji X-owych.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 CC="%{__cc}" \
This page took 0.164975 seconds and 4 git commands to generate.