]> git.pld-linux.org Git - packages/xorg-xserver-server.git/commitdiff
- fix mouse stuck on primary display with separate X screens regression auto/th/xorg-xserver-server-1.13.0-2
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 24 Oct 2012 11:37:33 +0000 (13:37 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 24 Oct 2012 11:37:33 +0000 (13:37 +0200)
- rel 2

0001-dix-fix-zaphod-screen-scrossing-54654.patch [new file with mode: 0644]
xorg-xserver-server.spec

diff --git a/0001-dix-fix-zaphod-screen-scrossing-54654.patch b/0001-dix-fix-zaphod-screen-scrossing-54654.patch
new file mode 100644 (file)
index 0000000..e3e42d4
--- /dev/null
@@ -0,0 +1,42 @@
+From 29d84d5a7ca4cc12cce47de9313adeb8554fb894 Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Thu, 18 Oct 2012 15:11:31 +1000
+Subject: [PATCH] dix: fix zaphod screen scrossing (#54654)
+
+POINTER_SCREEN coordinates are screen-relative. For a Zaphod setup, the
+coordinates after a screen crossing are already relative to the new screen's
+origin. Add that offset to the coordinates before re-setting.
+
+regression introduced by
+commit bafbd99080be49a17be97d2cc758fbe623369945
+Author: Peter Hutterer <peter.hutterer@who-t.net>
+Date:   Wed Aug 8 11:34:32 2012 +1000
+
+    dix: work around scaling issues during WarpPointer (#53037)
+
+X.Org Bug 54654 <http://bugs.freedesktop.org/show_bug.cgi?id=54654>
+
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+ dix/getevents.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/dix/getevents.c b/dix/getevents.c
+index 71d83c4..8b4379d 100644
+--- a/dix/getevents.c
++++ b/dix/getevents.c
+@@ -1400,8 +1400,9 @@ fill_pointer_events(InternalEvent *events, DeviceIntPtr pDev, int type,
+        coordinates were.
+      */
+     if (flags & POINTER_SCREEN) {
+-        screenx = sx;
+-        screeny = sy;
++        scr = miPointerGetScreen(pDev);
++        screenx = sx + scr->x;
++        screeny = sy + scr->y;
+     }
+     scr = positionSprite(pDev, (flags & POINTER_ABSOLUTE) ? Absolute : Relative,
+-- 
+1.7.11.7
+
index c783b2cebad8365c9e3c1a249256c574b94b578c..69a211d96b177f52ae8b91e3bb9dfb1fee07b90a 100644 (file)
@@ -24,7 +24,7 @@ Summary:      X.org server
 Summary(pl.UTF-8):     Serwer X.org
 Name:          xorg-xserver-server
 Version:       1.13.0
-Release:       1
+Release:       2
 License:       MIT
 Group:         X11/Servers
 Source0:       http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
@@ -41,6 +41,8 @@ Patch4:               %{name}-builtin-SHA1.patch
 Patch5:                %{name}-export-GetMaster.patch
 Patch6:                110_nvidia_slowdow_fix.patch
 Patch7:                %{name}-include-defs.patch
+# https://bugs.freedesktop.org/show_bug.cgi?id=54654
+Patch8:                0001-dix-fix-zaphod-screen-scrossing-54654.patch
 URL:           http://xorg.freedesktop.org/
 BuildRequires: Mesa-libGL-devel >= 7.8.1
 # for glx headers
@@ -365,6 +367,8 @@ Biblioteka rozszerzenia GLX dla serwera X.org.
 #unfortunately breaks build
 #patch7 -p1
 
+%patch8 -p1
+
 # xserver uses pixman-1 API/ABI so put that explictly here
 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
 
This page took 0.150199 seconds and 4 git commands to generate.