]> git.pld-linux.org Git - packages/xorg-xserver-server.git/commitdiff
- up to 1.14.0 auto/th/xorg-xserver-server-1.14.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 6 Mar 2013 19:38:25 +0000 (20:38 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 6 Mar 2013 19:38:25 +0000 (20:38 +0100)
xorg-xserver-server-builtin-SHA1.patch
xorg-xserver-server.spec

index 1baf8aaec0259f5b37afd62be1ecb08ea32fc455..ae3ae74d553466a34c2de240ad532391f075bcae 100644 (file)
@@ -52,7 +52,7 @@ diff --git a/include/dix-config.h.in b/include/dix-config.h.in
 index 058c8fd..d6e99a5 100644
 --- a/include/dix-config.h.in
 +++ b/include/dix-config.h.in
-@@ -142,24 +142,6 @@
+@@ -142,27 +142,6 @@
  /* Define to 1 if you have the <rpcsvc/dbm.h> header file. */
  #undef HAVE_RPCSVC_DBM_H
  
@@ -71,6 +71,9 @@ index 058c8fd..d6e99a5 100644
 -/* Define to use libgcrypt SHA1 functions */
 -#undef HAVE_SHA1_IN_LIBGCRYPT
 -
+-/* Define to use libnettle SHA1 functions */
+-#undef HAVE_SHA1_IN_LIBNETTLE
+-
 -/* Define to use libsha1 for SHA1 */
 -#undef HAVE_SHA1_IN_LIBSHA1
 -
@@ -91,7 +94,7 @@ index 66a4a0f..b8c1636 100644
        $(XORG_SRCS)
 --- a/os/xsha1.c       2012-03-30 04:57:28.000000000 +0200
 +++ /dev/null  2011-06-01 08:46:43.490033582 +0200
-@@ -1,237 +0,0 @@
+@@ -1,267 +0,0 @@
 -#ifdef HAVE_DIX_CONFIG_H
 -#include <dix-config.h>
 -#endif
@@ -210,6 +213,36 @@ index 66a4a0f..b8c1636 100644
 -    return 1;
 -}
 -
+-#elif defined(HAVE_SHA1_IN_LIBNETTLE)   /* Use libnettle for SHA1 */
+-
+-#include <nettle/sha.h>
+-
+-void *
+-x_sha1_init(void)
+-{
+-    struct sha1_ctx *ctx = malloc(sizeof(*ctx));
+-
+-    if (!ctx)
+-        return NULL;
+-    sha1_init(ctx);
+-    return ctx;
+-}
+-
+-int
+-x_sha1_update(void *ctx, void *data, int size)
+-{
+-    sha1_update(ctx, size, data);
+-    return 1;
+-}
+-
+-int
+-x_sha1_final(void *ctx, unsigned char result[20])
+-{
+-    sha1_digest(ctx, 20, result);
+-    free(ctx);
+-    return 1;
+-}
+-
 -#elif defined(HAVE_SHA1_IN_LIBGCRYPT)   /* Use libgcrypt for SHA1 */
 -
 -#include <gcrypt.h>
@@ -648,13 +681,13 @@ index 0000000..ace7d97
  else
    DIX_LIB='$(top_builddir)/dix/libdix.la'
    OS_LIB='$(top_builddir)/os/libos.la'
-@@ -1358,112 +1358,6 @@
+@@ -1358,124 +1358,6 @@
  MIEXT_SYNC_LIB='$(top_builddir)/miext/sync/libsync.la'
  CORE_INCS='-I$(top_srcdir)/include -I$(top_builddir)/include'
  
 -# SHA1 hashing
 -AC_ARG_WITH([sha1],
--            [AS_HELP_STRING([--with-sha1=libc|libmd|libgcrypt|libcrypto|libsha1|CommonCrypto|CryptoAPI],
+-            [AS_HELP_STRING([--with-sha1=libc|libmd|libnettle|libgcrypt|libcrypto|libsha1|CommonCrypto|CryptoAPI],
 -                            [choose SHA1 implementation])])
 -AC_CHECK_FUNC([SHA1Init], [HAVE_SHA1_IN_LIBC=yes])
 -if test "x$with_sha1" = x && test "x$HAVE_SHA1_IN_LIBC" = xyes; then
@@ -717,6 +750,18 @@ index 0000000..ace7d97
 -                [Use libsha1 for SHA1])
 -      SHA1_LIBS=-lsha1
 -fi
+-AC_CHECK_LIB([nettle], [nettle_sha1_init], [HAVE_LIBNETTLE=yes])
+-if test "x$with_sha1" = x && test "x$HAVE_LIBNETTLE" = xyes; then
+-      with_sha1=libnettle
+-fi
+-if test "x$with_sha1" = xlibnettle && test "x$HAVE_LIBNETTLE" != xyes; then
+-      AC_MSG_ERROR([libnettle requested but not found])
+-fi
+-if test "x$with_sha1" = xlibnettle; then
+-      AC_DEFINE([HAVE_SHA1_IN_LIBNETTLE], [1],
+-                [Use libnettle SHA1 functions])
+-      SHA1_LIBS=-lnettle
+-fi
 -AC_CHECK_LIB([gcrypt], [gcry_md_open], [HAVE_LIBGCRYPT=yes])
 -if test "x$with_sha1" = x && test "x$HAVE_LIBGCRYPT" = xyes; then
 -      with_sha1=libgcrypt
index a473cc6433559e07d1336929675a1dc967afc247..8eae2599b8c776397501e995751eb5119cf0b996 100644 (file)
 %define        xorg_xserver_server_ansic_abi           0.4
 %define        xorg_xserver_server_extension_abi       7.0
 %define        xorg_xserver_server_font_abi            0.6
-%define        xorg_xserver_server_videodrv_abi        13.1
-%define        xorg_xserver_server_xinput_abi          18.0
+%define        xorg_xserver_server_videodrv_abi        14.1
+%define        xorg_xserver_server_xinput_abi          19.1
 #
 %define        pixman_ver      0.28.0
 
 Summary:       X.org server
 Summary(pl.UTF-8):     Serwer X.org
 Name:          xorg-xserver-server
-Version:       1.13.2
+Version:       1.14.0
 Release:       1
 License:       MIT
 Group:         X11/Servers
 Source0:       http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
-# Source0-md5: 553fd7902e1156115f15cc1656f46a6f
+# Source0-md5: 86110278b784e279381b7f6f2295c508
 Source1:       10-quirks.conf
 Source2:       xserver.pamd
 Source10:      %{name}-Xvfb.init
@@ -100,7 +100,7 @@ BuildRequires:      xorg-proto-fixesproto-devel >= 5.0
 BuildRequires: xorg-proto-fontcacheproto-devel
 BuildRequires: xorg-proto-fontsproto-devel
 BuildRequires: xorg-proto-glproto-devel >= 1.4.16
-BuildRequires: xorg-proto-inputproto-devel >= 2.2
+BuildRequires: xorg-proto-inputproto-devel >= 2.2.99.1
 BuildRequires: xorg-proto-kbproto-devel >= 1.0.3
 BuildRequires: xorg-proto-printproto-devel
 BuildRequires: xorg-proto-randrproto-devel >= 1.4.0
This page took 0.079802 seconds and 4 git commands to generate.