]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- up to 1.16.2
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 # - upstream --enable-suid-wrapper vs Xwrapper patch?
5 #
6 # Conditional build:
7 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
8 %bcond_with     hal             # HAL support for configuration (if no udev)
9 %bcond_without  udev            # UDEV support for configuration
10 %bcond_without  dri2            # DRI2 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_without  glamor          # glamor dix module
18 %bcond_without  systemtap       # systemtap/dtrace probes
19 #
20 # ABI versions, see hw/xfree86/common/xf86Module.h
21 %define xorg_xserver_server_ansic_abi           0.4
22 %define xorg_xserver_server_extension_abi       8.0
23 %define xorg_xserver_server_font_abi            0.6
24 %define xorg_xserver_server_videodrv_abi        18.0
25 %define xorg_xserver_server_xinput_abi          21.0
26
27 %define pixman_ver      0.30.0
28
29 Summary:        X.org server
30 Summary(pl.UTF-8):      Serwer X.org
31 Name:           xorg-xserver-server
32 Version:        1.16.2
33 Release:        1
34 License:        MIT
35 Group:          X11/Servers
36 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
37 # Source0-md5:  89620960b13515db8d0a8dbb92a1378a
38 Source1:        10-quirks.conf
39 Source2:        xserver.pamd
40 Source10:       %{name}-Xvfb.init
41 Source11:       %{name}-Xvfb.sysconfig
42 Source12:       xvfb-run.sh
43
44 Patch0:         %{name}-xwrapper.patch
45 Patch1:         %{name}-pic-libxf86config.patch
46
47 Patch4:         %{name}-builtin-SHA1.patch
48 Patch5:         %{name}-export-GetMaster.patch
49 Patch6:         110_nvidia_slowdow_fix.patch
50 Patch7:         %{name}-include-defs.patch
51 URL:            http://xorg.freedesktop.org/
52 BuildRequires:  Mesa-libGL-devel >= 7.8.1
53 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
54 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
55 # for glx headers
56 BuildRequires:  OpenGL-GLX-devel
57 %{?with_xselinux:BuildRequires: audit-libs-devel}
58 BuildRequires:  autoconf >= 2.60
59 BuildRequires:  automake
60 BuildRequires:  cpp
61 BuildRequires:  docbook-dtd43-xml
62 #BuildRequires: doxygen >= 1.6.1
63 %if %{with hal} || %{with dbus}
64 BuildRequires:  dbus-devel >= 1.0
65 %endif
66 %{?with_hal:BuildRequires:      hal-devel}
67 BuildRequires:  libdrm-devel >= 2.4.39
68 %if %{with glamor} || %{with wayland}
69 BuildRequires:  libepoxy-devel
70 %endif
71 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
72 BuildRequires:  libtool >= 2:2.2
73 BuildRequires:  libunwind-devel
74 BuildRequires:  libxcb-devel >= 1.6
75 BuildRequires:  pam-devel
76 BuildRequires:  perl-base
77 BuildRequires:  pixman-devel >= %{pixman_ver}
78 BuildRequires:  pkgconfig >= 1:0.19
79 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
80 BuildRequires:  udev-devel >= 1:143
81 # wayland-client
82 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
83 BuildRequires:  xcb-util-devel
84 BuildRequires:  xcb-util-image-devel
85 BuildRequires:  xcb-util-keysyms-devel
86 BuildRequires:  xcb-util-wm-devel
87 BuildRequires:  xmlto >= 0.0.20
88 BuildRequires:  xorg-app-mkfontscale
89 BuildRequires:  xorg-font-font-util >= 1.1
90 BuildRequires:  xorg-lib-libX11-devel >= 1.6
91 BuildRequires:  xorg-lib-libXau-devel
92 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
93 BuildRequires:  xorg-lib-libXdamage-devel
94 BuildRequires:  xorg-lib-libXdmcp-devel
95 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
96 BuildRequires:  xorg-lib-libXfixes-devel
97 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
98 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
99 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
100 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
101 BuildRequires:  xorg-lib-libXrender-devel
102 BuildRequires:  xorg-lib-libXres-devel
103 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
104 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
105 BuildRequires:  xorg-lib-libXv-devel
106 BuildRequires:  xorg-lib-libXxf86dga-devel
107 BuildRequires:  xorg-lib-libXxf86misc-devel
108 BuildRequires:  xorg-lib-libXxf86vm-devel
109 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
110 BuildRequires:  xorg-lib-libfontenc-devel
111 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
112 BuildRequires:  xorg-lib-libxkbfile-devel
113 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
114 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.3
115 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
116 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
117 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
118 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
119 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
120 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
121 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
122 BuildRequires:  xorg-proto-fontcacheproto-devel
123 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
124 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
125 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
126 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
127 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
128 BuildRequires:  xorg-proto-printproto-devel
129 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
130 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
131 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
132 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
133 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
134 BuildRequires:  xorg-proto-videoproto-devel
135 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
136 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
137 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
138 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
139 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
140 BuildRequires:  xorg-proto-xf86miscproto-devel
141 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
142 BuildRequires:  xorg-proto-xineramaproto-devel
143 BuildRequires:  xorg-proto-xproto-devel >= 7.0.26
144 BuildRequires:  xorg-sgml-doctools >= 1.8
145 BuildRequires:  xorg-util-util-macros >= 1.14
146 #BR: tslib (for KDRIVE only)
147 Requires(triggerpostun):        sed >= 4.0
148 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
149 Requires:       libdrm >= 2.4.39
150 Requires:       pixman >= %{pixman_ver}
151 Requires:       udev-libs >= 1:143
152 Requires:       xkeyboard-config
153 # for rgb.txt
154 Requires:       xorg-app-rgb >= 0.99.3
155 Requires:       xorg-app-xkbcomp
156 # xserver requires fixed and cursor fonts
157 Requires:       xorg-font-font-alias
158 Requires:       xorg-font-font-cursor-misc
159 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
160 Requires:       xorg-lib-libXfont >= 1.4.2
161 Requires:       xorg-lib-libpciaccess >= 0.12.901
162 Requires:       xorg-lib-libxshmfence >= 1.1
163 Suggests:       dbus-x11 >= 1.0
164 %{?with_hal:Suggests:   hal}
165 Suggests:       udev-acl >= 1:143
166 %{?with_udev:Suggests:  udev-core >= 1:143}
167 Suggests:       xkeyboard-config
168 Suggests:       xorg-driver-input-evdev
169 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
170 Suggests:       xorg-driver-video
171 Provides:       xorg-xserver-libdri = %{version}-%{release}
172 Provides:       xorg-xserver-module(dri)
173 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
174 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
175 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
176 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
177 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
178 Obsoletes:      X11-Xserver < 1:7.0.0
179 Obsoletes:      X11-driver-i2c < 1:7.0.0
180 Obsoletes:      X11-modules < 1:7.0.0
181 Obsoletes:      X11-setup < 1:7.0.0
182 Obsoletes:      XFree86-Xserver < 1:7.0.0
183 Obsoletes:      XFree86-modules < 1:7.0.0
184 Obsoletes:      XFree86-setup < 1:7.0.0
185 Obsoletes:      Xserver
186 %{?with_glamor:Obsoletes:       glamor}
187 Obsoletes:      xorg-xserver-libdri
188 Obsoletes:      xorg-xserver-server-xorgcfg
189 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
190
191 # avoid self-dependencies on included modules
192 %define         _noautoreq      libscanpci.so libxf1bpp.so
193
194 %description
195 Xorg server is a generally used X server which uses display hardware.
196 It requires proper driver for your display hardware.
197
198 %description -l pl.UTF-8
199 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
200 graficznej. Do działania wymaga odpowiedniego sterownika.
201
202 %package -n xorg-xserver-Xdmx
203 Summary:        Xdmx - distributed multi-head X server
204 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
205 Group:          X11/Servers
206 Requires:       pixman >= %{pixman_ver}
207 Requires:       xorg-lib-libX11 >= 1.6
208 Requires:       xorg-lib-libXext >= 1.0.99.4
209 Requires:       xorg-lib-libXfont >= 1.4.2
210 Requires:       xorg-lib-libXi >= 1.2.99.1
211 Requires:       xorg-lib-libdmx >= 1.0.99.1
212
213 %description -n xorg-xserver-Xdmx
214 Xdmx - distributed multi-head X server.
215
216 %description -n xorg-xserver-Xdmx -l pl.UTF-8
217 Xdmx - rozproszony, wielomonitorowy serwer X.
218
219 %package -n xorg-xserver-Xnest
220 Summary:        Xnest - nested X server
221 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
222 Group:          X11/Servers
223 Requires:       pixman >= %{pixman_ver}
224 Requires:       xorg-lib-libXext >= 1.0.99.4
225 Requires:       xorg-lib-libXfont >= 1.4.2
226 Obsoletes:      X11-Xnest < 1:7.0.0
227 Obsoletes:      XFree86-Xnest < 1:7.0.0
228 Obsoletes:      Xserver-Xnest
229
230 %description -n xorg-xserver-Xnest
231 Xnest is an X Window System server which runs in an X window. Xnest is
232 a 'nested' window server, actually a client of the real X server,
233 which manages windows and graphics requests for Xnest, while Xnest
234 manages the windows and graphics requests for its own clients.
235
236 %description -n xorg-xserver-Xnest -l pl.UTF-8
237 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
238 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
239 serwer X dla własnych klientów.
240
241 %description -n xorg-xserver-Xnest -l ru.UTF-8
242 Xnest - это сервер X Window System, который работает в окне X. На
243 самом деле это клиент реального X-сервера, который управляет окнами и
244 графическими запросами для Xnest в то время, как Xnest управляет
245 окнами и графическими запросами для своих собственных клиентов.
246
247 %description -n xorg-xserver-Xnest -l uk.UTF-8
248 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
249 клієнт реального X-сервера, який керує вікнами та графічними запитами
250 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
251 своїх власних клієнтів.
252
253 %package -n xorg-xserver-Xephyr
254 Summary:        Xephyr - nested X server
255 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
256 Group:          X11/Servers
257 Requires:       Mesa-libGL >= 7.1.0
258 Requires:       libxcb >= 1.6
259 Requires:       pixman >= %{pixman_ver}
260 Requires:       xorg-lib-libXfont >= 1.4.2
261
262 %description -n xorg-xserver-Xephyr
263 Xephyr is a kdrive server that outputs to a window on a pre-existing
264 'host' X display. Think Xnest but with support for modern extensions
265 like composite, damage and randr.
266
267 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
268 the host X server, Xephyr is a real X server which uses the host X
269 server window as "framebuffer" via fast SHM XImages.
270
271 It also has support for 'visually' debugging what the server is
272 painting.
273
274 %description -n xorg-xserver-Xephyr -l pl.UTF-8
275 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
276 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
277 wspólczesnych rozszerzeń jak composite, damage i randr.
278
279 %package -n xorg-xserver-Xfbdev
280 Summary:        Xfbdev - Linux framebuffer device X server
281 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
282 Group:          X11/Servers
283 Requires:       pixman >= %{pixman_ver}
284 Requires:       xorg-lib-libXfont >= 1.4.2
285
286 %description -n xorg-xserver-Xfbdev
287 Xfbdev is a Linux framebuffer device X server based on the kdrive X
288 server.
289
290 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
291 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
292
293 %package -n xorg-xserver-Xvfb
294 Summary:        Xvfb - virtual framebuffer X server
295 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
296 Group:          X11/Servers
297 Requires:       Mesa-libGL >= 7.1.0
298 Requires:       mktemp
299 Requires:       pixman >= %{pixman_ver}
300 Requires:       util-linux
301 Requires:       which
302 Requires:       xkeyboard-config
303 Requires:       xorg-app-xauth
304 Requires:       xorg-app-xkbcomp
305 # requires fixed and cursor fonts
306 Requires:       xorg-font-font-alias
307 Requires:       xorg-font-font-cursor-misc
308 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
309 Requires:       xorg-lib-libXfont >= 1.4.2
310 Obsoletes:      X11-Xvfb < 1:7.0.0
311 Obsoletes:      XFree86-Xvfb < 1:7.0.0
312
313 %description -n xorg-xserver-Xvfb
314 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
315 capable of running on machines with no display hardware and no
316 physical input devices. Xvfb emulates a dumb framebuffer using virtual
317 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
318 display. Xvfb is normally used for testing servers. Using Xvfb, the
319 mfb or cfb code for any depth can be exercised without using real
320 hardware that supports the desired depths. Xvfb has also been used to
321 test X clients against unusual depths and screen configurations, to do
322 batch processing with Xvfb as a background rendering engine, to do
323 load testing, to help with porting an X server to a new platform, and
324 to provide an unobtrusive way of running applications which really
325 don't need an X server but insist on having one.
326
327 %description -n xorg-xserver-Xvfb -l pl.UTF-8
328 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
329 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
330 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
331 używany do testowania serwerów X, może też być używany do testowania
332 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
333 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
334 serwera X, ale odmawiają uruchomienia bez niego.
335
336 %package -n xorg-xserver-Xvfb-init
337 Summary:        Init scripts for Xvfb
338 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
339 Group:          X11/Servers
340 Requires:       xorg-xserver-Xvfb
341
342 %description -n xorg-xserver-Xvfb-init
343 This package contains init scripts for Xvfb and registers Xvfb as
344 system service.
345
346 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
347 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
348 usługę systemową.
349
350 %package -n xorg-xserver-Xwayland
351 Summary:        Xwayland - X server integrated into a Wayland window system
352 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
353 Group:          X11/Servers
354 Requires:       pixman >= %{pixman_ver}
355 Requires:       xorg-lib-libX11 >= 1.6
356 Requires:       xorg-lib-libXext >= 1.0.99.4
357 Requires:       xorg-lib-libXfont >= 1.4.2
358 Requires:       xorg-lib-libXi >= 1.2.99.1
359
360 %description -n xorg-xserver-Xwayland
361 Xwayland - server integrated into a Wayland window system.
362
363 %description -n xorg-xserver-Xwayland -l pl.UTF-8
364 Xwayland - serwer X integrowalny w Wayland.
365
366 %package devel
367 Summary:        Header files for X.org server
368 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
369 Group:          X11/Development/Libraries
370 Requires:       Mesa-libGL-devel >= 7.8.0
371 Requires:       libdrm-devel >= 2.4.39
372 Requires:       pixman-devel >= %{pixman_ver}
373 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
374 Requires:       xorg-lib-libxkbfile-devel
375 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
376 Requires:       xorg-proto-dri3proto-devel >= 1.0
377 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
378 Requires:       xorg-proto-glproto-devel >= 1.4.17
379 Requires:       xorg-proto-inputproto-devel >= 2.3
380 Requires:       xorg-proto-kbproto-devel >= 1.0.3
381 Requires:       xorg-proto-presentproto-devel >= 1.0
382 Requires:       xorg-proto-randrproto-devel >= 1.4.0
383 Requires:       xorg-proto-renderproto-devel >= 0.11
384 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
385 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
386 Requires:       xorg-proto-videoproto-devel
387 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
388 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
389 Requires:       xorg-proto-xineramaproto-devel
390 Requires:       xorg-proto-xproto-devel >= 7.0.26
391 Obsoletes:      X11-Xserver-devel < 1:7.0.0
392 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
393 %{?with_glamor:Obsoletes:       glamor-devel}
394
395 %description devel
396 Header files for X.org server.
397
398 %description devel -l pl.UTF-8
399 Pliki nagłówkowe dla serwera X.org.
400
401 %package source
402 Summary:        X.org server source code
403 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
404 Group:          X11/Development/Libraries
405
406 %description source
407 X.org server source code.
408
409 %description source -l pl.UTF-8
410 Pliki źródłowe dla serwera X.org.
411
412 %package -n xorg-xserver-libglx
413 Summary:        GLX extension library for X.org server
414 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
415 Group:          X11/Servers
416 Requires:       %{name} = %{version}-%{release}
417 Requires:       Mesa-libGL >= 7.1.0
418 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
419 # Mesa version glapi tables in glx/ dir come from
420 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
421 Provides:       xorg-xserver-module(glx)
422 Obsoletes:      X11-OpenGL-core < 1:7.0.0
423 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
424
425 %description -n xorg-xserver-libglx
426 GLX extension library for X.org server.
427
428 %description -n xorg-xserver-libglx -l pl.UTF-8
429 Biblioteka rozszerzenia GLX dla serwera X.org.
430
431 %prep
432 %setup -q -n xorg-server-%{version}
433 %patch0 -p0
434 %patch1 -p1
435
436 %patch4 -p1
437 %patch5 -p1
438 %patch6 -p1
439
440 #unfortunately breaks build
441 #patch7 -p1
442
443 # xserver uses pixman-1 API/ABI so put that explictly here
444 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
445
446 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
447 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
448
449 %build
450 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
451 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
452         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
453         exit 1
454 fi
455
456 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
457 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
458         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
459         exit 1
460 fi
461
462 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
463 if [ $API != %{xorg_xserver_server_font_abi} ]; then
464         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
465         exit 1
466 fi
467 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
468 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
469         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
470         exit 1
471 fi
472 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
473 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
474         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
475         exit 1
476 fi
477
478 %{__libtoolize}
479 %{__aclocal} -I m4
480 %{__autoconf}
481 %{__autoheader}
482 %{__automake}
483 %configure \
484         --with-os-name="PLD/Linux" \
485         --with-os-vendor="PLD/Team" \
486         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
487         --with-xkb-output=/var/lib/xkb \
488         --disable-linux-acpi \
489         --disable-linux-apm \
490         --enable-aiglx \
491         %{?with_dbus:--enable-config-dbus} \
492         --enable-config-hal%{!?with_hal:=no} \
493         --enable-config-udev%{!?with_udev:=no} \
494         --enable-dga \
495         %{?with_dmx:--enable-dmx} \
496         --enable-dri2%{!?with_dri2:=no} \
497         %{?with_glamor:--enable-glamor} \
498         --enable-glx-tls \
499         --enable-install-libxf86config \
500         --enable-kdrive \
501         --enable-libunwind \
502         %{?with_record:--enable-record} \
503         --enable-secure-rpc \
504         %{?with_xcsecurity:--enable-xcsecurity} \
505         --enable-xephyr \
506         %{?with_xf86bigfont:--enable-xf86bigfont} \
507         --disable-xfake \
508         --enable-xfbdev \
509         %{?with_xselinux:--enable-xselinux} \
510         %{?with_wayland:--enable-xwayland} \
511         %{!?with_systemtap:--without-dtrace} \
512         --without-fop \
513         --with-systemd-daemon
514
515 %{__make}
516
517 %install
518 rm -rf $RPM_BUILD_ROOT
519
520 %if "%{_libdir}" != "%{_exec_prefix}/lib"
521 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
522 %endif
523
524 %{__make} install \
525         DESTDIR=$RPM_BUILD_ROOT
526
527 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
528 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
529 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
530 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
531 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
532
533 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
534 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
535
536 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
537
538 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
539
540 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
541 install -d $RPM_BUILD_ROOT/etc/sysconfig
542 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
543 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
544
545 # prepare source package
546 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
547 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
548 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
549 %{__make} distclean
550 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
551 find -name '*.h' | xargs chmod a-x
552
553 %if %{with systemtap}
554 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
555 %endif
556
557 %clean
558 rm -rf $RPM_BUILD_ROOT
559
560 %triggerpostun -- xorg-xserver-server < 1.5.0
561 if [ -f /etc/X11/xorg.conf ]; then
562         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
563         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
564 %if %{without record}
565         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
566 %endif
567         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
568 fi
569
570 %post -n xorg-xserver-Xvfb-init
571 /sbin/chkconfig --add Xvfb
572 %service Xvfb restart
573
574 %preun -n xorg-xserver-Xvfb-init
575 if [ "$1" = "0" ]; then
576         %service -q Xvfb stop
577         /sbin/chkconfig --del Xvfb
578 fi
579
580 %files
581 %defattr(644,root,root,755)
582 %doc COPYING ChangeLog README
583 %attr(755,root,root) %{_bindir}/X
584 %attr(755,root,root) %{_bindir}/Xorg
585 %attr(4755,root,root) %{_bindir}/Xwrapper
586 %attr(755,root,root) %{_bindir}/cvt
587 %attr(755,root,root) %{_bindir}/gtf
588 %dir %{_libdir}/xorg
589 %{_libdir}/xorg/protocol.txt
590 %dir %{_libdir}/xorg/modules
591 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
592 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
593 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
594 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
595 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
596 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
597 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
598 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
599 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
600 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
601 %dir %{_libdir}/xorg/modules/dri
602 %dir %{_libdir}/xorg/modules/drivers
603 %dir %{_libdir}/xorg/modules/extensions
604 %dir %{_libdir}/xorg/modules/input
605 %dir %{_libdir}/xorg/modules/multimedia
606 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/bt829_drv.so
607 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/fi1236_drv.so
608 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/msp3430_drv.so
609 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/tda8425_drv.so
610 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/tda9850_drv.so
611 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/tda9885_drv.so
612 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/uda1380_drv.so
613 %if "%{_libdir}" != "%{_exec_prefix}/lib"
614 %dir %{_exec_prefix}/lib/xorg
615 %dir %{_exec_prefix}/lib/xorg/modules
616 %dir %{_exec_prefix}/lib/xorg/modules/dri
617 %endif
618 %dir /var/lib/xkb
619 /var/lib/xkb/README.compiled
620 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
621 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
622 %config(missingok) /etc/security/console.apps/xserver
623 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
624 %dir /etc/X11/xorg.conf.d
625 %dir %{_datadir}/X11/xorg.conf.d
626 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
627 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-evdev.conf
628 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
629 %{_mandir}/man1/Xorg.1*
630 %{_mandir}/man1/Xserver.1*
631 %{_mandir}/man1/cvt.1*
632 %{_mandir}/man1/gtf.1*
633 %{_mandir}/man4/exa.4*
634 %{_mandir}/man4/fbdevhw.4*
635 %{_mandir}/man5/xorg.conf.5*
636 %{_mandir}/man5/xorg.conf.d.5*
637
638 %if %{with dmx}
639 %files -n xorg-xserver-Xdmx
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_bindir}/Xdmx
642 %attr(755,root,root) %{_bindir}/dmxaddinput
643 %attr(755,root,root) %{_bindir}/dmxaddscreen
644 %attr(755,root,root) %{_bindir}/dmxinfo
645 %attr(755,root,root) %{_bindir}/dmxreconfig
646 %attr(755,root,root) %{_bindir}/dmxresize
647 %attr(755,root,root) %{_bindir}/dmxrminput
648 %attr(755,root,root) %{_bindir}/dmxrmscreen
649 %attr(755,root,root) %{_bindir}/dmxtodmx
650 %attr(755,root,root) %{_bindir}/dmxwininfo
651 %attr(755,root,root) %{_bindir}/vdltodmx
652 %attr(755,root,root) %{_bindir}/xdmxconfig
653 %{_mandir}/man1/Xdmx.1*
654 %{_mandir}/man1/dmxtodmx.1*
655 %{_mandir}/man1/vdltodmx.1*
656 %{_mandir}/man1/xdmxconfig.1*
657 %endif
658
659 %files -n xorg-xserver-Xnest
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_bindir}/Xnest
662 %{_mandir}/man1/Xnest.1*
663
664 %files -n xorg-xserver-Xephyr
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_bindir}/Xephyr
667 %{_mandir}/man1/Xephyr.1*
668
669 %files -n xorg-xserver-Xfbdev
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_bindir}/Xfbdev
672
673 %files -n xorg-xserver-Xvfb
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_bindir}/Xvfb
676 %attr(755,root,root) %{_bindir}/xvfb-run
677 %{_mandir}/man1/Xvfb.1*
678
679 %files -n xorg-xserver-Xvfb-init
680 %defattr(644,root,root,755)
681 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
682 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
683
684 %if %{with wayland}
685 %files -n xorg-xserver-Xwayland
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_bindir}/Xwayland
688 %endif
689
690 %files devel
691 %defattr(644,root,root,755)
692 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
693 %{_includedir}/xorg
694 %{_libdir}/libxf86config.a
695 %{_libdir}/libxf86config.la
696 %{_aclocaldir}/xorg-server.m4
697 %{_pkgconfigdir}/xorg-server.pc
698
699 %files source
700 %defattr(644,root,root,755)
701 # keep file perms from install time, but have default defattr to keep adapter happy
702 %defattr(-,root,root,755)
703 %{_usrsrc}/%{name}-%{version}
704
705 %files -n xorg-xserver-libglx
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.21405 seconds and 4 git commands to generate.