]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- use upstream wrapper (no pam but non-root support for KMS based drivers)
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  record          # RECORD extension
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 %bcond_without  dmx             # DMX DDX (Xdmx server)
15 %bcond_without  wayland         # Wayland DDX (Xwayland server)
16 %bcond_without  glamor          # glamor dix module
17 %bcond_without  systemtap       # systemtap/dtrace probes
18 %bcond_without  libunwind       # use libunwind for backtracing
19 #
20 # ABI versions, see hw/xfree86/common/xf86Module.h
21 %define xorg_xserver_server_ansic_abi           0.4
22 %define xorg_xserver_server_extension_abi       9.0
23 %define xorg_xserver_server_font_abi            0.6
24 %define xorg_xserver_server_videodrv_abi        20.0
25 %define xorg_xserver_server_xinput_abi          22.1
26
27 %define pixman_ver      0.30.0
28
29 %ifarch x32
30 %undefine       with_libunwind
31 %endif
32
33 Summary:        X.org server
34 Summary(pl.UTF-8):      Serwer X.org
35 Name:           xorg-xserver-server
36 Version:        1.18.0
37 Release:        1
38 License:        MIT
39 Group:          X11/Servers
40 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
41 # Source0-md5:  3c1c1057d3ad27380d8dd87ffcc182cd
42 Source1:        10-quirks.conf
43 Source2:        xserver.pamd
44 Source10:       %{name}-Xvfb.init
45 Source11:       %{name}-Xvfb.sysconfig
46 Source12:       xvfb-run.sh
47
48 Patch2:         dtrace-link.patch
49
50 Patch4:         %{name}-builtin-SHA1.patch
51
52 Patch6:         110_nvidia_slowdow_fix.patch
53 Patch7:         %{name}-include-defs.patch
54 URL:            http://xorg.freedesktop.org/
55 BuildRequires:  Mesa-libGL-devel >= 7.8.1
56 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
57 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
58 # for glx headers
59 BuildRequires:  OpenGL-GLX-devel
60 %{?with_xselinux:BuildRequires: audit-libs-devel}
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  cpp
64 BuildRequires:  docbook-dtd43-xml
65 #BuildRequires: doxygen >= 1.6.1
66 %if %{with hal} || %{with dbus}
67 BuildRequires:  dbus-devel >= 1.0
68 %endif
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.46
71 %if %{with glamor} || %{with wayland}
72 BuildRequires:  libepoxy-devel
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtool >= 2:2.2
76 %{?with_libunwind:BuildRequires:        libunwind-devel}
77 BuildRequires:  libxcb-devel >= 1.6
78 BuildRequires:  pam-devel
79 BuildRequires:  perl-base
80 BuildRequires:  pixman-devel >= %{pixman_ver}
81 BuildRequires:  pkgconfig >= 1:0.19
82 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
83 BuildRequires:  udev-devel >= 1:143
84 # wayland-client
85 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
86 BuildRequires:  xcb-util-devel
87 BuildRequires:  xcb-util-image-devel
88 BuildRequires:  xcb-util-keysyms-devel
89 BuildRequires:  xcb-util-wm-devel
90 BuildRequires:  xmlto >= 0.0.20
91 BuildRequires:  xorg-app-mkfontscale
92 BuildRequires:  xorg-lib-libX11-devel >= 1.6
93 BuildRequires:  xorg-lib-libXau-devel
94 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
95 BuildRequires:  xorg-lib-libXdamage-devel
96 BuildRequires:  xorg-lib-libXdmcp-devel
97 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
98 BuildRequires:  xorg-lib-libXfixes-devel
99 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
100 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
101 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
102 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
103 BuildRequires:  xorg-lib-libXrender-devel
104 BuildRequires:  xorg-lib-libXres-devel
105 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
106 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
107 BuildRequires:  xorg-lib-libXv-devel
108 BuildRequires:  xorg-lib-libXxf86dga-devel
109 BuildRequires:  xorg-lib-libXxf86misc-devel
110 BuildRequires:  xorg-lib-libXxf86vm-devel
111 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
112 BuildRequires:  xorg-lib-libfontenc-devel
113 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
114 BuildRequires:  xorg-lib-libxkbfile-devel
115 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
116 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
117 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
118 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
119 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
120 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
121 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
122 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
123 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
124 BuildRequires:  xorg-proto-fontcacheproto-devel
125 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
126 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
127 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
128 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
129 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
130 BuildRequires:  xorg-proto-printproto-devel
131 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
132 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
133 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
134 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
135 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
136 BuildRequires:  xorg-proto-videoproto-devel
137 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
138 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
139 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
140 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
141 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
142 BuildRequires:  xorg-proto-xf86miscproto-devel
143 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
144 BuildRequires:  xorg-proto-xineramaproto-devel
145 BuildRequires:  xorg-proto-xproto-devel >= 7.0.26
146 BuildRequires:  xorg-sgml-doctools >= 1.8
147 BuildRequires:  xorg-util-util-macros >= 1.14
148 #BR: tslib (for KDRIVE only)
149 Requires(triggerpostun):        sed >= 4.0
150 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
151 Requires:       libdrm >= 2.4.46
152 Requires:       pixman >= %{pixman_ver}
153 Requires:       udev-libs >= 1:143
154 Requires:       xkeyboard-config
155 # for rgb.txt
156 Requires:       xorg-app-rgb >= 0.99.3
157 Requires:       xorg-app-xkbcomp
158 Requires:       xorg-lib-libXfont >= 1.4.2
159 Requires:       xorg-lib-libpciaccess >= 0.12.901
160 Requires:       xorg-lib-libxshmfence >= 1.1
161 Suggests:       dbus-x11 >= 1.0
162 %{?with_hal:Suggests:   hal}
163 Suggests:       udev-acl >= 1:143
164 %{?with_udev:Suggests:  udev-core >= 1:143}
165 Suggests:       xkeyboard-config
166 Suggests:       xorg-driver-input-evdev
167 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
168 Suggests:       xorg-driver-video
169 Provides:       xorg-xserver-libdri = %{version}-%{release}
170 Provides:       xorg-xserver-module(dri)
171 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
172 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
173 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
174 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
175 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
176 Obsoletes:      X11-Xserver < 1:7.0.0
177 Obsoletes:      X11-driver-i2c < 1:7.0.0
178 Obsoletes:      X11-modules < 1:7.0.0
179 Obsoletes:      X11-setup < 1:7.0.0
180 Obsoletes:      XFree86-Xserver < 1:7.0.0
181 Obsoletes:      XFree86-modules < 1:7.0.0
182 Obsoletes:      XFree86-setup < 1:7.0.0
183 Obsoletes:      Xserver
184 %{?with_glamor:Obsoletes:       glamor}
185 Obsoletes:      xorg-xserver-libdri
186 Obsoletes:      xorg-xserver-server-xorgcfg
187 Obsoletes:      xorg-driver-video-modesetting
188 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
189
190 # avoid self-dependencies on included modules
191 %define         _noautoreq      libscanpci.so libxf1bpp.so
192
193 %description
194 Xorg server is a generally used X server which uses display hardware.
195 It requires proper driver for your display hardware.
196
197 %description -l pl.UTF-8
198 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
199 graficznej. Do działania wymaga odpowiedniego sterownika.
200
201 %package -n xorg-xserver-Xdmx
202 Summary:        Xdmx - distributed multi-head X server
203 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
204 Group:          X11/Servers
205 Requires:       pixman >= %{pixman_ver}
206 Requires:       xorg-lib-libX11 >= 1.6
207 Requires:       xorg-lib-libXext >= 1.0.99.4
208 Requires:       xorg-lib-libXfont >= 1.4.2
209 Requires:       xorg-lib-libXi >= 1.2.99.1
210 Requires:       xorg-lib-libdmx >= 1.0.99.1
211
212 %description -n xorg-xserver-Xdmx
213 Xdmx - distributed multi-head X server.
214
215 %description -n xorg-xserver-Xdmx -l pl.UTF-8
216 Xdmx - rozproszony, wielomonitorowy serwer X.
217
218 %package -n xorg-xserver-Xnest
219 Summary:        Xnest - nested X server
220 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
221 Group:          X11/Servers
222 Requires:       pixman >= %{pixman_ver}
223 Requires:       xorg-lib-libXext >= 1.0.99.4
224 Requires:       xorg-lib-libXfont >= 1.4.2
225 Obsoletes:      X11-Xnest < 1:7.0.0
226 Obsoletes:      XFree86-Xnest < 1:7.0.0
227 Obsoletes:      Xserver-Xnest
228
229 %description -n xorg-xserver-Xnest
230 Xnest is an X Window System server which runs in an X window. Xnest is
231 a 'nested' window server, actually a client of the real X server,
232 which manages windows and graphics requests for Xnest, while Xnest
233 manages the windows and graphics requests for its own clients.
234
235 %description -n xorg-xserver-Xnest -l pl.UTF-8
236 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
237 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
238 serwer X dla własnych klientów.
239
240 %description -n xorg-xserver-Xnest -l ru.UTF-8
241 Xnest - это сервер X Window System, который работает в окне X. На
242 самом деле это клиент реального X-сервера, который управляет окнами и
243 графическими запросами для Xnest в то время, как Xnest управляет
244 окнами и графическими запросами для своих собственных клиентов.
245
246 %description -n xorg-xserver-Xnest -l uk.UTF-8
247 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
248 клієнт реального X-сервера, який керує вікнами та графічними запитами
249 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
250 своїх власних клієнтів.
251
252 %package -n xorg-xserver-Xephyr
253 Summary:        Xephyr - nested X server
254 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
255 Group:          X11/Servers
256 Requires:       Mesa-libGL >= 7.1.0
257 Requires:       libxcb >= 1.6
258 Requires:       pixman >= %{pixman_ver}
259 Requires:       xorg-lib-libXfont >= 1.4.2
260
261 %description -n xorg-xserver-Xephyr
262 Xephyr is a kdrive server that outputs to a window on a pre-existing
263 'host' X display. Think Xnest but with support for modern extensions
264 like composite, damage and randr.
265
266 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
267 the host X server, Xephyr is a real X server which uses the host X
268 server window as "framebuffer" via fast SHM XImages.
269
270 It also has support for 'visually' debugging what the server is
271 painting.
272
273 %description -n xorg-xserver-Xephyr -l pl.UTF-8
274 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
275 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
276 wspólczesnych rozszerzeń jak composite, damage i randr.
277
278 %package -n xorg-xserver-Xfbdev
279 Summary:        Xfbdev - Linux framebuffer device X server
280 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
281 Group:          X11/Servers
282 Requires:       pixman >= %{pixman_ver}
283 Requires:       xorg-lib-libXfont >= 1.4.2
284
285 %description -n xorg-xserver-Xfbdev
286 Xfbdev is a Linux framebuffer device X server based on the kdrive X
287 server.
288
289 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
290 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
291
292 %package -n xorg-xserver-Xvfb
293 Summary:        Xvfb - virtual framebuffer X server
294 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
295 Group:          X11/Servers
296 Requires:       Mesa-libGL >= 7.1.0
297 Requires:       mktemp
298 Requires:       pixman >= %{pixman_ver}
299 Requires:       util-linux
300 Requires:       which
301 Requires:       xkeyboard-config
302 Requires:       xorg-app-xauth
303 Requires:       xorg-app-xkbcomp
304 Requires:       xorg-lib-libXfont >= 1.4.2
305 Obsoletes:      X11-Xvfb < 1:7.0.0
306 Obsoletes:      XFree86-Xvfb < 1:7.0.0
307
308 %description -n xorg-xserver-Xvfb
309 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
310 capable of running on machines with no display hardware and no
311 physical input devices. Xvfb emulates a dumb framebuffer using virtual
312 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
313 display. Xvfb is normally used for testing servers. Using Xvfb, the
314 mfb or cfb code for any depth can be exercised without using real
315 hardware that supports the desired depths. Xvfb has also been used to
316 test X clients against unusual depths and screen configurations, to do
317 batch processing with Xvfb as a background rendering engine, to do
318 load testing, to help with porting an X server to a new platform, and
319 to provide an unobtrusive way of running applications which really
320 don't need an X server but insist on having one.
321
322 %description -n xorg-xserver-Xvfb -l pl.UTF-8
323 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
324 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
325 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
326 używany do testowania serwerów X, może też być używany do testowania
327 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
328 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
329 serwera X, ale odmawiają uruchomienia bez niego.
330
331 %package -n xorg-xserver-Xvfb-init
332 Summary:        Init scripts for Xvfb
333 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
334 Group:          X11/Servers
335 Requires:       xorg-xserver-Xvfb
336
337 %description -n xorg-xserver-Xvfb-init
338 This package contains init scripts for Xvfb and registers Xvfb as
339 system service.
340
341 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
342 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
343 usługę systemową.
344
345 %package -n xorg-xserver-Xwayland
346 Summary:        Xwayland - X server integrated into a Wayland window system
347 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
348 Group:          X11/Servers
349 Requires:       pixman >= %{pixman_ver}
350 Requires:       xorg-lib-libX11 >= 1.6
351 Requires:       xorg-lib-libXext >= 1.0.99.4
352 Requires:       xorg-lib-libXfont >= 1.4.2
353 Requires:       xorg-lib-libXi >= 1.2.99.1
354
355 %description -n xorg-xserver-Xwayland
356 Xwayland - server integrated into a Wayland window system.
357
358 %description -n xorg-xserver-Xwayland -l pl.UTF-8
359 Xwayland - serwer X integrowalny w Wayland.
360
361 %package devel
362 Summary:        Header files for X.org server
363 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
364 Group:          X11/Development/Libraries
365 Requires:       Mesa-libGL-devel >= 7.8.0
366 Requires:       libdrm-devel >= 2.4.46
367 Requires:       pixman-devel >= %{pixman_ver}
368 Requires:       xorg-lib-libXfont-devel
369 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
370 Requires:       xorg-lib-libxkbfile-devel
371 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
372 Requires:       xorg-proto-dri3proto-devel >= 1.0
373 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
374 Requires:       xorg-proto-glproto-devel >= 1.4.17
375 Requires:       xorg-proto-inputproto-devel >= 2.3
376 Requires:       xorg-proto-kbproto-devel >= 1.0.3
377 Requires:       xorg-proto-presentproto-devel >= 1.0
378 Requires:       xorg-proto-randrproto-devel >= 1.4.0
379 Requires:       xorg-proto-renderproto-devel >= 0.11
380 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
381 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
382 Requires:       xorg-proto-videoproto-devel
383 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
384 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
385 Requires:       xorg-proto-xineramaproto-devel
386 Requires:       xorg-proto-xproto-devel >= 7.0.26
387 Obsoletes:      X11-Xserver-devel < 1:7.0.0
388 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
389 %{?with_glamor:Obsoletes:       glamor-devel}
390
391 %description devel
392 Header files for X.org server.
393
394 %description devel -l pl.UTF-8
395 Pliki nagłówkowe dla serwera X.org.
396
397 %package source
398 Summary:        X.org server source code
399 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
400 Group:          X11/Development/Libraries
401
402 %description source
403 X.org server source code.
404
405 %description source -l pl.UTF-8
406 Pliki źródłowe dla serwera X.org.
407
408 %package -n xorg-xserver-libglx
409 Summary:        GLX extension library for X.org server
410 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
411 Group:          X11/Servers
412 Requires:       %{name} = %{version}-%{release}
413 Requires:       Mesa-libGL >= 7.1.0
414 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
415 # Mesa version glapi tables in glx/ dir come from
416 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
417 Provides:       xorg-xserver-module(glx)
418 Obsoletes:      X11-OpenGL-core < 1:7.0.0
419 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
420
421 %description -n xorg-xserver-libglx
422 GLX extension library for X.org server.
423
424 %description -n xorg-xserver-libglx -l pl.UTF-8
425 Biblioteka rozszerzenia GLX dla serwera X.org.
426
427 %prep
428 %setup -q -n xorg-server-%{version}
429
430 %patch2 -p1
431
432 %patch4 -p1
433
434 %patch6 -p1
435 %patch7 -p1
436
437 # xserver uses pixman-1 API/ABI so put that explictly here
438 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
439
440 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
441 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
442
443 %build
444 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
445 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
446         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
447         exit 1
448 fi
449
450 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
451 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
452         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
453         exit 1
454 fi
455
456 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
457 if [ $API != %{xorg_xserver_server_font_abi} ]; then
458         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
459         exit 1
460 fi
461 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
462 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
463         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
464         exit 1
465 fi
466 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
467 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
468         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
469         exit 1
470 fi
471
472 %{__libtoolize}
473 %{__aclocal} -I m4
474 %{__autoconf}
475 %{__autoheader}
476 %{__automake}
477 %configure \
478         --libexecdir=%{_libdir}/xorg \
479         --with-os-name="PLD/Linux" \
480         --with-os-vendor="PLD/Team" \
481         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
482         --with-xkb-output=/var/lib/xkb \
483         --disable-linux-acpi \
484         --disable-linux-apm \
485         --enable-aiglx \
486         %{?with_dbus:--enable-config-dbus} \
487         --enable-config-hal%{!?with_hal:=no} \
488         --enable-config-udev%{!?with_udev:=no} \
489         --enable-dga \
490         %{?with_dmx:--enable-dmx} \
491         --enable-dri2%{!?with_dri2:=no} \
492         %{?with_glamor:--enable-glamor} \
493         --enable-kdrive \
494         %{?with_libunwind:--enable-libunwind} \
495         %{?with_record:--enable-record} \
496         --enable-secure-rpc \
497         %{?with_xcsecurity:--enable-xcsecurity} \
498         --enable-xephyr \
499         %{?with_xf86bigfont:--enable-xf86bigfont} \
500         --disable-xfake \
501         --enable-xfbdev \
502         %{?with_xselinux:--enable-xselinux} \
503         %{?with_wayland:--enable-xwayland} \
504         %{!?with_systemtap:--without-dtrace} \
505         --without-fop \
506         --enable-suid-wrapper \
507         --with-systemd-daemon
508
509 %{__make} -j1
510
511 %install
512 rm -rf $RPM_BUILD_ROOT
513
514 %if "%{_libdir}" != "%{_exec_prefix}/lib"
515 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
516 %endif
517
518 %{__make} install \
519         DESTDIR=$RPM_BUILD_ROOT
520
521 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
522 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
523 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
524 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
525 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
526
527 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
528 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
529
530 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
531
532 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
533
534 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
535 install -d $RPM_BUILD_ROOT/etc/sysconfig
536 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
537 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
538
539 # compatibility with old xwrapper
540 ln -s %{_libdir}/xorg/Xorg.wraap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
541
542 # prepare source package
543 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
544 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
545 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
546 %{__make} distclean
547 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
548 find -name '*.h' | xargs chmod a-x
549
550 %if %{with systemtap}
551 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
552 %endif
553
554 %clean
555 rm -rf $RPM_BUILD_ROOT
556
557 %triggerpostun -- xorg-xserver-server < 1.5.0
558 if [ -f /etc/X11/xorg.conf ]; then
559         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
560         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
561 %if %{without record}
562         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
563 %endif
564         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
565 fi
566
567 %post -n xorg-xserver-Xvfb-init
568 /sbin/chkconfig --add Xvfb
569 %service Xvfb restart
570
571 %preun -n xorg-xserver-Xvfb-init
572 if [ "$1" = "0" ]; then
573         %service -q Xvfb stop
574         /sbin/chkconfig --del Xvfb
575 fi
576
577 %files
578 %defattr(644,root,root,755)
579 %doc COPYING ChangeLog README
580 %attr(755,root,root) %{_bindir}/X
581 %attr(755,root,root) %{_bindir}/Xorg
582 %attr(4755,root,root) %{_bindir}/Xwrapper
583 %attr(755,root,root) %{_bindir}/cvt
584 %attr(755,root,root) %{_bindir}/gtf
585 %dir %{_libdir}/xorg
586 %{_libdir}/xorg/protocol.txt
587 %attr(755,root,root) %{_libdir}/xorg/Xorg
588 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
589 %dir %{_libdir}/xorg/modules
590 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
591 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
592 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
593 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
594 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
595 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
596 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
597 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
598 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
599 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
600 %dir %{_libdir}/xorg/modules/dri
601 %dir %{_libdir}/xorg/modules/drivers
602 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
603 %dir %{_libdir}/xorg/modules/extensions
604 %dir %{_libdir}/xorg/modules/input
605 %if "%{_libdir}" != "%{_exec_prefix}/lib"
606 %dir %{_exec_prefix}/lib/xorg
607 %dir %{_exec_prefix}/lib/xorg/modules
608 %dir %{_exec_prefix}/lib/xorg/modules/dri
609 %endif
610 %dir /var/lib/xkb
611 /var/lib/xkb/README.compiled
612 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
613 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
614 %config(missingok) /etc/security/console.apps/xserver
615 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
616 %dir /etc/X11/xorg.conf.d
617 %dir %{_datadir}/X11/xorg.conf.d
618 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
619 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
620 %{_mandir}/man1/Xorg.1*
621 %{_mandir}/man1/Xorg.wrap.1*
622 %{_mandir}/man1/Xserver.1*
623 %{_mandir}/man1/cvt.1*
624 %{_mandir}/man1/gtf.1*
625 %{_mandir}/man4/exa.4*
626 %{_mandir}/man4/fbdevhw.4*
627 %{_mandir}/man4/modesetting.4*
628 %{_mandir}/man5/Xwrapper.config.5*
629 %{_mandir}/man5/xorg.conf.5*
630 %{_mandir}/man5/xorg.conf.d.5*
631
632 %if %{with dmx}
633 %files -n xorg-xserver-Xdmx
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_bindir}/Xdmx
636 %attr(755,root,root) %{_bindir}/dmxaddinput
637 %attr(755,root,root) %{_bindir}/dmxaddscreen
638 %attr(755,root,root) %{_bindir}/dmxinfo
639 %attr(755,root,root) %{_bindir}/dmxreconfig
640 %attr(755,root,root) %{_bindir}/dmxresize
641 %attr(755,root,root) %{_bindir}/dmxrminput
642 %attr(755,root,root) %{_bindir}/dmxrmscreen
643 %attr(755,root,root) %{_bindir}/dmxtodmx
644 %attr(755,root,root) %{_bindir}/dmxwininfo
645 %attr(755,root,root) %{_bindir}/vdltodmx
646 %attr(755,root,root) %{_bindir}/xdmxconfig
647 %{_mandir}/man1/Xdmx.1*
648 %{_mandir}/man1/dmxtodmx.1*
649 %{_mandir}/man1/vdltodmx.1*
650 %{_mandir}/man1/xdmxconfig.1*
651 %endif
652
653 %files -n xorg-xserver-Xnest
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_bindir}/Xnest
656 %{_mandir}/man1/Xnest.1*
657
658 %files -n xorg-xserver-Xephyr
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_bindir}/Xephyr
661 %{_mandir}/man1/Xephyr.1*
662
663 %files -n xorg-xserver-Xfbdev
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_bindir}/Xfbdev
666
667 %files -n xorg-xserver-Xvfb
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_bindir}/Xvfb
670 %attr(755,root,root) %{_bindir}/xvfb-run
671 %{_mandir}/man1/Xvfb.1*
672
673 %files -n xorg-xserver-Xvfb-init
674 %defattr(644,root,root,755)
675 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
676 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
677
678 %if %{with wayland}
679 %files -n xorg-xserver-Xwayland
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_bindir}/Xwayland
682 %endif
683
684 %files devel
685 %defattr(644,root,root,755)
686 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
687 %{_includedir}/xorg
688 %{_aclocaldir}/xorg-server.m4
689 %{_pkgconfigdir}/xorg-server.pc
690
691 %files source
692 %defattr(644,root,root,755)
693 # keep file perms from install time, but have default defattr to keep adapter happy
694 %defattr(-,root,root,755)
695 %{_usrsrc}/%{name}-%{version}
696
697 %files -n xorg-xserver-libglx
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.073787 seconds and 4 git commands to generate.