]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
also restored comment for glen
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_without  glamor          # glamor dix module
18 %bcond_without  systemtap       # systemtap/dtrace probes
19 %bcond_without  libunwind       # use libunwind for backtracing
20 #
21 # ABI versions, see hw/xfree86/common/xf86Module.h
22 %define xorg_xserver_server_ansic_abi           0.4
23 %define xorg_xserver_server_extension_abi       10.0
24 %define xorg_xserver_server_font_abi            0.6
25 %define xorg_xserver_server_videodrv_abi        23.0
26 %define xorg_xserver_server_xinput_abi          24.1
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        1.19.0
38 Release:        1
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
42 # Source0-md5:  6a4d01e4e5047ab8f556960424ba1fa9
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48 Patch1:         %{name}-xwrapper-pam.patch
49 Patch2:         dtrace-link.patch
50
51 Patch4:         %{name}-builtin-SHA1.patch
52
53 Patch6:         110_nvidia_slowdow_fix.patch
54 URL:            http://xorg.freedesktop.org/
55 BuildRequires:  Mesa-libGL-devel >= 7.8.1
56 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
57 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
58 # for glx headers
59 BuildRequires:  OpenGL-GLX-devel
60 %{?with_xselinux:BuildRequires: audit-libs-devel}
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  cpp
64 BuildRequires:  docbook-dtd43-xml
65 #BuildRequires: doxygen >= 1.6.1
66 %if %{with hal} || %{with dbus}
67 BuildRequires:  dbus-devel >= 1.0
68 %endif
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.46
71 %if %{with glamor} || %{with wayland}
72 BuildRequires:  libepoxy-devel
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtool >= 2:2.2
76 %{?with_libunwind:BuildRequires:        libunwind-devel}
77 BuildRequires:  libxcb-devel >= 1.6
78 BuildRequires:  pam-devel
79 BuildRequires:  perl-base
80 BuildRequires:  pixman-devel >= %{pixman_ver}
81 BuildRequires:  pkgconfig >= 1:0.19
82 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
83 BuildRequires:  systemd-devel >= 209
84 BuildRequires:  udev-devel >= 1:143
85 # wayland-client
86 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
87 %{?with_wayland:BuildRequires:  wayland-protocols >= 1.1}
88 BuildRequires:  xcb-util-devel
89 BuildRequires:  xcb-util-image-devel
90 BuildRequires:  xcb-util-keysyms-devel
91 BuildRequires:  xcb-util-renderutil-devel
92 BuildRequires:  xcb-util-wm-devel
93 BuildRequires:  xmlto >= 0.0.20
94 BuildRequires:  xorg-app-mkfontscale
95 BuildRequires:  xorg-font-font-util >= 1.1
96 BuildRequires:  xorg-lib-libX11-devel >= 1.6
97 BuildRequires:  xorg-lib-libXau-devel
98 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
99 BuildRequires:  xorg-lib-libXdamage-devel
100 BuildRequires:  xorg-lib-libXdmcp-devel
101 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
102 BuildRequires:  xorg-lib-libXfixes-devel
103 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
104 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
105 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
106 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
107 BuildRequires:  xorg-lib-libXrender-devel
108 BuildRequires:  xorg-lib-libXres-devel
109 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
110 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
111 BuildRequires:  xorg-lib-libXv-devel
112 BuildRequires:  xorg-lib-libXxf86dga-devel
113 BuildRequires:  xorg-lib-libXxf86misc-devel
114 BuildRequires:  xorg-lib-libXxf86vm-devel
115 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
116 BuildRequires:  xorg-lib-libfontenc-devel
117 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
118 BuildRequires:  xorg-lib-libxkbfile-devel
119 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
120 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
121 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
122 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
123 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
124 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
125 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
126 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
127 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
128 BuildRequires:  xorg-proto-fontcacheproto-devel
129 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
130 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
131 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
132 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
133 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
134 BuildRequires:  xorg-proto-printproto-devel
135 BuildRequires:  xorg-proto-randrproto-devel >= 1.5.0
136 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
137 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
138 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
139 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
140 BuildRequires:  xorg-proto-videoproto-devel
141 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
142 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
143 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
144 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
145 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
146 BuildRequires:  xorg-proto-xf86miscproto-devel
147 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
148 BuildRequires:  xorg-proto-xineramaproto-devel
149 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
150 BuildRequires:  xorg-sgml-doctools >= 1.8
151 BuildRequires:  xorg-util-util-macros >= 1.14
152 #BR: tslib (for KDRIVE only)
153 Requires(triggerpostun):        sed >= 4.0
154 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
155 Requires:       libdrm >= 2.4.46
156 Requires:       pixman >= %{pixman_ver}
157 Requires:       udev-libs >= 1:143
158 Requires:       xkeyboard-config
159 # for rgb.txt
160 Requires:       xorg-app-rgb >= 0.99.3
161 Requires:       xorg-app-xkbcomp
162 Requires:       xorg-lib-libXfont2 >= 2.0.0
163 Requires:       xorg-lib-libpciaccess >= 0.12.901
164 Requires:       xorg-lib-libxshmfence >= 1.1
165 Suggests:       dbus-x11 >= 1.0
166 %{?with_hal:Suggests:   hal}
167 Suggests:       udev-acl >= 1:143
168 %{?with_udev:Suggests:  udev-core >= 1:143}
169 Suggests:       xkeyboard-config
170 Suggests:       xorg-driver-input-libinput
171 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
172 Suggests:       xorg-driver-video
173 Provides:       xorg-driver-video-modesetting
174 Provides:       xorg-xserver-libdri = %{version}-%{release}
175 Provides:       xorg-xserver-module(dri)
176 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
177 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
178 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
179 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
180 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
181 Obsoletes:      X11-Xserver < 1:7.0.0
182 Obsoletes:      X11-driver-i2c < 1:7.0.0
183 Obsoletes:      X11-modules < 1:7.0.0
184 Obsoletes:      X11-setup < 1:7.0.0
185 Obsoletes:      XFree86-Xserver < 1:7.0.0
186 Obsoletes:      XFree86-modules < 1:7.0.0
187 Obsoletes:      XFree86-setup < 1:7.0.0
188 Obsoletes:      Xserver
189 %{?with_glamor:Obsoletes:       glamor}
190 Obsoletes:      xorg-xserver-libdri
191 Obsoletes:      xorg-xserver-server-xorgcfg
192 Obsoletes:      xorg-driver-video-modesetting
193 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
194
195 %description
196 Xorg server is a generally used X server which uses display hardware.
197 It requires proper driver for your display hardware.
198
199 %description -l pl.UTF-8
200 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
201 graficznej. Do działania wymaga odpowiedniego sterownika.
202
203 %package -n xorg-xserver-Xdmx
204 Summary:        Xdmx - distributed multi-head X server
205 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
206 Group:          X11/Servers
207 Requires:       pixman >= %{pixman_ver}
208 Requires:       xorg-lib-libX11 >= 1.6
209 Requires:       xorg-lib-libXext >= 1.0.99.4
210 Requires:       xorg-lib-libXfont2 >= 2.0.0
211 Requires:       xorg-lib-libXi >= 1.2.99.1
212 Requires:       xorg-lib-libdmx >= 1.0.99.1
213
214 %description -n xorg-xserver-Xdmx
215 Xdmx - distributed multi-head X server.
216
217 %description -n xorg-xserver-Xdmx -l pl.UTF-8
218 Xdmx - rozproszony, wielomonitorowy serwer X.
219
220 %package -n xorg-xserver-Xnest
221 Summary:        Xnest - nested X server
222 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
223 Group:          X11/Servers
224 Requires:       pixman >= %{pixman_ver}
225 Requires:       xorg-lib-libXext >= 1.0.99.4
226 Requires:       xorg-lib-libXfont2 >= 2.0.0
227 Obsoletes:      X11-Xnest < 1:7.0.0
228 Obsoletes:      XFree86-Xnest < 1:7.0.0
229 Obsoletes:      Xserver-Xnest
230
231 %description -n xorg-xserver-Xnest
232 Xnest is an X Window System server which runs in an X window. Xnest is
233 a 'nested' window server, actually a client of the real X server,
234 which manages windows and graphics requests for Xnest, while Xnest
235 manages the windows and graphics requests for its own clients.
236
237 %description -n xorg-xserver-Xnest -l pl.UTF-8
238 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
239 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
240 serwer X dla własnych klientów.
241
242 %description -n xorg-xserver-Xnest -l ru.UTF-8
243 Xnest - это сервер X Window System, который работает в окне X. На
244 самом деле это клиент реального X-сервера, который управляет окнами и
245 графическими запросами для Xnest в то время, как Xnest управляет
246 окнами и графическими запросами для своих собственных клиентов.
247
248 %description -n xorg-xserver-Xnest -l uk.UTF-8
249 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
250 клієнт реального X-сервера, який керує вікнами та графічними запитами
251 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
252 своїх власних клієнтів.
253
254 %package -n xorg-xserver-Xephyr
255 Summary:        Xephyr - nested X server
256 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
257 Group:          X11/Servers
258 Requires:       Mesa-libGL >= 7.1.0
259 Requires:       libxcb >= 1.6
260 Requires:       pixman >= %{pixman_ver}
261 Requires:       xorg-lib-libXfont2 >= 2.0.0
262
263 %description -n xorg-xserver-Xephyr
264 Xephyr is a kdrive server that outputs to a window on a pre-existing
265 'host' X display. Think Xnest but with support for modern extensions
266 like composite, damage and randr.
267
268 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
269 the host X server, Xephyr is a real X server which uses the host X
270 server window as "framebuffer" via fast SHM XImages.
271
272 It also has support for 'visually' debugging what the server is
273 painting.
274
275 %description -n xorg-xserver-Xephyr -l pl.UTF-8
276 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
277 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
278 wspólczesnych rozszerzeń jak composite, damage i randr.
279
280 %package -n xorg-xserver-Xfbdev
281 Summary:        Xfbdev - Linux framebuffer device X server
282 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
283 Group:          X11/Servers
284 Requires:       pixman >= %{pixman_ver}
285 Requires:       xorg-lib-libXfont2 >= 2.0.0
286
287 %description -n xorg-xserver-Xfbdev
288 Xfbdev is a Linux framebuffer device X server based on the kdrive X
289 server.
290
291 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
292 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
293
294 %package -n xorg-xserver-Xvfb
295 Summary:        Xvfb - virtual framebuffer X server
296 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
297 Group:          X11/Servers
298 Requires:       Mesa-libGL >= 7.1.0
299 Requires:       mktemp
300 Requires:       pixman >= %{pixman_ver}
301 Requires:       util-linux
302 Requires:       which
303 Requires:       xkeyboard-config
304 Requires:       xorg-app-xauth
305 Requires:       xorg-app-xkbcomp
306 Requires:       xorg-lib-libXfont2 >= 2.0.0
307 Obsoletes:      X11-Xvfb < 1:7.0.0
308 Obsoletes:      XFree86-Xvfb < 1:7.0.0
309
310 %description -n xorg-xserver-Xvfb
311 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
312 capable of running on machines with no display hardware and no
313 physical input devices. Xvfb emulates a dumb framebuffer using virtual
314 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
315 display. Xvfb is normally used for testing servers. Using Xvfb, the
316 mfb or cfb code for any depth can be exercised without using real
317 hardware that supports the desired depths. Xvfb has also been used to
318 test X clients against unusual depths and screen configurations, to do
319 batch processing with Xvfb as a background rendering engine, to do
320 load testing, to help with porting an X server to a new platform, and
321 to provide an unobtrusive way of running applications which really
322 don't need an X server but insist on having one.
323
324 %description -n xorg-xserver-Xvfb -l pl.UTF-8
325 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
326 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
327 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
328 używany do testowania serwerów X, może też być używany do testowania
329 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
330 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
331 serwera X, ale odmawiają uruchomienia bez niego.
332
333 %package -n xorg-xserver-Xvfb-init
334 Summary:        Init scripts for Xvfb
335 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
336 Group:          X11/Servers
337 Requires:       xorg-xserver-Xvfb
338
339 %description -n xorg-xserver-Xvfb-init
340 This package contains init scripts for Xvfb and registers Xvfb as
341 system service.
342
343 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
344 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
345 usługę systemową.
346
347 %package -n xorg-xserver-Xwayland
348 Summary:        Xwayland - X server integrated into a Wayland window system
349 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
350 Group:          X11/Servers
351 Requires:       pixman >= %{pixman_ver}
352 Requires:       xorg-lib-libX11 >= 1.6
353 Requires:       xorg-lib-libXext >= 1.0.99.4
354 Requires:       xorg-lib-libXfont2 >= 2.0.0
355 Requires:       xorg-lib-libXi >= 1.2.99.1
356
357 %description -n xorg-xserver-Xwayland
358 Xwayland - server integrated into a Wayland window system.
359
360 %description -n xorg-xserver-Xwayland -l pl.UTF-8
361 Xwayland - serwer X integrowalny w Wayland.
362
363 %package devel
364 Summary:        Header files for X.org server
365 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
366 Group:          X11/Development/Libraries
367 Requires:       Mesa-libGL-devel >= 7.8.0
368 Requires:       libdrm-devel >= 2.4.46
369 Requires:       pixman-devel >= %{pixman_ver}
370 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
371 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
372 Requires:       xorg-lib-libxkbfile-devel
373 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
374 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
375 Requires:       xorg-proto-dri3proto-devel >= 1.0
376 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
377 Requires:       xorg-proto-glproto-devel >= 1.4.17
378 Requires:       xorg-proto-inputproto-devel >= 2.3
379 Requires:       xorg-proto-kbproto-devel >= 1.0.3
380 Requires:       xorg-proto-presentproto-devel >= 1.0
381 Requires:       xorg-proto-randrproto-devel >= 1.5.0
382 Requires:       xorg-proto-renderproto-devel >= 0.11
383 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
384 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
385 Requires:       xorg-proto-videoproto-devel
386 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
387 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
388 Requires:       xorg-proto-xineramaproto-devel
389 Requires:       xorg-proto-xproto-devel >= 7.0.31
390 Obsoletes:      X11-Xserver-devel < 1:7.0.0
391 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
392 %{?with_glamor:Obsoletes:       glamor-devel}
393
394 %description devel
395 Header files for X.org server.
396
397 %description devel -l pl.UTF-8
398 Pliki nagłówkowe dla serwera X.org.
399
400 %package source
401 Summary:        X.org server source code
402 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
403 Group:          X11/Development/Libraries
404
405 %description source
406 X.org server source code.
407
408 %description source -l pl.UTF-8
409 Pliki źródłowe dla serwera X.org.
410
411 %package -n xorg-xserver-libglx
412 Summary:        GLX extension library for X.org server
413 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
414 Group:          X11/Servers
415 Requires:       %{name} = %{version}-%{release}
416 Requires:       Mesa-libGL >= 7.1.0
417 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
418 # Mesa version glapi tables in glx/ dir come from
419 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
420 Provides:       xorg-xserver-module(glx)
421 Obsoletes:      X11-OpenGL-core < 1:7.0.0
422 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
423
424 %description -n xorg-xserver-libglx
425 GLX extension library for X.org server.
426
427 %description -n xorg-xserver-libglx -l pl.UTF-8
428 Biblioteka rozszerzenia GLX dla serwera X.org.
429
430 %prep
431 %setup -q -n xorg-server-%{version}
432 %patch1 -p1
433 %patch2 -p1
434
435 %patch4 -p1
436
437 %patch6 -p1
438
439 # xserver uses pixman-1 API/ABI so put that explictly here
440 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
441
442 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
443 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
444
445 %build
446 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
447 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
448         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
449         exit 1
450 fi
451
452 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
453 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
454         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
455         exit 1
456 fi
457
458 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
459 if [ $API != %{xorg_xserver_server_font_abi} ]; then
460         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
461         exit 1
462 fi
463 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
464 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
465         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
466         exit 1
467 fi
468 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
469 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
470         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
471         exit 1
472 fi
473
474 %{__libtoolize}
475 %{__aclocal} -I m4
476 %{__autoconf}
477 %{__autoheader}
478 %{__automake}
479 %configure \
480         --libexecdir=%{_libdir}/xorg \
481         --with-os-name="PLD/Linux" \
482         --with-os-vendor="PLD/Team" \
483         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
484         --with-xkb-output=/var/lib/xkb \
485         --disable-linux-acpi \
486         --disable-linux-apm \
487         --enable-aiglx \
488         %{?with_dbus:--enable-config-dbus} \
489         --enable-config-hal%{!?with_hal:=no} \
490         --enable-config-udev%{!?with_udev:=no} \
491         --enable-dga \
492         %{?with_dmx:--enable-dmx} \
493         --enable-dri2%{!?with_dri2:=no} \
494         --enable-dri3%{!?with_dri3:=no} \
495         %{?with_glamor:--enable-glamor} \
496         --enable-kdrive \
497         %{?with_libunwind:--enable-libunwind} \
498         %{?with_record:--enable-record} \
499         --enable-secure-rpc \
500         %{?with_xcsecurity:--enable-xcsecurity} \
501         --enable-xephyr \
502         %{?with_xf86bigfont:--enable-xf86bigfont} \
503         --disable-xfake \
504         --enable-xfbdev \
505         %{?with_xselinux:--enable-xselinux} \
506         %{?with_wayland:--enable-xwayland} \
507         %{!?with_systemtap:--without-dtrace} \
508         --without-fop \
509         --enable-suid-wrapper \
510         --with-systemd-daemon
511
512 %{__make} -j1
513
514 %install
515 rm -rf $RPM_BUILD_ROOT
516
517 %if "%{_libdir}" != "%{_exec_prefix}/lib"
518 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
519 %endif
520
521 %{__make} install \
522         DESTDIR=$RPM_BUILD_ROOT
523
524 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
525 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
526 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
527 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
528 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
529
530 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
531 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
532
533 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
534
535 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
536
537 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
538 install -d $RPM_BUILD_ROOT/etc/sysconfig
539 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
540 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
541
542 # Xorg.wrap config
543 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
544 # allowed values: rootonly console anybody pam
545 allowed_users = pam
546
547 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
548 #needs_root_rights = yes
549 EOF
550
551 # compatibility with old xwrapper
552 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
553
554 # prepare source package
555 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
556 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
557 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
558 %{__make} distclean
559 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
560 find -name '*.h' | xargs chmod a-x
561
562 %if %{with systemtap}
563 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
564 %endif
565
566 %clean
567 rm -rf $RPM_BUILD_ROOT
568
569 %triggerpostun -- xorg-xserver-server < 1.5.0
570 if [ -f /etc/X11/xorg.conf ]; then
571         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
572         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
573 %if %{without record}
574         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
575 %endif
576         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
577 fi
578
579 %post -n xorg-xserver-Xvfb-init
580 /sbin/chkconfig --add Xvfb
581 %service Xvfb restart
582
583 %preun -n xorg-xserver-Xvfb-init
584 if [ "$1" = "0" ]; then
585         %service -q Xvfb stop
586         /sbin/chkconfig --del Xvfb
587 fi
588
589 %files
590 %defattr(644,root,root,755)
591 %doc COPYING ChangeLog README
592 %attr(755,root,root) %{_bindir}/X
593 %attr(755,root,root) %{_bindir}/Xorg
594 %attr(4755,root,root) %{_bindir}/Xwrapper
595 %attr(755,root,root) %{_bindir}/cvt
596 %attr(755,root,root) %{_bindir}/gtf
597 %dir %{_libdir}/xorg
598 %{_libdir}/xorg/protocol.txt
599 %attr(755,root,root) %{_libdir}/xorg/Xorg
600 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
601 %dir %{_libdir}/xorg/modules
602 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
603 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
604 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
605 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
606 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
607 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
608 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
609 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
610 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
611 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
612 %dir %{_libdir}/xorg/modules/dri
613 %dir %{_libdir}/xorg/modules/drivers
614 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
615 %dir %{_libdir}/xorg/modules/extensions
616 %dir %{_libdir}/xorg/modules/input
617 %if "%{_libdir}" != "%{_exec_prefix}/lib"
618 %dir %{_exec_prefix}/lib/xorg
619 %dir %{_exec_prefix}/lib/xorg/modules
620 %dir %{_exec_prefix}/lib/xorg/modules/dri
621 %endif
622 %dir /var/lib/xkb
623 /var/lib/xkb/README.compiled
624 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
625 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
626 %config(missingok) /etc/security/console.apps/xserver
627 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
628 %dir /etc/X11/xorg.conf.d
629 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
630 %dir %{_datadir}/X11/xorg.conf.d
631 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
632 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
633 %{_mandir}/man1/Xorg.1*
634 %{_mandir}/man1/Xorg.wrap.1*
635 %{_mandir}/man1/Xserver.1*
636 %{_mandir}/man1/cvt.1*
637 %{_mandir}/man1/gtf.1*
638 %{_mandir}/man4/exa.4*
639 %{_mandir}/man4/fbdevhw.4*
640 %{_mandir}/man4/modesetting.4*
641 %{_mandir}/man5/Xwrapper.config.5*
642 %{_mandir}/man5/xorg.conf.5*
643 %{_mandir}/man5/xorg.conf.d.5*
644
645 %if %{with dmx}
646 %files -n xorg-xserver-Xdmx
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_bindir}/Xdmx
649 %attr(755,root,root) %{_bindir}/dmxaddinput
650 %attr(755,root,root) %{_bindir}/dmxaddscreen
651 %attr(755,root,root) %{_bindir}/dmxinfo
652 %attr(755,root,root) %{_bindir}/dmxreconfig
653 %attr(755,root,root) %{_bindir}/dmxresize
654 %attr(755,root,root) %{_bindir}/dmxrminput
655 %attr(755,root,root) %{_bindir}/dmxrmscreen
656 %attr(755,root,root) %{_bindir}/dmxtodmx
657 %attr(755,root,root) %{_bindir}/dmxwininfo
658 %attr(755,root,root) %{_bindir}/vdltodmx
659 %attr(755,root,root) %{_bindir}/xdmxconfig
660 %{_mandir}/man1/Xdmx.1*
661 %{_mandir}/man1/dmxtodmx.1*
662 %{_mandir}/man1/vdltodmx.1*
663 %{_mandir}/man1/xdmxconfig.1*
664 %endif
665
666 %files -n xorg-xserver-Xnest
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/Xnest
669 %{_mandir}/man1/Xnest.1*
670
671 %files -n xorg-xserver-Xephyr
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_bindir}/Xephyr
674 %{_mandir}/man1/Xephyr.1*
675
676 %files -n xorg-xserver-Xfbdev
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_bindir}/Xfbdev
679
680 %files -n xorg-xserver-Xvfb
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_bindir}/Xvfb
683 %attr(755,root,root) %{_bindir}/xvfb-run
684 %{_mandir}/man1/Xvfb.1*
685
686 %files -n xorg-xserver-Xvfb-init
687 %defattr(644,root,root,755)
688 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
689 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
690
691 %if %{with wayland}
692 %files -n xorg-xserver-Xwayland
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_bindir}/Xwayland
695 %endif
696
697 %files devel
698 %defattr(644,root,root,755)
699 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
700 %{_includedir}/xorg
701 %{_aclocaldir}/xorg-server.m4
702 %{_pkgconfigdir}/xorg-server.pc
703
704 %files source
705 %defattr(644,root,root,755)
706 # keep file perms from install time, but have default defattr to keep adapter happy
707 %defattr(-,root,root,755)
708 %{_usrsrc}/%{name}-%{version}
709
710 %files -n xorg-xserver-libglx
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.231034 seconds and 4 git commands to generate.