]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- updated dependencies, added install time dependencies for individual servers
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
5 %bcond_with     hal             # HAL support for configuration (if no udev)
6 %bcond_without  udev            # UDEV support for configuration
7 %bcond_without  dmx             # DMX support
8 %bcond_without  dri2            # DRI2 extension
9 %bcond_without  record          # RECORD extension
10 %bcond_without  systemtap       # systemtap/dtrace probes
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 #
15 # ABI versions, see hw/xfree86/common/xf86Module.h
16 %define xorg_xserver_server_ansic_abi           0.4
17 %define xorg_xserver_server_extension_abi       8.0
18 %define xorg_xserver_server_font_abi            0.6
19 %define xorg_xserver_server_videodrv_abi        15.0
20 %define xorg_xserver_server_xinput_abi          20.0
21 #
22 %define pixman_ver      0.30.0
23
24 Summary:        X.org server
25 Summary(pl.UTF-8):      Serwer X.org
26 Name:           xorg-xserver-server
27 Version:        1.15.0
28 Release:        1
29 License:        MIT
30 Group:          X11/Servers
31 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
32 # Source0-md5:  c2ace3697b32414094cf8c597c39d7d9
33 Source1:        10-quirks.conf
34 Source2:        xserver.pamd
35 Source10:       %{name}-Xvfb.init
36 Source11:       %{name}-Xvfb.sysconfig
37 Source12:       xvfb-run.sh
38
39 Patch0:         %{name}-xwrapper.patch
40 Patch1:         %{name}-pic-libxf86config.patch
41
42 Patch4:         %{name}-builtin-SHA1.patch
43 Patch5:         %{name}-export-GetMaster.patch
44 Patch6:         110_nvidia_slowdow_fix.patch
45 Patch7:         %{name}-include-defs.patch
46 URL:            http://xorg.freedesktop.org/
47 BuildRequires:  Mesa-libGL-devel >= 7.8.1
48 # for glx headers
49 BuildRequires:  OpenGL-GLX-devel
50 %{?with_xselinux:BuildRequires: audit-libs-devel}
51 BuildRequires:  autoconf >= 2.60
52 BuildRequires:  automake
53 BuildRequires:  cpp
54 BuildRequires:  docbook-dtd43-xml
55 #BuildRequires: doxygen >= 1.6.1
56 %if %{with hal} || %{with dbus}
57 BuildRequires:  dbus-devel >= 1.0
58 %endif
59 %{?with_hal:BuildRequires:      hal-devel}
60 BuildRequires:  libdrm-devel >= 2.4.39
61 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
62 BuildRequires:  libtool
63 BuildRequires:  libunwind-devel
64 BuildRequires:  libxcb-devel >= 1.6
65 BuildRequires:  ncurses-devel
66 BuildRequires:  pam-devel
67 BuildRequires:  perl-base
68 BuildRequires:  pixman-devel >= %{pixman_ver}
69 BuildRequires:  pkgconfig >= 1:0.19
70 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
71 BuildRequires:  udev-devel >= 1:143
72 BuildRequires:  xcb-util-devel
73 BuildRequires:  xcb-util-image-devel
74 BuildRequires:  xcb-util-keysyms-devel
75 BuildRequires:  xcb-util-wm-devel
76 BuildRequires:  xmlto >= 0.0.20
77 BuildRequires:  xorg-app-mkfontscale
78 BuildRequires:  xorg-font-font-util >= 1.1
79 BuildRequires:  xorg-lib-libX11-devel >= 1.6
80 BuildRequires:  xorg-lib-libXau-devel
81 BuildRequires:  xorg-lib-libXaw-devel
82 BuildRequires:  xorg-lib-libXdamage-devel
83 BuildRequires:  xorg-lib-libXdmcp-devel
84 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
85 BuildRequires:  xorg-lib-libXfixes-devel
86 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
87 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
88 BuildRequires:  xorg-lib-libXmu-devel
89 BuildRequires:  xorg-lib-libXpm-devel
90 BuildRequires:  xorg-lib-libXrender-devel
91 BuildRequires:  xorg-lib-libXres-devel
92 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
93 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
94 BuildRequires:  xorg-lib-libXv-devel
95 BuildRequires:  xorg-lib-libXxf86dga-devel
96 BuildRequires:  xorg-lib-libXxf86misc-devel
97 BuildRequires:  xorg-lib-libXxf86vm-devel
98 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
99 BuildRequires:  xorg-lib-libfontenc-devel
100 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
101 BuildRequires:  xorg-lib-libxkbfile-devel
102 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
103 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.2
104 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
105 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
106 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
107 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
108 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
109 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
110 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
111 BuildRequires:  xorg-proto-fontcacheproto-devel
112 BuildRequires:  xorg-proto-fontsproto-devel
113 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
114 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
115 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
116 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
117 BuildRequires:  xorg-proto-printproto-devel
118 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
119 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
120 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
121 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
122 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
123 BuildRequires:  xorg-proto-videoproto-devel
124 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
125 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
126 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
127 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
128 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
129 BuildRequires:  xorg-proto-xf86miscproto-devel
130 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
131 BuildRequires:  xorg-proto-xineramaproto-devel
132 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
133 BuildRequires:  xorg-sgml-doctools >= 1.8
134 BuildRequires:  xorg-util-util-macros >= 1.14
135 #BR: tslib (for KDRIVE only)
136 Requires(triggerpostun):        sed >= 4.0
137 Requires:       libdrm >= 2.4.39
138 Requires:       pixman >= %{pixman_ver}
139 Requires:       udev-libs >= 1:143
140 Requires:       xkeyboard-config
141 # for rgb.txt
142 Requires:       xorg-app-rgb >= 0.99.3
143 Requires:       xorg-app-xkbcomp
144 # xserver requires fixed and cursor fonts
145 Requires:       xorg-font-font-alias
146 Requires:       xorg-font-font-cursor-misc
147 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
148 Requires:       xorg-lib-libXfont >= 1.4.2
149 Requires:       xorg-lib-libpciaccess >= 0.12.901
150 Requires:       xorg-lib-libxshmfence >= 1.1
151 Suggests:       dbus-x11 >= 1.0
152 %{?with_hal:Suggests:   hal}
153 Suggests:       udev-acl >= 1:143
154 %{?with_udev:Suggests:  udev-core >= 1:143}
155 Suggests:       xkeyboard-config
156 Suggests:       xorg-driver-input-evdev
157 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
158 Suggests:       xorg-driver-video
159 Provides:       xorg-xserver-libdri = %{version}-%{release}
160 Provides:       xorg-xserver-module(dri)
161 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
162 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
163 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
164 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
165 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
166 Obsoletes:      X11-Xserver < 1:7.0.0
167 Obsoletes:      X11-driver-i2c < 1:7.0.0
168 Obsoletes:      X11-modules < 1:7.0.0
169 Obsoletes:      X11-setup < 1:7.0.0
170 Obsoletes:      XFree86-Xserver < 1:7.0.0
171 Obsoletes:      XFree86-modules < 1:7.0.0
172 Obsoletes:      XFree86-setup < 1:7.0.0
173 Obsoletes:      Xserver
174 Obsoletes:      xorg-xserver-libdri
175 Obsoletes:      xorg-xserver-server-xorgcfg
176 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
177
178 # avoid self-dependencies on included modules
179 %define         _noautoreq      libscanpci.so libxf1bpp.so
180
181 %description
182 Xorg server is a generally used X server which uses display hardware.
183 It requires proper driver for your display hardware.
184
185 %description -l pl.UTF-8
186 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
187 graficznej. Do działania wymaga odpowiedniego sterownika.
188
189 %package -n xorg-xserver-Xdmx
190 Summary:        Xdmx - distributed multi-head X server
191 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
192 Group:          X11/Servers
193 Requires:       pixman >= %{pixman_ver}
194 Requires:       xorg-lib-libX11 >= 1.6
195 Requires:       xorg-lib-libXext >= 1.0.99.4
196 Requires:       xorg-lib-libXfont >= 1.4.2
197 Requires:       xorg-lib-libXi >= 1.2.99.1
198 Requires:       xorg-lib-libdmx >= 1.0.99.1
199
200 %description -n xorg-xserver-Xdmx
201 Xdmx - distributed multi-head X server.
202
203 %description -n xorg-xserver-Xdmx -l pl.UTF-8
204 Xdmx - rozproszony, wielomonitorowy serwer X.
205
206 %package -n xorg-xserver-Xnest
207 Summary:        Xnest - nested X server
208 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
209 Group:          X11/Servers
210 Requires:       pixman >= %{pixman_ver}
211 Requires:       xorg-lib-libXext >= 1.0.99.4
212 Requires:       xorg-lib-libXfont >= 1.4.2
213 Obsoletes:      X11-Xnest < 1:7.0.0
214 Obsoletes:      XFree86-Xnest < 1:7.0.0
215 Obsoletes:      Xserver-Xnest
216
217 %description -n xorg-xserver-Xnest
218 Xnest is an X Window System server which runs in an X window. Xnest is
219 a 'nested' window server, actually a client of the real X server,
220 which manages windows and graphics requests for Xnest, while Xnest
221 manages the windows and graphics requests for its own clients.
222
223 %description -n xorg-xserver-Xnest -l pl.UTF-8
224 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
225 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
226 serwer X dla własnych klientów.
227
228 %description -n xorg-xserver-Xnest -l ru.UTF-8
229 Xnest - это сервер X Window System, который работает в окне X. На
230 самом деле это клиент реального X-сервера, который управляет окнами и
231 графическими запросами для Xnest в то время, как Xnest управляет
232 окнами и графическими запросами для своих собственных клиентов.
233
234 %description -n xorg-xserver-Xnest -l uk.UTF-8
235 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
236 клієнт реального X-сервера, який керує вікнами та графічними запитами
237 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
238 своїх власних клієнтів.
239
240 %package -n xorg-xserver-Xephyr
241 Summary:        Xephyr - nested X server
242 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
243 Group:          X11/Servers
244 Requires:       Mesa-libGL >= 7.1.0
245 Requires:       libxcb >= 1.6
246 Requires:       pixman >= %{pixman_ver}
247 Requires:       xorg-lib-libXfont >= 1.4.2
248
249 %description -n xorg-xserver-Xephyr
250 Xephyr is a a kdrive server that outputs to a window on a pre-existing
251 'host' X display. Think Xnest but with support for modern extensions
252 like composite, damage and randr.
253
254 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
255 the host X server, Xephyr is a real X server which uses the host X
256 server window as "framebuffer" via fast SHM XImages.
257
258 It also has support for 'visually' debugging what the server is
259 painting.
260
261 %description -n xorg-xserver-Xephyr -l pl.UTF-8
262 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
263 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
264 wspólczesnych rozszerzeń jak composite, damage i randr.
265
266 %package -n xorg-xserver-Xfbdev
267 Summary:        Xfbdev - Linux framebuffer device X server
268 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
269 Group:          X11/Servers
270 Requires:       pixman >= %{pixman_ver}
271 Requires:       xorg-lib-libXfont >= 1.4.2
272
273 %description -n xorg-xserver-Xfbdev
274 Xfbdev is a Linux framebuffer device X server based on the kdrive X
275 server.
276
277 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
278 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
279
280 %package -n xorg-xserver-Xvfb
281 Summary:        Xvfb - virtual framebuffer X server
282 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
283 Group:          X11/Servers
284 Requires:       Mesa-libGL >= 7.1.0
285 Requires:       mktemp
286 Requires:       pixman >= %{pixman_ver}
287 Requires:       util-linux
288 Requires:       which
289 Requires:       xorg-app-xauth
290 # requires fixed and cursor fonts
291 Requires:       xorg-font-font-alias
292 Requires:       xorg-font-font-cursor-misc
293 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
294 Requires:       xorg-lib-libXfont >= 1.4.2
295 Obsoletes:      X11-Xvfb < 1:7.0.0
296 Obsoletes:      XFree86-Xvfb < 1:7.0.0
297
298 %description -n xorg-xserver-Xvfb
299 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
300 capable of running on machines with no display hardware and no
301 physical input devices. Xvfb emulates a dumb framebuffer using virtual
302 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
303 display. Xvfb is normally used for testing servers. Using Xvfb, the
304 mfb or cfb code for any depth can be exercised without using real
305 hardware that supports the desired depths. Xvfb has also been used to
306 test X clients against unusual depths and screen configurations, to do
307 batch processing with Xvfb as a background rendering engine, to do
308 load testing, to help with porting an X server to a new platform, and
309 to provide an unobtrusive way of running applications which really
310 don't need an X server but insist on having one.
311
312 %description -n xorg-xserver-Xvfb -l pl.UTF-8
313 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
314 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
315 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
316 używany do testowania serwerów X, może też być używany do testowania
317 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
318 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
319 serwera X, ale odmawiają uruchomienia bez niego.
320
321 %package -n xorg-xserver-Xvfb-init
322 Summary:        Init scripts for Xvfb
323 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
324 Group:          X11/Servers
325 Requires:       xorg-xserver-Xvfb
326
327 %description -n xorg-xserver-Xvfb-init
328 This package contains init scripts for Xvfb and registers Xvfb as
329 system service.
330
331 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
332 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
333 usługę systemową.
334
335 %package devel
336 Summary:        Header files for X.org server
337 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
338 Group:          X11/Development/Libraries
339 Requires:       Mesa-libGL-devel >= 7.8.0
340 Requires:       libdrm-devel >= 2.4.39
341 Requires:       pixman-devel >= %{pixman_ver}
342 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
343 Requires:       xorg-lib-libxkbfile-devel
344 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
345 Requires:       xorg-proto-dri3proto-devel >= 1.0
346 Requires:       xorg-proto-fontsproto-devel
347 Requires:       xorg-proto-glproto-devel >= 1.4.17
348 Requires:       xorg-proto-inputproto-devel >= 2.3
349 Requires:       xorg-proto-kbproto-devel >= 1.0.3
350 Requires:       xorg-proto-presentproto-devel >= 1.0
351 Requires:       xorg-proto-randrproto-devel >= 1.4.0
352 Requires:       xorg-proto-renderproto-devel >= 0.11
353 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
354 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
355 Requires:       xorg-proto-videoproto-devel
356 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
357 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
358 Requires:       xorg-proto-xineramaproto-devel
359 Requires:       xorg-proto-xproto-devel >= 7.0.22
360 Obsoletes:      X11-Xserver-devel < 1:7.0.0
361 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
362
363 %description devel
364 Header files for X.org server.
365
366 %description devel -l pl.UTF-8
367 Pliki nagłówkowe dla serwera X.org.
368
369 %package source
370 Summary:        X.org server source code
371 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
372 Group:          X11/Development/Libraries
373
374 %description source
375 X.org server source code.
376
377 %description source -l pl.UTF-8
378 Pliki źródłowe dla serwera X.org.
379
380 %package -n xorg-xserver-libglx
381 Summary:        GLX extension library for X.org server
382 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
383 Group:          X11/Servers
384 Requires:       %{name} = %{version}-%{release}
385 Requires:       Mesa-libGL >= 7.1.0
386 # Mesa version glapi tables in glx/ dir come from
387 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
388 Provides:       xorg-xserver-module(glx)
389 Obsoletes:      X11-OpenGL-core < 1:7.0.0
390 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
391
392 %description -n xorg-xserver-libglx
393 GLX extension library for X.org server.
394
395 %description -n xorg-xserver-libglx -l pl.UTF-8
396 Biblioteka rozszerzenia GLX dla serwera X.org.
397
398 %prep
399 %setup -q -n xorg-server-%{version}
400 %patch0 -p0
401 %patch1 -p1
402
403 %patch4 -p1
404 %patch5 -p1
405 %patch6 -p1
406
407 #unfortunately breaks build
408 #patch7 -p1
409
410 # xserver uses pixman-1 API/ABI so put that explictly here
411 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
412
413 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
414 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
415
416 %build
417 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
418 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
419         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
420         exit 1
421 fi
422
423 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
424 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
425         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
426         exit 1
427 fi
428
429 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
430 if [ $API != %{xorg_xserver_server_font_abi} ]; then
431         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
432         exit 1
433 fi
434 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
435 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
436         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
437         exit 1
438 fi
439 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
440 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
441         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
442         exit 1
443 fi
444
445 %{__libtoolize}
446 %{__aclocal} -I m4
447 %{__autoconf}
448 %{__autoheader}
449 %{__automake}
450 %configure \
451         --with-os-name="PLD/Linux" \
452         --with-os-vendor="PLD/Team" \
453         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
454         --with-xkb-output=/var/lib/xkb \
455         %{!?with_systemtap:--without-dtrace} \
456         --without-fop \
457         --disable-linux-acpi \
458         --disable-linux-apm \
459         --enable-aiglx \
460         %{?with_dbus:--enable-config-dbus} \
461         --enable-config-hal%{!?with_hal:=no} \
462         --enable-config-udev%{!?with_udev:=no} \
463         --enable-dga \
464         %{?with_dmx:--enable-dmx} \
465         --enable-dri2%{!?with_dri2:=no} \
466         --enable-glx-tls \
467         --enable-install-libxf86config \
468         --enable-kdrive \
469         --enable-libunwind \
470         %{?with_record:--enable-record} \
471         --enable-secure-rpc \
472         %{?with_xcsecurity:--enable-xcsecurity} \
473         --enable-xephyr \
474         %{?with_xf86bigfont:--enable-xf86bigfont} \
475         --disable-xfake \
476         --enable-xfbdev \
477         %{?with_xselinux:--enable-xselinux}
478
479 %{__make}
480
481 %install
482 rm -rf $RPM_BUILD_ROOT
483
484 %if "%{_libdir}" != "%{_exec_prefix}/lib"
485 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
486 %endif
487
488 %{__make} install \
489         DESTDIR=$RPM_BUILD_ROOT
490
491 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
492 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
493 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
494 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
495 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
496
497 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
498 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
499
500 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
501
502 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
503
504 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
505 install -d $RPM_BUILD_ROOT/etc/sysconfig
506 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
507 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
508
509 # prepare source package
510 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
511 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
512 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
513 %{__make} distclean
514 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
515 find -name '*.h' | xargs chmod a-x
516
517 %if %{with systemtap}
518 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
519 %endif
520
521 %clean
522 rm -rf $RPM_BUILD_ROOT
523
524 %triggerpostun -- xorg-xserver-server < 1.5.0
525 if [ -f /etc/X11/xorg.conf ]; then
526         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
527         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
528 %if %{without record}
529         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
530 %endif
531         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
532 fi
533
534 %post -n xorg-xserver-Xvfb-init
535 /sbin/chkconfig --add Xvfb
536 %service Xvfb restart
537
538 %preun -n xorg-xserver-Xvfb-init
539 if [ "$1" = "0" ]; then
540         %service -q Xvfb stop
541         /sbin/chkconfig --del Xvfb
542 fi
543
544 %files
545 %defattr(644,root,root,755)
546 %doc COPYING ChangeLog README
547 %attr(755,root,root) %{_bindir}/X
548 %attr(755,root,root) %{_bindir}/Xorg
549 %attr(4755,root,root) %{_bindir}/Xwrapper
550 %attr(755,root,root) %{_bindir}/cvt
551 %attr(755,root,root) %{_bindir}/gtf
552 %dir %{_libdir}/xorg
553 %{_libdir}/xorg/protocol.txt
554 %dir %{_libdir}/xorg/modules
555 %dir %{_libdir}/xorg/modules/dri
556 %dir %{_libdir}/xorg/modules/drivers
557 %dir %{_libdir}/xorg/modules/extensions
558 %dir %{_libdir}/xorg/modules/input
559 %dir %{_libdir}/xorg/modules/multimedia
560 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
561 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
562 %if "%{_libdir}" != "%{_exec_prefix}/lib"
563 %dir %{_exec_prefix}/lib/xorg
564 %dir %{_exec_prefix}/lib/xorg/modules
565 %dir %{_exec_prefix}/lib/xorg/modules/dri
566 %endif
567 %dir /var/lib/xkb
568 /var/lib/xkb/README.compiled
569 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
570 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
571 %config(missingok) /etc/security/console.apps/xserver
572 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
573 %dir /etc/X11/xorg.conf.d
574 %dir %{_datadir}/X11/xorg.conf.d
575 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
576 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
577 %{_mandir}/man1/Xorg.1*
578 %{_mandir}/man1/Xserver.1*
579 %{_mandir}/man1/cvt.1*
580 %{_mandir}/man1/gtf.1*
581 %{_mandir}/man4/exa.4*
582 %{_mandir}/man4/fbdevhw.4*
583 %{_mandir}/man5/xorg.conf.5*
584 %{_mandir}/man5/xorg.conf.d.5*
585
586 %if %{with dmx}
587 %files -n xorg-xserver-Xdmx
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/Xdmx
590 %attr(755,root,root) %{_bindir}/dmxaddinput
591 %attr(755,root,root) %{_bindir}/dmxaddscreen
592 %attr(755,root,root) %{_bindir}/dmxinfo
593 %attr(755,root,root) %{_bindir}/dmxreconfig
594 %attr(755,root,root) %{_bindir}/dmxresize
595 %attr(755,root,root) %{_bindir}/dmxrminput
596 %attr(755,root,root) %{_bindir}/dmxrmscreen
597 %attr(755,root,root) %{_bindir}/dmxtodmx
598 %attr(755,root,root) %{_bindir}/dmxwininfo
599 %attr(755,root,root) %{_bindir}/vdltodmx
600 %attr(755,root,root) %{_bindir}/xdmxconfig
601 %{_mandir}/man1/Xdmx.1*
602 %{_mandir}/man1/dmxtodmx.1*
603 %{_mandir}/man1/vdltodmx.1*
604 %{_mandir}/man1/xdmxconfig.1*
605 %endif
606
607 %files -n xorg-xserver-Xnest
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_bindir}/Xnest
610 %{_mandir}/man1/Xnest.1*
611
612 %files -n xorg-xserver-Xephyr
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_bindir}/Xephyr
615 %{_mandir}/man1/Xephyr.1*
616
617 %files -n xorg-xserver-Xfbdev
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/Xfbdev
620
621 %files -n xorg-xserver-Xvfb
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_bindir}/Xvfb
624 %attr(755,root,root) %{_bindir}/xvfb-run
625 %{_mandir}/man1/Xvfb.1*
626
627 %files -n xorg-xserver-Xvfb-init
628 %defattr(644,root,root,755)
629 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
630 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
631
632 %files devel
633 %defattr(644,root,root,755)
634 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
635 %{_includedir}/xorg
636 %{_libdir}/libxf86config.a
637 %{_libdir}/libxf86config.la
638 %{_aclocaldir}/xorg-server.m4
639 %{_pkgconfigdir}/xorg-server.pc
640
641 %files source
642 %defattr(644,root,root,755)
643 # keep file perms from install time, but have default defattr to keep adapter happy
644 %defattr(-,root,root,755)
645 %{_usrsrc}/%{name}-%{version}
646
647 %files -n xorg-xserver-libglx
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.113079 seconds and 4 git commands to generate.