]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- updated dependencies
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_without  glamor          # glamor dix module
18 %bcond_without  systemtap       # systemtap/dtrace probes
19 %bcond_without  libunwind       # use libunwind for backtracing
20 #
21 # ABI versions, see hw/xfree86/common/xf86Module.h
22 %define xorg_xserver_server_ansic_abi           0.4
23 %define xorg_xserver_server_extension_abi       10.0
24 %define xorg_xserver_server_font_abi            0.6
25 %define xorg_xserver_server_videodrv_abi        23.0
26 %define xorg_xserver_server_xinput_abi          24.1
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        1.19.0
38 Release:        1
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
42 # Source0-md5:  6a4d01e4e5047ab8f556960424ba1fa9
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48 Patch1:         %{name}-xwrapper-pam.patch
49 Patch2:         dtrace-link.patch
50
51 Patch4:         %{name}-builtin-SHA1.patch
52
53 Patch6:         110_nvidia_slowdow_fix.patch
54 URL:            http://xorg.freedesktop.org/
55 BuildRequires:  Mesa-libGL-devel >= 7.8.1
56 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
57 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
58 # for glx headers
59 BuildRequires:  OpenGL-GLX-devel
60 %{?with_xselinux:BuildRequires: audit-libs-devel}
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  cpp
64 BuildRequires:  docbook-dtd43-xml
65 #BuildRequires: doxygen >= 1.6.1
66 %if %{with hal} || %{with dbus}
67 BuildRequires:  dbus-devel >= 1.0
68 %endif
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.46
71 %if %{with glamor} || %{with wayland}
72 BuildRequires:  libepoxy-devel
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtool >= 2:2.2
76 %{?with_libunwind:BuildRequires:        libunwind-devel}
77 BuildRequires:  libxcb-devel >= 1.6
78 BuildRequires:  pam-devel
79 BuildRequires:  perl-base
80 BuildRequires:  pixman-devel >= %{pixman_ver}
81 BuildRequires:  pkgconfig >= 1:0.19
82 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
83 BuildRequires:  systemd-devel >= 209
84 BuildRequires:  udev-devel >= 1:143
85 # wayland-client
86 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
87 %{?with_wayland:BuildRequires:  wayland-protocols >= 1.1}
88 BuildRequires:  xcb-util-devel
89 BuildRequires:  xcb-util-image-devel
90 BuildRequires:  xcb-util-keysyms-devel
91 BuildRequires:  xcb-util-renderutil-devel
92 BuildRequires:  xcb-util-wm-devel
93 BuildRequires:  xmlto >= 0.0.20
94 BuildRequires:  xorg-app-mkfontscale
95 BuildRequires:  xorg-font-font-util >= 1.1
96 BuildRequires:  xorg-lib-libX11-devel >= 1.6
97 BuildRequires:  xorg-lib-libXau-devel
98 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
99 BuildRequires:  xorg-lib-libXdamage-devel
100 BuildRequires:  xorg-lib-libXdmcp-devel
101 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
102 BuildRequires:  xorg-lib-libXfixes-devel
103 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
104 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
105 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
106 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
107 BuildRequires:  xorg-lib-libXrender-devel
108 BuildRequires:  xorg-lib-libXres-devel
109 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
110 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
111 BuildRequires:  xorg-lib-libXv-devel
112 BuildRequires:  xorg-lib-libXxf86dga-devel
113 BuildRequires:  xorg-lib-libXxf86misc-devel
114 BuildRequires:  xorg-lib-libXxf86vm-devel
115 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
116 BuildRequires:  xorg-lib-libfontenc-devel
117 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
118 BuildRequires:  xorg-lib-libxkbfile-devel
119 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
120 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
121 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
122 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
123 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
124 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
125 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
126 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
127 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
128 BuildRequires:  xorg-proto-fontcacheproto-devel
129 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
130 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
131 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
132 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
133 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
134 BuildRequires:  xorg-proto-printproto-devel
135 BuildRequires:  xorg-proto-randrproto-devel >= 1.5.0
136 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
137 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
138 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
139 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
140 BuildRequires:  xorg-proto-videoproto-devel
141 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
142 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
143 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
144 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
145 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
146 BuildRequires:  xorg-proto-xf86miscproto-devel
147 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
148 BuildRequires:  xorg-proto-xineramaproto-devel
149 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
150 BuildRequires:  xorg-sgml-doctools >= 1.8
151 BuildRequires:  xorg-util-util-macros >= 1.14
152 #BR: tslib (for KDRIVE only)
153 Requires(triggerpostun):        sed >= 4.0
154 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
155 Requires:       libdrm >= 2.4.46
156 Requires:       pixman >= %{pixman_ver}
157 Requires:       udev-libs >= 1:143
158 Requires:       xkeyboard-config
159 # for rgb.txt
160 Requires:       xorg-app-rgb >= 0.99.3
161 Requires:       xorg-app-xkbcomp
162 Requires:       xorg-lib-libXfont2 >= 2.0.0
163 Requires:       xorg-lib-libpciaccess >= 0.12.901
164 Requires:       xorg-lib-libxshmfence >= 1.1
165 Suggests:       dbus-x11 >= 1.0
166 %{?with_hal:Suggests:   hal}
167 Suggests:       udev-acl >= 1:143
168 %{?with_udev:Suggests:  udev-core >= 1:143}
169 Suggests:       xkeyboard-config
170 Suggests:       xorg-driver-input-libinput
171 Provides:       xorg-driver-video
172 Provides:       xorg-driver-video-modesetting
173 Provides:       xorg-xserver-libdri = %{version}-%{release}
174 Provides:       xorg-xserver-module(dri)
175 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
176 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
177 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
178 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
179 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
180 Obsoletes:      X11-Xserver < 1:7.0.0
181 Obsoletes:      X11-driver-i2c < 1:7.0.0
182 Obsoletes:      X11-modules < 1:7.0.0
183 Obsoletes:      X11-setup < 1:7.0.0
184 Obsoletes:      XFree86-Xserver < 1:7.0.0
185 Obsoletes:      XFree86-modules < 1:7.0.0
186 Obsoletes:      XFree86-setup < 1:7.0.0
187 Obsoletes:      Xserver
188 %{?with_glamor:Obsoletes:       glamor}
189 Obsoletes:      xorg-xserver-libdri
190 Obsoletes:      xorg-xserver-server-xorgcfg
191 Obsoletes:      xorg-driver-video-modesetting
192 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
193
194 %description
195 Xorg server is a generally used X server which uses display hardware.
196 It requires proper driver for your display hardware.
197
198 %description -l pl.UTF-8
199 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
200 graficznej. Do działania wymaga odpowiedniego sterownika.
201
202 %package -n xorg-xserver-Xdmx
203 Summary:        Xdmx - distributed multi-head X server
204 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
205 Group:          X11/Servers
206 Requires:       pixman >= %{pixman_ver}
207 Requires:       xorg-lib-libX11 >= 1.6
208 Requires:       xorg-lib-libXext >= 1.0.99.4
209 Requires:       xorg-lib-libXfont2 >= 2.0.0
210 Requires:       xorg-lib-libXi >= 1.2.99.1
211 Requires:       xorg-lib-libdmx >= 1.0.99.1
212
213 %description -n xorg-xserver-Xdmx
214 Xdmx - distributed multi-head X server.
215
216 %description -n xorg-xserver-Xdmx -l pl.UTF-8
217 Xdmx - rozproszony, wielomonitorowy serwer X.
218
219 %package -n xorg-xserver-Xnest
220 Summary:        Xnest - nested X server
221 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
222 Group:          X11/Servers
223 Requires:       pixman >= %{pixman_ver}
224 Requires:       xorg-lib-libXext >= 1.0.99.4
225 Requires:       xorg-lib-libXfont2 >= 2.0.0
226 Obsoletes:      X11-Xnest < 1:7.0.0
227 Obsoletes:      XFree86-Xnest < 1:7.0.0
228 Obsoletes:      Xserver-Xnest
229
230 %description -n xorg-xserver-Xnest
231 Xnest is an X Window System server which runs in an X window. Xnest is
232 a 'nested' window server, actually a client of the real X server,
233 which manages windows and graphics requests for Xnest, while Xnest
234 manages the windows and graphics requests for its own clients.
235
236 %description -n xorg-xserver-Xnest -l pl.UTF-8
237 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
238 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
239 serwer X dla własnych klientów.
240
241 %description -n xorg-xserver-Xnest -l ru.UTF-8
242 Xnest - это сервер X Window System, который работает в окне X. На
243 самом деле это клиент реального X-сервера, который управляет окнами и
244 графическими запросами для Xnest в то время, как Xnest управляет
245 окнами и графическими запросами для своих собственных клиентов.
246
247 %description -n xorg-xserver-Xnest -l uk.UTF-8
248 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
249 клієнт реального X-сервера, який керує вікнами та графічними запитами
250 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
251 своїх власних клієнтів.
252
253 %package -n xorg-xserver-Xephyr
254 Summary:        Xephyr - nested X server
255 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
256 Group:          X11/Servers
257 Requires:       Mesa-libGL >= 7.1.0
258 Requires:       libxcb >= 1.6
259 Requires:       pixman >= %{pixman_ver}
260 Requires:       xorg-lib-libXfont2 >= 2.0.0
261
262 %description -n xorg-xserver-Xephyr
263 Xephyr is a kdrive server that outputs to a window on a pre-existing
264 'host' X display. Think Xnest but with support for modern extensions
265 like composite, damage and randr.
266
267 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
268 the host X server, Xephyr is a real X server which uses the host X
269 server window as "framebuffer" via fast SHM XImages.
270
271 It also has support for 'visually' debugging what the server is
272 painting.
273
274 %description -n xorg-xserver-Xephyr -l pl.UTF-8
275 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
276 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
277 wspólczesnych rozszerzeń jak composite, damage i randr.
278
279 %package -n xorg-xserver-Xfbdev
280 Summary:        Xfbdev - Linux framebuffer device X server
281 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
282 Group:          X11/Servers
283 Requires:       pixman >= %{pixman_ver}
284 Requires:       xorg-lib-libXfont2 >= 2.0.0
285
286 %description -n xorg-xserver-Xfbdev
287 Xfbdev is a Linux framebuffer device X server based on the kdrive X
288 server.
289
290 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
291 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
292
293 %package -n xorg-xserver-Xvfb
294 Summary:        Xvfb - virtual framebuffer X server
295 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
296 Group:          X11/Servers
297 Requires:       Mesa-libGL >= 7.1.0
298 Requires:       mktemp
299 Requires:       pixman >= %{pixman_ver}
300 Requires:       util-linux
301 Requires:       which
302 Requires:       xkeyboard-config
303 Requires:       xorg-app-xauth
304 Requires:       xorg-app-xkbcomp
305 Requires:       xorg-lib-libXfont2 >= 2.0.0
306 Obsoletes:      X11-Xvfb < 1:7.0.0
307 Obsoletes:      XFree86-Xvfb < 1:7.0.0
308
309 %description -n xorg-xserver-Xvfb
310 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
311 capable of running on machines with no display hardware and no
312 physical input devices. Xvfb emulates a dumb framebuffer using virtual
313 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
314 display. Xvfb is normally used for testing servers. Using Xvfb, the
315 mfb or cfb code for any depth can be exercised without using real
316 hardware that supports the desired depths. Xvfb has also been used to
317 test X clients against unusual depths and screen configurations, to do
318 batch processing with Xvfb as a background rendering engine, to do
319 load testing, to help with porting an X server to a new platform, and
320 to provide an unobtrusive way of running applications which really
321 don't need an X server but insist on having one.
322
323 %description -n xorg-xserver-Xvfb -l pl.UTF-8
324 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
325 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
326 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
327 używany do testowania serwerów X, może też być używany do testowania
328 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
329 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
330 serwera X, ale odmawiają uruchomienia bez niego.
331
332 %package -n xorg-xserver-Xvfb-init
333 Summary:        Init scripts for Xvfb
334 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
335 Group:          X11/Servers
336 Requires:       xorg-xserver-Xvfb
337
338 %description -n xorg-xserver-Xvfb-init
339 This package contains init scripts for Xvfb and registers Xvfb as
340 system service.
341
342 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
343 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
344 usługę systemową.
345
346 %package -n xorg-xserver-Xwayland
347 Summary:        Xwayland - X server integrated into a Wayland window system
348 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
349 Group:          X11/Servers
350 Requires:       pixman >= %{pixman_ver}
351 Requires:       xorg-lib-libX11 >= 1.6
352 Requires:       xorg-lib-libXext >= 1.0.99.4
353 Requires:       xorg-lib-libXfont2 >= 2.0.0
354 Requires:       xorg-lib-libXi >= 1.2.99.1
355
356 %description -n xorg-xserver-Xwayland
357 Xwayland - server integrated into a Wayland window system.
358
359 %description -n xorg-xserver-Xwayland -l pl.UTF-8
360 Xwayland - serwer X integrowalny w Wayland.
361
362 %package devel
363 Summary:        Header files for X.org server
364 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
365 Group:          X11/Development/Libraries
366 Requires:       Mesa-libGL-devel >= 7.8.0
367 Requires:       libdrm-devel >= 2.4.46
368 Requires:       pixman-devel >= %{pixman_ver}
369 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
370 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
371 Requires:       xorg-lib-libxkbfile-devel
372 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
373 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
374 Requires:       xorg-proto-dri3proto-devel >= 1.0
375 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
376 Requires:       xorg-proto-glproto-devel >= 1.4.17
377 Requires:       xorg-proto-inputproto-devel >= 2.3
378 Requires:       xorg-proto-kbproto-devel >= 1.0.3
379 Requires:       xorg-proto-presentproto-devel >= 1.0
380 Requires:       xorg-proto-randrproto-devel >= 1.5.0
381 Requires:       xorg-proto-renderproto-devel >= 0.11
382 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
383 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
384 Requires:       xorg-proto-videoproto-devel
385 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
386 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
387 Requires:       xorg-proto-xineramaproto-devel
388 Requires:       xorg-proto-xproto-devel >= 7.0.31
389 Obsoletes:      X11-Xserver-devel < 1:7.0.0
390 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
391 %{?with_glamor:Obsoletes:       glamor-devel}
392
393 %description devel
394 Header files for X.org server.
395
396 %description devel -l pl.UTF-8
397 Pliki nagłówkowe dla serwera X.org.
398
399 %package source
400 Summary:        X.org server source code
401 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
402 Group:          X11/Development/Libraries
403
404 %description source
405 X.org server source code.
406
407 %description source -l pl.UTF-8
408 Pliki źródłowe dla serwera X.org.
409
410 %package -n xorg-xserver-libglx
411 Summary:        GLX extension library for X.org server
412 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
413 Group:          X11/Servers
414 Requires:       %{name} = %{version}-%{release}
415 Requires:       Mesa-libGL >= 7.1.0
416 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
417 # Mesa version glapi tables in glx/ dir come from
418 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
419 Provides:       xorg-xserver-module(glx)
420 Obsoletes:      X11-OpenGL-core < 1:7.0.0
421 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
422
423 %description -n xorg-xserver-libglx
424 GLX extension library for X.org server.
425
426 %description -n xorg-xserver-libglx -l pl.UTF-8
427 Biblioteka rozszerzenia GLX dla serwera X.org.
428
429 %prep
430 %setup -q -n xorg-server-%{version}
431 %patch1 -p1
432 %patch2 -p1
433
434 %patch4 -p1
435
436 %patch6 -p1
437
438 # xserver uses pixman-1 API/ABI so put that explictly here
439 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
440
441 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
442 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
443
444 %build
445 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
446 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
447         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
448         exit 1
449 fi
450
451 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
452 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
453         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
454         exit 1
455 fi
456
457 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
458 if [ $API != %{xorg_xserver_server_font_abi} ]; then
459         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
460         exit 1
461 fi
462 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
463 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
464         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
465         exit 1
466 fi
467 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
468 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
469         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
470         exit 1
471 fi
472
473 %{__libtoolize}
474 %{__aclocal} -I m4
475 %{__autoconf}
476 %{__autoheader}
477 %{__automake}
478 %configure \
479         --libexecdir=%{_libdir}/xorg \
480         --with-os-name="PLD/Linux" \
481         --with-os-vendor="PLD/Team" \
482         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
483         --with-xkb-output=/var/lib/xkb \
484         --disable-linux-acpi \
485         --disable-linux-apm \
486         --enable-aiglx \
487         %{?with_dbus:--enable-config-dbus} \
488         --enable-config-hal%{!?with_hal:=no} \
489         --enable-config-udev%{!?with_udev:=no} \
490         --enable-dga \
491         %{?with_dmx:--enable-dmx} \
492         --enable-dri2%{!?with_dri2:=no} \
493         --enable-dri3%{!?with_dri3:=no} \
494         %{?with_glamor:--enable-glamor} \
495         --enable-kdrive \
496         %{?with_libunwind:--enable-libunwind} \
497         %{?with_record:--enable-record} \
498         --enable-secure-rpc \
499         %{?with_xcsecurity:--enable-xcsecurity} \
500         --enable-xephyr \
501         %{?with_xf86bigfont:--enable-xf86bigfont} \
502         --disable-xfake \
503         --enable-xfbdev \
504         %{?with_xselinux:--enable-xselinux} \
505         %{?with_wayland:--enable-xwayland} \
506         %{!?with_systemtap:--without-dtrace} \
507         --without-fop \
508         --enable-suid-wrapper \
509         --with-systemd-daemon
510
511 %{__make} -j1
512
513 %install
514 rm -rf $RPM_BUILD_ROOT
515
516 %if "%{_libdir}" != "%{_exec_prefix}/lib"
517 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
518 %endif
519
520 %{__make} install \
521         DESTDIR=$RPM_BUILD_ROOT
522
523 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
524 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
525 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
526 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
527 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
528
529 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
530 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
531
532 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
533
534 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
535
536 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
537 install -d $RPM_BUILD_ROOT/etc/sysconfig
538 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
539 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
540
541 # Xorg.wrap config
542 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
543 # allowed values: rootonly console anybody pam
544 allowed_users = pam
545
546 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
547 #needs_root_rights = yes
548 EOF
549
550 # compatibility with old xwrapper
551 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
552
553 # prepare source package
554 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
555 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
556 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
557 %{__make} distclean
558 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
559 find -name '*.h' | xargs chmod a-x
560
561 %if %{with systemtap}
562 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
563 %endif
564
565 %clean
566 rm -rf $RPM_BUILD_ROOT
567
568 %triggerpostun -- xorg-xserver-server < 1.5.0
569 if [ -f /etc/X11/xorg.conf ]; then
570         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
571         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
572 %if %{without record}
573         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
574 %endif
575         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
576 fi
577
578 %post -n xorg-xserver-Xvfb-init
579 /sbin/chkconfig --add Xvfb
580 %service Xvfb restart
581
582 %preun -n xorg-xserver-Xvfb-init
583 if [ "$1" = "0" ]; then
584         %service -q Xvfb stop
585         /sbin/chkconfig --del Xvfb
586 fi
587
588 %files
589 %defattr(644,root,root,755)
590 %doc COPYING ChangeLog README
591 %attr(755,root,root) %{_bindir}/X
592 %attr(755,root,root) %{_bindir}/Xorg
593 %attr(4755,root,root) %{_bindir}/Xwrapper
594 %attr(755,root,root) %{_bindir}/cvt
595 %attr(755,root,root) %{_bindir}/gtf
596 %dir %{_libdir}/xorg
597 %{_libdir}/xorg/protocol.txt
598 %attr(755,root,root) %{_libdir}/xorg/Xorg
599 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
600 %dir %{_libdir}/xorg/modules
601 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
602 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
603 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
604 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
605 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
606 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
607 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
608 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
609 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
610 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
611 %dir %{_libdir}/xorg/modules/dri
612 %dir %{_libdir}/xorg/modules/drivers
613 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
614 %dir %{_libdir}/xorg/modules/extensions
615 %dir %{_libdir}/xorg/modules/input
616 %if "%{_libdir}" != "%{_exec_prefix}/lib"
617 %dir %{_exec_prefix}/lib/xorg
618 %dir %{_exec_prefix}/lib/xorg/modules
619 %dir %{_exec_prefix}/lib/xorg/modules/dri
620 %endif
621 %dir /var/lib/xkb
622 /var/lib/xkb/README.compiled
623 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
624 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
625 %config(missingok) /etc/security/console.apps/xserver
626 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
627 %dir /etc/X11/xorg.conf.d
628 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
629 %dir %{_datadir}/X11/xorg.conf.d
630 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
631 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
632 %{_mandir}/man1/Xorg.1*
633 %{_mandir}/man1/Xorg.wrap.1*
634 %{_mandir}/man1/Xserver.1*
635 %{_mandir}/man1/cvt.1*
636 %{_mandir}/man1/gtf.1*
637 %{_mandir}/man4/exa.4*
638 %{_mandir}/man4/fbdevhw.4*
639 %{_mandir}/man4/modesetting.4*
640 %{_mandir}/man5/Xwrapper.config.5*
641 %{_mandir}/man5/xorg.conf.5*
642 %{_mandir}/man5/xorg.conf.d.5*
643
644 %if %{with dmx}
645 %files -n xorg-xserver-Xdmx
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_bindir}/Xdmx
648 %attr(755,root,root) %{_bindir}/dmxaddinput
649 %attr(755,root,root) %{_bindir}/dmxaddscreen
650 %attr(755,root,root) %{_bindir}/dmxinfo
651 %attr(755,root,root) %{_bindir}/dmxreconfig
652 %attr(755,root,root) %{_bindir}/dmxresize
653 %attr(755,root,root) %{_bindir}/dmxrminput
654 %attr(755,root,root) %{_bindir}/dmxrmscreen
655 %attr(755,root,root) %{_bindir}/dmxtodmx
656 %attr(755,root,root) %{_bindir}/dmxwininfo
657 %attr(755,root,root) %{_bindir}/vdltodmx
658 %attr(755,root,root) %{_bindir}/xdmxconfig
659 %{_mandir}/man1/Xdmx.1*
660 %{_mandir}/man1/dmxtodmx.1*
661 %{_mandir}/man1/vdltodmx.1*
662 %{_mandir}/man1/xdmxconfig.1*
663 %endif
664
665 %files -n xorg-xserver-Xnest
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/Xnest
668 %{_mandir}/man1/Xnest.1*
669
670 %files -n xorg-xserver-Xephyr
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_bindir}/Xephyr
673 %{_mandir}/man1/Xephyr.1*
674
675 %files -n xorg-xserver-Xfbdev
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_bindir}/Xfbdev
678
679 %files -n xorg-xserver-Xvfb
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_bindir}/Xvfb
682 %attr(755,root,root) %{_bindir}/xvfb-run
683 %{_mandir}/man1/Xvfb.1*
684
685 %files -n xorg-xserver-Xvfb-init
686 %defattr(644,root,root,755)
687 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
688 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
689
690 %if %{with wayland}
691 %files -n xorg-xserver-Xwayland
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_bindir}/Xwayland
694 %endif
695
696 %files devel
697 %defattr(644,root,root,755)
698 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
699 %{_includedir}/xorg
700 %{_aclocaldir}/xorg-server.m4
701 %{_pkgconfigdir}/xorg-server.pc
702
703 %files source
704 %defattr(644,root,root,755)
705 # keep file perms from install time, but have default defattr to keep adapter happy
706 %defattr(-,root,root,755)
707 %{_usrsrc}/%{name}-%{version}
708
709 %files -n xorg-xserver-libglx
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.11683 seconds and 4 git commands to generate.