]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- up to 1.18.1
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  record          # RECORD extension
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 %bcond_without  dmx             # DMX DDX (Xdmx server)
15 %bcond_without  wayland         # Wayland DDX (Xwayland server)
16 %bcond_without  glamor          # glamor dix module
17 %bcond_without  systemtap       # systemtap/dtrace probes
18 %bcond_without  libunwind       # use libunwind for backtracing
19 #
20 # ABI versions, see hw/xfree86/common/xf86Module.h
21 %define xorg_xserver_server_ansic_abi           0.4
22 %define xorg_xserver_server_extension_abi       9.0
23 %define xorg_xserver_server_font_abi            0.6
24 %define xorg_xserver_server_videodrv_abi        20.0
25 %define xorg_xserver_server_xinput_abi          22.1
26
27 %define pixman_ver      0.30.0
28
29 %ifarch x32
30 %undefine       with_libunwind
31 %endif
32
33 Summary:        X.org server
34 Summary(pl.UTF-8):      Serwer X.org
35 Name:           xorg-xserver-server
36 Version:        1.18.1
37 Release:        1
38 License:        MIT
39 Group:          X11/Servers
40 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
41 # Source0-md5:  1b9e85420c3790dd487addd50313f4da
42 Source1:        10-quirks.conf
43 Source2:        xserver.pamd
44 Source10:       %{name}-Xvfb.init
45 Source11:       %{name}-Xvfb.sysconfig
46 Source12:       xvfb-run.sh
47 Patch1:         %{name}-xwrapper-pam.patch
48 Patch2:         dtrace-link.patch
49
50 Patch4:         %{name}-builtin-SHA1.patch
51
52 Patch6:         110_nvidia_slowdow_fix.patch
53 URL:            http://xorg.freedesktop.org/
54 BuildRequires:  Mesa-libGL-devel >= 7.8.1
55 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
56 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
57 # for glx headers
58 BuildRequires:  OpenGL-GLX-devel
59 %{?with_xselinux:BuildRequires: audit-libs-devel}
60 BuildRequires:  autoconf >= 2.60
61 BuildRequires:  automake
62 BuildRequires:  cpp
63 BuildRequires:  docbook-dtd43-xml
64 #BuildRequires: doxygen >= 1.6.1
65 %if %{with hal} || %{with dbus}
66 BuildRequires:  dbus-devel >= 1.0
67 %endif
68 %{?with_hal:BuildRequires:      hal-devel}
69 BuildRequires:  libdrm-devel >= 2.4.46
70 %if %{with glamor} || %{with wayland}
71 BuildRequires:  libepoxy-devel
72 %endif
73 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
74 BuildRequires:  libtool >= 2:2.2
75 %{?with_libunwind:BuildRequires:        libunwind-devel}
76 BuildRequires:  libxcb-devel >= 1.6
77 BuildRequires:  pam-devel
78 BuildRequires:  perl-base
79 BuildRequires:  pixman-devel >= %{pixman_ver}
80 BuildRequires:  pkgconfig >= 1:0.19
81 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
82 BuildRequires:  systemd-devel
83 BuildRequires:  udev-devel >= 1:143
84 # wayland-client
85 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
86 BuildRequires:  xcb-util-devel
87 BuildRequires:  xcb-util-image-devel
88 BuildRequires:  xcb-util-keysyms-devel
89 BuildRequires:  xcb-util-renderutil-devel
90 BuildRequires:  xcb-util-wm-devel
91 BuildRequires:  xmlto >= 0.0.20
92 BuildRequires:  xorg-app-mkfontscale
93 BuildRequires:  xorg-font-font-util >= 1.1
94 BuildRequires:  xorg-lib-libX11-devel >= 1.6
95 BuildRequires:  xorg-lib-libXau-devel
96 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
97 BuildRequires:  xorg-lib-libXdamage-devel
98 BuildRequires:  xorg-lib-libXdmcp-devel
99 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
100 BuildRequires:  xorg-lib-libXfixes-devel
101 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
102 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
103 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
104 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
105 BuildRequires:  xorg-lib-libXrender-devel
106 BuildRequires:  xorg-lib-libXres-devel
107 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
108 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
109 BuildRequires:  xorg-lib-libXv-devel
110 BuildRequires:  xorg-lib-libXxf86dga-devel
111 BuildRequires:  xorg-lib-libXxf86misc-devel
112 BuildRequires:  xorg-lib-libXxf86vm-devel
113 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
114 BuildRequires:  xorg-lib-libfontenc-devel
115 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
116 BuildRequires:  xorg-lib-libxkbfile-devel
117 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
118 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
119 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
120 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
121 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
122 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
123 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
124 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
125 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
126 BuildRequires:  xorg-proto-fontcacheproto-devel
127 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
128 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
129 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
130 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
131 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
132 BuildRequires:  xorg-proto-printproto-devel
133 BuildRequires:  xorg-proto-randrproto-devel >= 1.5.0
134 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
135 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
136 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
137 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
138 BuildRequires:  xorg-proto-videoproto-devel
139 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
140 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
141 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
142 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
143 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
144 BuildRequires:  xorg-proto-xf86miscproto-devel
145 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
146 BuildRequires:  xorg-proto-xineramaproto-devel
147 BuildRequires:  xorg-proto-xproto-devel >= 7.0.28
148 BuildRequires:  xorg-sgml-doctools >= 1.8
149 BuildRequires:  xorg-util-util-macros >= 1.14
150 #BR: tslib (for KDRIVE only)
151 Requires(triggerpostun):        sed >= 4.0
152 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
153 Requires:       libdrm >= 2.4.46
154 Requires:       pixman >= %{pixman_ver}
155 Requires:       udev-libs >= 1:143
156 Requires:       xkeyboard-config
157 # for rgb.txt
158 Requires:       xorg-app-rgb >= 0.99.3
159 Requires:       xorg-app-xkbcomp
160 Requires:       xorg-lib-libXfont >= 1.4.2
161 Requires:       xorg-lib-libpciaccess >= 0.12.901
162 Requires:       xorg-lib-libxshmfence >= 1.1
163 Suggests:       dbus-x11 >= 1.0
164 %{?with_hal:Suggests:   hal}
165 Suggests:       udev-acl >= 1:143
166 %{?with_udev:Suggests:  udev-core >= 1:143}
167 Suggests:       xkeyboard-config
168 Suggests:       xorg-driver-input-evdev
169 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
170 Suggests:       xorg-driver-video
171 Provides:       xorg-xserver-libdri = %{version}-%{release}
172 Provides:       xorg-xserver-module(dri)
173 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
174 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
175 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
176 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
177 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
178 Obsoletes:      X11-Xserver < 1:7.0.0
179 Obsoletes:      X11-driver-i2c < 1:7.0.0
180 Obsoletes:      X11-modules < 1:7.0.0
181 Obsoletes:      X11-setup < 1:7.0.0
182 Obsoletes:      XFree86-Xserver < 1:7.0.0
183 Obsoletes:      XFree86-modules < 1:7.0.0
184 Obsoletes:      XFree86-setup < 1:7.0.0
185 Obsoletes:      Xserver
186 %{?with_glamor:Obsoletes:       glamor}
187 Obsoletes:      xorg-xserver-libdri
188 Obsoletes:      xorg-xserver-server-xorgcfg
189 Obsoletes:      xorg-driver-video-modesetting
190 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
191
192 # avoid self-dependencies on included modules
193 %define         _noautoreq      libscanpci.so libxf1bpp.so
194
195 %description
196 Xorg server is a generally used X server which uses display hardware.
197 It requires proper driver for your display hardware.
198
199 %description -l pl.UTF-8
200 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
201 graficznej. Do działania wymaga odpowiedniego sterownika.
202
203 %package -n xorg-xserver-Xdmx
204 Summary:        Xdmx - distributed multi-head X server
205 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
206 Group:          X11/Servers
207 Requires:       pixman >= %{pixman_ver}
208 Requires:       xorg-lib-libX11 >= 1.6
209 Requires:       xorg-lib-libXext >= 1.0.99.4
210 Requires:       xorg-lib-libXfont >= 1.4.2
211 Requires:       xorg-lib-libXi >= 1.2.99.1
212 Requires:       xorg-lib-libdmx >= 1.0.99.1
213
214 %description -n xorg-xserver-Xdmx
215 Xdmx - distributed multi-head X server.
216
217 %description -n xorg-xserver-Xdmx -l pl.UTF-8
218 Xdmx - rozproszony, wielomonitorowy serwer X.
219
220 %package -n xorg-xserver-Xnest
221 Summary:        Xnest - nested X server
222 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
223 Group:          X11/Servers
224 Requires:       pixman >= %{pixman_ver}
225 Requires:       xorg-lib-libXext >= 1.0.99.4
226 Requires:       xorg-lib-libXfont >= 1.4.2
227 Obsoletes:      X11-Xnest < 1:7.0.0
228 Obsoletes:      XFree86-Xnest < 1:7.0.0
229 Obsoletes:      Xserver-Xnest
230
231 %description -n xorg-xserver-Xnest
232 Xnest is an X Window System server which runs in an X window. Xnest is
233 a 'nested' window server, actually a client of the real X server,
234 which manages windows and graphics requests for Xnest, while Xnest
235 manages the windows and graphics requests for its own clients.
236
237 %description -n xorg-xserver-Xnest -l pl.UTF-8
238 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
239 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
240 serwer X dla własnych klientów.
241
242 %description -n xorg-xserver-Xnest -l ru.UTF-8
243 Xnest - это сервер X Window System, который работает в окне X. На
244 самом деле это клиент реального X-сервера, который управляет окнами и
245 графическими запросами для Xnest в то время, как Xnest управляет
246 окнами и графическими запросами для своих собственных клиентов.
247
248 %description -n xorg-xserver-Xnest -l uk.UTF-8
249 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
250 клієнт реального X-сервера, який керує вікнами та графічними запитами
251 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
252 своїх власних клієнтів.
253
254 %package -n xorg-xserver-Xephyr
255 Summary:        Xephyr - nested X server
256 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
257 Group:          X11/Servers
258 Requires:       Mesa-libGL >= 7.1.0
259 Requires:       libxcb >= 1.6
260 Requires:       pixman >= %{pixman_ver}
261 Requires:       xorg-lib-libXfont >= 1.4.2
262
263 %description -n xorg-xserver-Xephyr
264 Xephyr is a kdrive server that outputs to a window on a pre-existing
265 'host' X display. Think Xnest but with support for modern extensions
266 like composite, damage and randr.
267
268 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
269 the host X server, Xephyr is a real X server which uses the host X
270 server window as "framebuffer" via fast SHM XImages.
271
272 It also has support for 'visually' debugging what the server is
273 painting.
274
275 %description -n xorg-xserver-Xephyr -l pl.UTF-8
276 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
277 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
278 wspólczesnych rozszerzeń jak composite, damage i randr.
279
280 %package -n xorg-xserver-Xfbdev
281 Summary:        Xfbdev - Linux framebuffer device X server
282 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
283 Group:          X11/Servers
284 Requires:       pixman >= %{pixman_ver}
285 Requires:       xorg-lib-libXfont >= 1.4.2
286
287 %description -n xorg-xserver-Xfbdev
288 Xfbdev is a Linux framebuffer device X server based on the kdrive X
289 server.
290
291 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
292 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
293
294 %package -n xorg-xserver-Xvfb
295 Summary:        Xvfb - virtual framebuffer X server
296 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
297 Group:          X11/Servers
298 Requires:       Mesa-libGL >= 7.1.0
299 Requires:       mktemp
300 Requires:       pixman >= %{pixman_ver}
301 Requires:       util-linux
302 Requires:       which
303 Requires:       xkeyboard-config
304 Requires:       xorg-app-xauth
305 Requires:       xorg-app-xkbcomp
306 Requires:       xorg-lib-libXfont >= 1.4.2
307 Obsoletes:      X11-Xvfb < 1:7.0.0
308 Obsoletes:      XFree86-Xvfb < 1:7.0.0
309
310 %description -n xorg-xserver-Xvfb
311 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
312 capable of running on machines with no display hardware and no
313 physical input devices. Xvfb emulates a dumb framebuffer using virtual
314 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
315 display. Xvfb is normally used for testing servers. Using Xvfb, the
316 mfb or cfb code for any depth can be exercised without using real
317 hardware that supports the desired depths. Xvfb has also been used to
318 test X clients against unusual depths and screen configurations, to do
319 batch processing with Xvfb as a background rendering engine, to do
320 load testing, to help with porting an X server to a new platform, and
321 to provide an unobtrusive way of running applications which really
322 don't need an X server but insist on having one.
323
324 %description -n xorg-xserver-Xvfb -l pl.UTF-8
325 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
326 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
327 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
328 używany do testowania serwerów X, może też być używany do testowania
329 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
330 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
331 serwera X, ale odmawiają uruchomienia bez niego.
332
333 %package -n xorg-xserver-Xvfb-init
334 Summary:        Init scripts for Xvfb
335 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
336 Group:          X11/Servers
337 Requires:       xorg-xserver-Xvfb
338
339 %description -n xorg-xserver-Xvfb-init
340 This package contains init scripts for Xvfb and registers Xvfb as
341 system service.
342
343 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
344 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
345 usługę systemową.
346
347 %package -n xorg-xserver-Xwayland
348 Summary:        Xwayland - X server integrated into a Wayland window system
349 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
350 Group:          X11/Servers
351 Requires:       pixman >= %{pixman_ver}
352 Requires:       xorg-lib-libX11 >= 1.6
353 Requires:       xorg-lib-libXext >= 1.0.99.4
354 Requires:       xorg-lib-libXfont >= 1.4.2
355 Requires:       xorg-lib-libXi >= 1.2.99.1
356
357 %description -n xorg-xserver-Xwayland
358 Xwayland - server integrated into a Wayland window system.
359
360 %description -n xorg-xserver-Xwayland -l pl.UTF-8
361 Xwayland - serwer X integrowalny w Wayland.
362
363 %package devel
364 Summary:        Header files for X.org server
365 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
366 Group:          X11/Development/Libraries
367 Requires:       Mesa-libGL-devel >= 7.8.0
368 Requires:       libdrm-devel >= 2.4.46
369 Requires:       pixman-devel >= %{pixman_ver}
370 Requires:       xorg-lib-libXfont-devel
371 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
372 Requires:       xorg-lib-libxkbfile-devel
373 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
374 Requires:       xorg-proto-dri3proto-devel >= 1.0
375 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
376 Requires:       xorg-proto-glproto-devel >= 1.4.17
377 Requires:       xorg-proto-inputproto-devel >= 2.3
378 Requires:       xorg-proto-kbproto-devel >= 1.0.3
379 Requires:       xorg-proto-presentproto-devel >= 1.0
380 Requires:       xorg-proto-randrproto-devel >= 1.5.0
381 Requires:       xorg-proto-renderproto-devel >= 0.11
382 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
383 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
384 Requires:       xorg-proto-videoproto-devel
385 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
386 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
387 Requires:       xorg-proto-xineramaproto-devel
388 Requires:       xorg-proto-xproto-devel >= 7.0.28
389 Obsoletes:      X11-Xserver-devel < 1:7.0.0
390 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
391 %{?with_glamor:Obsoletes:       glamor-devel}
392
393 %description devel
394 Header files for X.org server.
395
396 %description devel -l pl.UTF-8
397 Pliki nagłówkowe dla serwera X.org.
398
399 %package source
400 Summary:        X.org server source code
401 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
402 Group:          X11/Development/Libraries
403
404 %description source
405 X.org server source code.
406
407 %description source -l pl.UTF-8
408 Pliki źródłowe dla serwera X.org.
409
410 %package -n xorg-xserver-libglx
411 Summary:        GLX extension library for X.org server
412 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
413 Group:          X11/Servers
414 Requires:       %{name} = %{version}-%{release}
415 Requires:       Mesa-libGL >= 7.1.0
416 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
417 # Mesa version glapi tables in glx/ dir come from
418 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
419 Provides:       xorg-xserver-module(glx)
420 Obsoletes:      X11-OpenGL-core < 1:7.0.0
421 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
422
423 %description -n xorg-xserver-libglx
424 GLX extension library for X.org server.
425
426 %description -n xorg-xserver-libglx -l pl.UTF-8
427 Biblioteka rozszerzenia GLX dla serwera X.org.
428
429 %prep
430 %setup -q -n xorg-server-%{version}
431 %patch1 -p1
432 %patch2 -p1
433
434 %patch4 -p1
435
436 %patch6 -p1
437
438 # xserver uses pixman-1 API/ABI so put that explictly here
439 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
440
441 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
442 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
443
444 %build
445 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
446 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
447         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
448         exit 1
449 fi
450
451 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
452 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
453         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
454         exit 1
455 fi
456
457 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
458 if [ $API != %{xorg_xserver_server_font_abi} ]; then
459         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
460         exit 1
461 fi
462 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
463 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
464         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
465         exit 1
466 fi
467 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
468 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
469         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
470         exit 1
471 fi
472
473 %{__libtoolize}
474 %{__aclocal} -I m4
475 %{__autoconf}
476 %{__autoheader}
477 %{__automake}
478 %configure \
479         --libexecdir=%{_libdir}/xorg \
480         --with-os-name="PLD/Linux" \
481         --with-os-vendor="PLD/Team" \
482         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
483         --with-xkb-output=/var/lib/xkb \
484         --disable-linux-acpi \
485         --disable-linux-apm \
486         --enable-aiglx \
487         %{?with_dbus:--enable-config-dbus} \
488         --enable-config-hal%{!?with_hal:=no} \
489         --enable-config-udev%{!?with_udev:=no} \
490         --enable-dga \
491         %{?with_dmx:--enable-dmx} \
492         --enable-dri2%{!?with_dri2:=no} \
493         %{?with_glamor:--enable-glamor} \
494         --enable-kdrive \
495         %{?with_libunwind:--enable-libunwind} \
496         %{?with_record:--enable-record} \
497         --enable-secure-rpc \
498         %{?with_xcsecurity:--enable-xcsecurity} \
499         --enable-xephyr \
500         %{?with_xf86bigfont:--enable-xf86bigfont} \
501         --disable-xfake \
502         --enable-xfbdev \
503         %{?with_xselinux:--enable-xselinux} \
504         %{?with_wayland:--enable-xwayland} \
505         %{!?with_systemtap:--without-dtrace} \
506         --without-fop \
507         --enable-suid-wrapper \
508         --with-systemd-daemon
509
510 %{__make} -j1
511
512 %install
513 rm -rf $RPM_BUILD_ROOT
514
515 %if "%{_libdir}" != "%{_exec_prefix}/lib"
516 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
517 %endif
518
519 %{__make} install \
520         DESTDIR=$RPM_BUILD_ROOT
521
522 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
523 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
524 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
525 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
526 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
527
528 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
529 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
530
531 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
532
533 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
534
535 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
536 install -d $RPM_BUILD_ROOT/etc/sysconfig
537 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
538 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
539
540 # Xorg.wrap config
541 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
542 # allowed values: rootonly console anybody pam
543 allowed_users = pam
544
545 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
546 #needs_root_rights = yes
547 EOF
548
549 # compatibility with old xwrapper
550 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
551
552 # prepare source package
553 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
554 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
555 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
556 %{__make} distclean
557 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
558 find -name '*.h' | xargs chmod a-x
559
560 %if %{with systemtap}
561 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
562 %endif
563
564 %clean
565 rm -rf $RPM_BUILD_ROOT
566
567 %triggerpostun -- xorg-xserver-server < 1.5.0
568 if [ -f /etc/X11/xorg.conf ]; then
569         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
570         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
571 %if %{without record}
572         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
573 %endif
574         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
575 fi
576
577 %post -n xorg-xserver-Xvfb-init
578 /sbin/chkconfig --add Xvfb
579 %service Xvfb restart
580
581 %preun -n xorg-xserver-Xvfb-init
582 if [ "$1" = "0" ]; then
583         %service -q Xvfb stop
584         /sbin/chkconfig --del Xvfb
585 fi
586
587 %files
588 %defattr(644,root,root,755)
589 %doc COPYING ChangeLog README
590 %attr(755,root,root) %{_bindir}/X
591 %attr(755,root,root) %{_bindir}/Xorg
592 %attr(4755,root,root) %{_bindir}/Xwrapper
593 %attr(755,root,root) %{_bindir}/cvt
594 %attr(755,root,root) %{_bindir}/gtf
595 %dir %{_libdir}/xorg
596 %{_libdir}/xorg/protocol.txt
597 %attr(755,root,root) %{_libdir}/xorg/Xorg
598 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
599 %dir %{_libdir}/xorg/modules
600 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
601 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
602 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
603 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
604 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
605 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
606 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
607 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
608 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
609 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
610 %dir %{_libdir}/xorg/modules/dri
611 %dir %{_libdir}/xorg/modules/drivers
612 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
613 %dir %{_libdir}/xorg/modules/extensions
614 %dir %{_libdir}/xorg/modules/input
615 %if "%{_libdir}" != "%{_exec_prefix}/lib"
616 %dir %{_exec_prefix}/lib/xorg
617 %dir %{_exec_prefix}/lib/xorg/modules
618 %dir %{_exec_prefix}/lib/xorg/modules/dri
619 %endif
620 %dir /var/lib/xkb
621 /var/lib/xkb/README.compiled
622 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
623 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
624 %config(missingok) /etc/security/console.apps/xserver
625 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
626 %dir /etc/X11/xorg.conf.d
627 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
628 %dir %{_datadir}/X11/xorg.conf.d
629 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
630 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
631 %{_mandir}/man1/Xorg.1*
632 %{_mandir}/man1/Xorg.wrap.1*
633 %{_mandir}/man1/Xserver.1*
634 %{_mandir}/man1/cvt.1*
635 %{_mandir}/man1/gtf.1*
636 %{_mandir}/man4/exa.4*
637 %{_mandir}/man4/fbdevhw.4*
638 %{_mandir}/man4/modesetting.4*
639 %{_mandir}/man5/Xwrapper.config.5*
640 %{_mandir}/man5/xorg.conf.5*
641 %{_mandir}/man5/xorg.conf.d.5*
642
643 %if %{with dmx}
644 %files -n xorg-xserver-Xdmx
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_bindir}/Xdmx
647 %attr(755,root,root) %{_bindir}/dmxaddinput
648 %attr(755,root,root) %{_bindir}/dmxaddscreen
649 %attr(755,root,root) %{_bindir}/dmxinfo
650 %attr(755,root,root) %{_bindir}/dmxreconfig
651 %attr(755,root,root) %{_bindir}/dmxresize
652 %attr(755,root,root) %{_bindir}/dmxrminput
653 %attr(755,root,root) %{_bindir}/dmxrmscreen
654 %attr(755,root,root) %{_bindir}/dmxtodmx
655 %attr(755,root,root) %{_bindir}/dmxwininfo
656 %attr(755,root,root) %{_bindir}/vdltodmx
657 %attr(755,root,root) %{_bindir}/xdmxconfig
658 %{_mandir}/man1/Xdmx.1*
659 %{_mandir}/man1/dmxtodmx.1*
660 %{_mandir}/man1/vdltodmx.1*
661 %{_mandir}/man1/xdmxconfig.1*
662 %endif
663
664 %files -n xorg-xserver-Xnest
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_bindir}/Xnest
667 %{_mandir}/man1/Xnest.1*
668
669 %files -n xorg-xserver-Xephyr
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_bindir}/Xephyr
672 %{_mandir}/man1/Xephyr.1*
673
674 %files -n xorg-xserver-Xfbdev
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_bindir}/Xfbdev
677
678 %files -n xorg-xserver-Xvfb
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_bindir}/Xvfb
681 %attr(755,root,root) %{_bindir}/xvfb-run
682 %{_mandir}/man1/Xvfb.1*
683
684 %files -n xorg-xserver-Xvfb-init
685 %defattr(644,root,root,755)
686 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
687 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
688
689 %if %{with wayland}
690 %files -n xorg-xserver-Xwayland
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_bindir}/Xwayland
693 %endif
694
695 %files devel
696 %defattr(644,root,root,755)
697 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
698 %{_includedir}/xorg
699 %{_aclocaldir}/xorg-server.m4
700 %{_pkgconfigdir}/xorg-server.pc
701
702 %files source
703 %defattr(644,root,root,755)
704 # keep file perms from install time, but have default defattr to keep adapter happy
705 %defattr(-,root,root,755)
706 %{_usrsrc}/%{name}-%{version}
707
708 %files -n xorg-xserver-libglx
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.1498 seconds and 4 git commands to generate.