]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- more version updates
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
5 %bcond_with     hal             # HAL support for configuration (if no udev)
6 %bcond_without  udev            # UDEV support for configuration
7 %bcond_without  dri2            # DRI2 extension
8 %bcond_without  dmx             # DMX support
9 %bcond_without  record          # RECORD extension
10 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
11 %bcond_with     xf86bigfont     # XF86BigFont extension
12 %bcond_with     xselinux        # SELinux extension
13 #
14 # ABI versions, see hw/xfree86/common/xf86Module.h
15 %define xorg_xserver_server_ansic_abi           0.4
16 %define xorg_xserver_server_extension_abi       7.0
17 %define xorg_xserver_server_font_abi            0.6
18 %define xorg_xserver_server_videodrv_abi        13.0
19 %define xorg_xserver_server_xinput_abi          18.0
20 #
21 %define pixman_ver      0.26.0
22
23 Summary:        X.org server
24 Summary(pl.UTF-8):      Serwer X.org
25 Name:           xorg-xserver-server
26 Version:        1.13.0
27 Release:        1
28 License:        MIT
29 Group:          X11/Servers
30 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
31 # Source0-md5:  bde3d178b756597d2ec2a19ef60d2e1f
32 Source1:        10-quirks.conf
33 Source2:        xserver.pamd
34 Source10:       %{name}-Xvfb.init
35 Source11:       %{name}-Xvfb.sysconfig
36 Patch0:         %{name}-xwrapper.patch
37 Patch1:         %{name}-pic-libxf86config.patch
38
39 Patch3:         %{name}-less-acpi-brokenness.patch
40 Patch4:         %{name}-builtin-SHA1.patch
41 Patch5:         %{name}-export-GetMaster.patch
42 Patch6:         110_nvidia_slowdow_fix.patch
43 Patch7:         %{name}-include-defs.patch
44 URL:            http://xorg.freedesktop.org/
45 BuildRequires:  Mesa-libGL-devel >= 7.8.1
46 # for glx headers
47 BuildRequires:  OpenGL-GLX-devel
48 %{?with_xselinux:BuildRequires: audit-libs-devel}
49 BuildRequires:  autoconf >= 2.57
50 BuildRequires:  automake
51 BuildRequires:  cpp
52 BuildRequires:  docbook-dtd43-xml
53 #BuildRequires: doxygen >= 1.6.1
54 %if %{with hal} || %{with dbus}
55 BuildRequires:  dbus-devel >= 1.0
56 %endif
57 %{?with_hal:BuildRequires:      hal-devel}
58 BuildRequires:  libdrm-devel >= 2.4.39
59 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
60 BuildRequires:  libtool
61 BuildRequires:  ncurses-devel
62 BuildRequires:  pam-devel
63 BuildRequires:  perl-base
64 BuildRequires:  pixman-devel >= %{pixman_ver}
65 BuildRequires:  pkgconfig >= 1:0.19
66 BuildRequires:  udev-devel >= 1:143
67 BuildRequires:  xmlto >= 0.0.20
68 BuildRequires:  xorg-app-mkfontscale
69 BuildRequires:  xorg-font-font-util >= 1.1
70 BuildRequires:  xorg-lib-libX11-devel
71 BuildRequires:  xorg-lib-libXau-devel
72 BuildRequires:  xorg-lib-libXaw-devel
73 BuildRequires:  xorg-lib-libXdamage-devel
74 BuildRequires:  xorg-lib-libXdmcp-devel
75 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
76 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
77 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
78 BuildRequires:  xorg-lib-libXmu-devel
79 BuildRequires:  xorg-lib-libXpm-devel
80 BuildRequires:  xorg-lib-libXrender-devel
81 BuildRequires:  xorg-lib-libXres-devel
82 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
83 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
84 BuildRequires:  xorg-lib-libXv-devel
85 BuildRequires:  xorg-lib-libXxf86dga-devel
86 BuildRequires:  xorg-lib-libXxf86misc-devel
87 BuildRequires:  xorg-lib-libXxf86vm-devel
88 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
89 BuildRequires:  xorg-lib-libfontenc-devel
90 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
91 BuildRequires:  xorg-lib-libxkbfile-devel
92 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
93 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
94 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
95 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
96 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
97 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
98 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
99 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
100 BuildRequires:  xorg-proto-fontcacheproto-devel
101 BuildRequires:  xorg-proto-fontsproto-devel
102 BuildRequires:  xorg-proto-glproto-devel >= 1.4.16
103 BuildRequires:  xorg-proto-inputproto-devel >= 2.2
104 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
105 BuildRequires:  xorg-proto-printproto-devel
106 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
107 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
108 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
109 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
110 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
111 BuildRequires:  xorg-proto-videoproto-devel
112 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
113 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
114 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
115 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
116 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
117 BuildRequires:  xorg-proto-xf86miscproto-devel
118 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
119 BuildRequires:  xorg-proto-xineramaproto-devel
120 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
121 BuildRequires:  xorg-sgml-doctools >= 1.8
122 BuildRequires:  xorg-util-util-macros >= 1.14
123 #BR: tslib (for KDRIVE only)
124 Requires(triggerpostun):        sed >= 4.0
125 Requires:       pixman >= %{pixman_ver}
126 Requires:       xkeyboard-config
127 # for rgb.txt
128 Requires:       xorg-app-rgb >= 0.99.3
129 Requires:       xorg-app-xkbcomp
130 %{?with_hal:Suggests:   hal}
131 Suggests:       udev-acl >= 1:143
132 %{?with_udev:Suggests:  udev-core >= 1:143}
133 Suggests:       xorg-driver-input-evdev
134 # xserver requires fixed and cursor fonts
135 Requires:       xorg-font-font-alias
136 Requires:       xorg-font-font-cursor-misc
137 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
138 Suggests:       dbus-x11 >= 1.0
139 Suggests:       xkeyboard-config
140 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
141 Suggests:       xorg-driver-video
142 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
143 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
144 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
145 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
146 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
147 Provides:       xorg-xserver-module(dri)
148 Provides:       xorg-xserver-libdri = %{version}-%{release}
149 Obsoletes:      X11-Xserver < 1:7.0.0
150 Obsoletes:      X11-driver-i2c < 1:7.0.0
151 Obsoletes:      X11-modules < 1:7.0.0
152 Obsoletes:      X11-setup < 1:7.0.0
153 Obsoletes:      XFree86-Xserver < 1:7.0.0
154 Obsoletes:      XFree86-modules < 1:7.0.0
155 Obsoletes:      XFree86-setup < 1:7.0.0
156 Obsoletes:      Xserver
157 Obsoletes:      xorg-xserver-server-xorgcfg
158 Obsoletes:      xorg-xserver-libdri
159 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
160
161 # avoid self-dependencies on included modules
162 %define         _noautoreq      libscanpci.so libxf1bpp.so
163
164 %description
165 Xorg server is a generally used X server which uses display hardware.
166 It requires proper driver for your display hardware.
167
168 %description -l pl.UTF-8
169 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
170 graficznej. Do działania wymaga odpowiedniego sterownika.
171
172 %package -n xorg-xserver-Xdmx
173 Summary:        Xdmx - distributed multi-head X server
174 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
175 Group:          X11/Servers
176
177 %description -n xorg-xserver-Xdmx
178 Xdmx - distributed multi-head X server.
179
180 %description -n xorg-xserver-Xdmx -l pl.UTF-8
181 Xdmx - rozproszony, wielomonitorowy serwer X.
182
183 %package -n xorg-xserver-Xnest
184 Summary:        Xnest - nested X server
185 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
186 Group:          X11/Servers
187 Obsoletes:      X11-Xnest < 1:7.0.0
188 Obsoletes:      XFree86-Xnest < 1:7.0.0
189 Obsoletes:      Xserver-Xnest
190
191 %description -n xorg-xserver-Xnest
192 Xnest is an X Window System server which runs in an X window. Xnest is
193 a 'nested' window server, actually a client of the real X server,
194 which manages windows and graphics requests for Xnest, while Xnest
195 manages the windows and graphics requests for its own clients.
196
197 %description -n xorg-xserver-Xnest -l pl.UTF-8
198 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
199 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
200 serwer X dla własnych klientów.
201
202 %description -n xorg-xserver-Xnest -l ru.UTF-8
203 Xnest - это сервер X Window System, который работает в окне X. На
204 самом деле это клиент реального X-сервера, который управляет окнами и
205 графическими запросами для Xnest в то время, как Xnest управляет
206 окнами и графическими запросами для своих собственных клиентов.
207
208 %description -n xorg-xserver-Xnest -l uk.UTF-8
209 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
210 клієнт реального X-сервера, який керує вікнами та графічними запитами
211 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
212 своїх власних клієнтів.
213
214 %package -n xorg-xserver-Xephyr
215 Summary:        Xephyr - nested X server
216 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
217 Group:          X11/Servers
218 Requires:       pixman >= %{pixman_ver}
219
220 %description -n xorg-xserver-Xephyr
221 Xephyr is a a kdrive server that outputs to a window on a pre-existing
222 'host' X display. Think Xnest but with support for modern extensions
223 like composite, damage and randr.
224
225 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
226 the host X server, Xephyr is a real X server which uses the host X
227 server window as "framebuffer" via fast SHM XImages.
228
229 It also has support for 'visually' debugging what the server is
230 painting.
231
232 %description -n xorg-xserver-Xephyr -l pl.UTF-8
233 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
234 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
235 wspólczesnych rozszerzeń jak composite, damage i randr.
236
237 %package -n xorg-xserver-Xfbdev
238 Summary:        Xfbdev - Linux framebuffer device X server
239 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
240 Group:          X11/Servers
241
242 %description -n xorg-xserver-Xfbdev
243 Xfbdev is a Linux framebuffer device X server based on the kdrive X
244 server.
245
246 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
247 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
248
249 %package -n xorg-xserver-Xvfb
250 Summary:        Xvfb - virtual framebuffer X server
251 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
252 Group:          X11/Servers
253 # requires fixed and cursor fonts
254 Requires:       xorg-font-font-alias
255 Requires:       xorg-font-font-cursor-misc
256 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
257 Obsoletes:      X11-Xvfb < 1:7.0.0
258 Obsoletes:      XFree86-Xvfb < 1:7.0.0
259
260 %description -n xorg-xserver-Xvfb
261 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
262 capable of running on machines with no display hardware and no
263 physical input devices. Xvfb emulates a dumb framebuffer using virtual
264 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
265 display. Xvfb is normally used for testing servers. Using Xvfb, the
266 mfb or cfb code for any depth can be exercised without using real
267 hardware that supports the desired depths. Xvfb has also been used to
268 test X clients against unusual depths and screen configurations, to do
269 batch processing with Xvfb as a background rendering engine, to do
270 load testing, to help with porting an X server to a new platform, and
271 to provide an unobtrusive way of running applications which really
272 don't need an X server but insist on having one.
273
274 %description -n xorg-xserver-Xvfb -l pl.UTF-8
275 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
276 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
277 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
278 używany do testowania serwerów X, może też być używany do testowania
279 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
280 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
281 serwera X, ale odmawiają uruchomienia bez niego.
282
283 %package -n xorg-xserver-Xvfb-init
284 Summary:        Init scripts for Xvfb
285 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
286 Group:          X11/Servers
287 Requires:       xorg-xserver-Xvfb
288
289 %description -n xorg-xserver-Xvfb-init
290 This package contains init scripts for Xvfb and registers Xvfb as
291 system service.
292
293 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
294 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
295 usługę systemową.
296
297 %package devel
298 Summary:        Header files for X.org server
299 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
300 Group:          X11/Development/Libraries
301 Requires:       libdrm-devel >= 2.4.39
302 Requires:       pixman-devel >= %{pixman_ver}
303 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
304 Requires:       xorg-lib-libxkbfile-devel
305 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
306 Requires:       xorg-proto-fontsproto-devel
307 Requires:       xorg-proto-inputproto-devel >= 2.2
308 Requires:       xorg-proto-kbproto-devel >= 1.0.3
309 Requires:       xorg-proto-randrproto-devel >= 1.4.0
310 Requires:       xorg-proto-renderproto-devel >= 0.11
311 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
312 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
313 Requires:       xorg-proto-videoproto-devel
314 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
315 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
316 Requires:       xorg-proto-xineramaproto-devel
317 Requires:       xorg-proto-xproto-devel >= 7.0.22
318 Obsoletes:      X11-Xserver-devel < 1:7.0.0
319 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
320
321 %description devel
322 Header files for X.org server.
323
324 %description devel -l pl.UTF-8
325 Pliki nagłówkowe dla serwera X.org.
326
327 %package source
328 Summary:        X.org server source code
329 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
330 Group:          X11/Development/Libraries
331
332 %description source
333 X.org server source code.
334
335 %description source -l pl.UTF-8
336 Pliki źródłowe dla serwera X.org.
337
338 %package -n xorg-xserver-libglx
339 Summary:        GLX extension library for X.org server
340 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
341 Group:          X11/Servers
342 Requires:       %{name} = %{version}-%{release}
343 # Mesa version glapi tables in glx/ dir come from
344 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
345 Provides:       xorg-xserver-module(glx)
346 Obsoletes:      X11-OpenGL-core < 1:7.0.0
347 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
348
349 %description -n xorg-xserver-libglx
350 GLX extension library for X.org server.
351
352 %description -n xorg-xserver-libglx -l pl.UTF-8
353 Biblioteka rozszerzenia GLX dla serwera X.org.
354
355 %prep
356 %setup -q -n xorg-server-%{version}
357 %patch0 -p0
358 %patch1 -p1
359
360 %patch3 -p1
361 %patch4 -p1
362 %patch5 -p1
363 %patch6 -p1
364
365 #unfortunately breaks build
366 #patch7 -p1
367
368 # xserver uses pixman-1 API/ABI so put that explictly here
369 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
370
371 %build
372 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
373 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
374         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
375         exit 1
376 fi
377
378 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
379 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
380         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
381         exit 1
382 fi
383
384 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
385 if [ $API != %{xorg_xserver_server_font_abi} ]; then
386         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
387         exit 1
388 fi
389 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
390 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
391         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
392         exit 1
393 fi
394 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
395 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
396         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
397         exit 1
398 fi
399
400 %{__libtoolize}
401 %{__aclocal} -I m4
402 %{__autoconf}
403 %{__autoheader}
404 %{__automake}
405 %configure \
406         --with-os-name="PLD/Linux" \
407         --with-os-vendor="PLD/Team" \
408         --without-fop \
409         %{?with_dbus:--enable-config-dbus} \
410         --enable-config-hal%{!?with_hal:=no} \
411         --enable-config-udev%{!?with_udev:=no} \
412         --enable-aiglx \
413         --enable-dga \
414         %{?with_dmx:--enable-dmx} \
415         --enable-glx-tls \
416         --enable-install-libxf86config \
417         %{?with_record:--enable-record} \
418         --enable-kdrive \
419         %{?with_xcsecurity:--enable-xcsecurity} \
420         --enable-xephyr \
421         %{?with_xf86bigfont:--enable-xf86bigfont} \
422         --enable-xfbdev \
423         %{?with_xselinux:--enable-xselinux} \
424         --enable-glx-tls \
425         --disable-xfake \
426         --enable-secure-rpc \
427         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
428         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
429         --with-xkb-output=/var/lib/xkb
430
431 %{__make}
432
433 %install
434 rm -rf $RPM_BUILD_ROOT
435
436 %{__make} install \
437         DESTDIR=$RPM_BUILD_ROOT
438
439 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
440 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
441 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
442 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
443
444 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
445 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
446
447 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
448
449 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
450
451 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
452 install -d $RPM_BUILD_ROOT/etc/sysconfig
453 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
454 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
455
456 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
457 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
458 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
459 %{__make} distclean
460 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
461 find -name '*.h' | xargs chmod a-x
462
463 %clean
464 rm -rf $RPM_BUILD_ROOT
465
466 %triggerpostun -- xorg-xserver-server < 1.5.0
467 if [ -f /etc/X11/xorg.conf ]; then
468         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
469         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
470 %if %{without record}
471         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
472 %endif
473         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
474 fi
475
476 %post -n xorg-xserver-Xvfb-init
477 /sbin/chkconfig --add Xvfb
478 %service Xvfb restart
479
480 %preun -n xorg-xserver-Xvfb-init
481 if [ "$1" = "0" ]; then
482         %service -q Xvfb stop
483         /sbin/chkconfig --del Xvfb
484 fi
485
486 %files
487 %defattr(644,root,root,755)
488 %doc COPYING ChangeLog README
489 %attr(755,root,root) %{_bindir}/X
490 %attr(755,root,root) %{_bindir}/Xorg
491 %attr(4755,root,root) %{_bindir}/Xwrapper
492 %attr(755,root,root) %{_bindir}/cvt
493 %attr(755,root,root) %{_bindir}/gtf
494 %dir %{_libdir}/xorg
495 %{_libdir}/xorg/protocol.txt
496 %dir %{_libdir}/xorg/modules
497 %dir %{_libdir}/xorg/modules/dri
498 %dir %{_libdir}/xorg/modules/drivers
499 %dir %{_libdir}/xorg/modules/extensions
500 %dir %{_libdir}/xorg/modules/input
501 %dir %{_libdir}/xorg/modules/multimedia
502 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
503 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
504 %dir /var/lib/xkb
505 /var/lib/xkb/README.compiled
506 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
507 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
508 %config(missingok) /etc/security/console.apps/xserver
509 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
510 %dir /etc/X11/xorg.conf.d
511 %dir %{_datadir}/X11/xorg.conf.d
512 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
513 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
514 %{_mandir}/man1/Xorg.1x*
515 %{_mandir}/man1/Xserver.1x*
516 %{_mandir}/man1/cvt.1*
517 %{_mandir}/man1/gtf.1x*
518 %{_mandir}/man4/exa.4*
519 %{_mandir}/man4/fbdevhw.4*
520 %{_mandir}/man5/xorg.conf.5x*
521 %{_mandir}/man5/xorg.conf.d.5x
522
523 %if %{with dmx}
524 %files -n xorg-xserver-Xdmx
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_bindir}/Xdmx
527 %attr(755,root,root) %{_bindir}/dmxaddinput
528 %attr(755,root,root) %{_bindir}/dmxaddscreen
529 %attr(755,root,root) %{_bindir}/dmxinfo
530 %attr(755,root,root) %{_bindir}/dmxreconfig
531 %attr(755,root,root) %{_bindir}/dmxresize
532 %attr(755,root,root) %{_bindir}/dmxrminput
533 %attr(755,root,root) %{_bindir}/dmxrmscreen
534 %attr(755,root,root) %{_bindir}/dmxtodmx
535 %attr(755,root,root) %{_bindir}/dmxwininfo
536 %attr(755,root,root) %{_bindir}/vdltodmx
537 %attr(755,root,root) %{_bindir}/xdmxconfig
538 %{_mandir}/man1/Xdmx.1x*
539 %{_mandir}/man1/dmxtodmx.1x*
540 %{_mandir}/man1/vdltodmx.1x*
541 %{_mandir}/man1/xdmxconfig.1x*
542 %endif
543
544 %files -n xorg-xserver-Xnest
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_bindir}/Xnest
547 %{_mandir}/man1/Xnest.1x*
548
549 %files -n xorg-xserver-Xephyr
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_bindir}/Xephyr
552 %{_mandir}/man1/Xephyr.1x*
553
554 %files -n xorg-xserver-Xfbdev
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_bindir}/Xfbdev
557
558 %files -n xorg-xserver-Xvfb
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/Xvfb
561 %{_mandir}/man1/Xvfb.1x*
562
563 %files -n xorg-xserver-Xvfb-init
564 %defattr(644,root,root,755)
565 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
566 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
567
568 %files devel
569 %defattr(644,root,root,755)
570 %doc doc/{Xinput,Xserver-spec}.html
571 %{_includedir}/xorg
572 %{_libdir}/libxf86config.a
573 %{_libdir}/libxf86config.la
574 %{_aclocaldir}/xorg-server.m4
575 %{_pkgconfigdir}/xorg-server.pc
576
577 %files source
578 %defattr(644,root,root,755)
579 # keep file perms from install time, but have default defattr to keep adapter happy
580 %defattr(-,root,root,755)
581 %{_usrsrc}/%{name}-%{version}
582
583 %files -n xorg-xserver-libglx
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.063142 seconds and 4 git commands to generate.