]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- up to 1.16.0
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dmx             # DMX support
10 %bcond_without  dri2            # DRI2 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_without  systemtap       # systemtap/dtrace probes
13 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
14 %bcond_with     xf86bigfont     # XF86BigFont extension
15 %bcond_with     xselinux        # SELinux extension
16 #
17 # ABI versions, see hw/xfree86/common/xf86Module.h
18 %define xorg_xserver_server_ansic_abi           0.4
19 %define xorg_xserver_server_extension_abi       8.0
20 %define xorg_xserver_server_font_abi            0.6
21 %define xorg_xserver_server_videodrv_abi        18.0
22 %define xorg_xserver_server_xinput_abi          21.0
23
24 %define pixman_ver      0.30.0
25
26 Summary:        X.org server
27 Summary(pl.UTF-8):      Serwer X.org
28 Name:           xorg-xserver-server
29 Version:        1.16.0
30 Release:        1
31 License:        MIT
32 Group:          X11/Servers
33 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
34 # Source0-md5:  8a9ff6ee9907360f09b5bdabb8089502
35 Source1:        10-quirks.conf
36 Source2:        xserver.pamd
37 Source10:       %{name}-Xvfb.init
38 Source11:       %{name}-Xvfb.sysconfig
39 Source12:       xvfb-run.sh
40
41 Patch0:         %{name}-xwrapper.patch
42 Patch1:         %{name}-pic-libxf86config.patch
43
44 Patch4:         %{name}-builtin-SHA1.patch
45 Patch5:         %{name}-export-GetMaster.patch
46 Patch6:         110_nvidia_slowdow_fix.patch
47 Patch7:         %{name}-include-defs.patch
48 URL:            http://xorg.freedesktop.org/
49 BuildRequires:  Mesa-libGL-devel >= 7.8.1
50 # for glx headers
51 BuildRequires:  OpenGL-GLX-devel
52 %{?with_xselinux:BuildRequires: audit-libs-devel}
53 BuildRequires:  autoconf >= 2.60
54 BuildRequires:  automake
55 BuildRequires:  cpp
56 BuildRequires:  docbook-dtd43-xml
57 #BuildRequires: doxygen >= 1.6.1
58 %if %{with hal} || %{with dbus}
59 BuildRequires:  dbus-devel >= 1.0
60 %endif
61 %{?with_hal:BuildRequires:      hal-devel}
62 BuildRequires:  libdrm-devel >= 2.4.39
63 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
64 BuildRequires:  libtool
65 BuildRequires:  libunwind-devel
66 BuildRequires:  libxcb-devel >= 1.6
67 BuildRequires:  ncurses-devel
68 BuildRequires:  pam-devel
69 BuildRequires:  perl-base
70 BuildRequires:  pixman-devel >= %{pixman_ver}
71 BuildRequires:  pkgconfig >= 1:0.19
72 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
73 BuildRequires:  udev-devel >= 1:143
74 BuildRequires:  xcb-util-devel
75 BuildRequires:  xcb-util-image-devel
76 BuildRequires:  xcb-util-keysyms-devel
77 BuildRequires:  xcb-util-wm-devel
78 BuildRequires:  xmlto >= 0.0.20
79 BuildRequires:  xorg-app-mkfontscale
80 BuildRequires:  xorg-font-font-util >= 1.1
81 BuildRequires:  xorg-lib-libX11-devel >= 1.6
82 BuildRequires:  xorg-lib-libXau-devel
83 BuildRequires:  xorg-lib-libXaw-devel
84 BuildRequires:  xorg-lib-libXdamage-devel
85 BuildRequires:  xorg-lib-libXdmcp-devel
86 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
87 BuildRequires:  xorg-lib-libXfixes-devel
88 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
89 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
90 BuildRequires:  xorg-lib-libXmu-devel
91 BuildRequires:  xorg-lib-libXpm-devel
92 BuildRequires:  xorg-lib-libXrender-devel
93 BuildRequires:  xorg-lib-libXres-devel
94 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
95 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
96 BuildRequires:  xorg-lib-libXv-devel
97 BuildRequires:  xorg-lib-libXxf86dga-devel
98 BuildRequires:  xorg-lib-libXxf86misc-devel
99 BuildRequires:  xorg-lib-libXxf86vm-devel
100 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
101 BuildRequires:  xorg-lib-libfontenc-devel
102 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
103 BuildRequires:  xorg-lib-libxkbfile-devel
104 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
105 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.2
106 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
107 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
108 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
109 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
110 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
111 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
112 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
113 BuildRequires:  xorg-proto-fontcacheproto-devel
114 BuildRequires:  xorg-proto-fontsproto-devel
115 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
116 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
117 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
118 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
119 BuildRequires:  xorg-proto-printproto-devel
120 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
121 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
122 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
123 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
124 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
125 BuildRequires:  xorg-proto-videoproto-devel
126 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
127 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
128 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
129 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
130 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
131 BuildRequires:  xorg-proto-xf86miscproto-devel
132 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
133 BuildRequires:  xorg-proto-xineramaproto-devel
134 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
135 BuildRequires:  xorg-sgml-doctools >= 1.8
136 BuildRequires:  xorg-util-util-macros >= 1.14
137 #BR: tslib (for KDRIVE only)
138 Requires(triggerpostun):        sed >= 4.0
139 Requires:       libdrm >= 2.4.39
140 Requires:       pixman >= %{pixman_ver}
141 Requires:       udev-libs >= 1:143
142 Requires:       xkeyboard-config
143 # for rgb.txt
144 Requires:       xorg-app-rgb >= 0.99.3
145 Requires:       xorg-app-xkbcomp
146 # xserver requires fixed and cursor fonts
147 Requires:       xorg-font-font-alias
148 Requires:       xorg-font-font-cursor-misc
149 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
150 Requires:       xorg-lib-libXfont >= 1.4.2
151 Requires:       xorg-lib-libpciaccess >= 0.12.901
152 Requires:       xorg-lib-libxshmfence >= 1.1
153 Suggests:       dbus-x11 >= 1.0
154 %{?with_hal:Suggests:   hal}
155 Suggests:       udev-acl >= 1:143
156 %{?with_udev:Suggests:  udev-core >= 1:143}
157 Suggests:       xkeyboard-config
158 Suggests:       xorg-driver-input-evdev
159 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
160 Suggests:       xorg-driver-video
161 Provides:       xorg-xserver-libdri = %{version}-%{release}
162 Provides:       xorg-xserver-module(dri)
163 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
164 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
165 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
166 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
167 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
168 Obsoletes:      X11-Xserver < 1:7.0.0
169 Obsoletes:      X11-driver-i2c < 1:7.0.0
170 Obsoletes:      X11-modules < 1:7.0.0
171 Obsoletes:      X11-setup < 1:7.0.0
172 Obsoletes:      XFree86-Xserver < 1:7.0.0
173 Obsoletes:      XFree86-modules < 1:7.0.0
174 Obsoletes:      XFree86-setup < 1:7.0.0
175 Obsoletes:      Xserver
176 Obsoletes:      xorg-xserver-libdri
177 Obsoletes:      xorg-xserver-server-xorgcfg
178 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
179
180 # avoid self-dependencies on included modules
181 %define         _noautoreq      libscanpci.so libxf1bpp.so
182
183 %description
184 Xorg server is a generally used X server which uses display hardware.
185 It requires proper driver for your display hardware.
186
187 %description -l pl.UTF-8
188 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
189 graficznej. Do działania wymaga odpowiedniego sterownika.
190
191 %package -n xorg-xserver-Xdmx
192 Summary:        Xdmx - distributed multi-head X server
193 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
194 Group:          X11/Servers
195 Requires:       pixman >= %{pixman_ver}
196 Requires:       xorg-lib-libX11 >= 1.6
197 Requires:       xorg-lib-libXext >= 1.0.99.4
198 Requires:       xorg-lib-libXfont >= 1.4.2
199 Requires:       xorg-lib-libXi >= 1.2.99.1
200 Requires:       xorg-lib-libdmx >= 1.0.99.1
201
202 %description -n xorg-xserver-Xdmx
203 Xdmx - distributed multi-head X server.
204
205 %description -n xorg-xserver-Xdmx -l pl.UTF-8
206 Xdmx - rozproszony, wielomonitorowy serwer X.
207
208 %package -n xorg-xserver-Xnest
209 Summary:        Xnest - nested X server
210 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
211 Group:          X11/Servers
212 Requires:       pixman >= %{pixman_ver}
213 Requires:       xorg-lib-libXext >= 1.0.99.4
214 Requires:       xorg-lib-libXfont >= 1.4.2
215 Obsoletes:      X11-Xnest < 1:7.0.0
216 Obsoletes:      XFree86-Xnest < 1:7.0.0
217 Obsoletes:      Xserver-Xnest
218
219 %description -n xorg-xserver-Xnest
220 Xnest is an X Window System server which runs in an X window. Xnest is
221 a 'nested' window server, actually a client of the real X server,
222 which manages windows and graphics requests for Xnest, while Xnest
223 manages the windows and graphics requests for its own clients.
224
225 %description -n xorg-xserver-Xnest -l pl.UTF-8
226 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
227 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
228 serwer X dla własnych klientów.
229
230 %description -n xorg-xserver-Xnest -l ru.UTF-8
231 Xnest - это сервер X Window System, который работает в окне X. На
232 самом деле это клиент реального X-сервера, который управляет окнами и
233 графическими запросами для Xnest в то время, как Xnest управляет
234 окнами и графическими запросами для своих собственных клиентов.
235
236 %description -n xorg-xserver-Xnest -l uk.UTF-8
237 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
238 клієнт реального X-сервера, який керує вікнами та графічними запитами
239 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
240 своїх власних клієнтів.
241
242 %package -n xorg-xserver-Xephyr
243 Summary:        Xephyr - nested X server
244 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
245 Group:          X11/Servers
246 Requires:       Mesa-libGL >= 7.1.0
247 Requires:       libxcb >= 1.6
248 Requires:       pixman >= %{pixman_ver}
249 Requires:       xorg-lib-libXfont >= 1.4.2
250
251 %description -n xorg-xserver-Xephyr
252 Xephyr is a a kdrive server that outputs to a window on a pre-existing
253 'host' X display. Think Xnest but with support for modern extensions
254 like composite, damage and randr.
255
256 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
257 the host X server, Xephyr is a real X server which uses the host X
258 server window as "framebuffer" via fast SHM XImages.
259
260 It also has support for 'visually' debugging what the server is
261 painting.
262
263 %description -n xorg-xserver-Xephyr -l pl.UTF-8
264 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
265 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
266 wspólczesnych rozszerzeń jak composite, damage i randr.
267
268 %package -n xorg-xserver-Xfbdev
269 Summary:        Xfbdev - Linux framebuffer device X server
270 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
271 Group:          X11/Servers
272 Requires:       pixman >= %{pixman_ver}
273 Requires:       xorg-lib-libXfont >= 1.4.2
274
275 %description -n xorg-xserver-Xfbdev
276 Xfbdev is a Linux framebuffer device X server based on the kdrive X
277 server.
278
279 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
280 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
281
282 %package -n xorg-xserver-Xvfb
283 Summary:        Xvfb - virtual framebuffer X server
284 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
285 Group:          X11/Servers
286 Requires:       Mesa-libGL >= 7.1.0
287 Requires:       mktemp
288 Requires:       pixman >= %{pixman_ver}
289 Requires:       util-linux
290 Requires:       which
291 Requires:       xkeyboard-config
292 Requires:       xorg-app-xkbcomp
293 Requires:       xorg-app-xauth
294 # requires fixed and cursor fonts
295 Requires:       xorg-font-font-alias
296 Requires:       xorg-font-font-cursor-misc
297 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
298 Requires:       xorg-lib-libXfont >= 1.4.2
299 Obsoletes:      X11-Xvfb < 1:7.0.0
300 Obsoletes:      XFree86-Xvfb < 1:7.0.0
301
302 %description -n xorg-xserver-Xvfb
303 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
304 capable of running on machines with no display hardware and no
305 physical input devices. Xvfb emulates a dumb framebuffer using virtual
306 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
307 display. Xvfb is normally used for testing servers. Using Xvfb, the
308 mfb or cfb code for any depth can be exercised without using real
309 hardware that supports the desired depths. Xvfb has also been used to
310 test X clients against unusual depths and screen configurations, to do
311 batch processing with Xvfb as a background rendering engine, to do
312 load testing, to help with porting an X server to a new platform, and
313 to provide an unobtrusive way of running applications which really
314 don't need an X server but insist on having one.
315
316 %description -n xorg-xserver-Xvfb -l pl.UTF-8
317 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
318 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
319 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
320 używany do testowania serwerów X, może też być używany do testowania
321 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
322 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
323 serwera X, ale odmawiają uruchomienia bez niego.
324
325 %package -n xorg-xserver-Xvfb-init
326 Summary:        Init scripts for Xvfb
327 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
328 Group:          X11/Servers
329 Requires:       xorg-xserver-Xvfb
330
331 %description -n xorg-xserver-Xvfb-init
332 This package contains init scripts for Xvfb and registers Xvfb as
333 system service.
334
335 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
336 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
337 usługę systemową.
338
339 %package devel
340 Summary:        Header files for X.org server
341 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
342 Group:          X11/Development/Libraries
343 Requires:       Mesa-libGL-devel >= 7.8.0
344 Requires:       libdrm-devel >= 2.4.39
345 Requires:       pixman-devel >= %{pixman_ver}
346 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
347 Requires:       xorg-lib-libxkbfile-devel
348 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
349 Requires:       xorg-proto-dri3proto-devel >= 1.0
350 Requires:       xorg-proto-fontsproto-devel
351 Requires:       xorg-proto-glproto-devel >= 1.4.17
352 Requires:       xorg-proto-inputproto-devel >= 2.3
353 Requires:       xorg-proto-kbproto-devel >= 1.0.3
354 Requires:       xorg-proto-presentproto-devel >= 1.0
355 Requires:       xorg-proto-randrproto-devel >= 1.4.0
356 Requires:       xorg-proto-renderproto-devel >= 0.11
357 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
358 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
359 Requires:       xorg-proto-videoproto-devel
360 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
361 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
362 Requires:       xorg-proto-xineramaproto-devel
363 Requires:       xorg-proto-xproto-devel >= 7.0.22
364 Obsoletes:      X11-Xserver-devel < 1:7.0.0
365 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
366
367 %description devel
368 Header files for X.org server.
369
370 %description devel -l pl.UTF-8
371 Pliki nagłówkowe dla serwera X.org.
372
373 %package source
374 Summary:        X.org server source code
375 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
376 Group:          X11/Development/Libraries
377
378 %description source
379 X.org server source code.
380
381 %description source -l pl.UTF-8
382 Pliki źródłowe dla serwera X.org.
383
384 %package -n xorg-xserver-libglx
385 Summary:        GLX extension library for X.org server
386 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
387 Group:          X11/Servers
388 Requires:       %{name} = %{version}-%{release}
389 Requires:       Mesa-libGL >= 7.1.0
390 # Mesa version glapi tables in glx/ dir come from
391 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
392 Provides:       xorg-xserver-module(glx)
393 Obsoletes:      X11-OpenGL-core < 1:7.0.0
394 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
395
396 %description -n xorg-xserver-libglx
397 GLX extension library for X.org server.
398
399 %description -n xorg-xserver-libglx -l pl.UTF-8
400 Biblioteka rozszerzenia GLX dla serwera X.org.
401
402 %prep
403 %setup -q -n xorg-server-%{version}
404 %patch0 -p0
405 %patch1 -p1
406
407 %patch4 -p1
408 %patch5 -p1
409 %patch6 -p1
410
411 #unfortunately breaks build
412 #patch7 -p1
413
414 # xserver uses pixman-1 API/ABI so put that explictly here
415 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
416
417 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
418 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
419
420 %build
421 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
422 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
423         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
424         exit 1
425 fi
426
427 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
428 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
429         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
430         exit 1
431 fi
432
433 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
434 if [ $API != %{xorg_xserver_server_font_abi} ]; then
435         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
436         exit 1
437 fi
438 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
439 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
440         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
441         exit 1
442 fi
443 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
444 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
445         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
446         exit 1
447 fi
448
449 %{__libtoolize}
450 %{__aclocal} -I m4
451 %{__autoconf}
452 %{__autoheader}
453 %{__automake}
454 %configure \
455         --with-os-name="PLD/Linux" \
456         --with-os-vendor="PLD/Team" \
457         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
458         --with-xkb-output=/var/lib/xkb \
459         %{!?with_systemtap:--without-dtrace} \
460         --without-fop \
461         --disable-linux-acpi \
462         --disable-linux-apm \
463         --enable-aiglx \
464         %{?with_dbus:--enable-config-dbus} \
465         --enable-config-hal%{!?with_hal:=no} \
466         --enable-config-udev%{!?with_udev:=no} \
467         --enable-dga \
468         %{?with_dmx:--enable-dmx} \
469         --enable-dri2%{!?with_dri2:=no} \
470         --enable-glx-tls \
471         --enable-install-libxf86config \
472         --enable-kdrive \
473         --enable-libunwind \
474         %{?with_record:--enable-record} \
475         --enable-secure-rpc \
476         %{?with_xcsecurity:--enable-xcsecurity} \
477         --enable-xephyr \
478         %{?with_xf86bigfont:--enable-xf86bigfont} \
479         --disable-xfake \
480         --enable-xfbdev \
481         %{?with_xselinux:--enable-xselinux}
482
483 %{__make}
484
485 %install
486 rm -rf $RPM_BUILD_ROOT
487
488 %if "%{_libdir}" != "%{_exec_prefix}/lib"
489 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
490 %endif
491
492 %{__make} install \
493         DESTDIR=$RPM_BUILD_ROOT
494
495 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
496 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
497 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
498 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
499 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
500
501 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
502 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
503
504 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
505
506 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
507
508 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
509 install -d $RPM_BUILD_ROOT/etc/sysconfig
510 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
511 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
512
513 # prepare source package
514 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
515 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
516 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
517 %{__make} distclean
518 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
519 find -name '*.h' | xargs chmod a-x
520
521 %if %{with systemtap}
522 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
523 %endif
524
525 %clean
526 rm -rf $RPM_BUILD_ROOT
527
528 %triggerpostun -- xorg-xserver-server < 1.5.0
529 if [ -f /etc/X11/xorg.conf ]; then
530         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
531         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
532 %if %{without record}
533         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
534 %endif
535         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
536 fi
537
538 %post -n xorg-xserver-Xvfb-init
539 /sbin/chkconfig --add Xvfb
540 %service Xvfb restart
541
542 %preun -n xorg-xserver-Xvfb-init
543 if [ "$1" = "0" ]; then
544         %service -q Xvfb stop
545         /sbin/chkconfig --del Xvfb
546 fi
547
548 %files
549 %defattr(644,root,root,755)
550 %doc COPYING ChangeLog README
551 %attr(755,root,root) %{_bindir}/X
552 %attr(755,root,root) %{_bindir}/Xorg
553 %attr(4755,root,root) %{_bindir}/Xwrapper
554 %attr(755,root,root) %{_bindir}/cvt
555 %attr(755,root,root) %{_bindir}/gtf
556 %dir %{_libdir}/xorg
557 %{_libdir}/xorg/protocol.txt
558 %dir %{_libdir}/xorg/modules
559 %dir %{_libdir}/xorg/modules/dri
560 %dir %{_libdir}/xorg/modules/drivers
561 %dir %{_libdir}/xorg/modules/extensions
562 %dir %{_libdir}/xorg/modules/input
563 %dir %{_libdir}/xorg/modules/multimedia
564 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
565 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
566 %if "%{_libdir}" != "%{_exec_prefix}/lib"
567 %dir %{_exec_prefix}/lib/xorg
568 %dir %{_exec_prefix}/lib/xorg/modules
569 %dir %{_exec_prefix}/lib/xorg/modules/dri
570 %endif
571 %dir /var/lib/xkb
572 /var/lib/xkb/README.compiled
573 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
574 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
575 %config(missingok) /etc/security/console.apps/xserver
576 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
577 %dir /etc/X11/xorg.conf.d
578 %dir %{_datadir}/X11/xorg.conf.d
579 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
580 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
581 %{_mandir}/man1/Xorg.1*
582 %{_mandir}/man1/Xserver.1*
583 %{_mandir}/man1/cvt.1*
584 %{_mandir}/man1/gtf.1*
585 %{_mandir}/man4/exa.4*
586 %{_mandir}/man4/fbdevhw.4*
587 %{_mandir}/man5/xorg.conf.5*
588 %{_mandir}/man5/xorg.conf.d.5*
589
590 %if %{with dmx}
591 %files -n xorg-xserver-Xdmx
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_bindir}/Xdmx
594 %attr(755,root,root) %{_bindir}/dmxaddinput
595 %attr(755,root,root) %{_bindir}/dmxaddscreen
596 %attr(755,root,root) %{_bindir}/dmxinfo
597 %attr(755,root,root) %{_bindir}/dmxreconfig
598 %attr(755,root,root) %{_bindir}/dmxresize
599 %attr(755,root,root) %{_bindir}/dmxrminput
600 %attr(755,root,root) %{_bindir}/dmxrmscreen
601 %attr(755,root,root) %{_bindir}/dmxtodmx
602 %attr(755,root,root) %{_bindir}/dmxwininfo
603 %attr(755,root,root) %{_bindir}/vdltodmx
604 %attr(755,root,root) %{_bindir}/xdmxconfig
605 %{_mandir}/man1/Xdmx.1*
606 %{_mandir}/man1/dmxtodmx.1*
607 %{_mandir}/man1/vdltodmx.1*
608 %{_mandir}/man1/xdmxconfig.1*
609 %endif
610
611 %files -n xorg-xserver-Xnest
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_bindir}/Xnest
614 %{_mandir}/man1/Xnest.1*
615
616 %files -n xorg-xserver-Xephyr
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/Xephyr
619 %{_mandir}/man1/Xephyr.1*
620
621 %files -n xorg-xserver-Xfbdev
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_bindir}/Xfbdev
624
625 %files -n xorg-xserver-Xvfb
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_bindir}/Xvfb
628 %attr(755,root,root) %{_bindir}/xvfb-run
629 %{_mandir}/man1/Xvfb.1*
630
631 %files -n xorg-xserver-Xvfb-init
632 %defattr(644,root,root,755)
633 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
634 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
635
636 %files devel
637 %defattr(644,root,root,755)
638 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
639 %{_includedir}/xorg
640 %{_libdir}/libxf86config.a
641 %{_libdir}/libxf86config.la
642 %{_aclocaldir}/xorg-server.m4
643 %{_pkgconfigdir}/xorg-server.pc
644
645 %files source
646 %defattr(644,root,root,755)
647 # keep file perms from install time, but have default defattr to keep adapter happy
648 %defattr(-,root,root,755)
649 %{_usrsrc}/%{name}-%{version}
650
651 %files -n xorg-xserver-libglx
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.092026 seconds and 4 git commands to generate.