]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
f4e6263e8b5137fcdd985401c29a8935fe52cd3d
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  record          # RECORD extension
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 %bcond_without  dmx             # DMX DDX (Xdmx server)
15 %bcond_without  wayland         # Wayland DDX (Xwayland server)
16 %bcond_without  glamor          # glamor dix module
17 %bcond_without  systemtap       # systemtap/dtrace probes
18 %bcond_without  libunwind       # use libunwind for backtracing
19 #
20 # ABI versions, see hw/xfree86/common/xf86Module.h
21 %define xorg_xserver_server_ansic_abi           0.4
22 %define xorg_xserver_server_extension_abi       9.0
23 %define xorg_xserver_server_font_abi            0.6
24 %define xorg_xserver_server_videodrv_abi        20.0
25 %define xorg_xserver_server_xinput_abi          22.1
26
27 %define pixman_ver      0.30.0
28
29 %ifarch x32
30 %undefine       with_libunwind
31 %endif
32
33 Summary:        X.org server
34 Summary(pl.UTF-8):      Serwer X.org
35 Name:           xorg-xserver-server
36 Version:        1.18.0
37 Release:        2
38 License:        MIT
39 Group:          X11/Servers
40 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
41 # Source0-md5:  3c1c1057d3ad27380d8dd87ffcc182cd
42 Source1:        10-quirks.conf
43 Source2:        xserver.pamd
44 Source10:       %{name}-Xvfb.init
45 Source11:       %{name}-Xvfb.sysconfig
46 Source12:       xvfb-run.sh
47 Patch1:         %{name}-xwrapper-pam.patch
48 Patch2:         dtrace-link.patch
49
50 Patch4:         %{name}-builtin-SHA1.patch
51
52 Patch6:         110_nvidia_slowdow_fix.patch
53 Patch7:         %{name}-include-defs.patch
54 URL:            http://xorg.freedesktop.org/
55 BuildRequires:  Mesa-libGL-devel >= 7.8.1
56 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
57 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
58 # for glx headers
59 BuildRequires:  OpenGL-GLX-devel
60 %{?with_xselinux:BuildRequires: audit-libs-devel}
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  cpp
64 BuildRequires:  docbook-dtd43-xml
65 #BuildRequires: doxygen >= 1.6.1
66 %if %{with hal} || %{with dbus}
67 BuildRequires:  dbus-devel >= 1.0
68 %endif
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.46
71 %if %{with glamor} || %{with wayland}
72 BuildRequires:  libepoxy-devel
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtool >= 2:2.2
76 %{?with_libunwind:BuildRequires:        libunwind-devel}
77 BuildRequires:  libxcb-devel >= 1.6
78 BuildRequires:  pam-devel
79 BuildRequires:  perl-base
80 BuildRequires:  pixman-devel >= %{pixman_ver}
81 BuildRequires:  pkgconfig >= 1:0.19
82 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
83 BuildRequires:  systemd-devel
84 BuildRequires:  udev-devel >= 1:143
85 # wayland-client
86 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
87 BuildRequires:  xcb-util-devel
88 BuildRequires:  xcb-util-image-devel
89 BuildRequires:  xcb-util-keysyms-devel
90 BuildRequires:  xcb-util-renderutil-devel
91 BuildRequires:  xcb-util-wm-devel
92 BuildRequires:  xmlto >= 0.0.20
93 BuildRequires:  xorg-app-mkfontscale
94 BuildRequires:  xorg-font-font-util >= 1.1
95 BuildRequires:  xorg-lib-libX11-devel >= 1.6
96 BuildRequires:  xorg-lib-libXau-devel
97 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
98 BuildRequires:  xorg-lib-libXdamage-devel
99 BuildRequires:  xorg-lib-libXdmcp-devel
100 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
101 BuildRequires:  xorg-lib-libXfixes-devel
102 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
103 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
104 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
105 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
106 BuildRequires:  xorg-lib-libXrender-devel
107 BuildRequires:  xorg-lib-libXres-devel
108 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
109 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
110 BuildRequires:  xorg-lib-libXv-devel
111 BuildRequires:  xorg-lib-libXxf86dga-devel
112 BuildRequires:  xorg-lib-libXxf86misc-devel
113 BuildRequires:  xorg-lib-libXxf86vm-devel
114 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
115 BuildRequires:  xorg-lib-libfontenc-devel
116 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
117 BuildRequires:  xorg-lib-libxkbfile-devel
118 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
119 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
120 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
121 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
122 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
123 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
124 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
125 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
126 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
127 BuildRequires:  xorg-proto-fontcacheproto-devel
128 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
129 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
130 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
131 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
132 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
133 BuildRequires:  xorg-proto-printproto-devel
134 BuildRequires:  xorg-proto-randrproto-devel >= 1.5.0
135 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
136 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
137 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
138 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
139 BuildRequires:  xorg-proto-videoproto-devel
140 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
141 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
142 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
143 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
144 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
145 BuildRequires:  xorg-proto-xf86miscproto-devel
146 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
147 BuildRequires:  xorg-proto-xineramaproto-devel
148 BuildRequires:  xorg-proto-xproto-devel >= 7.0.28
149 BuildRequires:  xorg-sgml-doctools >= 1.8
150 BuildRequires:  xorg-util-util-macros >= 1.14
151 #BR: tslib (for KDRIVE only)
152 Requires(triggerpostun):        sed >= 4.0
153 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
154 Requires:       libdrm >= 2.4.46
155 Requires:       pixman >= %{pixman_ver}
156 Requires:       udev-libs >= 1:143
157 Requires:       xkeyboard-config
158 # for rgb.txt
159 Requires:       xorg-app-rgb >= 0.99.3
160 Requires:       xorg-app-xkbcomp
161 Requires:       xorg-lib-libXfont >= 1.4.2
162 Requires:       xorg-lib-libpciaccess >= 0.12.901
163 Requires:       xorg-lib-libxshmfence >= 1.1
164 Suggests:       dbus-x11 >= 1.0
165 %{?with_hal:Suggests:   hal}
166 Suggests:       udev-acl >= 1:143
167 %{?with_udev:Suggests:  udev-core >= 1:143}
168 Suggests:       xkeyboard-config
169 Suggests:       xorg-driver-input-evdev
170 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
171 Suggests:       xorg-driver-video
172 Provides:       xorg-xserver-libdri = %{version}-%{release}
173 Provides:       xorg-xserver-module(dri)
174 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
175 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
176 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
177 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
178 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
179 Obsoletes:      X11-Xserver < 1:7.0.0
180 Obsoletes:      X11-driver-i2c < 1:7.0.0
181 Obsoletes:      X11-modules < 1:7.0.0
182 Obsoletes:      X11-setup < 1:7.0.0
183 Obsoletes:      XFree86-Xserver < 1:7.0.0
184 Obsoletes:      XFree86-modules < 1:7.0.0
185 Obsoletes:      XFree86-setup < 1:7.0.0
186 Obsoletes:      Xserver
187 %{?with_glamor:Obsoletes:       glamor}
188 Obsoletes:      xorg-xserver-libdri
189 Obsoletes:      xorg-xserver-server-xorgcfg
190 Obsoletes:      xorg-driver-video-modesetting
191 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
192
193 # avoid self-dependencies on included modules
194 %define         _noautoreq      libscanpci.so libxf1bpp.so
195
196 %description
197 Xorg server is a generally used X server which uses display hardware.
198 It requires proper driver for your display hardware.
199
200 %description -l pl.UTF-8
201 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
202 graficznej. Do działania wymaga odpowiedniego sterownika.
203
204 %package -n xorg-xserver-Xdmx
205 Summary:        Xdmx - distributed multi-head X server
206 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
207 Group:          X11/Servers
208 Requires:       pixman >= %{pixman_ver}
209 Requires:       xorg-lib-libX11 >= 1.6
210 Requires:       xorg-lib-libXext >= 1.0.99.4
211 Requires:       xorg-lib-libXfont >= 1.4.2
212 Requires:       xorg-lib-libXi >= 1.2.99.1
213 Requires:       xorg-lib-libdmx >= 1.0.99.1
214
215 %description -n xorg-xserver-Xdmx
216 Xdmx - distributed multi-head X server.
217
218 %description -n xorg-xserver-Xdmx -l pl.UTF-8
219 Xdmx - rozproszony, wielomonitorowy serwer X.
220
221 %package -n xorg-xserver-Xnest
222 Summary:        Xnest - nested X server
223 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
224 Group:          X11/Servers
225 Requires:       pixman >= %{pixman_ver}
226 Requires:       xorg-lib-libXext >= 1.0.99.4
227 Requires:       xorg-lib-libXfont >= 1.4.2
228 Obsoletes:      X11-Xnest < 1:7.0.0
229 Obsoletes:      XFree86-Xnest < 1:7.0.0
230 Obsoletes:      Xserver-Xnest
231
232 %description -n xorg-xserver-Xnest
233 Xnest is an X Window System server which runs in an X window. Xnest is
234 a 'nested' window server, actually a client of the real X server,
235 which manages windows and graphics requests for Xnest, while Xnest
236 manages the windows and graphics requests for its own clients.
237
238 %description -n xorg-xserver-Xnest -l pl.UTF-8
239 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
240 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
241 serwer X dla własnych klientów.
242
243 %description -n xorg-xserver-Xnest -l ru.UTF-8
244 Xnest - это сервер X Window System, который работает в окне X. На
245 самом деле это клиент реального X-сервера, который управляет окнами и
246 графическими запросами для Xnest в то время, как Xnest управляет
247 окнами и графическими запросами для своих собственных клиентов.
248
249 %description -n xorg-xserver-Xnest -l uk.UTF-8
250 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
251 клієнт реального X-сервера, який керує вікнами та графічними запитами
252 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
253 своїх власних клієнтів.
254
255 %package -n xorg-xserver-Xephyr
256 Summary:        Xephyr - nested X server
257 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
258 Group:          X11/Servers
259 Requires:       Mesa-libGL >= 7.1.0
260 Requires:       libxcb >= 1.6
261 Requires:       pixman >= %{pixman_ver}
262 Requires:       xorg-lib-libXfont >= 1.4.2
263
264 %description -n xorg-xserver-Xephyr
265 Xephyr is a kdrive server that outputs to a window on a pre-existing
266 'host' X display. Think Xnest but with support for modern extensions
267 like composite, damage and randr.
268
269 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
270 the host X server, Xephyr is a real X server which uses the host X
271 server window as "framebuffer" via fast SHM XImages.
272
273 It also has support for 'visually' debugging what the server is
274 painting.
275
276 %description -n xorg-xserver-Xephyr -l pl.UTF-8
277 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
278 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
279 wspólczesnych rozszerzeń jak composite, damage i randr.
280
281 %package -n xorg-xserver-Xfbdev
282 Summary:        Xfbdev - Linux framebuffer device X server
283 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
284 Group:          X11/Servers
285 Requires:       pixman >= %{pixman_ver}
286 Requires:       xorg-lib-libXfont >= 1.4.2
287
288 %description -n xorg-xserver-Xfbdev
289 Xfbdev is a Linux framebuffer device X server based on the kdrive X
290 server.
291
292 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
293 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
294
295 %package -n xorg-xserver-Xvfb
296 Summary:        Xvfb - virtual framebuffer X server
297 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
298 Group:          X11/Servers
299 Requires:       Mesa-libGL >= 7.1.0
300 Requires:       mktemp
301 Requires:       pixman >= %{pixman_ver}
302 Requires:       util-linux
303 Requires:       which
304 Requires:       xkeyboard-config
305 Requires:       xorg-app-xauth
306 Requires:       xorg-app-xkbcomp
307 Requires:       xorg-lib-libXfont >= 1.4.2
308 Obsoletes:      X11-Xvfb < 1:7.0.0
309 Obsoletes:      XFree86-Xvfb < 1:7.0.0
310
311 %description -n xorg-xserver-Xvfb
312 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
313 capable of running on machines with no display hardware and no
314 physical input devices. Xvfb emulates a dumb framebuffer using virtual
315 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
316 display. Xvfb is normally used for testing servers. Using Xvfb, the
317 mfb or cfb code for any depth can be exercised without using real
318 hardware that supports the desired depths. Xvfb has also been used to
319 test X clients against unusual depths and screen configurations, to do
320 batch processing with Xvfb as a background rendering engine, to do
321 load testing, to help with porting an X server to a new platform, and
322 to provide an unobtrusive way of running applications which really
323 don't need an X server but insist on having one.
324
325 %description -n xorg-xserver-Xvfb -l pl.UTF-8
326 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
327 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
328 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
329 używany do testowania serwerów X, może też być używany do testowania
330 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
331 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
332 serwera X, ale odmawiają uruchomienia bez niego.
333
334 %package -n xorg-xserver-Xvfb-init
335 Summary:        Init scripts for Xvfb
336 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
337 Group:          X11/Servers
338 Requires:       xorg-xserver-Xvfb
339
340 %description -n xorg-xserver-Xvfb-init
341 This package contains init scripts for Xvfb and registers Xvfb as
342 system service.
343
344 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
345 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
346 usługę systemową.
347
348 %package -n xorg-xserver-Xwayland
349 Summary:        Xwayland - X server integrated into a Wayland window system
350 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
351 Group:          X11/Servers
352 Requires:       pixman >= %{pixman_ver}
353 Requires:       xorg-lib-libX11 >= 1.6
354 Requires:       xorg-lib-libXext >= 1.0.99.4
355 Requires:       xorg-lib-libXfont >= 1.4.2
356 Requires:       xorg-lib-libXi >= 1.2.99.1
357
358 %description -n xorg-xserver-Xwayland
359 Xwayland - server integrated into a Wayland window system.
360
361 %description -n xorg-xserver-Xwayland -l pl.UTF-8
362 Xwayland - serwer X integrowalny w Wayland.
363
364 %package devel
365 Summary:        Header files for X.org server
366 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
367 Group:          X11/Development/Libraries
368 Requires:       Mesa-libGL-devel >= 7.8.0
369 Requires:       libdrm-devel >= 2.4.46
370 Requires:       pixman-devel >= %{pixman_ver}
371 Requires:       xorg-lib-libXfont-devel
372 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
373 Requires:       xorg-lib-libxkbfile-devel
374 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
375 Requires:       xorg-proto-dri3proto-devel >= 1.0
376 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
377 Requires:       xorg-proto-glproto-devel >= 1.4.17
378 Requires:       xorg-proto-inputproto-devel >= 2.3
379 Requires:       xorg-proto-kbproto-devel >= 1.0.3
380 Requires:       xorg-proto-presentproto-devel >= 1.0
381 Requires:       xorg-proto-randrproto-devel >= 1.5.0
382 Requires:       xorg-proto-renderproto-devel >= 0.11
383 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
384 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
385 Requires:       xorg-proto-videoproto-devel
386 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
387 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
388 Requires:       xorg-proto-xineramaproto-devel
389 Requires:       xorg-proto-xproto-devel >= 7.0.28
390 Obsoletes:      X11-Xserver-devel < 1:7.0.0
391 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
392 %{?with_glamor:Obsoletes:       glamor-devel}
393
394 %description devel
395 Header files for X.org server.
396
397 %description devel -l pl.UTF-8
398 Pliki nagłówkowe dla serwera X.org.
399
400 %package source
401 Summary:        X.org server source code
402 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
403 Group:          X11/Development/Libraries
404
405 %description source
406 X.org server source code.
407
408 %description source -l pl.UTF-8
409 Pliki źródłowe dla serwera X.org.
410
411 %package -n xorg-xserver-libglx
412 Summary:        GLX extension library for X.org server
413 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
414 Group:          X11/Servers
415 Requires:       %{name} = %{version}-%{release}
416 Requires:       Mesa-libGL >= 7.1.0
417 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
418 # Mesa version glapi tables in glx/ dir come from
419 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
420 Provides:       xorg-xserver-module(glx)
421 Obsoletes:      X11-OpenGL-core < 1:7.0.0
422 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
423
424 %description -n xorg-xserver-libglx
425 GLX extension library for X.org server.
426
427 %description -n xorg-xserver-libglx -l pl.UTF-8
428 Biblioteka rozszerzenia GLX dla serwera X.org.
429
430 %prep
431 %setup -q -n xorg-server-%{version}
432 %patch1 -p1
433 %patch2 -p1
434
435 %patch4 -p1
436
437 %patch6 -p1
438 %patch7 -p1
439
440 # xserver uses pixman-1 API/ABI so put that explictly here
441 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
442
443 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
444 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
445
446 %build
447 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
448 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
449         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
450         exit 1
451 fi
452
453 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
454 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
455         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
456         exit 1
457 fi
458
459 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
460 if [ $API != %{xorg_xserver_server_font_abi} ]; then
461         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
462         exit 1
463 fi
464 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
465 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
466         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
467         exit 1
468 fi
469 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
470 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
471         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
472         exit 1
473 fi
474
475 %{__libtoolize}
476 %{__aclocal} -I m4
477 %{__autoconf}
478 %{__autoheader}
479 %{__automake}
480 %configure \
481         --libexecdir=%{_libdir}/xorg \
482         --with-os-name="PLD/Linux" \
483         --with-os-vendor="PLD/Team" \
484         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
485         --with-xkb-output=/var/lib/xkb \
486         --disable-linux-acpi \
487         --disable-linux-apm \
488         --enable-aiglx \
489         %{?with_dbus:--enable-config-dbus} \
490         --enable-config-hal%{!?with_hal:=no} \
491         --enable-config-udev%{!?with_udev:=no} \
492         --enable-dga \
493         %{?with_dmx:--enable-dmx} \
494         --enable-dri2%{!?with_dri2:=no} \
495         %{?with_glamor:--enable-glamor} \
496         --enable-kdrive \
497         %{?with_libunwind:--enable-libunwind} \
498         %{?with_record:--enable-record} \
499         --enable-secure-rpc \
500         %{?with_xcsecurity:--enable-xcsecurity} \
501         --enable-xephyr \
502         %{?with_xf86bigfont:--enable-xf86bigfont} \
503         --disable-xfake \
504         --enable-xfbdev \
505         %{?with_xselinux:--enable-xselinux} \
506         %{?with_wayland:--enable-xwayland} \
507         %{!?with_systemtap:--without-dtrace} \
508         --without-fop \
509         --enable-suid-wrapper \
510         --with-systemd-daemon
511
512 %{__make} -j1
513
514 %install
515 rm -rf $RPM_BUILD_ROOT
516
517 %if "%{_libdir}" != "%{_exec_prefix}/lib"
518 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
519 %endif
520
521 %{__make} install \
522         DESTDIR=$RPM_BUILD_ROOT
523
524 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
525 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
526 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
527 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
528 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
529
530 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
531 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
532
533 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
534
535 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
536
537 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
538 install -d $RPM_BUILD_ROOT/etc/sysconfig
539 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
540 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
541
542 # Xorg.wrap config
543 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
544 # allowed values: rootonly console anybody pam
545 allowed_users = pam
546
547 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
548 #needs_root_rights = yes
549 EOF
550
551 # compatibility with old xwrapper
552 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
553
554 # prepare source package
555 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
556 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
557 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
558 %{__make} distclean
559 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
560 find -name '*.h' | xargs chmod a-x
561
562 %if %{with systemtap}
563 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
564 %endif
565
566 %clean
567 rm -rf $RPM_BUILD_ROOT
568
569 %triggerpostun -- xorg-xserver-server < 1.5.0
570 if [ -f /etc/X11/xorg.conf ]; then
571         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
572         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
573 %if %{without record}
574         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
575 %endif
576         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
577 fi
578
579 %post -n xorg-xserver-Xvfb-init
580 /sbin/chkconfig --add Xvfb
581 %service Xvfb restart
582
583 %preun -n xorg-xserver-Xvfb-init
584 if [ "$1" = "0" ]; then
585         %service -q Xvfb stop
586         /sbin/chkconfig --del Xvfb
587 fi
588
589 %files
590 %defattr(644,root,root,755)
591 %doc COPYING ChangeLog README
592 %attr(755,root,root) %{_bindir}/X
593 %attr(755,root,root) %{_bindir}/Xorg
594 %attr(4755,root,root) %{_bindir}/Xwrapper
595 %attr(755,root,root) %{_bindir}/cvt
596 %attr(755,root,root) %{_bindir}/gtf
597 %dir %{_libdir}/xorg
598 %{_libdir}/xorg/protocol.txt
599 %attr(755,root,root) %{_libdir}/xorg/Xorg
600 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
601 %dir %{_libdir}/xorg/modules
602 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
603 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
604 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
605 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
606 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
607 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
608 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
609 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
610 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
611 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
612 %dir %{_libdir}/xorg/modules/dri
613 %dir %{_libdir}/xorg/modules/drivers
614 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
615 %dir %{_libdir}/xorg/modules/extensions
616 %dir %{_libdir}/xorg/modules/input
617 %if "%{_libdir}" != "%{_exec_prefix}/lib"
618 %dir %{_exec_prefix}/lib/xorg
619 %dir %{_exec_prefix}/lib/xorg/modules
620 %dir %{_exec_prefix}/lib/xorg/modules/dri
621 %endif
622 %dir /var/lib/xkb
623 /var/lib/xkb/README.compiled
624 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
625 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
626 %config(missingok) /etc/security/console.apps/xserver
627 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
628 %dir /etc/X11/xorg.conf.d
629 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
630 %dir %{_datadir}/X11/xorg.conf.d
631 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
632 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
633 %{_mandir}/man1/Xorg.1*
634 %{_mandir}/man1/Xorg.wrap.1*
635 %{_mandir}/man1/Xserver.1*
636 %{_mandir}/man1/cvt.1*
637 %{_mandir}/man1/gtf.1*
638 %{_mandir}/man4/exa.4*
639 %{_mandir}/man4/fbdevhw.4*
640 %{_mandir}/man4/modesetting.4*
641 %{_mandir}/man5/Xwrapper.config.5*
642 %{_mandir}/man5/xorg.conf.5*
643 %{_mandir}/man5/xorg.conf.d.5*
644
645 %if %{with dmx}
646 %files -n xorg-xserver-Xdmx
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_bindir}/Xdmx
649 %attr(755,root,root) %{_bindir}/dmxaddinput
650 %attr(755,root,root) %{_bindir}/dmxaddscreen
651 %attr(755,root,root) %{_bindir}/dmxinfo
652 %attr(755,root,root) %{_bindir}/dmxreconfig
653 %attr(755,root,root) %{_bindir}/dmxresize
654 %attr(755,root,root) %{_bindir}/dmxrminput
655 %attr(755,root,root) %{_bindir}/dmxrmscreen
656 %attr(755,root,root) %{_bindir}/dmxtodmx
657 %attr(755,root,root) %{_bindir}/dmxwininfo
658 %attr(755,root,root) %{_bindir}/vdltodmx
659 %attr(755,root,root) %{_bindir}/xdmxconfig
660 %{_mandir}/man1/Xdmx.1*
661 %{_mandir}/man1/dmxtodmx.1*
662 %{_mandir}/man1/vdltodmx.1*
663 %{_mandir}/man1/xdmxconfig.1*
664 %endif
665
666 %files -n xorg-xserver-Xnest
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/Xnest
669 %{_mandir}/man1/Xnest.1*
670
671 %files -n xorg-xserver-Xephyr
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_bindir}/Xephyr
674 %{_mandir}/man1/Xephyr.1*
675
676 %files -n xorg-xserver-Xfbdev
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_bindir}/Xfbdev
679
680 %files -n xorg-xserver-Xvfb
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_bindir}/Xvfb
683 %attr(755,root,root) %{_bindir}/xvfb-run
684 %{_mandir}/man1/Xvfb.1*
685
686 %files -n xorg-xserver-Xvfb-init
687 %defattr(644,root,root,755)
688 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
689 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
690
691 %if %{with wayland}
692 %files -n xorg-xserver-Xwayland
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_bindir}/Xwayland
695 %endif
696
697 %files devel
698 %defattr(644,root,root,755)
699 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
700 %{_includedir}/xorg
701 %{_aclocaldir}/xorg-server.m4
702 %{_pkgconfigdir}/xorg-server.pc
703
704 %files source
705 %defattr(644,root,root,755)
706 # keep file perms from install time, but have default defattr to keep adapter happy
707 %defattr(-,root,root,755)
708 %{_usrsrc}/%{name}-%{version}
709
710 %files -n xorg-xserver-libglx
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.068551 seconds and 2 git commands to generate.