]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
8e750f9b0ce0ae774348df1f09114eb57872a433
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_with     wayland         # Wayland DDX (Xwayland server) [newer version in xorg-xserver-Xwayland.spec]
17 %bcond_without  xnest           # Xnest DDX (Xnest server)
18 %bcond_without  xvfb            # Xvfb DDX (Xvfb server)
19 %bcond_without  xephyr          # kdrive Xephyr server
20 %bcond_with     eglstream       # XWayland eglstream support
21 %bcond_without  glamor          # glamor dix module
22 %bcond_without  systemtap       # systemtap/dtrace probes
23 %bcond_without  libunwind       # use libunwind for backtracing
24 #
25 # ABI versions, see hw/xfree86/common/xf86Module.h
26 %define xorg_xserver_server_ansic_abi           0.4
27 %define xorg_xserver_server_extension_abi       10.0
28 %define xorg_xserver_server_videodrv_abi        24.1
29 %define xorg_xserver_server_xinput_abi          24.1
30
31 %define pixman_ver      0.30.0
32
33 %ifarch x32
34 %undefine       with_libunwind
35 %endif
36
37 Summary:        X.org server
38 Summary(pl.UTF-8):      Serwer X.org
39 Name:           xorg-xserver-server
40 Version:        1.20.11
41 Release:        3
42 License:        MIT
43 Group:          X11/Servers
44 Source0:        https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
45 # Source0-md5:  a22ccd74a5eee721cad6805e489c7144
46 Source1:        10-quirks.conf
47 Source2:        xserver.pamd
48 Source10:       %{name}-Xvfb.init
49 Source11:       %{name}-Xvfb.sysconfig
50 Source12:       xvfb-run.sh
51 Patch1:         %{name}-xwrapper-pam.patch
52
53 Patch4:         %{name}-builtin-SHA1.patch
54
55 Patch6:         110_nvidia_slowdow_fix.patch
56 Patch7:         platform_probe_crash.patch
57 URL:            https://xorg.freedesktop.org/
58 BuildRequires:  Mesa-dri-devel >= 7.8.1
59 %{?with_dri2:BuildRequires:     Mesa-dri-devel >= 9.2.0}
60 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 17.1.0}
61 BuildRequires:  OpenGL-devel >= 3.0
62 # for glx headers
63 BuildRequires:  OpenGL-GLX-devel >= 1.3
64 %{?with_xselinux:BuildRequires: audit-libs-devel}
65 BuildRequires:  autoconf >= 2.60
66 BuildRequires:  automake
67 BuildRequires:  cpp
68 BuildRequires:  docbook-dtd43-xml
69 #BuildRequires: doxygen >= 1.6.1
70 %if %{with hal} || %{with dbus}
71 BuildRequires:  dbus-devel >= 1.0
72 %endif
73 %{?with_eglstream:BuildRequires:        egl-wayland-devel >= 1.0.2}
74 %{?with_hal:BuildRequires:      hal-devel}
75 BuildRequires:  libdrm-devel >= 2.4.89
76 %if %{with glamor}
77 BuildRequires:  libepoxy-devel >= 1.5.4
78 %endif
79 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
80 BuildRequires:  libtirpc-devel
81 BuildRequires:  libtool >= 2:2.2
82 %{?with_libunwind:BuildRequires:        libunwind-devel}
83 BuildRequires:  libxcb-devel >= 1.9.3
84 BuildRequires:  pam-devel
85 BuildRequires:  perl-base
86 BuildRequires:  pixman-devel >= %{pixman_ver}
87 BuildRequires:  pkgconfig >= 1:0.19
88 BuildRequires:  pkgconfig(gl) >= 1.2
89 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
90 BuildRequires:  systemd-devel >= 1:209
91 BuildRequires:  udev-devel >= 1:143
92 # wayland-client
93 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
94 %{?with_wayland:BuildRequires:  wayland-protocols >= 1.10}
95 BuildRequires:  xcb-util-devel
96 BuildRequires:  xcb-util-image-devel
97 BuildRequires:  xcb-util-keysyms-devel
98 BuildRequires:  xcb-util-renderutil-devel
99 BuildRequires:  xcb-util-wm-devel
100 BuildRequires:  xmlto >= 0.0.20
101 BuildRequires:  xorg-app-mkfontscale
102 BuildRequires:  xorg-font-font-util >= 1.1
103 BuildRequires:  xorg-lib-libX11-devel >= 1.6
104 BuildRequires:  xorg-lib-libXau-devel
105 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
106 BuildRequires:  xorg-lib-libXdamage-devel
107 BuildRequires:  xorg-lib-libXdmcp-devel
108 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
109 BuildRequires:  xorg-lib-libXfixes-devel
110 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
111 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
112 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
113 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
114 BuildRequires:  xorg-lib-libXrender-devel
115 BuildRequires:  xorg-lib-libXres-devel
116 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
117 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
118 BuildRequires:  xorg-lib-libXv-devel
119 BuildRequires:  xorg-lib-libXxf86dga-devel
120 BuildRequires:  xorg-lib-libXxf86misc-devel
121 BuildRequires:  xorg-lib-libXxf86vm-devel
122 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
123 BuildRequires:  xorg-lib-libfontenc-devel
124 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
125 BuildRequires:  xorg-lib-libxkbfile-devel
126 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
127 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
128 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
129 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
130 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
131 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
132 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
133 BuildRequires:  xorg-proto-dri3proto-devel >= 1.2
134 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
135 BuildRequires:  xorg-proto-fontcacheproto-devel
136 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
137 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
138 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
139 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
140 BuildRequires:  xorg-proto-presentproto-devel >= 1.1
141 BuildRequires:  xorg-proto-printproto-devel
142 BuildRequires:  xorg-proto-randrproto-devel >= 1.6.0
143 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
144 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
145 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
146 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
147 BuildRequires:  xorg-proto-videoproto-devel
148 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
149 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
150 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
151 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
152 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
153 BuildRequires:  xorg-proto-xf86miscproto-devel
154 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
155 BuildRequires:  xorg-proto-xineramaproto-devel
156 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
157 BuildRequires:  xorg-sgml-doctools >= 1.8
158 BuildRequires:  xorg-util-util-macros >= 1.14
159 %{?with_glamor:Requires:        Mesa-libgbm >= 17.1.0}
160 Requires:       libdrm >= 2.4.89
161 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
162 Requires:       pixman >= %{pixman_ver}
163 Requires:       sed >= 4.0
164 Requires:       udev-libs >= 1:143
165 Requires:       xkeyboard-config
166 # for rgb.txt
167 Requires:       xorg-app-rgb >= 0.99.3
168 Requires:       xorg-app-xkbcomp
169 Requires:       xorg-lib-libXfont2 >= 2.0.0
170 Requires:       xorg-lib-libpciaccess >= 0.12.901
171 Requires:       xorg-lib-libxshmfence >= 1.1
172 # for protocol.txt
173 Requires:       xorg-xserver-common = %{version}-%{release}
174 Suggests:       dbus-x11 >= 1.0
175 %{?with_hal:Suggests:   hal}
176 Suggests:       udev-acl >= 1:143
177 %{?with_udev:Suggests:  udev-core >= 1:143}
178 Suggests:       xkeyboard-config
179 Suggests:       xorg-driver-input-libinput
180 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
181 Suggests:       xorg-driver-video
182 Provides:       xorg-driver-video-modesetting
183 Provides:       xorg-xserver-libdri = %{version}-%{release}
184 Provides:       xorg-xserver-module(dri)
185 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
186 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
187 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
188 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
189 Obsoletes:      X11-Xserver < 1:7.0.0
190 Obsoletes:      X11-driver-i2c < 1:7.0.0
191 Obsoletes:      X11-modules < 1:7.0.0
192 Obsoletes:      X11-setup < 1:7.0.0
193 Obsoletes:      XFree86-Xserver < 1:7.0.0
194 Obsoletes:      XFree86-modules < 1:7.0.0
195 Obsoletes:      XFree86-setup < 1:7.0.0
196 Obsoletes:      Xserver < 7.0
197 %{?with_glamor:Obsoletes:       glamor < 0.6.1}
198 Obsoletes:      xorg-xserver-libdri < 1.12.99
199 Obsoletes:      xorg-xserver-server-xorgcfg < 1.5.99
200 Obsoletes:      xorg-driver-video-modesetting < 0.9.1
201 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
202
203 %define         tirpc_cflags    $(pkg-config --cflags libtirpc)
204 %define         tirpc_libs      $(pkg-config --libs libtirpc)
205
206 %description
207 Xorg server is a generally used X server which uses display hardware.
208 It requires proper driver for your display hardware.
209
210 %description -l pl.UTF-8
211 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
212 graficznej. Do działania wymaga odpowiedniego sterownika.
213
214 %package devel
215 Summary:        Header files for X.org server
216 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
217 Group:          X11/Development/Libraries
218 Requires:       Mesa-dri-devel >= 7.8.0
219 Requires:       libdrm-devel >= 2.4.89
220 Requires:       pixman-devel >= %{pixman_ver}
221 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
222 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
223 Requires:       xorg-lib-libxkbfile-devel
224 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
225 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
226 Requires:       xorg-proto-dri3proto-devel >= 1.0
227 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
228 Requires:       xorg-proto-glproto-devel >= 1.4.17
229 Requires:       xorg-proto-inputproto-devel >= 2.3
230 Requires:       xorg-proto-kbproto-devel >= 1.0.3
231 Requires:       xorg-proto-presentproto-devel >= 1.1
232 Requires:       xorg-proto-randrproto-devel >= 1.6.0
233 Requires:       xorg-proto-renderproto-devel >= 0.11
234 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
235 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
236 Requires:       xorg-proto-videoproto-devel
237 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
238 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
239 Requires:       xorg-proto-xineramaproto-devel
240 Requires:       xorg-proto-xproto-devel >= 7.0.31
241 Obsoletes:      X11-Xserver-devel < 1:7.0.0
242 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
243 %{?with_glamor:Obsoletes:       glamor-devel < 0.6.1}
244
245 %description devel
246 Header files for X.org server.
247
248 %description devel -l pl.UTF-8
249 Pliki nagłówkowe dla serwera X.org.
250
251 %package source
252 Summary:        X.org server source code
253 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
254 Group:          X11/Development/Libraries
255
256 %description source
257 X.org server source code.
258
259 %description source -l pl.UTF-8
260 Pliki źródłowe dla serwera X.org.
261
262 %package -n xorg-xserver-libglx
263 Summary:        GLX extension library for X.org server
264 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
265 Group:          X11/Servers
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       OpenGL >= 1.2
268 # Mesa version glapi tables in glx/ dir come from
269 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
270 Provides:       xorg-xserver-module(glx)
271 Obsoletes:      X11-OpenGL-core < 1:7.0.0
272 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
273
274 %description -n xorg-xserver-libglx
275 GLX extension library for X.org server.
276
277 %description -n xorg-xserver-libglx -l pl.UTF-8
278 Biblioteka rozszerzenia GLX dla serwera X.org.
279
280 %package -n xorg-xserver-Xdmx
281 Summary:        Xdmx - distributed multi-head X server
282 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
283 Group:          X11/Servers
284 Requires:       pixman >= %{pixman_ver}
285 Requires:       xorg-lib-libX11 >= 1.6
286 Requires:       xorg-lib-libXext >= 1.0.99.4
287 Requires:       xorg-lib-libXfont2 >= 2.0.0
288 Requires:       xorg-lib-libXi >= 1.2.99.1
289 Requires:       xorg-lib-libdmx >= 1.0.99.1
290
291 %description -n xorg-xserver-Xdmx
292 Xdmx - distributed multi-head X server.
293
294 %description -n xorg-xserver-Xdmx -l pl.UTF-8
295 Xdmx - rozproszony, wielomonitorowy serwer X.
296
297 %package -n xorg-xserver-Xephyr
298 Summary:        Xephyr - nested X server
299 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
300 Group:          X11/Servers
301 Requires:       OpenGL >= 3.0
302 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
303 Requires:       libxcb >= 1.9.3
304 Requires:       pixman >= %{pixman_ver}
305 Requires:       xorg-lib-libXfont2 >= 2.0.0
306
307 %description -n xorg-xserver-Xephyr
308 Xephyr is a kdrive server that outputs to a window on a pre-existing
309 'host' X display. Think Xnest but with support for modern extensions
310 like composite, damage and randr.
311
312 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
313 the host X server, Xephyr is a real X server which uses the host X
314 server window as "framebuffer" via fast SHM XImages.
315
316 It also has support for 'visually' debugging what the server is
317 painting.
318
319 %description -n xorg-xserver-Xephyr -l pl.UTF-8
320 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
321 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
322 wspólczesnych rozszerzeń jak composite, damage i randr.
323
324 %package -n xorg-xserver-Xnest
325 Summary:        Xnest - nested X server
326 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
327 Group:          X11/Servers
328 Requires:       pixman >= %{pixman_ver}
329 Requires:       xorg-lib-libXext >= 1.0.99.4
330 Requires:       xorg-lib-libXfont2 >= 2.0.0
331 Obsoletes:      X11-Xnest < 1:7.0.0
332 Obsoletes:      XFree86-Xnest < 1:7.0.0
333 Obsoletes:      Xserver-Xnest < 7.0
334
335 %description -n xorg-xserver-Xnest
336 Xnest is an X Window System server which runs in an X window. Xnest is
337 a 'nested' window server, actually a client of the real X server,
338 which manages windows and graphics requests for Xnest, while Xnest
339 manages the windows and graphics requests for its own clients.
340
341 %description -n xorg-xserver-Xnest -l pl.UTF-8
342 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
343 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
344 serwer X dla własnych klientów.
345
346 %description -n xorg-xserver-Xnest -l ru.UTF-8
347 Xnest - это сервер X Window System, который работает в окне X. На
348 самом деле это клиент реального X-сервера, который управляет окнами и
349 графическими запросами для Xnest в то время, как Xnest управляет
350 окнами и графическими запросами для своих собственных клиентов.
351
352 %description -n xorg-xserver-Xnest -l uk.UTF-8
353 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
354 клієнт реального X-сервера, який керує вікнами та графічними запитами
355 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
356 своїх власних клієнтів.
357
358 %package -n xorg-xserver-Xvfb
359 Summary:        Xvfb - virtual framebuffer X server
360 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
361 Group:          X11/Servers
362 Requires:       OpenGL >= 1.2.1
363 Requires:       mktemp
364 Requires:       pixman >= %{pixman_ver}
365 Requires:       util-linux
366 Requires:       which
367 Requires:       xkeyboard-config
368 Requires:       xorg-app-xauth
369 Requires:       xorg-app-xkbcomp
370 Requires:       xorg-lib-libXfont2 >= 2.0.0
371 Obsoletes:      X11-Xvfb < 1:7.0.0
372 Obsoletes:      XFree86-Xvfb < 1:7.0.0
373
374 %description -n xorg-xserver-Xvfb
375 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
376 capable of running on machines with no display hardware and no
377 physical input devices. Xvfb emulates a dumb framebuffer using virtual
378 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
379 display. Xvfb is normally used for testing servers. Using Xvfb, the
380 mfb or cfb code for any depth can be exercised without using real
381 hardware that supports the desired depths. Xvfb has also been used to
382 test X clients against unusual depths and screen configurations, to do
383 batch processing with Xvfb as a background rendering engine, to do
384 load testing, to help with porting an X server to a new platform, and
385 to provide an unobtrusive way of running applications which really
386 don't need an X server but insist on having one.
387
388 %description -n xorg-xserver-Xvfb -l pl.UTF-8
389 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
390 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
391 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
392 używany do testowania serwerów X, może też być używany do testowania
393 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
394 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
395 serwera X, ale odmawiają uruchomienia bez niego.
396
397 %package -n xorg-xserver-Xvfb-init
398 Summary:        Init scripts for Xvfb
399 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
400 Group:          X11/Servers
401 Requires:       xorg-xserver-Xvfb = %{version}-%{release}
402
403 %description -n xorg-xserver-Xvfb-init
404 This package contains init scripts for Xvfb and registers Xvfb as
405 system service.
406
407 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
408 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
409 usługę systemową.
410
411 %package -n xorg-xserver-Xwayland
412 Summary:        Xwayland - X server integrated into a Wayland window system
413 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
414 Group:          X11/Servers
415 %{?with_eglstream:Requires:     egl-wayland >= 1.0.2}
416 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
417 Requires:       pixman >= %{pixman_ver}
418 Requires:       xorg-lib-libX11 >= 1.6
419 Requires:       xorg-lib-libXext >= 1.0.99.4
420 Requires:       xorg-lib-libXfont2 >= 2.0.0
421 Requires:       xorg-lib-libXi >= 1.2.99.1
422 # for protocol.txt
423 Requires:       xorg-xserver-common = %{version}-%{release}
424
425 %description -n xorg-xserver-Xwayland
426 Xwayland - server integrated into a Wayland window system.
427
428 %description -n xorg-xserver-Xwayland -l pl.UTF-8
429 Xwayland - serwer X integrowalny w Wayland.
430
431 %package -n xorg-xserver-common
432 Summary:        Common files for various X servers
433 Summary(pl.UTF-8):      Pliki wspólne dla serwerów X
434 Group:          X11/Servers
435 Conflicts:      xorg-xserver-server < 1.20.11-2
436
437 %description -n xorg-xserver-common
438 Common files for various X servers.
439
440 %description -n xorg-xserver-common -l pl.UTF-8
441 Pliki wspólne dla serwerów X.
442
443 %prep
444 %setup -q -n xorg-server-%{version}
445 %patch1 -p1
446
447 %patch4 -p1
448
449 %patch6 -p1
450 %patch7 -p1
451
452 # xserver uses pixman-1 API/ABI so put that explictly here
453 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
454
455 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
456 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
457
458 %{__sed} -i -e '1s|#!/usr/bin/python$|#!%{__python}|' config/fdi2iclass.py
459
460 %build
461 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
462 if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
463         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
464         exit 1
465 fi
466
467 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
468 if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
469         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
470         exit 1
471 fi
472
473 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
474 if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
475         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
476         exit 1
477 fi
478 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
479 if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
480         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
481         exit 1
482 fi
483
484 %{__libtoolize}
485 %{__aclocal} -I m4
486 %{__autoconf}
487 %{__autoheader}
488 %{__automake}
489 %configure \
490         CPPFLAGS="%{rpmcppflags} %{tirpc_cflags}" \
491         LIBS="%{tirpc_libs}" \
492         --libexecdir=%{_libdir}/xorg \
493         --with-os-name="PLD/Linux" \
494         --with-os-vendor="PLD/Team" \
495         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
496         --with-xkb-output=/var/lib/xkb \
497         --disable-linux-acpi \
498         --disable-linux-apm \
499         %{?with_dbus:--enable-config-dbus} \
500         --enable-config-hal%{!?with_hal:=no} \
501         --enable-config-udev%{!?with_udev:=no} \
502         --enable-dga \
503         %{?with_dmx:--enable-dmx} \
504         --enable-dri2%{!?with_dri2:=no} \
505         --enable-dri3%{!?with_dri3:=no} \
506         %{?with_glamor:--enable-glamor} \
507         --enable-kdrive \
508         %{?with_libunwind:--enable-libunwind} \
509         %{?with_record:--enable-record} \
510         --enable-secure-rpc \
511         --enable-suid-wrapper \
512         %{?with_xcsecurity:--enable-xcsecurity} \
513         --enable-xephyr%{!?with_xephyr:=no} \
514         %{?with_xf86bigfont:--enable-xf86bigfont} \
515         --enable-xnest%{!?with_xnest:=no} \
516         %{?with_xselinux:--enable-xselinux} \
517         %{!?with_xvfb:--disable-xvfb} \
518         --enable-xwayland%{!?with_wayland:=no} \
519         %{?with_eglstream:--enable-xwayland-eglstream} \
520         %{!?with_systemtap:--without-dtrace} \
521         --without-fop \
522         --with-systemd-daemon
523
524 %{__make}
525
526 %install
527 rm -rf $RPM_BUILD_ROOT
528
529 %if "%{_libdir}" != "%{_exec_prefix}/lib"
530 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
531 %endif
532
533 %{__make} install \
534         DESTDIR=$RPM_BUILD_ROOT
535
536 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
537 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
538 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
539 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
540 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
541
542 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
543 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
544
545 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
546
547 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
548
549 %if %{with xvfb}
550 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
551 install -d $RPM_BUILD_ROOT/etc/sysconfig
552 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
553 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
554 %endif
555
556 # Xorg.wrap config
557 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
558 # allowed values: rootonly console anybody pam
559 allowed_users = pam
560
561 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
562 #needs_root_rights = yes
563 EOF
564
565 # compatibility with old xwrapper
566 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
567
568 # prepare source package
569 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
570 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
571 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
572 %{__make} distclean
573 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
574 find -name '*.h' | xargs chmod a-x
575
576 %if %{with systemtap}
577 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
578 %endif
579
580 %clean
581 rm -rf $RPM_BUILD_ROOT
582
583 %triggerpostun -- xorg-xserver-server < 1.5.0
584 if [ -f /etc/X11/xorg.conf ]; then
585         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
586         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
587 %if %{without record}
588         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
589 %endif
590         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
591 fi
592
593 %post -n xorg-xserver-Xvfb-init
594 /sbin/chkconfig --add Xvfb
595 %service Xvfb restart
596
597 %preun -n xorg-xserver-Xvfb-init
598 if [ "$1" = "0" ]; then
599         %service -q Xvfb stop
600         /sbin/chkconfig --del Xvfb
601 fi
602
603 %files
604 %defattr(644,root,root,755)
605 %doc COPYING ChangeLog README.md
606 %attr(755,root,root) %{_bindir}/X
607 %attr(755,root,root) %{_bindir}/Xorg
608 %attr(4755,root,root) %{_bindir}/Xwrapper
609 %attr(755,root,root) %{_bindir}/cvt
610 %attr(755,root,root) %{_bindir}/gtf
611 %attr(755,root,root) %{_libdir}/xorg/Xorg
612 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
613 %dir %{_libdir}/xorg/modules
614 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
615 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
616 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
617 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
618 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
619 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
620 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
621 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
622 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
623 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
624 %dir %{_libdir}/xorg/modules/dri
625 %dir %{_libdir}/xorg/modules/drivers
626 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
627 %dir %{_libdir}/xorg/modules/extensions
628 %dir %{_libdir}/xorg/modules/input
629 %if "%{_libdir}" != "%{_exec_prefix}/lib"
630 %dir %{_exec_prefix}/lib/xorg
631 %dir %{_exec_prefix}/lib/xorg/modules
632 %dir %{_exec_prefix}/lib/xorg/modules/dri
633 %endif
634 %dir /var/lib/xkb
635 /var/lib/xkb/README.compiled
636 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
637 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
638 %config(missingok) /etc/security/console.apps/xserver
639 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
640 %dir /etc/X11/xorg.conf.d
641 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
642 %dir %{_datadir}/X11/xorg.conf.d
643 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
644 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
645 %{_mandir}/man1/Xorg.1*
646 %{_mandir}/man1/Xorg.wrap.1*
647 %{_mandir}/man1/cvt.1*
648 %{_mandir}/man1/gtf.1*
649 %{_mandir}/man4/exa.4*
650 %{_mandir}/man4/fbdevhw.4*
651 %{_mandir}/man4/modesetting.4*
652 %{_mandir}/man5/Xwrapper.config.5*
653 %{_mandir}/man5/xorg.conf.5*
654 %{_mandir}/man5/xorg.conf.d.5*
655
656 %files devel
657 %defattr(644,root,root,755)
658 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
659 %{_includedir}/xorg
660 %{_aclocaldir}/xorg-server.m4
661 %{_pkgconfigdir}/xorg-server.pc
662
663 %files source
664 %defattr(644,root,root,755)
665 # keep file perms from install time, but have default defattr to keep adapter happy
666 %defattr(-,root,root,755)
667 %{_usrsrc}/%{name}-%{version}
668
669 %files -n xorg-xserver-libglx
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
672
673 %if %{with dmx}
674 %files -n xorg-xserver-Xdmx
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_bindir}/Xdmx
677 %attr(755,root,root) %{_bindir}/dmxaddinput
678 %attr(755,root,root) %{_bindir}/dmxaddscreen
679 %attr(755,root,root) %{_bindir}/dmxinfo
680 %attr(755,root,root) %{_bindir}/dmxreconfig
681 %attr(755,root,root) %{_bindir}/dmxresize
682 %attr(755,root,root) %{_bindir}/dmxrminput
683 %attr(755,root,root) %{_bindir}/dmxrmscreen
684 %attr(755,root,root) %{_bindir}/dmxtodmx
685 %attr(755,root,root) %{_bindir}/dmxwininfo
686 %attr(755,root,root) %{_bindir}/vdltodmx
687 %attr(755,root,root) %{_bindir}/xdmxconfig
688 %{_mandir}/man1/Xdmx.1*
689 %{_mandir}/man1/dmxtodmx.1*
690 %{_mandir}/man1/vdltodmx.1*
691 %{_mandir}/man1/xdmxconfig.1*
692 %endif
693
694 %if %{with xephyr}
695 %files -n xorg-xserver-Xephyr
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_bindir}/Xephyr
698 %{_mandir}/man1/Xephyr.1*
699 %endif
700
701 %if %{with xnest}
702 %files -n xorg-xserver-Xnest
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_bindir}/Xnest
705 %{_mandir}/man1/Xnest.1*
706 %endif
707
708 %if %{with xvfb}
709 %files -n xorg-xserver-Xvfb
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_bindir}/Xvfb
712 %attr(755,root,root) %{_bindir}/xvfb-run
713 %{_mandir}/man1/Xvfb.1*
714
715 %files -n xorg-xserver-Xvfb-init
716 %defattr(644,root,root,755)
717 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
718 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
719 %endif
720
721 %if %{with wayland}
722 %files -n xorg-xserver-Xwayland
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_bindir}/Xwayland
725 %endif
726
727 %files -n xorg-xserver-common
728 %defattr(644,root,root,755)
729 %dir %{_libdir}/xorg
730 %{_libdir}/xorg/protocol.txt
731 %{_mandir}/man1/Xserver.1*
This page took 0.065826 seconds and 2 git commands to generate.