]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- separated -tools with cvt and gtf; release 4
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_with     wayland         # Wayland DDX (Xwayland server) [newer version in xorg-xserver-Xwayland.spec]
17 %bcond_without  xnest           # Xnest DDX (Xnest server)
18 %bcond_without  xvfb            # Xvfb DDX (Xvfb server)
19 %bcond_without  xephyr          # kdrive Xephyr server
20 %bcond_with     eglstream       # XWayland eglstream support
21 %bcond_without  glamor          # glamor dix module
22 %bcond_without  systemtap       # systemtap/dtrace probes
23 %bcond_without  libunwind       # use libunwind for backtracing
24 #
25 # ABI versions, see hw/xfree86/common/xf86Module.h
26 %define xorg_xserver_server_ansic_abi           0.4
27 %define xorg_xserver_server_extension_abi       10.0
28 %define xorg_xserver_server_videodrv_abi        24.1
29 %define xorg_xserver_server_xinput_abi          24.1
30
31 %define pixman_ver      0.30.0
32
33 %ifarch x32
34 %undefine       with_libunwind
35 %endif
36
37 Summary:        X.org server
38 Summary(pl.UTF-8):      Serwer X.org
39 Name:           xorg-xserver-server
40 Version:        1.20.11
41 Release:        4
42 License:        MIT
43 Group:          X11/Servers
44 Source0:        https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
45 # Source0-md5:  a22ccd74a5eee721cad6805e489c7144
46 Source1:        10-quirks.conf
47 Source2:        xserver.pamd
48 Source10:       %{name}-Xvfb.init
49 Source11:       %{name}-Xvfb.sysconfig
50 Source12:       xvfb-run.sh
51 Patch1:         %{name}-xwrapper-pam.patch
52
53 Patch4:         %{name}-builtin-SHA1.patch
54
55 Patch6:         110_nvidia_slowdow_fix.patch
56 Patch7:         platform_probe_crash.patch
57 URL:            https://xorg.freedesktop.org/
58 BuildRequires:  Mesa-dri-devel >= 7.8.1
59 %{?with_dri2:BuildRequires:     Mesa-dri-devel >= 9.2.0}
60 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 17.1.0}
61 BuildRequires:  OpenGL-devel >= 3.0
62 # for glx headers
63 BuildRequires:  OpenGL-GLX-devel >= 1.3
64 %{?with_xselinux:BuildRequires: audit-libs-devel}
65 BuildRequires:  autoconf >= 2.60
66 BuildRequires:  automake
67 BuildRequires:  cpp
68 BuildRequires:  docbook-dtd43-xml
69 #BuildRequires: doxygen >= 1.6.1
70 %if %{with hal} || %{with dbus}
71 BuildRequires:  dbus-devel >= 1.0
72 %endif
73 %{?with_eglstream:BuildRequires:        egl-wayland-devel >= 1.0.2}
74 %{?with_hal:BuildRequires:      hal-devel}
75 BuildRequires:  libdrm-devel >= 2.4.89
76 %if %{with glamor}
77 BuildRequires:  libepoxy-devel >= 1.5.4
78 %endif
79 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
80 BuildRequires:  libtirpc-devel
81 BuildRequires:  libtool >= 2:2.2
82 %{?with_libunwind:BuildRequires:        libunwind-devel}
83 BuildRequires:  libxcb-devel >= 1.9.3
84 BuildRequires:  pam-devel
85 BuildRequires:  perl-base
86 BuildRequires:  pixman-devel >= %{pixman_ver}
87 BuildRequires:  pkgconfig >= 1:0.19
88 BuildRequires:  pkgconfig(gl) >= 1.2
89 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
90 BuildRequires:  systemd-devel >= 1:209
91 BuildRequires:  udev-devel >= 1:143
92 # wayland-client
93 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
94 %{?with_wayland:BuildRequires:  wayland-protocols >= 1.10}
95 BuildRequires:  xcb-util-devel
96 BuildRequires:  xcb-util-image-devel
97 BuildRequires:  xcb-util-keysyms-devel
98 BuildRequires:  xcb-util-renderutil-devel
99 BuildRequires:  xcb-util-wm-devel
100 BuildRequires:  xmlto >= 0.0.20
101 BuildRequires:  xorg-app-mkfontscale
102 BuildRequires:  xorg-font-font-util >= 1.1
103 BuildRequires:  xorg-lib-libX11-devel >= 1.6
104 BuildRequires:  xorg-lib-libXau-devel
105 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
106 BuildRequires:  xorg-lib-libXdamage-devel
107 BuildRequires:  xorg-lib-libXdmcp-devel
108 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
109 BuildRequires:  xorg-lib-libXfixes-devel
110 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
111 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
112 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
113 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
114 BuildRequires:  xorg-lib-libXrender-devel
115 BuildRequires:  xorg-lib-libXres-devel
116 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
117 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
118 BuildRequires:  xorg-lib-libXv-devel
119 BuildRequires:  xorg-lib-libXxf86dga-devel
120 BuildRequires:  xorg-lib-libXxf86misc-devel
121 BuildRequires:  xorg-lib-libXxf86vm-devel
122 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
123 BuildRequires:  xorg-lib-libfontenc-devel
124 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
125 BuildRequires:  xorg-lib-libxkbfile-devel
126 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
127 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
128 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
129 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
130 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
131 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
132 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
133 BuildRequires:  xorg-proto-dri3proto-devel >= 1.2
134 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
135 BuildRequires:  xorg-proto-fontcacheproto-devel
136 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
137 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
138 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
139 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
140 BuildRequires:  xorg-proto-presentproto-devel >= 1.1
141 BuildRequires:  xorg-proto-printproto-devel
142 BuildRequires:  xorg-proto-randrproto-devel >= 1.6.0
143 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
144 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
145 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
146 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
147 BuildRequires:  xorg-proto-videoproto-devel
148 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
149 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
150 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
151 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
152 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
153 BuildRequires:  xorg-proto-xf86miscproto-devel
154 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
155 BuildRequires:  xorg-proto-xineramaproto-devel
156 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
157 BuildRequires:  xorg-sgml-doctools >= 1.8
158 BuildRequires:  xorg-util-util-macros >= 1.14
159 %{?with_glamor:Requires:        Mesa-libgbm >= 17.1.0}
160 Requires:       libdrm >= 2.4.89
161 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
162 Requires:       pixman >= %{pixman_ver}
163 Requires:       sed >= 4.0
164 Requires:       udev-libs >= 1:143
165 Requires:       xkeyboard-config
166 # for rgb.txt
167 Requires:       xorg-app-rgb >= 0.99.3
168 Requires:       xorg-app-xkbcomp
169 Requires:       xorg-lib-libXfont2 >= 2.0.0
170 Requires:       xorg-lib-libpciaccess >= 0.12.901
171 Requires:       xorg-lib-libxshmfence >= 1.1
172 # for protocol.txt
173 Requires:       xorg-xserver-common = %{version}-%{release}
174 Suggests:       %{name}-tools = %{version}-%{release}
175 Suggests:       dbus-x11 >= 1.0
176 %{?with_hal:Suggests:   hal}
177 Suggests:       udev-acl >= 1:143
178 %{?with_udev:Suggests:  udev-core >= 1:143}
179 Suggests:       xkeyboard-config
180 Suggests:       xorg-driver-input-libinput
181 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
182 Suggests:       xorg-driver-video
183 Provides:       xorg-driver-video-modesetting
184 Provides:       xorg-xserver-libdri = %{version}-%{release}
185 Provides:       xorg-xserver-module(dri)
186 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
187 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
188 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
189 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
190 Obsoletes:      X11-Xserver < 1:7.0.0
191 Obsoletes:      X11-driver-i2c < 1:7.0.0
192 Obsoletes:      X11-modules < 1:7.0.0
193 Obsoletes:      X11-setup < 1:7.0.0
194 Obsoletes:      XFree86-Xserver < 1:7.0.0
195 Obsoletes:      XFree86-modules < 1:7.0.0
196 Obsoletes:      XFree86-setup < 1:7.0.0
197 Obsoletes:      Xserver < 7.0
198 %{?with_glamor:Obsoletes:       glamor < 0.6.1}
199 Obsoletes:      xorg-xserver-libdri < 1.12.99
200 Obsoletes:      xorg-xserver-server-xorgcfg < 1.5.99
201 Obsoletes:      xorg-driver-video-modesetting < 0.9.1
202 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
203
204 %define         tirpc_cflags    $(pkg-config --cflags libtirpc)
205 %define         tirpc_libs      $(pkg-config --libs libtirpc)
206
207 %description
208 Xorg server is a generally used X server which uses display hardware.
209 It requires proper driver for your display hardware.
210
211 %description -l pl.UTF-8
212 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
213 graficznej. Do działania wymaga odpowiedniego sterownika.
214
215 %package tools
216 Summary:        Tools to calculate modelines for X.org server
217 Summary(pl.UTF-8):      Narzędzia do liczenia opisów trybów graficznych (modeline) dla serwera X.org
218 Group:          X11/Applications
219 Conflicts:      xorg-xserver-server < 1.20.11-4
220
221 %description tools
222 Tools to calculate modelines for X.org server (using Coordinated Video
223 Timing or Generalized Timing Formula).
224
225 %description tools -l pl.UTF-8
226 Narzędzia do liczenia opisów trybów graficznych (modeline) dla serwera
227 X.org (przy użyciu algorytmów Coordinated Video Timing lub
228 Generalizaed Timing Formula).
229
230 %package devel
231 Summary:        Header files for X.org server
232 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
233 Group:          X11/Development/Libraries
234 Requires:       Mesa-dri-devel >= 7.8.0
235 Requires:       libdrm-devel >= 2.4.89
236 Requires:       pixman-devel >= %{pixman_ver}
237 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
238 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
239 Requires:       xorg-lib-libxkbfile-devel
240 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
241 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
242 Requires:       xorg-proto-dri3proto-devel >= 1.0
243 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
244 Requires:       xorg-proto-glproto-devel >= 1.4.17
245 Requires:       xorg-proto-inputproto-devel >= 2.3
246 Requires:       xorg-proto-kbproto-devel >= 1.0.3
247 Requires:       xorg-proto-presentproto-devel >= 1.1
248 Requires:       xorg-proto-randrproto-devel >= 1.6.0
249 Requires:       xorg-proto-renderproto-devel >= 0.11
250 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
251 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
252 Requires:       xorg-proto-videoproto-devel
253 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
254 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
255 Requires:       xorg-proto-xineramaproto-devel
256 Requires:       xorg-proto-xproto-devel >= 7.0.31
257 Obsoletes:      X11-Xserver-devel < 1:7.0.0
258 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
259 %{?with_glamor:Obsoletes:       glamor-devel < 0.6.1}
260
261 %description devel
262 Header files for X.org server.
263
264 %description devel -l pl.UTF-8
265 Pliki nagłówkowe dla serwera X.org.
266
267 %package source
268 Summary:        X.org server source code
269 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
270 Group:          X11/Development/Libraries
271
272 %description source
273 X.org server source code.
274
275 %description source -l pl.UTF-8
276 Pliki źródłowe dla serwera X.org.
277
278 %package -n xorg-xserver-libglx
279 Summary:        GLX extension library for X.org server
280 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
281 Group:          X11/Servers
282 Requires:       %{name} = %{version}-%{release}
283 Requires:       OpenGL >= 1.2
284 # Mesa version glapi tables in glx/ dir come from
285 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
286 Provides:       xorg-xserver-module(glx)
287 Obsoletes:      X11-OpenGL-core < 1:7.0.0
288 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
289
290 %description -n xorg-xserver-libglx
291 GLX extension library for X.org server.
292
293 %description -n xorg-xserver-libglx -l pl.UTF-8
294 Biblioteka rozszerzenia GLX dla serwera X.org.
295
296 %package -n xorg-xserver-Xdmx
297 Summary:        Xdmx - distributed multi-head X server
298 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
299 Group:          X11/Servers
300 Requires:       pixman >= %{pixman_ver}
301 Requires:       xorg-lib-libX11 >= 1.6
302 Requires:       xorg-lib-libXext >= 1.0.99.4
303 Requires:       xorg-lib-libXfont2 >= 2.0.0
304 Requires:       xorg-lib-libXi >= 1.2.99.1
305 Requires:       xorg-lib-libdmx >= 1.0.99.1
306
307 %description -n xorg-xserver-Xdmx
308 Xdmx - distributed multi-head X server.
309
310 %description -n xorg-xserver-Xdmx -l pl.UTF-8
311 Xdmx - rozproszony, wielomonitorowy serwer X.
312
313 %package -n xorg-xserver-Xephyr
314 Summary:        Xephyr - nested X server
315 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
316 Group:          X11/Servers
317 Requires:       OpenGL >= 3.0
318 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
319 Requires:       libxcb >= 1.9.3
320 Requires:       pixman >= %{pixman_ver}
321 Requires:       xorg-lib-libXfont2 >= 2.0.0
322
323 %description -n xorg-xserver-Xephyr
324 Xephyr is a kdrive server that outputs to a window on a pre-existing
325 'host' X display. Think Xnest but with support for modern extensions
326 like composite, damage and randr.
327
328 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
329 the host X server, Xephyr is a real X server which uses the host X
330 server window as "framebuffer" via fast SHM XImages.
331
332 It also has support for 'visually' debugging what the server is
333 painting.
334
335 %description -n xorg-xserver-Xephyr -l pl.UTF-8
336 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
337 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
338 wspólczesnych rozszerzeń jak composite, damage i randr.
339
340 %package -n xorg-xserver-Xnest
341 Summary:        Xnest - nested X server
342 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
343 Group:          X11/Servers
344 Requires:       pixman >= %{pixman_ver}
345 Requires:       xorg-lib-libXext >= 1.0.99.4
346 Requires:       xorg-lib-libXfont2 >= 2.0.0
347 Obsoletes:      X11-Xnest < 1:7.0.0
348 Obsoletes:      XFree86-Xnest < 1:7.0.0
349 Obsoletes:      Xserver-Xnest < 7.0
350
351 %description -n xorg-xserver-Xnest
352 Xnest is an X Window System server which runs in an X window. Xnest is
353 a 'nested' window server, actually a client of the real X server,
354 which manages windows and graphics requests for Xnest, while Xnest
355 manages the windows and graphics requests for its own clients.
356
357 %description -n xorg-xserver-Xnest -l pl.UTF-8
358 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
359 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
360 serwer X dla własnych klientów.
361
362 %description -n xorg-xserver-Xnest -l ru.UTF-8
363 Xnest - это сервер X Window System, который работает в окне X. На
364 самом деле это клиент реального X-сервера, который управляет окнами и
365 графическими запросами для Xnest в то время, как Xnest управляет
366 окнами и графическими запросами для своих собственных клиентов.
367
368 %description -n xorg-xserver-Xnest -l uk.UTF-8
369 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
370 клієнт реального X-сервера, який керує вікнами та графічними запитами
371 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
372 своїх власних клієнтів.
373
374 %package -n xorg-xserver-Xvfb
375 Summary:        Xvfb - virtual framebuffer X server
376 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
377 Group:          X11/Servers
378 Requires:       OpenGL >= 1.2.1
379 Requires:       mktemp
380 Requires:       pixman >= %{pixman_ver}
381 Requires:       util-linux
382 Requires:       which
383 Requires:       xkeyboard-config
384 Requires:       xorg-app-xauth
385 Requires:       xorg-app-xkbcomp
386 Requires:       xorg-lib-libXfont2 >= 2.0.0
387 Obsoletes:      X11-Xvfb < 1:7.0.0
388 Obsoletes:      XFree86-Xvfb < 1:7.0.0
389
390 %description -n xorg-xserver-Xvfb
391 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
392 capable of running on machines with no display hardware and no
393 physical input devices. Xvfb emulates a dumb framebuffer using virtual
394 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
395 display. Xvfb is normally used for testing servers. Using Xvfb, the
396 mfb or cfb code for any depth can be exercised without using real
397 hardware that supports the desired depths. Xvfb has also been used to
398 test X clients against unusual depths and screen configurations, to do
399 batch processing with Xvfb as a background rendering engine, to do
400 load testing, to help with porting an X server to a new platform, and
401 to provide an unobtrusive way of running applications which really
402 don't need an X server but insist on having one.
403
404 %description -n xorg-xserver-Xvfb -l pl.UTF-8
405 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
406 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
407 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
408 używany do testowania serwerów X, może też być używany do testowania
409 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
410 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
411 serwera X, ale odmawiają uruchomienia bez niego.
412
413 %package -n xorg-xserver-Xvfb-init
414 Summary:        Init scripts for Xvfb
415 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
416 Group:          X11/Servers
417 Requires:       xorg-xserver-Xvfb = %{version}-%{release}
418
419 %description -n xorg-xserver-Xvfb-init
420 This package contains init scripts for Xvfb and registers Xvfb as
421 system service.
422
423 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
424 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
425 usługę systemową.
426
427 %package -n xorg-xserver-Xwayland
428 Summary:        Xwayland - X server integrated into a Wayland window system
429 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
430 Group:          X11/Servers
431 %{?with_eglstream:Requires:     egl-wayland >= 1.0.2}
432 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
433 Requires:       pixman >= %{pixman_ver}
434 Requires:       xorg-lib-libX11 >= 1.6
435 Requires:       xorg-lib-libXext >= 1.0.99.4
436 Requires:       xorg-lib-libXfont2 >= 2.0.0
437 Requires:       xorg-lib-libXi >= 1.2.99.1
438 # for protocol.txt
439 Requires:       xorg-xserver-common = %{version}-%{release}
440
441 %description -n xorg-xserver-Xwayland
442 Xwayland - server integrated into a Wayland window system.
443
444 %description -n xorg-xserver-Xwayland -l pl.UTF-8
445 Xwayland - serwer X integrowalny w Wayland.
446
447 %package -n xorg-xserver-common
448 Summary:        Common files for various X servers
449 Summary(pl.UTF-8):      Pliki wspólne dla serwerów X
450 Group:          X11/Servers
451 Conflicts:      xorg-xserver-server < 1.20.11-2
452
453 %description -n xorg-xserver-common
454 Common files for various X servers.
455
456 %description -n xorg-xserver-common -l pl.UTF-8
457 Pliki wspólne dla serwerów X.
458
459 %prep
460 %setup -q -n xorg-server-%{version}
461 %patch1 -p1
462
463 %patch4 -p1
464
465 %patch6 -p1
466 %patch7 -p1
467
468 # xserver uses pixman-1 API/ABI so put that explictly here
469 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
470
471 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
472 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
473
474 %{__sed} -i -e '1s|#!/usr/bin/python$|#!%{__python}|' config/fdi2iclass.py
475
476 %build
477 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
478 if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
479         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
480         exit 1
481 fi
482
483 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
484 if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
485         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
486         exit 1
487 fi
488
489 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
490 if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
491         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
492         exit 1
493 fi
494 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
495 if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
496         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
497         exit 1
498 fi
499
500 %{__libtoolize}
501 %{__aclocal} -I m4
502 %{__autoconf}
503 %{__autoheader}
504 %{__automake}
505 %configure \
506         CPPFLAGS="%{rpmcppflags} %{tirpc_cflags}" \
507         LIBS="%{tirpc_libs}" \
508         --libexecdir=%{_libdir}/xorg \
509         --with-os-name="PLD/Linux" \
510         --with-os-vendor="PLD/Team" \
511         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
512         --with-xkb-output=/var/lib/xkb \
513         --disable-linux-acpi \
514         --disable-linux-apm \
515         %{?with_dbus:--enable-config-dbus} \
516         --enable-config-hal%{!?with_hal:=no} \
517         --enable-config-udev%{!?with_udev:=no} \
518         --enable-dga \
519         %{?with_dmx:--enable-dmx} \
520         --enable-dri2%{!?with_dri2:=no} \
521         --enable-dri3%{!?with_dri3:=no} \
522         %{?with_glamor:--enable-glamor} \
523         --enable-kdrive \
524         %{?with_libunwind:--enable-libunwind} \
525         %{?with_record:--enable-record} \
526         --enable-secure-rpc \
527         --enable-suid-wrapper \
528         %{?with_xcsecurity:--enable-xcsecurity} \
529         --enable-xephyr%{!?with_xephyr:=no} \
530         %{?with_xf86bigfont:--enable-xf86bigfont} \
531         --enable-xnest%{!?with_xnest:=no} \
532         %{?with_xselinux:--enable-xselinux} \
533         %{!?with_xvfb:--disable-xvfb} \
534         --enable-xwayland%{!?with_wayland:=no} \
535         %{?with_eglstream:--enable-xwayland-eglstream} \
536         %{!?with_systemtap:--without-dtrace} \
537         --without-fop \
538         --with-systemd-daemon
539
540 %{__make}
541
542 %install
543 rm -rf $RPM_BUILD_ROOT
544
545 %if "%{_libdir}" != "%{_exec_prefix}/lib"
546 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
547 %endif
548
549 %{__make} install \
550         DESTDIR=$RPM_BUILD_ROOT
551
552 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
553 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
554 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
555 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
556 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
557
558 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
559 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
560
561 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
562
563 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
564
565 %if %{with xvfb}
566 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
567 install -d $RPM_BUILD_ROOT/etc/sysconfig
568 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
569 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
570 %endif
571
572 # Xorg.wrap config
573 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
574 # allowed values: rootonly console anybody pam
575 allowed_users = pam
576
577 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
578 #needs_root_rights = yes
579 EOF
580
581 # compatibility with old xwrapper
582 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
583
584 # prepare source package
585 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
586 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
587 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
588 %{__make} distclean
589 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
590 find -name '*.h' | xargs chmod a-x
591
592 %if %{with systemtap}
593 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
594 %endif
595
596 %clean
597 rm -rf $RPM_BUILD_ROOT
598
599 %triggerpostun -- xorg-xserver-server < 1.5.0
600 if [ -f /etc/X11/xorg.conf ]; then
601         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
602         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
603 %if %{without record}
604         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
605 %endif
606         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
607 fi
608
609 %post -n xorg-xserver-Xvfb-init
610 /sbin/chkconfig --add Xvfb
611 %service Xvfb restart
612
613 %preun -n xorg-xserver-Xvfb-init
614 if [ "$1" = "0" ]; then
615         %service -q Xvfb stop
616         /sbin/chkconfig --del Xvfb
617 fi
618
619 %files
620 %defattr(644,root,root,755)
621 %doc COPYING ChangeLog README.md
622 %attr(755,root,root) %{_bindir}/X
623 %attr(755,root,root) %{_bindir}/Xorg
624 %attr(4755,root,root) %{_bindir}/Xwrapper
625 %attr(755,root,root) %{_libdir}/xorg/Xorg
626 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
627 %dir %{_libdir}/xorg/modules
628 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
629 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
630 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
631 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
632 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
633 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
634 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
635 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
636 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
637 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
638 %dir %{_libdir}/xorg/modules/dri
639 %dir %{_libdir}/xorg/modules/drivers
640 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
641 %dir %{_libdir}/xorg/modules/extensions
642 %dir %{_libdir}/xorg/modules/input
643 %if "%{_libdir}" != "%{_exec_prefix}/lib"
644 %dir %{_exec_prefix}/lib/xorg
645 %dir %{_exec_prefix}/lib/xorg/modules
646 %dir %{_exec_prefix}/lib/xorg/modules/dri
647 %endif
648 %dir /var/lib/xkb
649 /var/lib/xkb/README.compiled
650 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
651 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
652 %config(missingok) /etc/security/console.apps/xserver
653 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
654 %dir /etc/X11/xorg.conf.d
655 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
656 %dir %{_datadir}/X11/xorg.conf.d
657 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
658 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
659 %{_mandir}/man1/Xorg.1*
660 %{_mandir}/man1/Xorg.wrap.1*
661 %{_mandir}/man4/exa.4*
662 %{_mandir}/man4/fbdevhw.4*
663 %{_mandir}/man4/modesetting.4*
664 %{_mandir}/man5/Xwrapper.config.5*
665 %{_mandir}/man5/xorg.conf.5*
666 %{_mandir}/man5/xorg.conf.d.5*
667
668 %files tools
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/cvt
671 %attr(755,root,root) %{_bindir}/gtf
672 %{_mandir}/man1/cvt.1*
673 %{_mandir}/man1/gtf.1*
674
675 %files devel
676 %defattr(644,root,root,755)
677 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
678 %{_includedir}/xorg
679 %{_aclocaldir}/xorg-server.m4
680 %{_pkgconfigdir}/xorg-server.pc
681
682 %files source
683 %defattr(644,root,root,755)
684 # keep file perms from install time, but have default defattr to keep adapter happy
685 %defattr(-,root,root,755)
686 %{_usrsrc}/%{name}-%{version}
687
688 %files -n xorg-xserver-libglx
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
691
692 %if %{with dmx}
693 %files -n xorg-xserver-Xdmx
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_bindir}/Xdmx
696 %attr(755,root,root) %{_bindir}/dmxaddinput
697 %attr(755,root,root) %{_bindir}/dmxaddscreen
698 %attr(755,root,root) %{_bindir}/dmxinfo
699 %attr(755,root,root) %{_bindir}/dmxreconfig
700 %attr(755,root,root) %{_bindir}/dmxresize
701 %attr(755,root,root) %{_bindir}/dmxrminput
702 %attr(755,root,root) %{_bindir}/dmxrmscreen
703 %attr(755,root,root) %{_bindir}/dmxtodmx
704 %attr(755,root,root) %{_bindir}/dmxwininfo
705 %attr(755,root,root) %{_bindir}/vdltodmx
706 %attr(755,root,root) %{_bindir}/xdmxconfig
707 %{_mandir}/man1/Xdmx.1*
708 %{_mandir}/man1/dmxtodmx.1*
709 %{_mandir}/man1/vdltodmx.1*
710 %{_mandir}/man1/xdmxconfig.1*
711 %endif
712
713 %if %{with xephyr}
714 %files -n xorg-xserver-Xephyr
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_bindir}/Xephyr
717 %{_mandir}/man1/Xephyr.1*
718 %endif
719
720 %if %{with xnest}
721 %files -n xorg-xserver-Xnest
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_bindir}/Xnest
724 %{_mandir}/man1/Xnest.1*
725 %endif
726
727 %if %{with xvfb}
728 %files -n xorg-xserver-Xvfb
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_bindir}/Xvfb
731 %attr(755,root,root) %{_bindir}/xvfb-run
732 %{_mandir}/man1/Xvfb.1*
733
734 %files -n xorg-xserver-Xvfb-init
735 %defattr(644,root,root,755)
736 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
737 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
738 %endif
739
740 %if %{with wayland}
741 %files -n xorg-xserver-Xwayland
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_bindir}/Xwayland
744 %endif
745
746 %files -n xorg-xserver-common
747 %defattr(644,root,root,755)
748 %dir %{_libdir}/xorg
749 %{_libdir}/xorg/protocol.txt
750 %{_mandir}/man1/Xserver.1*
This page took 0.268128 seconds and 3 git commands to generate.