]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
try reenabling parallel build
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_with     eglstream       # XWayland eglstream support
18 %bcond_without  glamor          # glamor dix module
19 %bcond_without  systemtap       # systemtap/dtrace probes
20 %bcond_without  libunwind       # use libunwind for backtracing
21 #
22 # ABI versions, see hw/xfree86/common/xf86Module.h
23 %define xorg_xserver_server_ansic_abi           0.4
24 %define xorg_xserver_server_extension_abi       10.0
25 %define xorg_xserver_server_videodrv_abi        24.1
26 %define xorg_xserver_server_xinput_abi          24.1
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        1.20.8
38 Release:        2
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
42 # Source0-md5:  a770aec600116444a953ff632f51f839
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48 Patch1:         %{name}-xwrapper-pam.patch
49
50 Patch4:         %{name}-builtin-SHA1.patch
51
52 Patch6:         110_nvidia_slowdow_fix.patch
53 URL:            https://xorg.freedesktop.org/
54 BuildRequires:  Mesa-libGL-devel >= 7.8.1
55 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
56 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 17.1.0}
57 # for glx headers
58 BuildRequires:  OpenGL-GLX-devel
59 %{?with_xselinux:BuildRequires: audit-libs-devel}
60 BuildRequires:  autoconf >= 2.60
61 BuildRequires:  automake
62 BuildRequires:  cpp
63 BuildRequires:  docbook-dtd43-xml
64 #BuildRequires: doxygen >= 1.6.1
65 %if %{with hal} || %{with dbus}
66 BuildRequires:  dbus-devel >= 1.0
67 %endif
68 %{?with_eglstream:BuildRequires:        egl-wayland-devel >= 1.0.2}
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.89
71 %if %{with glamor}
72 BuildRequires:  libepoxy-devel >= 1.5.4
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtool >= 2:2.2
76 %{?with_libunwind:BuildRequires:        libunwind-devel}
77 BuildRequires:  libxcb-devel >= 1.9.3
78 BuildRequires:  pam-devel
79 BuildRequires:  perl-base
80 BuildRequires:  pixman-devel >= %{pixman_ver}
81 BuildRequires:  pkgconfig >= 1:0.19
82 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
83 BuildRequires:  systemd-devel >= 1:209
84 BuildRequires:  udev-devel >= 1:143
85 # wayland-client
86 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
87 %{?with_wayland:BuildRequires:  wayland-protocols >= 1.10}
88 BuildRequires:  xcb-util-devel
89 BuildRequires:  xcb-util-image-devel
90 BuildRequires:  xcb-util-keysyms-devel
91 BuildRequires:  xcb-util-renderutil-devel
92 BuildRequires:  xcb-util-wm-devel
93 BuildRequires:  xmlto >= 0.0.20
94 BuildRequires:  xorg-app-mkfontscale
95 BuildRequires:  xorg-font-font-util >= 1.1
96 BuildRequires:  xorg-lib-libX11-devel >= 1.6
97 BuildRequires:  xorg-lib-libXau-devel
98 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
99 BuildRequires:  xorg-lib-libXdamage-devel
100 BuildRequires:  xorg-lib-libXdmcp-devel
101 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
102 BuildRequires:  xorg-lib-libXfixes-devel
103 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
104 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
105 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
106 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
107 BuildRequires:  xorg-lib-libXrender-devel
108 BuildRequires:  xorg-lib-libXres-devel
109 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
110 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
111 BuildRequires:  xorg-lib-libXv-devel
112 BuildRequires:  xorg-lib-libXxf86dga-devel
113 BuildRequires:  xorg-lib-libXxf86misc-devel
114 BuildRequires:  xorg-lib-libXxf86vm-devel
115 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
116 BuildRequires:  xorg-lib-libfontenc-devel
117 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
118 BuildRequires:  xorg-lib-libxkbfile-devel
119 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
120 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
121 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
122 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
123 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
124 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
125 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
126 BuildRequires:  xorg-proto-dri3proto-devel >= 1.2
127 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
128 BuildRequires:  xorg-proto-fontcacheproto-devel
129 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
130 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
131 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
132 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
133 BuildRequires:  xorg-proto-presentproto-devel >= 1.1
134 BuildRequires:  xorg-proto-printproto-devel
135 BuildRequires:  xorg-proto-randrproto-devel >= 1.6.0
136 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
137 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
138 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
139 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
140 BuildRequires:  xorg-proto-videoproto-devel
141 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
142 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
143 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
144 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
145 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
146 BuildRequires:  xorg-proto-xf86miscproto-devel
147 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
148 BuildRequires:  xorg-proto-xineramaproto-devel
149 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
150 BuildRequires:  xorg-sgml-doctools >= 1.8
151 BuildRequires:  xorg-util-util-macros >= 1.14
152 #BR: tslib (for KDRIVE only)
153 Requires(triggerpostun):        sed >= 4.0
154 %{?with_glamor:Requires:        Mesa-libgbm >= 17.1.0}
155 Requires:       libdrm >= 2.4.89
156 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
157 Requires:       pixman >= %{pixman_ver}
158 Requires:       udev-libs >= 1:143
159 Requires:       xkeyboard-config
160 # for rgb.txt
161 Requires:       xorg-app-rgb >= 0.99.3
162 Requires:       xorg-app-xkbcomp
163 Requires:       xorg-lib-libXfont2 >= 2.0.0
164 Requires:       xorg-lib-libpciaccess >= 0.12.901
165 Requires:       xorg-lib-libxshmfence >= 1.1
166 Suggests:       dbus-x11 >= 1.0
167 %{?with_hal:Suggests:   hal}
168 Suggests:       udev-acl >= 1:143
169 %{?with_udev:Suggests:  udev-core >= 1:143}
170 Suggests:       xkeyboard-config
171 Suggests:       xorg-driver-input-libinput
172 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
173 Suggests:       xorg-driver-video
174 Provides:       xorg-driver-video-modesetting
175 Provides:       xorg-xserver-libdri = %{version}-%{release}
176 Provides:       xorg-xserver-module(dri)
177 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
178 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
179 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
180 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
181 Obsoletes:      X11-Xserver < 1:7.0.0
182 Obsoletes:      X11-driver-i2c < 1:7.0.0
183 Obsoletes:      X11-modules < 1:7.0.0
184 Obsoletes:      X11-setup < 1:7.0.0
185 Obsoletes:      XFree86-Xserver < 1:7.0.0
186 Obsoletes:      XFree86-modules < 1:7.0.0
187 Obsoletes:      XFree86-setup < 1:7.0.0
188 Obsoletes:      Xserver
189 %{?with_glamor:Obsoletes:       glamor}
190 Obsoletes:      xorg-xserver-libdri
191 Obsoletes:      xorg-xserver-server-xorgcfg
192 Obsoletes:      xorg-driver-video-modesetting
193 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
194
195 %description
196 Xorg server is a generally used X server which uses display hardware.
197 It requires proper driver for your display hardware.
198
199 %description -l pl.UTF-8
200 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
201 graficznej. Do działania wymaga odpowiedniego sterownika.
202
203 %package -n xorg-xserver-Xdmx
204 Summary:        Xdmx - distributed multi-head X server
205 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
206 Group:          X11/Servers
207 Requires:       pixman >= %{pixman_ver}
208 Requires:       xorg-lib-libX11 >= 1.6
209 Requires:       xorg-lib-libXext >= 1.0.99.4
210 Requires:       xorg-lib-libXfont2 >= 2.0.0
211 Requires:       xorg-lib-libXi >= 1.2.99.1
212 Requires:       xorg-lib-libdmx >= 1.0.99.1
213
214 %description -n xorg-xserver-Xdmx
215 Xdmx - distributed multi-head X server.
216
217 %description -n xorg-xserver-Xdmx -l pl.UTF-8
218 Xdmx - rozproszony, wielomonitorowy serwer X.
219
220 %package -n xorg-xserver-Xnest
221 Summary:        Xnest - nested X server
222 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
223 Group:          X11/Servers
224 Requires:       pixman >= %{pixman_ver}
225 Requires:       xorg-lib-libXext >= 1.0.99.4
226 Requires:       xorg-lib-libXfont2 >= 2.0.0
227 Obsoletes:      X11-Xnest < 1:7.0.0
228 Obsoletes:      XFree86-Xnest < 1:7.0.0
229 Obsoletes:      Xserver-Xnest
230
231 %description -n xorg-xserver-Xnest
232 Xnest is an X Window System server which runs in an X window. Xnest is
233 a 'nested' window server, actually a client of the real X server,
234 which manages windows and graphics requests for Xnest, while Xnest
235 manages the windows and graphics requests for its own clients.
236
237 %description -n xorg-xserver-Xnest -l pl.UTF-8
238 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
239 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
240 serwer X dla własnych klientów.
241
242 %description -n xorg-xserver-Xnest -l ru.UTF-8
243 Xnest - это сервер X Window System, который работает в окне X. На
244 самом деле это клиент реального X-сервера, который управляет окнами и
245 графическими запросами для Xnest в то время, как Xnest управляет
246 окнами и графическими запросами для своих собственных клиентов.
247
248 %description -n xorg-xserver-Xnest -l uk.UTF-8
249 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
250 клієнт реального X-сервера, який керує вікнами та графічними запитами
251 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
252 своїх власних клієнтів.
253
254 %package -n xorg-xserver-Xephyr
255 Summary:        Xephyr - nested X server
256 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
257 Group:          X11/Servers
258 Requires:       Mesa-libGL >= 7.1.0
259 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
260 Requires:       libxcb >= 1.9.3
261 Requires:       pixman >= %{pixman_ver}
262 Requires:       xorg-lib-libXfont2 >= 2.0.0
263
264 %description -n xorg-xserver-Xephyr
265 Xephyr is a kdrive server that outputs to a window on a pre-existing
266 'host' X display. Think Xnest but with support for modern extensions
267 like composite, damage and randr.
268
269 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
270 the host X server, Xephyr is a real X server which uses the host X
271 server window as "framebuffer" via fast SHM XImages.
272
273 It also has support for 'visually' debugging what the server is
274 painting.
275
276 %description -n xorg-xserver-Xephyr -l pl.UTF-8
277 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
278 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
279 wspólczesnych rozszerzeń jak composite, damage i randr.
280
281 %package -n xorg-xserver-Xvfb
282 Summary:        Xvfb - virtual framebuffer X server
283 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
284 Group:          X11/Servers
285 Requires:       Mesa-libGL >= 7.1.0
286 Requires:       mktemp
287 Requires:       pixman >= %{pixman_ver}
288 Requires:       util-linux
289 Requires:       which
290 Requires:       xkeyboard-config
291 Requires:       xorg-app-xauth
292 Requires:       xorg-app-xkbcomp
293 Requires:       xorg-lib-libXfont2 >= 2.0.0
294 Obsoletes:      X11-Xvfb < 1:7.0.0
295 Obsoletes:      XFree86-Xvfb < 1:7.0.0
296
297 %description -n xorg-xserver-Xvfb
298 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
299 capable of running on machines with no display hardware and no
300 physical input devices. Xvfb emulates a dumb framebuffer using virtual
301 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
302 display. Xvfb is normally used for testing servers. Using Xvfb, the
303 mfb or cfb code for any depth can be exercised without using real
304 hardware that supports the desired depths. Xvfb has also been used to
305 test X clients against unusual depths and screen configurations, to do
306 batch processing with Xvfb as a background rendering engine, to do
307 load testing, to help with porting an X server to a new platform, and
308 to provide an unobtrusive way of running applications which really
309 don't need an X server but insist on having one.
310
311 %description -n xorg-xserver-Xvfb -l pl.UTF-8
312 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
313 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
314 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
315 używany do testowania serwerów X, może też być używany do testowania
316 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
317 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
318 serwera X, ale odmawiają uruchomienia bez niego.
319
320 %package -n xorg-xserver-Xvfb-init
321 Summary:        Init scripts for Xvfb
322 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
323 Group:          X11/Servers
324 Requires:       xorg-xserver-Xvfb
325
326 %description -n xorg-xserver-Xvfb-init
327 This package contains init scripts for Xvfb and registers Xvfb as
328 system service.
329
330 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
331 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
332 usługę systemową.
333
334 %package -n xorg-xserver-Xwayland
335 Summary:        Xwayland - X server integrated into a Wayland window system
336 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
337 Group:          X11/Servers
338 %{?with_eglstream:Requires:     egl-wayland >= 1.0.2}
339 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
340 Requires:       pixman >= %{pixman_ver}
341 Requires:       xorg-lib-libX11 >= 1.6
342 Requires:       xorg-lib-libXext >= 1.0.99.4
343 Requires:       xorg-lib-libXfont2 >= 2.0.0
344 Requires:       xorg-lib-libXi >= 1.2.99.1
345
346 %description -n xorg-xserver-Xwayland
347 Xwayland - server integrated into a Wayland window system.
348
349 %description -n xorg-xserver-Xwayland -l pl.UTF-8
350 Xwayland - serwer X integrowalny w Wayland.
351
352 %package devel
353 Summary:        Header files for X.org server
354 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
355 Group:          X11/Development/Libraries
356 Requires:       Mesa-libGL-devel >= 7.8.0
357 Requires:       libdrm-devel >= 2.4.89
358 Requires:       pixman-devel >= %{pixman_ver}
359 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
360 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
361 Requires:       xorg-lib-libxkbfile-devel
362 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
363 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
364 Requires:       xorg-proto-dri3proto-devel >= 1.0
365 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
366 Requires:       xorg-proto-glproto-devel >= 1.4.17
367 Requires:       xorg-proto-inputproto-devel >= 2.3
368 Requires:       xorg-proto-kbproto-devel >= 1.0.3
369 Requires:       xorg-proto-presentproto-devel >= 1.1
370 Requires:       xorg-proto-randrproto-devel >= 1.6.0
371 Requires:       xorg-proto-renderproto-devel >= 0.11
372 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
373 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
374 Requires:       xorg-proto-videoproto-devel
375 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
376 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
377 Requires:       xorg-proto-xineramaproto-devel
378 Requires:       xorg-proto-xproto-devel >= 7.0.31
379 Obsoletes:      X11-Xserver-devel < 1:7.0.0
380 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
381 %{?with_glamor:Obsoletes:       glamor-devel}
382
383 %description devel
384 Header files for X.org server.
385
386 %description devel -l pl.UTF-8
387 Pliki nagłówkowe dla serwera X.org.
388
389 %package source
390 Summary:        X.org server source code
391 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
392 Group:          X11/Development/Libraries
393
394 %description source
395 X.org server source code.
396
397 %description source -l pl.UTF-8
398 Pliki źródłowe dla serwera X.org.
399
400 %package -n xorg-xserver-libglx
401 Summary:        GLX extension library for X.org server
402 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
403 Group:          X11/Servers
404 Requires:       %{name} = %{version}-%{release}
405 Requires:       Mesa-libGL >= 7.1.0
406 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
407 # Mesa version glapi tables in glx/ dir come from
408 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
409 Provides:       xorg-xserver-module(glx)
410 Obsoletes:      X11-OpenGL-core < 1:7.0.0
411 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
412
413 %description -n xorg-xserver-libglx
414 GLX extension library for X.org server.
415
416 %description -n xorg-xserver-libglx -l pl.UTF-8
417 Biblioteka rozszerzenia GLX dla serwera X.org.
418
419 %prep
420 %setup -q -n xorg-server-%{version}
421 %patch1 -p1
422
423 %patch4 -p1
424
425 %patch6 -p1
426
427 # xserver uses pixman-1 API/ABI so put that explictly here
428 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
429
430 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
431 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
432
433 %{__sed} -i -e '1s|#!/usr/bin/python$|#!%{__python}|' config/fdi2iclass.py
434
435 %build
436 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
437 if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
438         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
439         exit 1
440 fi
441
442 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
443 if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
444         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
445         exit 1
446 fi
447
448 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
449 if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
450         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
451         exit 1
452 fi
453 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
454 if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
455         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
456         exit 1
457 fi
458
459 %{__libtoolize}
460 %{__aclocal} -I m4
461 %{__autoconf}
462 %{__autoheader}
463 %{__automake}
464 %configure \
465         --libexecdir=%{_libdir}/xorg \
466         --with-os-name="PLD/Linux" \
467         --with-os-vendor="PLD/Team" \
468         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
469         --with-xkb-output=/var/lib/xkb \
470         --disable-linux-acpi \
471         --disable-linux-apm \
472         %{?with_dbus:--enable-config-dbus} \
473         --enable-config-hal%{!?with_hal:=no} \
474         --enable-config-udev%{!?with_udev:=no} \
475         --enable-dga \
476         %{?with_dmx:--enable-dmx} \
477         --enable-dri2%{!?with_dri2:=no} \
478         --enable-dri3%{!?with_dri3:=no} \
479         %{?with_glamor:--enable-glamor} \
480         --enable-kdrive \
481         %{?with_libunwind:--enable-libunwind} \
482         %{?with_record:--enable-record} \
483         --enable-secure-rpc \
484         %{?with_xcsecurity:--enable-xcsecurity} \
485         --enable-xephyr \
486         %{?with_xf86bigfont:--enable-xf86bigfont} \
487         %{?with_xselinux:--enable-xselinux} \
488         %{?with_wayland:--enable-xwayland} \
489         %{?with_eglstream:--enable-xwayland-eglstream} \
490         %{!?with_systemtap:--without-dtrace} \
491         --without-fop \
492         --enable-suid-wrapper \
493         --with-systemd-daemon
494
495 %{__make}
496
497 %install
498 rm -rf $RPM_BUILD_ROOT
499
500 %if "%{_libdir}" != "%{_exec_prefix}/lib"
501 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
502 %endif
503
504 %{__make} install \
505         DESTDIR=$RPM_BUILD_ROOT
506
507 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
508 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
509 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
510 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
511 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
512
513 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
514 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
515
516 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
517
518 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
519
520 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
521 install -d $RPM_BUILD_ROOT/etc/sysconfig
522 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
523 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
524
525 # Xorg.wrap config
526 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
527 # allowed values: rootonly console anybody pam
528 allowed_users = pam
529
530 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
531 #needs_root_rights = yes
532 EOF
533
534 # compatibility with old xwrapper
535 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
536
537 # prepare source package
538 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
539 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
540 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
541 %{__make} distclean
542 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
543 find -name '*.h' | xargs chmod a-x
544
545 %if %{with systemtap}
546 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
547 %endif
548
549 %clean
550 rm -rf $RPM_BUILD_ROOT
551
552 %triggerpostun -- xorg-xserver-server < 1.5.0
553 if [ -f /etc/X11/xorg.conf ]; then
554         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
555         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
556 %if %{without record}
557         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
558 %endif
559         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
560 fi
561
562 %post -n xorg-xserver-Xvfb-init
563 /sbin/chkconfig --add Xvfb
564 %service Xvfb restart
565
566 %preun -n xorg-xserver-Xvfb-init
567 if [ "$1" = "0" ]; then
568         %service -q Xvfb stop
569         /sbin/chkconfig --del Xvfb
570 fi
571
572 %files
573 %defattr(644,root,root,755)
574 %doc COPYING ChangeLog README.md
575 %attr(755,root,root) %{_bindir}/X
576 %attr(755,root,root) %{_bindir}/Xorg
577 %attr(4755,root,root) %{_bindir}/Xwrapper
578 %attr(755,root,root) %{_bindir}/cvt
579 %attr(755,root,root) %{_bindir}/gtf
580 %dir %{_libdir}/xorg
581 %{_libdir}/xorg/protocol.txt
582 %attr(755,root,root) %{_libdir}/xorg/Xorg
583 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
584 %dir %{_libdir}/xorg/modules
585 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
586 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
587 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
588 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
589 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
590 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
591 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
592 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
593 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
594 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
595 %dir %{_libdir}/xorg/modules/dri
596 %dir %{_libdir}/xorg/modules/drivers
597 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
598 %dir %{_libdir}/xorg/modules/extensions
599 %dir %{_libdir}/xorg/modules/input
600 %if "%{_libdir}" != "%{_exec_prefix}/lib"
601 %dir %{_exec_prefix}/lib/xorg
602 %dir %{_exec_prefix}/lib/xorg/modules
603 %dir %{_exec_prefix}/lib/xorg/modules/dri
604 %endif
605 %dir /var/lib/xkb
606 /var/lib/xkb/README.compiled
607 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
608 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
609 %config(missingok) /etc/security/console.apps/xserver
610 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
611 %dir /etc/X11/xorg.conf.d
612 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
613 %dir %{_datadir}/X11/xorg.conf.d
614 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
615 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
616 %{_mandir}/man1/Xorg.1*
617 %{_mandir}/man1/Xorg.wrap.1*
618 %{_mandir}/man1/Xserver.1*
619 %{_mandir}/man1/cvt.1*
620 %{_mandir}/man1/gtf.1*
621 %{_mandir}/man4/exa.4*
622 %{_mandir}/man4/fbdevhw.4*
623 %{_mandir}/man4/modesetting.4*
624 %{_mandir}/man5/Xwrapper.config.5*
625 %{_mandir}/man5/xorg.conf.5*
626 %{_mandir}/man5/xorg.conf.d.5*
627
628 %if %{with dmx}
629 %files -n xorg-xserver-Xdmx
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_bindir}/Xdmx
632 %attr(755,root,root) %{_bindir}/dmxaddinput
633 %attr(755,root,root) %{_bindir}/dmxaddscreen
634 %attr(755,root,root) %{_bindir}/dmxinfo
635 %attr(755,root,root) %{_bindir}/dmxreconfig
636 %attr(755,root,root) %{_bindir}/dmxresize
637 %attr(755,root,root) %{_bindir}/dmxrminput
638 %attr(755,root,root) %{_bindir}/dmxrmscreen
639 %attr(755,root,root) %{_bindir}/dmxtodmx
640 %attr(755,root,root) %{_bindir}/dmxwininfo
641 %attr(755,root,root) %{_bindir}/vdltodmx
642 %attr(755,root,root) %{_bindir}/xdmxconfig
643 %{_mandir}/man1/Xdmx.1*
644 %{_mandir}/man1/dmxtodmx.1*
645 %{_mandir}/man1/vdltodmx.1*
646 %{_mandir}/man1/xdmxconfig.1*
647 %endif
648
649 %files -n xorg-xserver-Xnest
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_bindir}/Xnest
652 %{_mandir}/man1/Xnest.1*
653
654 %files -n xorg-xserver-Xephyr
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_bindir}/Xephyr
657 %{_mandir}/man1/Xephyr.1*
658
659 %files -n xorg-xserver-Xvfb
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_bindir}/Xvfb
662 %attr(755,root,root) %{_bindir}/xvfb-run
663 %{_mandir}/man1/Xvfb.1*
664
665 %files -n xorg-xserver-Xvfb-init
666 %defattr(644,root,root,755)
667 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
668 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
669
670 %if %{with wayland}
671 %files -n xorg-xserver-Xwayland
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_bindir}/Xwayland
674 %endif
675
676 %files devel
677 %defattr(644,root,root,755)
678 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
679 %{_includedir}/xorg
680 %{_aclocaldir}/xorg-server.m4
681 %{_pkgconfigdir}/xorg-server.pc
682
683 %files source
684 %defattr(644,root,root,755)
685 # keep file perms from install time, but have default defattr to keep adapter happy
686 %defattr(-,root,root,755)
687 %{_usrsrc}/%{name}-%{version}
688
689 %files -n xorg-xserver-libglx
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.13 seconds and 3 git commands to generate.