]> git.pld-linux.org Git - packages/xorg-driver-video-qxl.git/commitdiff
- fix building with xserver 1.19 auto/th/xorg-driver-video-qxl-0.1.4-6
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 28 Nov 2016 19:26:15 +0000 (20:26 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 28 Nov 2016 19:26:15 +0000 (20:26 +0100)
- rel 6

xorg-driver-video-qxl.spec
xserver-1.19.patch [new file with mode: 0644]

index ac406459da37cb1e2ffab1617b9c236a0c0cf088..e39afafab78d1ee7593996c9e56620bb1c2b2590 100644 (file)
@@ -10,13 +10,14 @@ Summary:    X.org video driver for QXL virtual GPU
 Summary(pl.UTF-8):     Sterownik obrazu X.org dla wirtualnych procesorów graficznych QXL
 Name:          xorg-driver-video-qxl
 Version:       0.1.4
-Release:       5
+Release:       6
 License:       MIT
 Group:         X11/Applications
 Source0:       http://xorg.freedesktop.org/releases/individual/driver/xf86-video-qxl-%{version}.tar.bz2
 # Source0-md5: 41e234f38fe8045eef7ade83c34f6dd4
 Patch0:                %{name}-cast.patch
 Patch1:                libcacard.patch
+Patch2:                xserver-1.19.patch
 URL:           http://xorg.freedesktop.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -104,6 +105,7 @@ udostępnia wejście klawiatury i myszy oraz wyjście obrazu.
 %setup -q -n xf86-video-qxl-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
diff --git a/xserver-1.19.patch b/xserver-1.19.patch
new file mode 100644 (file)
index 0000000..4cd933a
--- /dev/null
@@ -0,0 +1,71 @@
+--- xf86-video-chips-1.2.6/src/compat-api.h~   2015-09-26 18:28:01.000000000 +0200
++++ xf86-video-chips-1.2.6/src/compat-api.h    2016-11-28 09:12:37.337570460 +0100
+@@ -75,8 +75,13 @@
+ #define SCREEN_INIT_ARGS_DECL ScreenPtr pScreen, int argc, char **argv
++#if ABI_VIDEODRV_VERSION >= SET_ABI_VERSION(23, 0)
++#define BLOCKHANDLER_ARGS_DECL ScreenPtr arg, pointer pTimeout
++#define BLOCKHANDLER_ARGS arg, pTimeout
++#else
+ #define BLOCKHANDLER_ARGS_DECL ScreenPtr arg, pointer pTimeout, pointer pReadmask
+ #define BLOCKHANDLER_ARGS arg, pTimeout, pReadmask
++#endif
+ #define CLOSE_SCREEN_ARGS_DECL ScreenPtr pScreen
+ #define CLOSE_SCREEN_ARGS pScreen
+
+From cfergeau at redhat.com  Tue Aug  4 08:53:26 2015
+From: cfergeau at redhat.com (Christophe Fergeau)
+Date: Tue,  4 Aug 2015 17:53:26 +0200
+Subject: [Spice-devel] [qxl 2/2] Fix compilation with newer Xorg versions
+In-Reply-To: <1438703606-20259-1-git-send-email-cfergeau@redhat.com>
+References: <1438703606-20259-1-git-send-email-cfergeau@redhat.com>
+Message-ID: <1438703606-20259-2-git-send-email-cfergeau@redhat.com>
+
+Xorg 1.18 stopped exporting some xfont related symbols in its
+headers/shared libraries, which causes QXL to fail to build:
+
+uxa-damage.c:947:5: error: implicit declaration of function 'QueryGlyphExtents' [-Werror=implicit-function-declaration]
+     QueryGlyphExtents(font, charinfo, n, &extents);
+
+The missing definition can be found in xfont, so this commit addes the
+needed configure.ac checks and includes.
+Note that dixfontstr.h must be included before the xfont headers or this
+will cause compile-time warnings on older Xorg versions (eg 1.17)
+---
+ configure.ac         | 2 +-
+ src/uxa/uxa-damage.c | 3 +++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6555a8d..7e95b01 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -61,7 +61,7 @@ XORG_DRIVER_CHECK_EXT(XV, videoproto)
+ XORG_DRIVER_CHECK_EXT(XFreeXDGA, xf86dgaproto)
+ # Obtain compiler/linker options for the driver dependencies
+-PKG_CHECK_MODULES(XORG, [xorg-server >= 1.0.99.901] xproto fontsproto $REQUIRED_MODULES)
++PKG_CHECK_MODULES(XORG, [xorg-server >= 1.0.99.901] xproto fontsproto xfont $REQUIRED_MODULES)
+ save_CFLAGS="$CFLAGS"
+diff --git a/src/uxa/uxa-damage.c b/src/uxa/uxa-damage.c
+index 6201712..a6d1ee3 100644
+--- a/src/uxa/uxa-damage.c
++++ b/src/uxa/uxa-damage.c
+@@ -33,6 +33,9 @@
+ #include <stdlib.h>
+ #include "uxa-priv.h"
+
+ #include    <X11/X.h>
++#include    <X11/fonts/font.h>
++#include    <X11/fonts/fontstruct.h>
++#include    <X11/fonts/fontutil.h>
+ #include    "scrnintstr.h"
+ #include    "windowstr.h"
+ #include    "dixfontstr.h"
+-- 
+2.4.3
+
This page took 0.162989 seconds and 4 git commands to generate.