]> git.pld-linux.org Git - packages/xorg-driver-video-intel.git/blob - xorg-driver-video-intel.spec
- Up to 2.21.9.
[packages/xorg-driver-video-intel.git] / xorg-driver-video-intel.spec
1 #
2 # Conditional build:
3 %bcond_with     glamor  Glamor acceleration
4 %bcond_without  sna     SandyBridge's New Acceleration (also for older generations)
5 #
6 %define libdrm_ver      2.4.41
7 %define pixman_ver      0.28.0
8 %if %{with sna}
9 %define xserver_ver     1.10
10 %else
11 %define xserver_ver     1.6.3
12 %endif
13 Summary:        X.org video driver for Intel integrated graphics chipsets
14 Summary(pl.UTF-8):      Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela
15 Name:           xorg-driver-video-intel
16 Version:        2.21.9
17 Release:        1
18 License:        MIT
19 Group:          X11/Applications
20 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-intel-%{version}.tar.bz2
21 # Source0-md5:  fd96651b0d90dc7e977b23fd54f2c3e8
22 URL:            http://xorg.freedesktop.org/
23 BuildRequires:  Mesa-libGL-devel
24 #BuildRequires: autoconf >= 2.63
25 #BuildRequires: automake >= 1:1.10.2-2
26 %{?with_glamor:BuildRequires:   glamor-devel >= 0.3.1}
27 BuildRequires:  libdrm-devel >= %{libdrm_ver}
28 #BuildRequires: libtool >= 2:2.2
29 BuildRequires:  libxcb-devel >= 1.5
30 BuildRequires:  pixman-devel >= %{pixman_ver}
31 BuildRequires:  pkgconfig >= 1:0.19
32 BuildRequires:  rpmbuild(macros) >= 1.389
33 BuildRequires:  udev-devel
34 BuildRequires:  xcb-util-devel
35 BuildRequires:  xorg-lib-libX11-devel
36 BuildRequires:  xorg-lib-libXfixes-devel
37 BuildRequires:  xorg-lib-libXrender-devel
38 BuildRequires:  xorg-lib-libXvMC-devel
39 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
40 BuildRequires:  xorg-proto-dri2proto-devel >= 2.6
41 BuildRequires:  xorg-proto-fontsproto-devel
42 BuildRequires:  xorg-proto-glproto-devel
43 BuildRequires:  xorg-proto-randrproto-devel
44 BuildRequires:  xorg-proto-renderproto-devel
45 BuildRequires:  xorg-proto-videoproto-devel
46 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
47 BuildRequires:  xorg-proto-xf86driproto-devel
48 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
49 BuildRequires:  xorg-util-util-macros >= 1.8
50 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
51 %{?requires_xorg_xserver_videodrv}
52 %{?with_glamor:Requires:        glamor >= 0.3.1}
53 Requires:       libdrm >= %{libdrm_ver}
54 Requires:       pixman >= %{pixman_ver}
55 Requires:       xorg-lib-libpciaccess >= 0.10
56 Requires:       xorg-xserver-libdri >= %{xserver_ver}
57 Requires:       xorg-xserver-libglx >= %{xserver_ver}
58 Requires:       xorg-xserver-server >= %{xserver_ver}
59 Provides:       xorg-driver-video
60 Provides:       xorg-driver-video-i810
61 Obsoletes:      X11-driver-i810 < 1:7.0.0
62 Obsoletes:      XFree86-driver-i810 < 1:7.0.0
63 Obsoletes:      XFree86-i810
64 Obsoletes:      xorg-driver-video-i810 < 1.7.2
65 Conflicts:      vbetool
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 X.org video driver for Intel integrated graphics chipsets. It
70 supports:
71 - i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM, 865G, 915G,
72   915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, G35,
73   Q35, GM45, G45, Q45, G43, G41 chipsets,
74 - Pineview-M in Atom N400 series,
75 - Pineview-D in Atom D400/D500 series.
76
77 Requires Kernel Mode Setting (KMS) to be active.
78
79 %description -l pl.UTF-8
80 Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela.
81 Obsługuje:
82 - układy i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM,
83   865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33,
84   Q33, G35, Q35, GM45, G45, Q45, G43, G41,
85 - Pineview-M w procesorach Atom z serii N400,
86 - Pineview-D w procesorach Atom z serii D400/D500.
87
88 Wymaga aktywnego Kernel Mode Setting (KMS).
89
90 %prep
91 %setup -q -n xf86-video-intel-%{version}
92
93 %build
94 %configure \
95         --disable-silent-rules \
96         %{?with_glamor:--enable-glamor} \
97         --with-default-accel=%{?with_sna:sna}%{!?with_sna:uxa} \
98         --enable-uxa \
99         --enable-sna%{!?with_sna:=no}
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la \
110         $RPM_BUILD_ROOT%{_libdir}/lib*XvMC.{la,so}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS COPYING ChangeLog NEWS README
121 %attr(755,root,root) %{_libdir}/libI810XvMC.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libI810XvMC.so.1
123 %attr(755,root,root) %{_libdir}/libIntelXvMC.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libIntelXvMC.so.1
125 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/intel_drv.so
126 %{_mandir}/man4/intel.4*
This page took 0.02936 seconds and 3 git commands to generate.