]> git.pld-linux.org Git - packages/xorg-driver-video-intel.git/blob - xorg-driver-video-intel.spec
0705e5e25f3f3d73a81ae652f70fdd30e88254a9
[packages/xorg-driver-video-intel.git] / xorg-driver-video-intel.spec
1 #
2 # Conditional build:
3 %bcond_with     glamor  Glamor acceleration
4 %bcond_without  sna     SandyBridge's New Acceleration (also for older generations)
5 %bcond_without  dri3    DRI3 support
6 #
7 %define libdrm_ver      2.4.41
8 %define pixman_ver      0.28.0
9 %if %{with sna}
10 %define xserver_ver     1.10
11 %else
12 %define xserver_ver     1.6.3
13 %endif
14 Summary:        X.org video driver for Intel integrated graphics chipsets
15 Summary(pl.UTF-8):      Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela
16 Name:           xorg-driver-video-intel
17 Version:        2.99.917
18 Release:        12
19 License:        MIT
20 Group:          X11/Applications
21 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-intel-%{version}.tar.bz2
22 # Source0-md5:  fa196a66e52c0c624fe5d350af7a5e7b
23 URL:            http://xorg.freedesktop.org/
24 Patch0:         xorg-driver-video-intel-git.patch
25 # Patch0-md5:   0fd5075aeaa258ae81fb9707906394fb
26 Patch1:         driver-intel-sna-cursor-Make-sure-hw-cursors-are-disabled-before-disabling-secondary-planes.patch
27 Patch4:         link.patch
28 Patch5:         ix86.patch
29 BuildRequires:  Mesa-libGL-devel
30 #BuildRequires: autoconf >= 2.63
31 #BuildRequires: automake >= 1:1.10.2-2
32 %{?with_glamor:BuildRequires:   glamor-devel >= 0.3.1}
33 BuildRequires:  libdrm-devel >= %{libdrm_ver}
34 #BuildRequires: libtool >= 2:2.2
35 BuildRequires:  libxcb-devel >= 1.5
36 BuildRequires:  pixman-devel >= %{pixman_ver}
37 BuildRequires:  pkgconfig >= 1:0.19
38 BuildRequires:  rpmbuild(macros) >= 1.389
39 BuildRequires:  udev-devel
40 BuildRequires:  xcb-util-devel
41 BuildRequires:  xorg-lib-libX11-devel
42 BuildRequires:  xorg-lib-libXfixes-devel
43 BuildRequires:  xorg-lib-libXrender-devel
44 BuildRequires:  xorg-lib-libXtst-devel
45 BuildRequires:  xorg-lib-libXvMC-devel
46 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
47 BuildRequires:  xorg-proto-dri2proto-devel >= 2.6
48 %{?with_dri3:BuildRequires:     xorg-proto-dri3proto-devel}
49 BuildRequires:  xorg-proto-fontsproto-devel
50 BuildRequires:  xorg-proto-glproto-devel
51 BuildRequires:  xorg-proto-randrproto-devel
52 BuildRequires:  xorg-proto-renderproto-devel
53 BuildRequires:  xorg-proto-videoproto-devel
54 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
55 BuildRequires:  xorg-proto-xf86driproto-devel
56 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
57 BuildRequires:  xorg-util-util-macros >= 1.8
58 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
59 %{?requires_xorg_xserver_videodrv}
60 %{?with_glamor:Requires:        glamor >= 0.3.1}
61 Requires:       libdrm >= %{libdrm_ver}
62 Requires:       pixman >= %{pixman_ver}
63 Requires:       xorg-lib-libpciaccess >= 0.10
64 Requires:       xorg-xserver-libdri >= %{xserver_ver}
65 Requires:       xorg-xserver-libglx >= %{xserver_ver}
66 Requires:       xorg-xserver-server >= %{xserver_ver}
67 Provides:       xorg-driver-video
68 Provides:       xorg-driver-video-i810
69 Obsoletes:      X11-driver-i810 < 1:7.0.0
70 Obsoletes:      XFree86-driver-i810 < 1:7.0.0
71 Obsoletes:      XFree86-i810
72 Obsoletes:      xorg-driver-video-i810 < 1.7.2
73 Conflicts:      vbetool
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 X.org video driver for Intel integrated graphics chipsets. It
78 supports:
79 - i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM, 865G, 915G,
80   915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, G35,
81   Q35, GM45, G45, Q45, G43, G41 chipsets,
82 - Pineview-M in Atom N400 series,
83 - Pineview-D in Atom D400/D500 series.
84
85 Requires Kernel Mode Setting (KMS) to be active.
86
87 %description -l pl.UTF-8
88 Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela.
89 Obsługuje:
90 - układy i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM,
91   865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33,
92   Q33, G35, Q35, GM45, G45, Q45, G43, G41,
93 - Pineview-M w procesorach Atom z serii N400,
94 - Pineview-D w procesorach Atom z serii D400/D500.
95
96 Wymaga aktywnego Kernel Mode Setting (KMS).
97
98 %prep
99 %setup -q -n xf86-video-intel-%{version}
100 %{__rm} src/render_program/exa_wm_yuv_rgb.g[67]a
101 %patch0 -p1
102 %patch1 -p1
103 %patch4 -p1
104 #%patch5 -p1
105
106 %build
107 %{__aclocal}
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --disable-silent-rules \
113         %{?with_glamor:--enable-glamor} \
114         --with-default-accel=%{?with_sna:sna}%{!?with_sna:uxa} \
115         --enable-uxa \
116         --enable-sna%{!?with_sna:=no} \
117         %{__enable_disable dri3}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la \
128         $RPM_BUILD_ROOT%{_libdir}/lib*XvMC.{la,so}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS COPYING ChangeLog NEWS README
139 %attr(755,root,root) %{_bindir}/intel-virtual-output
140 %attr(755,root,root) %{_libexecdir}/xf86-video-intel-backlight-helper
141 %attr(755,root,root) %{_libdir}/libI810XvMC.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libI810XvMC.so.1
143 %attr(755,root,root) %{_libdir}/libIntelXvMC.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libIntelXvMC.so.1
145 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/intel_drv.so
146 %{_mandir}/man4/intel.4*
147 %{_mandir}/man4/intel-virtual-output.4*
148 %{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
This page took 0.072598 seconds and 3 git commands to generate.