]> git.pld-linux.org Git - packages/xml-security-c.git/blob - xml-security-c.spec
- updated to 2.0.4
[packages/xml-security-c.git] / xml-security-c.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # unit tests
4 %bcond_without  static_libs     # static library
5 %bcond_with     nss             # NSS crypto provider
6 %bcond_without  openssl         # OpenSSL crypto provider
7 %bcond_without  xalan           # xalan-c (XPath and XSLT transformations) support
8
9 Summary:        C++ Implementation of W3C security standards for XML
10 Summary(pl.UTF-8):      Implementacja w C++ standardów bezpieczeństwa W3C dla XML
11 Name:           xml-security-c
12 Version:        2.0.4
13 Release:        1
14 License:        Apache v2.0
15 Group:          Libraries
16 Source0:        https://downloads.apache.org/santuario/c-library/%{name}-%{version}.tar.bz2
17 # Source0-md5:  53d202a6c8d082bd8291c727f4918db5
18 URL:            https://santuario.apache.org/cindex.html
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2
23 %{?with_nss:BuildRequires:      nss-devel >= 3}
24 %{?with_openssl:BuildRequires:  openssl-devel}
25 BuildRequires:  pkgconfig
26 BuildRequires:  sed >= 4.0
27 %{?with_xalan:BuildRequires:    xalan-c-devel >= 1.11}
28 BuildRequires:  xerces-c-devel >= 3.2
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The xml-security-c library is a C++ implementation of the XML Digital
33 Signature specification.
34
35 The library makes use of the Apache XML project's Xerces-C XML Parser
36 and Xalan-C XSLT processor. The latter is used for processing XPath
37 and XSLT transforms.
38
39 %description -l pl.UTF-8
40 Biblioteka xml-security-c to implementacja w C++ specyfikacji XML
41 Digital Signature.
42
43 Biblioteka wykorzystuje parser XML Xerces-C oraz procesor XSLT Xalan-C
44 z projektu Apache XML. Biblioteka Xalan-C jest wykorzystywana do
45 przekształceń XPath i XSLT.
46
47 %package devel
48 Summary:        Development files for xml-security-c
49 Summary(pl.UTF-8):      Pliki programistyczne xml-security-c
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libstdc++-devel
53 %{?with_nss:Requires:   nss-devel >= 3}
54 %{?with_openssl:Requires: openssl-devel}
55 %{?with_xalan:Requires: xalan-c-devel >= 1.11}
56 Requires:       xerces-c-devel >= 3.2
57
58 %description devel
59 This package provides development files for xml-security-c, a C++
60 library for XML Digital Signatures.
61
62 %description devel -l pl.UTF-8
63 Ten pakiet zawiera pliki programistyczne xml-security-c - biblioteki
64 C++ do podpisów cyfrowych XML.
65
66 %package static
67 Summary:        Static xml-security-c library
68 Summary(pl.UTF-8):      Statyczna biblioteka xml-security-c
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static xml-security-c library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka xml-security-c.
77
78 %prep
79 %setup -q
80
81 %build
82 # refresh lt for as-needed to work
83 %{__libtoolize}
84 %{__aclocal} -I m4
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         %{!?with_nss:--without-nss} \
90         %{!?with_openssl:--without-openssl} \
91         %{!?with_xalan:--without-xalan} \
92         %{?with_static_libs:--enable-static}
93 %{__make}
94
95 %if %{with tests}
96 # Verify that what was compiled actually works.
97 xsec/xsec-xtest
98 %endif
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         CPPROG="cp -p" \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 # obsoleted by pkg-config
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxml-security-c.la
109
110 # Do not ship library test utilities. These are only needed for
111 # xml-security-c developers and they should have the whole source anyway.
112 %{__rm} $RPM_BUILD_ROOT%{_bindir}/xsec-xtest
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc CHANGELOG.txt INSTALL.txt NOTICE.txt
123 %attr(755,root,root) %{_bindir}/xsec-c14n
124 %attr(755,root,root) %{_bindir}/xsec-checksig
125 %attr(755,root,root) %{_bindir}/xsec-cipher
126 %attr(755,root,root) %{_bindir}/xsec-siginf
127 %attr(755,root,root) %{_bindir}/xsec-templatesign
128 %attr(755,root,root) %{_bindir}/xsec-txfmout
129 %attr(755,root,root) %{_bindir}/xsec-xklient
130 %attr(755,root,root) %{_libdir}/libxml-security-c.so.*.*.*
131 %ghost %attr(755,root,root) %{_libdir}/libxml-security-c.so.20
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/libxml-security-c.so
136 %{_includedir}/xsec
137 %{_pkgconfigdir}/xml-security-c.pc
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libxml-security-c.a
143 %endif
This page took 0.108015 seconds and 4 git commands to generate.