]> git.pld-linux.org Git - packages/xfce4-weather-plugin.git/commitdiff
- rel 2 auto/th/xfce4-weather-plugin-0_7_4-2 auto/ti/xfce4-weather-plugin-0_7_4-2
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 1 Mar 2011 12:52:13 +0000 (12:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- port to libxfce4ui

Changed files:
    xfce4-weather-plugin-ui.patch -> 1.1
    xfce4-weather-plugin.spec -> 1.22

xfce4-weather-plugin-ui.patch [new file with mode: 0644]
xfce4-weather-plugin.spec

diff --git a/xfce4-weather-plugin-ui.patch b/xfce4-weather-plugin-ui.patch
new file mode 100644 (file)
index 0000000..39e5590
--- /dev/null
@@ -0,0 +1,81 @@
+diff -ur xfce4-weather-plugin-0.7.4-orig/configure.ac xfce4-weather-plugin-0.7.4/configure.ac
+--- xfce4-weather-plugin-0.7.4-orig/configure.ac       2011-02-02 21:31:29.000000000 +0100
++++ xfce4-weather-plugin-0.7.4/configure.ac    2011-03-01 11:56:04.369067640 +0100
+@@ -64,7 +64,7 @@
+ XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.6.0])
+ XDT_CHECK_PACKAGE([GTHREAD], [gthread-2.0], [2.6.0])
+ XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.3.90.2])
+-XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.90.2])
++XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.8.0])
+ XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.99.1])
+ XDT_CHECK_PACKAGE([LIBXML], [libxml-2.0], [2.4.0])
+diff -ur xfce4-weather-plugin-0.7.4-orig/panel-plugin/Makefile.am xfce4-weather-plugin-0.7.4/panel-plugin/Makefile.am
+--- xfce4-weather-plugin-0.7.4-orig/panel-plugin/Makefile.am   2011-02-02 21:31:29.000000000 +0100
++++ xfce4-weather-plugin-0.7.4/panel-plugin/Makefile.am        2011-03-01 11:46:29.227067641 +0100
+@@ -33,7 +33,7 @@
+ xfce4_weather_plugin_CFLAGS =                                         \
+       $(LIBXFCE4PANEL_CFLAGS)                                         \
+-      $(LIBXFCEGUI4_CFLAGS)                                           \
++      $(LIBXFCE4UI_CFLAGS)                                            \
+       $(LIBXFCE4UTIL_CFLAGS)                                          \
+       $(GTK_CFLAGS)                                                   \
+       $(LIBXML_CFLAGS)
+@@ -41,7 +41,7 @@
+ xfce4_weather_plugin_LDADD =                                          \
+       $(LIBXFCE4PANEL_LIBS)                                           \
+       $(LIBXFCE4UTIL_LIBS)                                            \
+-      $(LIBXFCEGUI4_LIBS)                                             \
++      $(LIBXFCE4UI_LIBS)                                              \
+       $(GTK_LIBS)                                                     \
+       $(LIBXML_LIBS)                                                  \
+       $(LIBRESOLV)
+diff -ur xfce4-weather-plugin-0.7.4-orig/panel-plugin/weather.c xfce4-weather-plugin-0.7.4/panel-plugin/weather.c
+--- xfce4-weather-plugin-0.7.4-orig/panel-plugin/weather.c     2011-02-02 21:31:29.000000000 +0100
++++ xfce4-weather-plugin-0.7.4/panel-plugin/weather.c  2011-03-01 11:23:33.860067640 +0100
+@@ -23,7 +23,7 @@
+ #include <sys/stat.h>
+ #include <libxfce4util/libxfce4util.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include "weather-parsers.h"
+ #include "weather-data.h"
+diff -ur xfce4-weather-plugin-0.7.4-orig/panel-plugin/weather-config.c xfce4-weather-plugin-0.7.4/panel-plugin/weather-config.c
+--- xfce4-weather-plugin-0.7.4-orig/panel-plugin/weather-config.c      2011-02-02 21:31:29.000000000 +0100
++++ xfce4-weather-plugin-0.7.4/panel-plugin/weather-config.c   2011-03-01 11:23:33.856067640 +0100
+@@ -20,7 +20,7 @@
+ #endif
+ #include <string.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include "weather-parsers.h"
+ #include "weather-data.h"
+diff -ur xfce4-weather-plugin-0.7.4-orig/panel-plugin/weather-search.c xfce4-weather-plugin-0.7.4/panel-plugin/weather-search.c
+--- xfce4-weather-plugin-0.7.4-orig/panel-plugin/weather-search.c      2011-02-02 21:31:29.000000000 +0100
++++ xfce4-weather-plugin-0.7.4/panel-plugin/weather-search.c   2011-03-01 11:23:33.842067640 +0100
+@@ -21,7 +21,7 @@
+ #include <string.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include "weather-parsers.h"
+ #include "weather-data.h"
+diff -ur xfce4-weather-plugin-0.7.4-orig/panel-plugin/weather-summary.c xfce4-weather-plugin-0.7.4/panel-plugin/weather-summary.c
+--- xfce4-weather-plugin-0.7.4-orig/panel-plugin/weather-summary.c     2011-02-02 21:31:29.000000000 +0100
++++ xfce4-weather-plugin-0.7.4/panel-plugin/weather-summary.c  2011-03-01 11:23:33.844067640 +0100
+@@ -19,7 +19,7 @@
+ #include <config.h>
+ #endif
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include "weather-parsers.h"
+ #include "weather-data.h"
index b8aca96897dc95e580f65b9c1752e544255c766e..f4903bad1cd139a2e4ed1a167328851ebd1549ed 100644 (file)
@@ -2,14 +2,19 @@ Summary:      A weather plugin for the Xfce panel
 Summary(pl.UTF-8):     Wtyczka panelu Xfce pokazująca pogodę
 Name:          xfce4-weather-plugin
 Version:       0.7.4
-Release:       1
+Release:       2
 License:       GPL
 Group:         X11/Applications
 Source0:       http://archive.xfce.org/src/panel-plugins/xfce4-weather-plugin/0.7/%{name}-%{version}.tar.bz2
 # Source0-md5: 03c972d13eba5cd226432ff66e3ff282
+Patch0:                %{name}-ui.patch
 URL:           http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake
 BuildRequires: gettext-devel
 BuildRequires: intltool
+BuildRequires: libtool
+BuildRequires: libxfce4ui-devel
 BuildRequires: libxml2-devel >= 1:2.6.27
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.601
@@ -27,8 +32,15 @@ Wtyczka dla panelu Xfce wyświetlająca pogodę.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
+%{__intltoolize}
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
        --disable-static
 
This page took 0.139479 seconds and 4 git commands to generate.