]> git.pld-linux.org Git - packages/xfce4-settings.git/commitdiff
- Fix mouse settings with the latest xorg (http://git.xfce.org/xfce/xfce4-settings... auto/th/xfce4-settings-4_6_1-6 auto/ti/xfce4-settings-4_6_1-6
authorJacek Konieczny <jajcus@pld-linux.org>
Wed, 5 May 2010 07:36:46 +0000 (07:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- Release: 6

Changed files:
    xfce4-settings-XI2.patch -> 1.1
    xfce4-settings.spec -> 1.10

xfce4-settings-XI2.patch [new file with mode: 0644]
xfce4-settings.spec

diff --git a/xfce4-settings-XI2.patch b/xfce4-settings-XI2.patch
new file mode 100644 (file)
index 0000000..67ecc4a
--- /dev/null
@@ -0,0 +1,84 @@
+diff -dur -x '*~' -x '*.orig' xfce4-settings-4.6.1.orig/dialogs/mouse-settings/main.c xfce4-settings-4.6.1/dialogs/mouse-settings/main.c
+--- xfce4-settings-4.6.1.orig/dialogs/mouse-settings/main.c    2009-03-28 10:57:59.000000000 +0100
++++ xfce4-settings-4.6.1/dialogs/mouse-settings/main.c 2010-05-05 09:18:12.000000000 +0200
+@@ -60,6 +60,10 @@
+ #define IsXExtensionPointer 4
+ #endif
++/* Xi 1.4 is required */
++#define MIN_XI_VERS_MAJOR 1
++#define MIN_XI_VERS_MINOR 4
++
+ /* settings */
+ #ifdef HAVE_XCURSOR
+ #define PREVIEW_ROWS    (3)
+@@ -1222,12 +1226,19 @@
+         return EXIT_FAILURE;
+     }
+     
+-    /* check for Xi 1.4 */
++    /* check for Xi */
+     version = XGetExtensionVersion (GDK_DISPLAY (), INAME);
+-    if (!version || !version->present || version->major_version < 1 || version->minor_version < 4)
++    if (version == NULL || !version->present) {
++        g_critical ("XI is not present.");
++        return EXIT_FAILURE;
++    }
++    else if (version->major_version < MIN_XI_VERS_MAJOR
++             || (version->major_version == MIN_XI_VERS_MAJOR
++                 && version->minor_version < MIN_XI_VERS_MINOR))
+     {
+-        g_critical ("XI is not present or too old.");
+-        
++        g_critical ("Your XI is too old (%d.%d) version %d.%d is required.",
++                    version->major_version, version->minor_version,
++                    MIN_XI_VERS_MAJOR, MIN_XI_VERS_MINOR);
+         return EXIT_FAILURE;
+     }
+diff -dur -x '*~' -x '*.orig' xfce4-settings-4.6.1.orig/xfce4-settings-helper/pointers.c xfce4-settings-4.6.1/xfce4-settings-helper/pointers.c
+--- xfce4-settings-4.6.1.orig/xfce4-settings-helper/pointers.c 2009-03-28 10:57:59.000000000 +0100
++++ xfce4-settings-4.6.1/xfce4-settings-helper/pointers.c      2010-05-05 09:18:12.000000000 +0200
+@@ -42,6 +42,10 @@
+ #define MAX_DENOMINATOR (100.00)
++/* Xi 1.4 is required */
++#define MIN_XI_VERS_MAJOR 1
++#define MIN_XI_VERS_MINOR 4
++
+ /* test if the required version of inputproto (1.4.2) is available */
+ #if XI_Add_DevicePresenceNotify_Major >= 1 && defined (DeviceRemoved)
+ #define HAS_DEVICE_HOTPLUGGING
+@@ -133,18 +137,22 @@
+     /* get the default display */
+     xdisplay = gdk_x11_display_get_xdisplay (gdk_display_get_default ());
+-    
++
+     /* query the extension version */
+     version = XGetExtensionVersion (xdisplay, INAME);
+-    
+-    /* check for Xi 1.4 */
+-    if (!version || !version->present || version->major_version < 1 || version->minor_version < 4)
+-    {
+-        /* print error */
+-        g_critical ("XI is not present or too old.");
+-        /* no channel */
+-        helper->channel = NULL;
++    /* check for Xi */
++    if (version == NULL || !version->present)
++    {
++        g_critical ("XI is not present.");
++    }
++    else if (version->major_version < MIN_XI_VERS_MAJOR
++             || (version->major_version == MIN_XI_VERS_MAJOR
++                 && version->minor_version < MIN_XI_VERS_MINOR))
++    {
++        g_critical ("Your XI is too old (%d.%d) version %d.%d is required.",
++                    version->major_version, version->minor_version,
++                    MIN_XI_VERS_MAJOR, MIN_XI_VERS_MINOR);
+     }
+     else
+     {
index f0baef4d0966de02e8e3661a48f384d8a6b4c26e..71e832e313f92028b71baadfb9c1c3480bcfa613 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Settings manager for the Xfce desktop environment
 Summary(pl.UTF-8):     Menadżer ustawień dla środowiska Xfce
 Name:          xfce4-settings
 Version:       4.6.1
-Release:       5
+Release:       6
 License:       GPL v2
 Group:         X11/Applications
 Source0:       http://www.xfce.org/archive/xfce-%{version}/src/%{name}-%{version}.tar.bz2
@@ -10,6 +10,7 @@ Source0:      http://www.xfce.org/archive/xfce-%{version}/src/%{name}-%{version}.tar.
 Patch0:                %{name}-default-icon-theme.patch
 Patch1:                %{name}-libxklavier4.patch
 Patch2:                %{name}-libxklavier5.patch
+Patch3:                %{name}-XI2.patch
 URL:           http://www.xfce.org/projects/xfce4-settings/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake >= 1:1.8
@@ -46,6 +47,7 @@ Menadżer ustawień pozwala w łatwy i intuicyjny sposób dostosowywać
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__intltoolize}
This page took 0.140813 seconds and 4 git commands to generate.