]> git.pld-linux.org Git - packages/xbase.git/blob - xbase.spec
- added am patch (fixes build with automake 1.13 and gcc configured --with-pkgversion)
[packages/xbase.git] / xbase.spec
1 Summary:        XBase - xbase-compatible C++ class library
2 Summary(pl.UTF-8):      XBase - kompatybilna z xbase biblioteka klas C++
3 Name:           xbase
4 Version:        2.1.1
5 Release:        4
6 License:        LGPL v2.1+ (library), GPL v2+ (programs)
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/xdb/%{name}-%{version}.tar.gz
9 # Source0-md5:  f36852f0ba0c4d9e047e84c3269fde37
10 Patch0:         %{name}-fix.patch
11 Patch1:         %{name}-gcc4.patch
12 Patch2:         %{name}-am.patch
13 URL:            http://linux.techass.com/projects/xdb/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.4d
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 XBase is an xbase (i.e. dBase, FoxPro, etc.) compatible C++ class
22 library. It's useful for accessing data in legacy dBase 3 and 4
23 database files as well as a general light-weight database engine. It
24 includes support for DBF (dBase version 3 and 4) data files, NDX and
25 NTX indexes, and DBT (dBase version 3 and 4). It supports file and
26 record locking under *nix OSes.
27
28 %description -l pl.UTF-8
29 XBase to kompatybilna z xbase (czyli dBase, FoxPro itp.) biblioteka
30 klas C++. Jest przydatna do dostępu do danych w plikach starych baz
31 dBase 3 i 4, a także jako lekki silnik baz danych ogólnego
32 przeznaczenia. Obsługuje pliki baz DBF (dBase w wersji 3 i 4), indeksy
33 NDX i NTX oraz DBT (dBase w wersji 3 i 4). Obsługuje blokowanie
34 plików i rekordów pod systemami uniksowymi.
35
36 %package devel
37 Summary:        XBase development files
38 Summary(pl.UTF-8):      Pliki dla programistów używających XBase
39 License:        LGPL
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       libstdc++-devel
43
44 %description devel
45 This package contains XBase development files.
46
47 %description devel -l pl.UTF-8
48 Ten pakiet zawiera pliki nagłówkowe potrzebne przy tworzeniu
49 aplikacji używających Xbase.
50
51 %package static
52 Summary:        Static XBase library
53 Summary(pl.UTF-8):      Statyczna biblioteka XBase
54 License:        LGPL
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static XBase library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka XBase.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69
70 %build
71 %{__libtoolize}
72 %{__aclocal}
73 %{__autoconf}
74 %{__autoheader}
75 %{__automake}
76 CXXFLAGS="%{rpmcflags} -fno-implicit-templates"
77 %configure \
78         --with-exceptions \
79         --with-index-ndx \
80         --with-index-ntx
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS ChangeLog NEWS README TODO
98 %attr(755,root,root) %{_bindir}/checkndx
99 %attr(755,root,root) %{_bindir}/copydbf
100 %attr(755,root,root) %{_bindir}/dbfutil1
101 %attr(755,root,root) %{_bindir}/dbfxtrct
102 %attr(755,root,root) %{_bindir}/deletall
103 %attr(755,root,root) %{_bindir}/dumphdr
104 %attr(755,root,root) %{_bindir}/dumprecs
105 %attr(755,root,root) %{_bindir}/packdbf
106 %attr(755,root,root) %{_bindir}/reindex
107 %attr(755,root,root) %{_bindir}/undelall
108 %attr(755,root,root) %{_bindir}/zap
109 %attr(755,root,root) %{_libdir}/libxbase.so.*.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libxbase.so.1
111
112 %files devel
113 %defattr(644,root,root,755)
114 %doc html/{*.html,*.jpg}
115 %attr(755,root,root) %{_bindir}/xbase-config
116 %attr(755,root,root) %{_libdir}/libxbase.so
117 %{_libdir}/libxbase.la
118 %{_includedir}/xbase
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libxbase.a
This page took 0.047359 seconds and 4 git commands to generate.