]> git.pld-linux.org Git - packages/xavs.git/blob - xavs.spec
- updated to svn rev. 55 (2011-08-21)
[packages/xavs.git] / xavs.spec
1 #
2 # Conditional build:
3 %bcond_without  asm     # MMX/SSE* x86 assembler optimizations
4
5 %ifnarch %{ix86} %{x8664}
6 %undefine       with_asm
7 %endif
8 Summary:        Audio Video Standard of China library
9 Summary(pl.UTF-8):      Biblioteka kodeka AVS (Audio Video Standard of China)
10 Name:           xavs
11 Version:        0
12 %define svnver  55
13 Release:        0.svn%{svnver}.2
14 License:        GPL v2+
15 Group:          Libraries
16 # svn co https://xavs.svn.sourceforge.net/svnroot/xavs/trunk xavs
17 Source0:        %{name}-r%{svnver}.tar.xz
18 # Source0-md5:  c4f73561424d850a5c59ef202d85f0d7
19 Patch0:         %{name}-dynamic-xavs.patch
20 Patch1:         %{name}-asm.patch
21 URL:            http://xavs.sourceforge.net/
22 BuildRequires:  tar >= 1:1.22
23 # for svnversion
24 BuildRequires:  subversion
25 BuildRequires:  xz
26 %if %{with asm}
27 BuildRequires:  binutils >= 2:2.17
28 BuildRequires:  yasm >= 0.6.1
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 AVS is the Audio Video Standard of China. This project aims to
34 implement high quality AVS encoder and decoder.
35
36 %description -l pl.UTF-8
37 AVS (Audio Video Standard of China) to standardowy kodek A/V dla Chin.
38 Celem projektu jest zaimplementowanie wysokiej jakości kodera i
39 dekodera AVS.
40
41 %package devel
42 Summary:        Header files for AVS library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AVS
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for AVS library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki AVS.
52
53 %package static
54 Summary:        Static AVS library
55 Summary(pl.UTF-8):      Statyczna biblioteka AVS
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static AVS library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka AVS.
64
65 %prep
66 %setup -q -n %{name}
67 %patch0 -p1
68 %patch1 -p1
69
70 %build
71 # not autoconf script
72 ./configure \
73         --prefix=%{_prefix} \
74         --libdir=%{_libdir} \
75         --enable-asm%{!?with_asm:=no} \
76         --enable-shared \
77         --extra-cflags="%{rpmcflags} %{rpmcppflags} -fno-strict-aliasing" \
78         --extra-ldflags="%{rpmldflags}"
79
80 # linking hack
81 ln -sf libxavs.so.1 libxavs.so
82
83 %{__make} default libxavs.a \
84         CC="%{__cc}"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_bindir}/xavs
101 %attr(755,root,root) %{_libdir}/libxavs.so.1
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libxavs.so
106 %{_includedir}/xavs.h
107 %{_pkgconfigdir}/xavs.pc
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libxavs.a
This page took 0.081249 seconds and 4 git commands to generate.