]> git.pld-linux.org Git - packages/x265.git/blob - x265.spec
- added x32 patch, asm could be enabled on x32 now
[packages/x265.git] / x265.spec
1 #
2 # Conditional build:
3 %bcond_without  asm     # x86 assembler
4
5 %ifnarch %{ix86} %{x8664} x32
6 %undefine       with_asm
7 %endif
8
9 Summary:        H.265/HEVC video encoder
10 Summary(pl.UTF-8):      Koder obrazu H.265/HEVC
11 Name:           x265
12 Version:        1.8
13 Release:        1
14 License:        GPL v2+
15 Group:          Libraries
16 # Source0Download: https://bitbucket.org/multicoreware/x265
17 Source0:        http://ftp.videolan.org/pub/videolan/x265/%{name}_%{version}.tar.gz
18 # Source0-md5:  72005f2c0acda56913c0eae4562dc5ad
19 Patch0:         %{name}-opt.patch
20 Patch1:         %{name}-x32.patch
21 URL:            http://x265.org/
22 BuildRequires:  cmake >= 2.8.8
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  numactl-devel
25 BuildRequires:  rpmbuild(macros) >= 1.605
26 %{?with_asm:BuildRequires:      yasm >= 1.2.0}
27 Requires:       libx265 = %{version}-%{release}
28 # see CMakeLists.txt, more is probably possible
29 ExclusiveArch:  %{ix86} %{x8664} x32 arm
30 # needs 64-bit atomic compare and swap
31 ExcludeArch:    i386 i486
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 H.265/HEVC video encoder.
36
37 %description -l pl.UTF-8
38 Koder obrazu H.265/HEVC.
39
40 %package -n libx265
41 Summary:        H.265/HEVC video encoder library
42 Summary(pl.UTF-8):      Biblioteka kodowania obrazu H.265/HEVC
43 Group:          Libraries
44
45 %description -n libx265
46 H.265/HEVC video encoder library.
47
48 %description -n libx265 -l pl.UTF-8
49 Biblioteka kodowania obrazu H.265/HEVC.
50
51 %package -n libx265-devel
52 Summary:        Header files for x265 library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x265
54 Group:          Development/Libraries
55 Requires:       libstdc++-devel
56 Requires:       libx265 = %{version}-%{release}
57
58 %description -n libx265-devel
59 Header files for x265 library.
60
61 %description -n libx265-devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki x265.
63
64 %package -n libx265-static
65 Summary:        Static x265 library
66 Summary(pl.UTF-8):      Statyczna biblioteka x265
67 Group:          Development/Libraries
68 Requires:       libx265-devel = %{version}-%{release}
69
70 %description -n libx265-static
71 Static x265 library.
72
73 %description -n libx265-static -l pl.UTF-8
74 Statyczna biblioteka x265.
75
76 %prep
77 %setup -q -n %{name}_%{version}
78 %patch0 -p1
79 %patch1 -p1
80
81 %build
82 install -d source/build
83 cd source/build
84 %cmake .. \
85         -DENABLE_ASSEMBLY=%{!?with_asm:OFF}%{?with_asm:ON} \
86         -DLIB_INSTALL_DIR=%{_lib}
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 %{__make} -C source/build install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -n libx265 -p /sbin/ldconfig
99 %postun -n libx265 -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc doc/reST/cli.rst
104 %attr(755,root,root) %{_bindir}/x265
105
106 %files -n libx265
107 %defattr(644,root,root,755)
108 %doc doc/reST/introduction.rst
109 %attr(755,root,root) %{_libdir}/libx265.so.68
110
111 %files -n libx265-devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libx265.so
114 %{_includedir}/x265.h
115 %{_includedir}/x265_config.h
116 %{_pkgconfigdir}/x265.pc
117
118 %files -n libx265-static
119 %defattr(644,root,root,755)
120 %{_libdir}/libx265.a
This page took 0.092578 seconds and 3 git commands to generate.