]> git.pld-linux.org Git - packages/wxWidgets.git/commitdiff
- catch sed errors; fix _configf macro auto/th/wxWidgets-3.0.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 14 Jan 2014 22:04:43 +0000 (23:04 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 14 Jan 2014 22:04:43 +0000 (23:04 +0100)
wxWidgets.spec

index 3826fc59abad692b0c94ce0ecc76bc9b22193f4e..1d3945d0bed0269ad2da43a640993879eaf99ee9 100644 (file)
@@ -10,6 +10,7 @@
 Summary:       wxWidgets library
 Summary(pl.UTF-8):     Biblioteka wxWidgets
 Name:          wxWidgets
+%define majver 3.0
 Version:       3.0.0
 Release:       1
 License:       wxWindows Library Licence 3.1 (LGPL v2+ with exception)
@@ -580,7 +581,12 @@ done
 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
 do
        b=`basename $i`
-       cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
+       c=`echo $b|sed -e 's/\(.*\)-%{majver}/\1/'`
+       if [ "$b" = "$c" ]; then
+               echo "Something is not right... Sed rule failed"
+               exit 1
+       fi
+       cp $i $RPM_BUILD_ROOT%{_bindir}/wx-${c}-config
 done
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
@@ -617,7 +623,7 @@ rm -rf $RPM_BUILD_ROOT
 %postun -n wxX11-unicode -p /sbin/ldconfig
 
 %define _libf %{?with_debug:d}
-%define _configf %{?with_debug:-debug}-3.0
+%define _configf %{?with_debug:-debug-%{majver}}
 
 %files -f wxstd.lang
 %defattr(644,root,root,755)
This page took 0.358317 seconds and 4 git commands to generate.