]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- updated pickerbase patch to fix build
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     gnomeprint              # GNOME print support
7 %bcond_with     debug                   # build with \--enable-debug
8                                         # (binary incompatible with non-debug)
9 #
10 # Unpackaged files:
11 #  /usr/bin/wxrc-2.8
12 #  /usr/share/locale/it/LC_MESSAGES/wxmsw.mo
13 #
14
15 Summary:        wxWidgets library
16 Summary(pl):    Biblioteka wxWidgets
17 Name:           wxWidgets
18 Version:        2.8.1
19 Release:        1
20 License:        wxWidgets Licence (LGPL with exception)
21 Group:          X11/Libraries
22 Source0:        http://ftp.wxwidgets.org/pub/%{version}/%{name}-%{version}.tar.bz2
23 # Source0-md5:  fe01afe1c055bc82875682e5905c7378
24 Patch0:         %{name}-samples.patch
25 Patch1:         %{name}-ogl.patch
26 Patch2:         %{name}-ac.patch
27 Patch3:         %{name}-gif0delay.patch
28 Patch4:         %{name}-x11unicode.patch
29 Patch5:         %{name}-gcc4.patch
30 Patch6:         %{name}-pickerbase.patch
31 URL:            http://www.wxWidgets.org/
32 BuildRequires:  OpenGL-GLU-devel
33 #BuildRequires: SDL-devel
34 BuildRequires:  autoconf >= 2.59-9
35 BuildRequires:  automake
36 #BuildRequires: bakefile >= 0.2.1
37 BuildRequires:  cppunit-devel
38 BuildRequires:  esound-devel
39 BuildRequires:  expat-devel
40 BuildRequires:  flex
41 BuildRequires:  gettext-devel
42 BuildRequires:  gtk+2-devel >= 2.0.0
43 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.8.0}
44 BuildRequires:  libjpeg-devel
45 BuildRequires:  libmng-devel
46 BuildRequires:  libmspack-devel
47 BuildRequires:  libpng-devel
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libtiff-devel
50 BuildRequires:  libtool
51 BuildRequires:  pkgconfig
52 %{?with_x11:BuildRequires:      xorg-lib-libXext-devel}
53 # these are not supported by wxWidgets
54 Obsoletes:      LDAPExplorerTool <= 0.6-1
55 Obsoletes:      abridge <= 0.4.0-1
56 # and these are replaced
57 Obsoletes:      wxGTK
58 Obsoletes:      wxGTK-devel
59 Obsoletes:      wxGTK-gl
60 Obsoletes:      wxGTK-gl-devel
61 Obsoletes:      wxGTK-univ
62 Obsoletes:      wxGTK-univ-devel
63 Obsoletes:      wxGTK-univ-gl
64 Obsoletes:      wxGTK-univ-gl-devel
65 Obsoletes:      wxGTK2-univ
66 Obsoletes:      wxGTK2-univ-devel
67 Obsoletes:      wxGTK2-univ-gl
68 Obsoletes:      wxGTK2-univ-gl-devel
69 Obsoletes:      wxGTK2-univ-unicode
70 Obsoletes:      wxGTK2-univ-unicode-devel
71 Obsoletes:      wxGTK2-univ-unicode-gl
72 Obsoletes:      wxGTK2-univ-unicode-gl-devel
73 Obsoletes:      wxMotif
74 Obsoletes:      wxMotif-devel
75 Obsoletes:      wxMotif-gl
76 Obsoletes:      wxMotif-gl-devel
77 Obsoletes:      wxWidgets-afm
78 Obsoletes:      wxWindows
79 Obsoletes:      wxWindows-afm
80 Obsoletes:      wxwin-afm
81 Obsoletes:      wxwin-common
82 Conflicts:      wxGTK2 < 2.6.0
83 Conflicts:      wxGTK2-unicode < 2.6.0
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         _sysconfdir     %{_datadir}
87
88 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
89
90 %description
91 wxWidgets is a free C++ library for cross-platform GUI development.
92 With wxWidgets, you can create applications for different GUIs (GTK+,
93 Motif/LessTif, MS Windows, Mac) from the same source code.
94
95 %description -l pl
96 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
97 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
98 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
99 Windows, Mac) z tego samego kodu ¼ród³owego.
100
101 %package devel
102 Summary:        wxWidgets header files and development documentation
103 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
104 Group:          X11/Development/Libraries
105 Requires:       libstdc++-devel
106 Obsoletes:      wxWindows-devel
107
108 %description devel
109 Header files and development documentation for the wxWidgets
110 libraries.
111
112 %description devel -l pl
113 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
114
115 %package -n bakefile-wxWidgets
116 Summary:        Files for Bakefile to generate wxWidgets project files
117 Summary(pl):    Pliki dla Bakefile generuj±ce pliki projektów wxWidgets
118 Group:          Development/Tools
119 Requires:       bakefile
120
121 %description -n bakefile-wxWidgets
122 Additional files for Bakefile to generate wxWidgets project files.
123
124 %description -n bakefile-wxWidgets -l pl
125 Dodatkowe pliki dla programu Bakefile umo¿liwiaj±ce wygenerowanie
126 projektów opartych na bibliotece wxWidgets.
127
128 %package examples
129 Summary:        wxWidgets example programs
130 Summary(pl):    Przyk³adowe programy wxWidgets
131 Group:          X11/Development/Libraries
132 Requires:       %{name}-devel = %{version}-%{release}
133 Obsoletes:      wxWindows-examples
134
135 %description examples
136 wxWidgets example programs.
137
138 %description examples -l pl
139 Przyk³adowe programy wxWidgets.
140
141 %package HelpGen
142 Summary:        Help file generator for wxWidgets programs
143 Summary(pl):    Generator plików pomocy dla programów wxWidgets
144 Group:          Development/Tools
145 Requires:       wxBase = %{version}-%{release}
146 Obsoletes:      wxWindows-HelpGen
147
148 %description HelpGen
149 Help file generator for wxWidgets programs.
150
151 %description HelpGen -l pl
152 Generator plików pomocy dla programów wxWidgets.
153
154 %package -n wxBase
155 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
156 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
157 Group:          X11/Libraries
158 Requires:       %{name} = %{version}-%{release}
159
160 %description -n wxBase
161 wxBase is a collection of C++ classes providing basic data structures
162 (strings, lists, arrays), powerful wxDateTime class for date
163 manipulations, portable wrappers around many OS-specific functions
164 allowing to build the same program under all supported folders,
165 wxThread class for writing multithreaded programs using either Win32
166 or POSIX threads and much more. wxBase currently supports the
167 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
168 HP-UX, ...) and BeOS.
169
170 %description -n wxBase -l pl
171 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
172 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
173 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
174 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
175 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
176 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
177 platformy: Win32, Unix i BeOS.
178
179 %package -n wxBase-devel
180 Summary:        wxBase headers needed for developping with wxBase
181 Summary(pl):    Pliki nag³ówkowe do wxBase
182 Group:          X11/Development/Libraries
183 Requires:       %{name}-devel = %{version}-%{release}
184 Requires:       wxBase = %{version}-%{release}
185
186 %description -n wxBase-devel
187 Header files for wxBase. You need them to develop programs using
188 wxBase.
189
190 %description -n wxBase-devel -l pl
191 Pliki nag³ówkowe do biblioteki wxBase.
192
193 %package -n wxBase-unicode
194 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
195 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
196 Group:          X11/Libraries
197 Requires:       %{name} = %{version}-%{release}
198
199 %description -n wxBase-unicode
200 wxBase is a collection of C++ classes providing basic data structures
201 (strings, lists, arrays), powerful wxDateTime class for date
202 manipulations, portable wrappers around many OS-specific functions
203 allowing to build the same program under all supported folders,
204 wxThread class for writing multithreaded programs using either Win32
205 or POSIX threads and much more. wxBase currently supports the
206 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
207 HP-UX, ...) and BeOS. This version is build with UNICODE support.
208
209 %description -n wxBase-unicode -l pl
210 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
211 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
212 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
213 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
214 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
215 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
216 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
217 UNICODE.
218
219 %package -n wxBase-unicode-devel
220 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
221 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
222 Group:          X11/Development/Libraries
223 Requires:       %{name}-devel = %{version}-%{release}
224 Requires:       wxBase-unicode = %{version}-%{release}
225
226 %description -n wxBase-unicode-devel
227 Header files for wxBase. You need them to develop programs using
228 UNICODE-enabled wxBase.
229
230 %description -n wxBase-unicode-devel -l pl
231 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
232
233 %package -n wxGTK2
234 Summary:        wxGTK2 library
235 Summary(pl):    Biblioteka wxGTK2
236 Group:          X11/Libraries
237 Requires:       %{name} = %{version}-%{release}
238 Obsoletes:      wxGTK2-univ
239
240 %description -n wxGTK2
241 wxWidgets library using GTK2 widgets.
242
243 %description -n wxGTK2 -l pl
244 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
245
246 %package -n wxGTK2-devel
247 Summary:        Header files for wxGTK2 library
248 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
249 Group:          X11/Development/Libraries
250 Requires:       wxBase-devel = %{version}-%{release}
251 Requires:       wxGTK2 = %{version}-%{release}
252 Obsoletes:      wxGTK2-univ-devel
253
254 %description -n wxGTK2-devel
255 Header files for wxWidgets library using GTK2 widgets.
256
257 %description -n wxGTK2-devel -l pl
258 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
259
260 %package -n wxGTK2-gl
261 Summary:        GL canvas library for wxGTK2
262 Summary(pl):    Biblioteka GL dla wxGTK2
263 Group:          X11/Libraries
264 Requires:       wxGTK2 = %{version}-%{release}
265 Obsoletes:      wxGTK2-univ-gl
266
267 %description -n wxGTK2-gl
268 wxGTK2 GL canvas library.
269
270 %description -n wxGTK2-gl -l pl
271 Biblioteka GL dla wxGTK2.
272
273 %package -n wxGTK2-gl-devel
274 Summary:        Development files for GL canvas library for wxGTK2
275 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
276 Group:          X11/Development/Libraries
277 Requires:       OpenGL-GLU-devel
278 Requires:       wxGTK2-devel = %{version}-%{release}
279 Requires:       wxGTK2-gl = %{version}-%{release}
280 Obsoletes:      wxGTK2-univ-gl-devel
281
282 %description -n wxGTK2-gl-devel
283 Development files for wxGTK2 GL canvas library.
284
285 %description -n wxGTK2-gl-devel -l pl
286 Pliki programistyczne biblioteki GL dla wxGTK2.
287
288 %package -n wxGTK2-unicode
289 Summary:        wxGTK2 library with UNICODE support
290 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
291 Group:          X11/Libraries
292 Requires:       %{name} = %{version}-%{release}
293 Obsoletes:      wxGTK2-univ-unicode
294
295 %description -n wxGTK2-unicode
296 wxWidgets library using GTK2 widgets with UNICODE support.
297
298 %description -n wxGTK2-unicode -l pl
299 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
300
301 %package -n wxGTK2-unicode-devel
302 Summary:        Header files for wxGTK2 library with UNICODE support
303 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
304 Group:          X11/Development/Libraries
305 Requires:       wxBase-unicode-devel = %{version}-%{release}
306 Requires:       wxGTK2-unicode = %{version}-%{release}
307 Obsoletes:      wxGTK2-univ-unicode-devel
308
309 %description -n wxGTK2-unicode-devel
310 Header files for wxWidgets library using GTK2 widgets with UNICODE
311 support.
312
313 %description -n wxGTK2-unicode-devel -l pl
314 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
315 obs³ug± UNICODE.
316
317 %package -n wxGTK2-unicode-gl
318 Summary:        GL canvas library for wxGTK2 with UNICODE support
319 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
320 Group:          X11/Libraries
321 Requires:       wxGTK2-unicode = %{version}-%{release}
322 Obsoletes:      wxGTK2-univ-unicode-gl
323
324 %description -n wxGTK2-unicode-gl
325 GL canvas library for wxGTK2 with UNICODE support.
326
327 %description -n wxGTK2-unicode-gl -l pl
328 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
329
330 %package -n wxGTK2-unicode-gl-devel
331 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
332 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
333 Group:          X11/Development/Libraries
334 Requires:       OpenGL-GLU-devel
335 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
336 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
337 Obsoletes:      wxGTK2-univ-unicode-gl-devel
338
339 %description -n wxGTK2-unicode-gl-devel
340 Development files for GL canvas library for wxGTK2 with UNICODE
341 support.
342
343 %description -n wxGTK2-unicode-gl-devel -l pl
344 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
345
346 %package utils
347 Summary:        Misc utils from wxWidgets project
348 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
349 Group:          X11/Development/Tools
350 Requires:       wxX11 = %{version}-%{release}
351 Obsoletes:      wxWindows-utils
352
353 %description utils
354 Misc utils from wxWidgets project: helpviewer, makegen, etc.
355
356 %description utils -l pl
357 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
358
359 %package -n wxX11
360 Summary:        wxUniversal-based wxX11 library
361 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
362 Group:          X11/Libraries
363 Requires:       %{name} = %{version}-%{release}
364 Obsoletes:      wxX11-univ
365
366 %description -n wxX11
367 wxUniversal-based wxX11 library.
368
369 %description -n wxX11 -l pl
370 Oparta na wxUniversal biblioteka wxX11.
371
372 %package -n wxX11-devel
373 Summary:        Header files for wxUniversal-based wxX11 library
374 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
375 Group:          X11/Libraries
376 Requires:       %{name}-devel = %{version}-%{release}
377 Requires:       wxX11 = %{version}-%{release}
378 Obsoletes:      wxX11-univ-devel
379
380 %description -n wxX11-devel
381 Header files for wxUniversal-based wxX11 library.
382
383 %description -n wxX11-devel -l pl
384 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
385
386 %package -n wxX11-gl
387 Summary:        GL canvas library for wxUniversal-based wxX11
388 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
389 Group:          X11/Libraries
390 Requires:       wxX11 = %{version}-%{release}
391 Obsoletes:      wxX11-univ-gl
392
393 %description -n wxX11-gl
394 GL canvas library for wxUniversal-based wxX11.
395
396 %description -n wxX11-gl -l pl
397 Biblioteka GL dla opartej na wxUniversal wxX11.
398
399 %package -n wxX11-gl-devel
400 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
401 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
402 Group:          X11/Development/Libraries
403 Requires:       OpenGL-GLU-devel
404 Requires:       wxX11-devel = %{version}-%{release}
405 Requires:       wxX11-gl = %{version}-%{release}
406 Obsoletes:      wxX11-univ-gl-devel
407
408 %description -n wxX11-gl-devel
409 Development files for GL canvas library for wxUniversal-based wxX11.
410
411 %description -n wxX11-gl-devel -l pl
412 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
413
414 %package -n wxX11-unicode
415 Summary:        wxUniversal-based wxX11 library with UNICODE support
416 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
417 Group:          X11/Libraries
418 Requires:       %{name} = %{version}-%{release}
419 Obsoletes:      wxX11-univ-unicode
420
421 %description -n wxX11-unicode
422 wxUniversal-based wxX11 library with UNICODE support.
423
424 %description -n wxX11-unicode -l pl
425 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
426
427 %package -n wxX11-unicode-devel
428 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
429 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
430 Group:          X11/Development/Libraries
431 Requires:       %{name}-devel = %{version}-%{release}
432 Requires:       wxX11-unicode = %{version}-%{release}
433 Obsoletes:      wxX11-univ-unicode-devel
434
435 %description -n wxX11-unicode-devel
436 Header files for wxUniversal-based wxX11 library with UNICODE support.
437
438 %description -n wxX11-unicode-devel -l pl
439 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug±
440 UNICODE.
441
442 %package -n wxX11-unicode-gl
443 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
444 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
445 Group:          X11/Libraries
446 Requires:       wxX11-unicode = %{version}-%{release}
447 Obsoletes:      wxX11-univ-unicode-gl
448
449 %description -n wxX11-unicode-gl
450 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
451
452 %description -n wxX11-unicode-gl -l pl
453 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
454
455 %package -n wxX11-unicode-gl-devel
456 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
457 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
458 Group:          X11/Development/Libraries
459 Requires:       OpenGL-GLU-devel
460 Requires:       wxX11-unicode-devel = %{version}-%{release}
461 Requires:       wxX11-unicode-gl = %{version}-%{release}
462 Obsoletes:      wxX11-univ-unicode-gl-devel
463
464 %description -n wxX11-unicode-gl-devel
465 Development files for GL canvas library for wxUniversal-based wxX11
466 with UNICODE support.
467
468 %description -n wxX11-unicode-gl-devel -l pl
469 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
470 obs³ug± UNICODE.
471
472 %prep
473 %setup -q
474 %patch0 -p1
475 %patch1 -p1
476 %patch2 -p1
477 %patch3 -p1
478 %patch4 -p1
479 %patch5 -p1
480 %patch6 -p1
481
482 %build
483 # if bakefiles rebuild is needed:
484 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.2.1"
485 #cd build/bakefiles
486 #bakefile_gen -f autoconf
487 #cd ../..
488 #%endif
489 cp -f /usr/share/automake/config.sub .
490 %{__aclocal} -I build/aclocal
491 %{__autoconf}
492
493 CPPFLAGS="%{rpmcflags} -I`pwd`/include"; export CPPFLAGS
494 # avoid adding -s to LDFLAGS
495 LDFLAGS=" "; export LDFLAGS
496 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
497         --enable-plugins \
498         --enable-std_iostreams \
499         --without-sdl \
500         --with-opengl \
501         --enable-calendar \
502         --enable-controls \
503         --enable-tabdialog"
504
505 gui='--with-gtk'
506 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
507         '--enable-unicode' ; do
508         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
509         mkdir $objdir
510         cd $objdir
511         ../%configure \
512                 ${args} \
513                 ${gui} \
514                 --disable-universal \
515                 ${unicode} \
516                 %{!?with_gnomeprint:--without-gnomeprint}
517         %{__make}
518         %{__make} -C contrib/src
519         cd ..
520 done
521
522 %if %{with x11}
523 gui='--with-x11'
524 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
525         '--enable-unicode' ; do
526         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
527         mkdir $objdir
528         cd $objdir
529         ../%configure \
530                 ${args} \
531                 ${gui} \
532                 --enable-universal \
533                 ${unicode}
534         %{__make}
535         %{__make} -C contrib/src
536         if echo $objdir| grep -q disable-unicode ; then
537                 %{__make} -C utils
538                 %{__make} -C utils/emulator
539                 %{__make} -C utils/hhp2cached
540                 # %{__make} -C contrib/utils
541         fi
542         cd ..
543 done
544 %endif
545
546 cd locale
547 %{__make} allmo
548
549 %install
550 rm -rf $RPM_BUILD_ROOT
551 install -d $RPM_BUILD_ROOT%{_bindir}
552
553 gui='--with-gtk'
554 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
555         '--enable-unicode' ; do
556         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
557         cd $objdir
558         %{__make} install \
559                 prefix=$RPM_BUILD_ROOT%{_prefix} \
560                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
561                 bindir=$RPM_BUILD_ROOT%{_bindir} \
562                 datadir=$RPM_BUILD_ROOT%{_datadir} \
563                 libdir=$RPM_BUILD_ROOT%{_libdir} \
564                 mandir=$RPM_BUILD_ROOT%{_mandir} \
565                 includedir=$RPM_BUILD_ROOT%{_includedir}
566
567         %{__make} -C contrib/src install \
568                 prefix=$RPM_BUILD_ROOT%{_prefix} \
569                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
570                 bindir=$RPM_BUILD_ROOT%{_bindir} \
571                 datadir=$RPM_BUILD_ROOT%{_datadir} \
572                 libdir=$RPM_BUILD_ROOT%{_libdir} \
573                 mandir=$RPM_BUILD_ROOT%{_mandir} \
574                 includedir=$RPM_BUILD_ROOT%{_includedir}
575         cd ..
576 done
577
578 %if %{with x11}
579 gui='--with-x11'
580 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
581         '--enable-unicode' ; do
582         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
583         cd $objdir
584         %{__make} install \
585                 prefix=$RPM_BUILD_ROOT%{_prefix} \
586                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
587                 bindir=$RPM_BUILD_ROOT%{_bindir} \
588                 datadir=$RPM_BUILD_ROOT%{_datadir} \
589                 libdir=$RPM_BUILD_ROOT%{_libdir} \
590                 mandir=$RPM_BUILD_ROOT%{_mandir} \
591                 includedir=$RPM_BUILD_ROOT%{_includedir}
592         if echo $objdir| grep -q disable-unicode ; then
593 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
594                 # TODO: install default config files and default backgrouds
595                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
596                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
597                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
598                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
599 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
600                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
601 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
602 #               install -m644 utils/makegen/templates/* \
603 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
604 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
605 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
606 #               install contrib/utils/wxrcedit/df/* \
607 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
608         fi
609
610         %{__make} -C contrib/src install \
611                 prefix=$RPM_BUILD_ROOT%{_prefix} \
612                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
613                 bindir=$RPM_BUILD_ROOT%{_bindir} \
614                 datadir=$RPM_BUILD_ROOT%{_datadir} \
615                 libdir=$RPM_BUILD_ROOT%{_libdir} \
616                 mandir=$RPM_BUILD_ROOT%{_mandir} \
617                 includedir=$RPM_BUILD_ROOT%{_includedir}
618
619         cd ..
620 done
621 %endif
622
623 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
624 do
625         b=`basename $i`
626         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
627 done
628
629 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
630 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
631 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
632
633 %find_lang wxstd
634
635 %clean
636 rm -rf $RPM_BUILD_ROOT
637
638 %post   -n wxBase -p /sbin/ldconfig
639 %postun -n wxBase -p /sbin/ldconfig
640
641 %post   -n wxBase-unicode -p /sbin/ldconfig
642 %postun -n wxBase-unicode -p /sbin/ldconfig
643
644 %post   -n wxGTK2 -p /sbin/ldconfig
645 %postun -n wxGTK2 -p /sbin/ldconfig
646
647 %post   -n wxGTK2-gl -p /sbin/ldconfig
648 %postun -n wxGTK2-gl -p /sbin/ldconfig
649
650 %post   -n wxGTK2-unicode -p /sbin/ldconfig
651 %postun -n wxGTK2-unicode -p /sbin/ldconfig
652
653 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
654 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
655
656 %post   -n wxX11 -p /sbin/ldconfig
657 %postun -n wxX11 -p /sbin/ldconfig
658
659 %post   -n wxX11-unicode -p /sbin/ldconfig
660 %postun -n wxX11-unicode -p /sbin/ldconfig
661
662 %define _libf %{?with_debug:d}
663 %define _configf %{?with_debug:-debug-2.8}
664
665 %files -f wxstd.lang
666 %defattr(644,root,root,755)
667 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
668
669 %files devel
670 %defattr(644,root,root,755)
671 %doc docs/html
672 %doc docs/tech docs/univ
673 %{_includedir}/wx*
674 %dir %{_libdir}/wx
675 %dir %{_libdir}/wx/include
676 %dir %{_libdir}/wx/config
677 %{_aclocaldir}/*.m4
678
679 %files -n bakefile-wxWidgets
680 %defattr(644,root,root,755)
681 %{_datadir}/bakefile/presets/*.bkl
682
683 %files examples
684 %defattr(644,root,root,755)
685 %{_examplesdir}/%{name}-%{version}
686
687 %if %{with x11}
688 %files HelpGen
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_bindir}/HelpGen
691 %endif
692
693 %if %{with ansi}
694 %files -n wxBase
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
697 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
698 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
699 %attr(755,root,root) %ghost %{_libdir}/libwx_base%{_libf}-*.so.0
700 %attr(755,root,root) %ghost %{_libdir}/libwx_base%{_libf}_*.so.0
701
702 %files -n wxBase-devel
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so
705 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so
706 %endif
707
708 %files -n wxBase-unicode
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
711 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
712 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
713 %attr(755,root,root) %ghost %{_libdir}/libwx_baseu%{_libf}-*.so.0
714 %attr(755,root,root) %ghost %{_libdir}/libwx_baseu%{_libf}_*.so.0
715
716 %files -n wxBase-unicode-devel
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so
719 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so
720
721 %if %{with ansi}
722 %files -n wxGTK2
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
725 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
726 %attr(755,root,root) %ghost %{_libdir}/libwx_gtk2%{_libf}_*.so.0
727 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.0
728
729 %files -n wxGTK2-devel
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*-*.so
732 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
733 %{_libdir}/wx/config/gtk2-ansi-*
734 %{_libdir}/wx/include/gtk2-ansi-*
735 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
736
737 %files -n wxGTK2-gl
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
740 %attr(755,root,root) %ghost %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.0
741
742 %files -n wxGTK2-gl-devel
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
745 %endif
746
747 %files -n wxGTK2-unicode
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
750 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
751 %attr(755,root,root) %ghost %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.0
752 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.0
753
754 %files -n wxGTK2-unicode-devel
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
757 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
758 %{_libdir}/wx/config/gtk2-unicode-*
759 %{_libdir}/wx/include/gtk2-unicode-*
760 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
761
762 %files -n wxGTK2-unicode-gl
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
765 %attr(755,root,root) %ghost %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.0
766
767 %files -n wxGTK2-unicode-gl-devel
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
770
771 %if %{with x11}
772 %if %{with ansi}
773 %files utils
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_bindir}/*
776 %exclude %{_bindir}/HelpGen
777 %exclude %{_bindir}/wx*-config
778
779 %files -n wxX11
780 %defattr(644,root,root,755)
781 %doc docs/wxX11-readme.txt
782 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
783 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
784 %attr(755,root,root) %ghost %{_libdir}/libwx_x11univ%{_libf}_*-*.so.0
785 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.0
786
787 %files -n wxX11-devel
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so
790 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
791 %{_libdir}/wx/config/x11univ-ansi-*
792 %{_libdir}/wx/include/x11univ-ansi-*
793 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
794
795 %files -n wxX11-gl
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
798 %attr(755,root,root) %ghost %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.0
799
800 %files -n wxX11-gl-devel
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
803 %endif
804
805 %files -n wxX11-unicode
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
808 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
809 %attr(755,root,root) %ghost %{_libdir}/libwx_x11univu%{_libf}_*-*.so.0
810 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.0
811
812 %files -n wxX11-unicode-devel
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so
815 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
816 %{_libdir}/wx/config/x11univ-unicode-*
817 %{_libdir}/wx/include/x11univ-unicode-*
818 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
819
820 %files -n wxX11-unicode-gl
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
823 %attr(755,root,root) %ghost %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.0
824
825 %files -n wxX11-unicode-gl-devel
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
828 %endif
This page took 0.109931 seconds and 4 git commands to generate.