]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- just fetch sources nothing more
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8 #
9 # Unpackaged files:
10 #  /usr/bin/wxrc-2.6
11 #  /usr/share/bakefile/presets/wx.bkl
12 #  /usr/share/bakefile/presets/wx_unix.bkl
13 #  /usr/share/bakefile/presets/wx_win32.bkl
14 #  /usr/share/locale/it/LC_MESSAGES/wxmsw.mo
15 #
16
17 Summary:        wxWidgets library
18 Summary(pl):    Biblioteka wxWidgets
19 Name:           wxWidgets
20 Version:        2.7.0
21 Release:        0.1
22 License:        wxWidgets Licence (LGPL with exception)
23 Group:          X11/Libraries
24 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}.tar.bz2
25 # Source0-md5:  262b6aa540800a7f84a39829cdf03529
26 #Source1:       ftp://biolpc22.york.ac.uk/pub/%{version}/%{name}-%{version}-Patch-2.tar.gz
27 # Source1-md5:  1218551e47e42185f31d819703004c46
28 Patch0:         %{name}-samples.patch
29 Patch1:         %{name}-ogl.patch
30 Patch2:         %{name}-ac.patch
31 Patch3:         %{name}-gif0delay.patch
32 Patch4:         %{name}-x11unicode.patch
33 Patch5:         %{name}-gcc4.patch
34 URL:            http://www.wxWidgets.org/
35 BuildRequires:  OpenGL-GLU-devel
36 #BuildRequires: SDL-devel
37 BuildRequires:  autoconf >= 2.59-9
38 BuildRequires:  automake
39 #BuildRequires: bakefile >= 0.1.9
40 BuildRequires:  cppunit-devel
41 BuildRequires:  esound-devel
42 BuildRequires:  expat-devel
43 BuildRequires:  flex
44 BuildRequires:  gettext-devel
45 BuildRequires:  gtk+2-devel >= 2.0.0
46 BuildRequires:  libjpeg-devel
47 BuildRequires:  libmng-devel
48 BuildRequires:  libmspack-devel
49 BuildRequires:  libpng-devel
50 BuildRequires:  libstdc++-devel
51 BuildRequires:  libtiff-devel
52 BuildRequires:  libtool
53 BuildRequires:  pkgconfig
54 %{?with_x11:BuildRequires:      xorg-lib-libXext-devel}
55 # these are not supported by wxWidgets
56 Obsoletes:      LDAPExplorerTool <= 0.6-1
57 Obsoletes:      abridge <= 0.4.0-1
58 # and these are replaced
59 Obsoletes:      wxGTK
60 Obsoletes:      wxGTK-devel
61 Obsoletes:      wxGTK-gl
62 Obsoletes:      wxGTK-gl-devel
63 Obsoletes:      wxGTK-univ
64 Obsoletes:      wxGTK-univ-devel
65 Obsoletes:      wxGTK-univ-gl
66 Obsoletes:      wxGTK-univ-gl-devel
67 Obsoletes:      wxGTK2-univ
68 Obsoletes:      wxGTK2-univ-devel
69 Obsoletes:      wxGTK2-univ-gl
70 Obsoletes:      wxGTK2-univ-gl-devel
71 Obsoletes:      wxGTK2-univ-unicode
72 Obsoletes:      wxGTK2-univ-unicode-devel
73 Obsoletes:      wxGTK2-univ-unicode-gl
74 Obsoletes:      wxGTK2-univ-unicode-gl-devel
75 Obsoletes:      wxMotif
76 Obsoletes:      wxMotif-devel
77 Obsoletes:      wxMotif-gl
78 Obsoletes:      wxMotif-gl-devel
79 Obsoletes:      wxWidgets-afm
80 Obsoletes:      wxWindows
81 Obsoletes:      wxWindows-afm
82 Obsoletes:      wxwin-afm
83 Obsoletes:      wxwin-common
84 Conflicts:      wxGTK2 < 2.6.0
85 Conflicts:      wxGTK2-unicode < 2.6.0
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %define         _sysconfdir     %{_datadir}
89
90 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
91
92 %description
93 wxWidgets is a free C++ library for cross-platform GUI development.
94 With wxWidgets, you can create applications for different GUIs (GTK+,
95 Motif/LessTif, MS Windows, Mac) from the same source code.
96
97 %description -l pl
98 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
99 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
100 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
101 Windows, Mac) z tego samego kodu ¼ród³owego.
102
103 %package devel
104 Summary:        wxWidgets header files and development documentation
105 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
106 Group:          X11/Development/Libraries
107 Requires:       libstdc++-devel
108 Obsoletes:      wxWindows-devel
109
110 %description devel
111 Header files and development documentation for the wxWidgets
112 libraries.
113
114 %description devel -l pl
115 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
116
117 %package examples
118 Summary:        wxWidgets example programs
119 Summary(pl):    Przyk³adowe programy wxWidgets
120 Group:          X11/Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122 Obsoletes:      wxWindows-examples
123
124 %description examples
125 wxWidgets example programs.
126
127 %description examples -l pl
128 Przyk³adowe programy wxWidgets.
129
130 %package HelpGen
131 Summary:        Help file generator for wxWidgets programs
132 Summary(pl):    Generator plików pomocy dla programów wxWidgets
133 Group:          Development/Tools
134 Requires:       wxBase = %{version}-%{release}
135 Obsoletes:      wxWindows-HelpGen
136
137 %description HelpGen
138 Help file generator for wxWidgets programs.
139
140 %description HelpGen -l pl
141 Generator plików pomocy dla programów wxWidgets.
142
143 %package -n wxBase
144 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
145 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
146 Group:          X11/Libraries
147 Requires:       %{name} = %{version}-%{release}
148
149 %description -n wxBase
150 wxBase is a collection of C++ classes providing basic data structures
151 (strings, lists, arrays), powerful wxDateTime class for date
152 manipulations, portable wrappers around many OS-specific functions
153 allowing to build the same program under all supported folders,
154 wxThread class for writing multithreaded programs using either Win32
155 or POSIX threads and much more. wxBase currently supports the
156 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
157 HP-UX, ...) and BeOS.
158
159 %description -n wxBase -l pl
160 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
161 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
162 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
163 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
164 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
165 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
166 platformy: Win32, Unix i BeOS.
167
168 %package -n wxBase-devel
169 Summary:        wxBase headers needed for developping with wxBase
170 Summary(pl):    Pliki nag³ówkowe do wxBase
171 Group:          X11/Development/Libraries
172 Requires:       %{name}-devel = %{version}-%{release}
173 Requires:       wxBase = %{version}-%{release}
174
175 %description -n wxBase-devel
176 Header files for wxBase. You need them to develop programs using
177 wxBase.
178
179 %description -n wxBase-devel -l pl
180 Pliki nag³ówkowe do biblioteki wxBase.
181
182 %package -n wxBase-unicode
183 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
184 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
185 Group:          X11/Libraries
186 Requires:       %{name} = %{version}-%{release}
187
188 %description -n wxBase-unicode
189 wxBase is a collection of C++ classes providing basic data structures
190 (strings, lists, arrays), powerful wxDateTime class for date
191 manipulations, portable wrappers around many OS-specific functions
192 allowing to build the same program under all supported folders,
193 wxThread class for writing multithreaded programs using either Win32
194 or POSIX threads and much more. wxBase currently supports the
195 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
196 HP-UX, ...) and BeOS. This version is build with UNICODE support.
197
198 %description -n wxBase-unicode -l pl
199 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
200 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
201 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
202 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
203 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
204 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
205 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
206 UNICODE.
207
208 %package -n wxBase-unicode-devel
209 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
210 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
211 Group:          X11/Development/Libraries
212 Requires:       %{name}-devel = %{version}-%{release}
213 Requires:       wxBase-unicode = %{version}-%{release}
214
215 %description -n wxBase-unicode-devel
216 Header files for wxBase. You need them to develop programs using
217 UNICODE-enabled wxBase.
218
219 %description -n wxBase-unicode-devel -l pl
220 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
221
222 %package -n wxGTK2
223 Summary:        wxGTK2 library
224 Summary(pl):    Biblioteka wxGTK2
225 Group:          X11/Libraries
226 Requires:       %{name} = %{version}-%{release}
227 Obsoletes:      wxGTK2-univ
228
229 %description -n wxGTK2
230 wxWidgets library using GTK2 widgets.
231
232 %description -n wxGTK2 -l pl
233 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
234
235 %package -n wxGTK2-devel
236 Summary:        Header files for wxGTK2 library
237 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
238 Group:          X11/Development/Libraries
239 Requires:       wxBase-devel = %{version}-%{release}
240 Requires:       wxGTK2 = %{version}-%{release}
241 Obsoletes:      wxGTK2-univ-devel
242
243 %description -n wxGTK2-devel
244 Header files for wxWidgets library using GTK2 widgets.
245
246 %description -n wxGTK2-devel -l pl
247 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
248
249 %package -n wxGTK2-gl
250 Summary:        GL canvas library for wxGTK2
251 Summary(pl):    Biblioteka GL dla wxGTK2
252 Group:          X11/Libraries
253 Requires:       wxGTK2 = %{version}-%{release}
254 Obsoletes:      wxGTK2-univ-gl
255
256 %description -n wxGTK2-gl
257 wxGTK2 GL canvas library.
258
259 %description -n wxGTK2-gl -l pl
260 Biblioteka GL dla wxGTK2.
261
262 %package -n wxGTK2-gl-devel
263 Summary:        Development files for GL canvas library for wxGTK2
264 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
265 Group:          X11/Development/Libraries
266 Requires:       wxGTK2-devel = %{version}-%{release}
267 Requires:       wxGTK2-gl = %{version}-%{release}
268 Requires:       OpenGL-GLU-devel
269 Obsoletes:      wxGTK2-univ-gl-devel
270
271 %description -n wxGTK2-gl-devel
272 Development files for wxGTK2 GL canvas library.
273
274 %description -n wxGTK2-gl-devel -l pl
275 Pliki programistyczne biblioteki GL dla wxGTK2.
276
277 %package -n wxGTK2-unicode
278 Summary:        wxGTK2 library with UNICODE support
279 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
280 Group:          X11/Libraries
281 Requires:       %{name} = %{version}-%{release}
282 Obsoletes:      wxGTK2-univ-unicode
283
284 %description -n wxGTK2-unicode
285 wxWidgets library using GTK2 widgets with UNICODE support.
286
287 %description -n wxGTK2-unicode -l pl
288 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
289
290 %package -n wxGTK2-unicode-devel
291 Summary:        Header files for wxGTK2 library with UNICODE support
292 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
293 Group:          X11/Development/Libraries
294 Requires:       wxBase-unicode-devel = %{version}-%{release}
295 Requires:       wxGTK2-unicode = %{version}-%{release}
296 Obsoletes:      wxGTK2-univ-unicode-devel
297
298 %description -n wxGTK2-unicode-devel
299 Header files for wxWidgets library using GTK2 widgets with UNICODE
300 support.
301
302 %description -n wxGTK2-unicode-devel -l pl
303 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
304 obs³ug± UNICODE.
305
306 %package -n wxGTK2-unicode-gl
307 Summary:        GL canvas library for wxGTK2 with UNICODE support
308 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
309 Group:          X11/Libraries
310 Requires:       wxGTK2-unicode = %{version}-%{release}
311 Obsoletes:      wxGTK2-univ-unicode-gl
312
313 %description -n wxGTK2-unicode-gl
314 GL canvas library for wxGTK2 with UNICODE support.
315
316 %description -n wxGTK2-unicode-gl -l pl
317 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
318
319 %package -n wxGTK2-unicode-gl-devel
320 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
321 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
322 Group:          X11/Development/Libraries
323 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
324 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
325 Requires:       OpenGL-GLU-devel
326 Obsoletes:      wxGTK2-univ-unicode-gl-devel
327
328 %description -n wxGTK2-unicode-gl-devel
329 Development files for GL canvas library for wxGTK2 with UNICODE
330 support.
331
332 %description -n wxGTK2-unicode-gl-devel -l pl
333 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
334
335 %package utils
336 Summary:        Misc utils from wxWidgets project
337 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
338 Group:          X11/Development/Tools
339 Requires:       wxX11 = %{version}-%{release}
340 Obsoletes:      wxWindows-utils
341
342 %description utils
343 Misc utils from wxWidgets project: helpviewer, makegen, etc.
344
345 %description utils -l pl
346 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
347
348 %package -n wxX11
349 Summary:        wxUniversal-based wxX11 library
350 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
351 Group:          X11/Libraries
352 Requires:       %{name} = %{version}-%{release}
353 Obsoletes:      wxX11-univ
354
355 %description -n wxX11
356 wxUniversal-based wxX11 library.
357
358 %description -n wxX11 -l pl
359 Oparta na wxUniversal biblioteka wxX11.
360
361 %package -n wxX11-devel
362 Summary:        Header files for wxUniversal-based wxX11 library
363 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
364 Group:          X11/Libraries
365 Requires:       %{name}-devel = %{version}-%{release}
366 Requires:       wxX11 = %{version}-%{release}
367 Obsoletes:      wxX11-univ-devel
368
369 %description -n wxX11-devel
370 Header files for wxUniversal-based wxX11 library.
371
372 %description -n wxX11-devel -l pl
373 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
374
375 %package -n wxX11-gl
376 Summary:        GL canvas library for wxUniversal-based wxX11
377 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
378 Group:          X11/Libraries
379 Requires:       wxX11 = %{version}-%{release}
380 Obsoletes:      wxX11-univ-gl
381
382 %description -n wxX11-gl
383 GL canvas library for wxUniversal-based wxX11.
384
385 %description -n wxX11-gl -l pl
386 Biblioteka GL dla opartej na wxUniversal wxX11.
387
388 %package -n wxX11-gl-devel
389 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
390 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
391 Group:          X11/Development/Libraries
392 Requires:       wxX11-gl = %{version}-%{release}
393 Requires:       wxX11-devel = %{version}-%{release}
394 Requires:       OpenGL-GLU-devel
395 Obsoletes:      wxX11-univ-gl-devel
396
397 %description -n wxX11-gl-devel
398 Development files for GL canvas library for wxUniversal-based wxX11.
399
400 %description -n wxX11-gl-devel -l pl
401 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
402
403 %package -n wxX11-unicode
404 Summary:        wxUniversal-based wxX11 library with UNICODE support
405 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
406 Group:          X11/Libraries
407 Requires:       %{name} = %{version}-%{release}
408 Obsoletes:      wxX11-univ-unicode
409
410 %description -n wxX11-unicode
411 wxUniversal-based wxX11 library with UNICODE support.
412
413 %description -n wxX11-unicode -l pl
414 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
415
416 %package -n wxX11-unicode-devel
417 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
418 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
419 Group:          X11/Development/Libraries
420 Requires:       %{name}-devel = %{version}-%{release}
421 Requires:       wxX11-unicode = %{version}-%{release}
422 Obsoletes:      wxX11-univ-unicode-devel
423
424 %description -n wxX11-unicode-devel
425 Header files for wxUniversal-based wxX11 library with UNICODE support.
426
427 %description -n wxX11-unicode-devel -l pl
428 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
429
430 %package -n wxX11-unicode-gl
431 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
432 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
433 Group:          X11/Libraries
434 Requires:       wxX11-unicode = %{version}-%{release}
435 Obsoletes:      wxX11-univ-unicode-gl
436
437 %description -n wxX11-unicode-gl
438 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
439
440 %description -n wxX11-unicode-gl -l pl
441 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
442
443 %package -n wxX11-unicode-gl-devel
444 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
445 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
446 Group:          X11/Development/Libraries
447 Requires:       wxX11-unicode-gl = %{version}-%{release}
448 Requires:       wxX11-unicode-devel = %{version}-%{release}
449 Requires:       OpenGL-GLU-devel
450 Obsoletes:      wxX11-univ-unicode-gl-devel
451
452 %description -n wxX11-unicode-gl-devel
453 Development files for GL canvas library for wxUniversal-based wxX11
454 with UNICODE support.
455
456 %description -n wxX11-unicode-gl-devel -l pl
457 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
458 obs³ug± UNICODE.
459
460 %prep
461 %setup -q -a1
462 %patch0 -p1
463 %patch1 -p1
464 %patch2 -p1
465 %patch3 -p1
466 %patch4 -p1
467 %patch5 -p1
468
469 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
470
471 %build
472 # if bakefiles rebuild is needed:
473 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.9"
474 #cd build/bakefiles
475 #bakefile_gen -f autoconf
476 #cd ../..
477 #%endif
478 cp -f /usr/share/automake/config.sub .
479 %{__aclocal} -I build/aclocal
480 %{__autoconf}
481
482 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
483 # avoid adding -s to LDFLAGS
484 LDFLAGS=" "; export LDFLAGS
485 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
486         --enable-plugins \
487         --enable-std_iostreams \
488         --without-sdl \
489         --with-opengl \
490         --enable-calendar \
491         --enable-controls \
492         --enable-tabdialog"
493
494 gui='--with-gtk'
495 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
496         '--enable-unicode' ; do
497         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
498         mkdir $objdir
499         cd $objdir
500         ../%configure \
501                 ${args} \
502                 ${gui} \
503                 --disable-universal \
504                 ${unicode}
505         %{__make}
506         %{__make} -C contrib/src
507         cd ..
508 done
509
510 %if %{with x11}
511 gui='--with-x11'
512 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
513         '--enable-unicode' ; do
514         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
515         mkdir $objdir
516         cd $objdir
517         ../%configure \
518                 ${args} \
519                 ${gui} \
520                 --enable-universal \
521                 ${unicode}
522         %{__make}
523         %{__make} -C contrib/src
524         if echo $objdir| grep -q disable-unicode ; then
525                 %{__make} -C utils
526                 %{__make} -C utils/emulator
527                 %{__make} -C utils/hhp2cached
528                 %{__make} -C contrib/utils
529         fi
530         cd ..
531 done
532 %endif
533
534 cd locale
535 %{__make} allmo
536
537 %install
538 rm -rf $RPM_BUILD_ROOT
539 install -d $RPM_BUILD_ROOT%{_bindir}
540
541 gui='--with-gtk'
542 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
543         '--enable-unicode' ; do
544         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
545         cd $objdir
546         %{__make} install \
547                 prefix=$RPM_BUILD_ROOT%{_prefix} \
548                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
549                 bindir=$RPM_BUILD_ROOT%{_bindir} \
550                 datadir=$RPM_BUILD_ROOT%{_datadir} \
551                 libdir=$RPM_BUILD_ROOT%{_libdir} \
552                 mandir=$RPM_BUILD_ROOT%{_mandir} \
553                 includedir=$RPM_BUILD_ROOT%{_includedir}
554
555         %{__make} -C contrib/src install \
556                 prefix=$RPM_BUILD_ROOT%{_prefix} \
557                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
558                 bindir=$RPM_BUILD_ROOT%{_bindir} \
559                 datadir=$RPM_BUILD_ROOT%{_datadir} \
560                 libdir=$RPM_BUILD_ROOT%{_libdir} \
561                 mandir=$RPM_BUILD_ROOT%{_mandir} \
562                 includedir=$RPM_BUILD_ROOT%{_includedir}
563         cd ..
564 done
565
566 %if %{with x11}
567 gui='--with-x11'
568 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
569         '--enable-unicode' ; do
570         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
571         cd $objdir
572         %{__make} install \
573                 prefix=$RPM_BUILD_ROOT%{_prefix} \
574                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
575                 bindir=$RPM_BUILD_ROOT%{_bindir} \
576                 datadir=$RPM_BUILD_ROOT%{_datadir} \
577                 libdir=$RPM_BUILD_ROOT%{_libdir} \
578                 mandir=$RPM_BUILD_ROOT%{_mandir} \
579                 includedir=$RPM_BUILD_ROOT%{_includedir}
580         if echo $objdir| grep -q disable-unicode ; then
581 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
582                 # TODO: install default config files and default backgrouds
583                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
584                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
585                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
586                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
587 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
588                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
589 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
590 #               install -m644 utils/makegen/templates/* \
591 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
592 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
593 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
594 #               install contrib/utils/wxrcedit/df/* \
595 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
596         fi
597
598         %{__make} -C contrib/src install \
599                 prefix=$RPM_BUILD_ROOT%{_prefix} \
600                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
601                 bindir=$RPM_BUILD_ROOT%{_bindir} \
602                 datadir=$RPM_BUILD_ROOT%{_datadir} \
603                 libdir=$RPM_BUILD_ROOT%{_libdir} \
604                 mandir=$RPM_BUILD_ROOT%{_mandir} \
605                 includedir=$RPM_BUILD_ROOT%{_includedir}
606
607         cd ..
608 done
609 %endif
610
611 set -x
612
613 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
614 do
615         b=`basename $i`
616         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
617 done
618
619 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
620 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
621 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
622
623 %find_lang wxstd
624
625 %clean
626 rm -rf $RPM_BUILD_ROOT
627
628 %post   -n wxBase -p /sbin/ldconfig
629 %postun -n wxBase -p /sbin/ldconfig
630
631 %post   -n wxBase-unicode -p /sbin/ldconfig
632 %postun -n wxBase-unicode -p /sbin/ldconfig
633
634 %post   -n wxGTK2 -p /sbin/ldconfig
635 %postun -n wxGTK2 -p /sbin/ldconfig
636
637 %post   -n wxGTK2-gl -p /sbin/ldconfig
638 %postun -n wxGTK2-gl -p /sbin/ldconfig
639
640 %post   -n wxGTK2-unicode -p /sbin/ldconfig
641 %postun -n wxGTK2-unicode -p /sbin/ldconfig
642
643 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
644 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
645
646 %post   -n wxX11 -p /sbin/ldconfig
647 %postun -n wxX11 -p /sbin/ldconfig
648
649 %post   -n wxX11-unicode -p /sbin/ldconfig
650 %postun -n wxX11-unicode -p /sbin/ldconfig
651
652 %define _libf %{?with_debug:d}
653 %define _configf %{?with_debug:-debug-2.6}
654
655 %files -f wxstd.lang
656 %defattr(644,root,root,755)
657 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
658
659 %files devel
660 %defattr(644,root,root,755)
661 %doc docs/html
662 %doc docs/tech docs/univ
663 %{_includedir}/wx*
664 %dir %{_libdir}/wx
665 %dir %{_libdir}/wx/include
666 %dir %{_libdir}/wx/config
667 %{_aclocaldir}/*.m4
668
669 %files examples
670 %defattr(644,root,root,755)
671 %{_examplesdir}/%{name}-%{version}
672
673 %if %{with x11}
674 %files HelpGen
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_bindir}/HelpGen
677 %endif
678
679 %if %{with ansi}
680 %files -n wxBase
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
683 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
684 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
685
686 %files -n wxBase-devel
687 %defattr(644,root,root,755)
688 %{_libdir}/libwx_base%{_libf}-*.so
689 %{_libdir}/libwx_base%{_libf}_*.so
690 %endif
691
692 %files -n wxBase-unicode
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
695 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
696 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
697
698 %files -n wxBase-unicode-devel
699 %defattr(644,root,root,755)
700 %{_libdir}/libwx_baseu%{_libf}-*.so
701 %{_libdir}/libwx_baseu%{_libf}_*.so
702
703 %if %{with ansi}
704 %files -n wxGTK2
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
707 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
708
709 %files -n wxGTK2-devel
710 %defattr(644,root,root,755)
711 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
712 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
713 %{_libdir}/wx/config/gtk2-ansi-*
714 %{_libdir}/wx/include/gtk2-ansi-*
715 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
716
717 %files -n wxGTK2-gl
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
720
721 %files -n wxGTK2-gl-devel
722 %defattr(644,root,root,755)
723 %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
724 %endif
725
726 %files -n wxGTK2-unicode
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
729 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
730
731 %files -n wxGTK2-unicode-devel
732 %defattr(644,root,root,755)
733 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
734 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
735 %{_libdir}/wx/config/gtk2-unicode-*
736 %{_libdir}/wx/include/gtk2-unicode-*
737 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
738
739 %files -n wxGTK2-unicode-gl
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
742
743 %files -n wxGTK2-unicode-gl-devel
744 %defattr(644,root,root,755)
745 %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
746
747 %if %{with x11}
748 %if %{with ansi}
749 %files utils
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_bindir}/*
752 %exclude %{_bindir}/HelpGen
753 %exclude %{_bindir}/wx*-config
754
755 %files -n wxX11
756 %defattr(644,root,root,755)
757 %doc docs/wxX11-readme.txt
758 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
759 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
760
761 %files -n wxX11-devel
762 %defattr(644,root,root,755)
763 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
764 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
765 %{_libdir}/wx/config/x11univ-ansi-*
766 %{_libdir}/wx/include/x11univ-ansi-*
767 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
768
769 %files -n wxX11-gl
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
772
773 %files -n wxX11-gl-devel
774 %defattr(644,root,root,755)
775 %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
776 %endif
777
778 %files -n wxX11-unicode
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
781 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
782
783 %files -n wxX11-unicode-devel
784 %defattr(644,root,root,755)
785 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
786 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
787 %{_libdir}/wx/config/x11univ-unicode-*
788 %{_libdir}/wx/include/x11univ-unicode-*
789 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
790
791 %files -n wxX11-unicode-gl
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
794
795 %files -n wxX11-unicode-gl-devel
796 %defattr(644,root,root,755)
797 %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
798 %endif
This page took 0.106811 seconds and 4 git commands to generate.