]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- up to 2.5.4,
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # without wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8
9 Summary:        wxWidgets library
10 Summary(pl):    Biblioteka wxWidgets
11 Name:           wxWidgets
12 Version:        2.5.4
13 Release:        0.1
14 License:        wxWidgets Licence (LGPL with exception)
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/wxwindows/wxAll-%{version}.tar.gz
17 # Source0-md5:  14b76e3774cdc59dd47655e6fac034ad
18 Patch0:         %{name}-samples.patch
19 Patch1:         %{name}-utils.patch
20 Patch2:         %{name}-ogl.patch
21 Patch3:         %{name}-ac.patch
22 Patch4:         %{name}-gif0delay.patch
23 URL:            http://www.wxWidgets.org/
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  SDL-devel
26 BuildRequires:  autoconf >= 2.58
27 BuildRequires:  automake
28 BuildRequires:  bakefile >= 0.1.4
29 BuildRequires:  cppunit-devel
30 BuildRequires:  esound-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  flex
33 BuildRequires:  gettext-devel
34 BuildRequires:  gtk+2-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libmng-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtiff-devel
40 BuildRequires:  libtool
41 BuildRequires:  pango-devel
42 Obsoletes:      wxwin-common
43 Obsoletes:      wxGTK
44 Obsoletes:      wxGTK-devel
45 Obsoletes:      wxGTK-gl
46 Obsoletes:      wxGTK-gl-devel
47 Obsoletes:      wxGTK-univ
48 Obsoletes:      wxGTK-univ-devel
49 Obsoletes:      wxGTK-univ-gl
50 Obsoletes:      wxGTK-univ-gl-devel
51 Obsoletes:      wxGTK2-univ
52 Obsoletes:      wxGTK2-univ-devel
53 Obsoletes:      wxGTK2-univ-gl
54 Obsoletes:      wxGTK2-univ-gl-devel
55 Obsoletes:      wxGTK2-univ-unicode
56 Obsoletes:      wxGTK2-univ-unicode-devel
57 Obsoletes:      wxGTK2-univ-unicode-gl
58 Obsoletes:      wxGTK2-univ-unicode-gl-devel
59 Obsoletes:      wxMotif
60 Obsoletes:      wxMotif-devel
61 Obsoletes:      wxMotif-gl
62 Obsoletes:      wxMotif-gl-devel
63 Obsoletes:      wxWindows
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         _sysconfdir     %{_datadir}
67
68 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
69
70 %description
71 wxWidgets is a free C++ library for cross-platform GUI development.
72 With wxWidgets, you can create applications for different GUIs (GTK+,
73 Motif/LessTif, MS Windows, Mac) from the same source code.
74
75 %description -l pl
76 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
77 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
78 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
79 Windows, Mac) z tego samego kodu ¼ród³owego.
80
81 %package afm
82 Summary:        Font metrics common for wxGTK, wxGTK2, wxMotif i wxX11
83 Summary(pl):    Metryki fontów wspólne dla wxGTK, wxGTK2, wxMotif i wxX11
84 Group:          X11/Libraries
85 Requires:       %{name} = %{version}-%{release}
86 Obsoletes:      wxwin-afm
87 Obsoletes:      wxWindows-afm
88
89 %description afm
90 Font metrics (in AFM format) common for wxGTK, wxGTK2, wxMotif and
91 wxX11 libraries.
92
93 %description afm -l pl
94 Metryki fontów (w formacie AFM) wspólne dla bibliotek wxGTK, wxGTK2,
95 wxMotif i wxX11.
96
97 %package devel
98 Summary:        wxWidgets header files and development documentation
99 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
100 Group:          X11/Development/Libraries
101 Requires:       libstdc++-devel
102 Obsoletes:      wxWindows-devel
103
104 %description devel
105 Header files and development documentation for the wxWidgets
106 libraries.
107
108 %description devel -l pl
109 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
110
111 %package examples
112 Summary:        wxWidgets example programs
113 Summary(pl):    Przyk³adowe programy wxWidgets
114 Group:          X11/Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116 Obsoletes:      wxWindows-examples
117
118 %description examples
119 wxWidgets example programs.
120
121 %description examples -l pl
122 Przyk³adowe programy wxWidgets.
123
124 %package HelpGen
125 Summary:        Help file generator for wxWidgets programs
126 Summary(pl):    Generator plików pomocy dla programów wxWidgets
127 Group:          Development/Tools
128 Requires:       wxBase = %{version}-%{release}
129 Obsoletes:      wxWindows-HelpGen
130
131 %description HelpGen
132 Help file generator for wxWidgets programs.
133
134 %description HelpGen -l pl
135 Generator plików pomocy dla programów wxWidgets.
136
137 %package -n wxBase
138 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
139 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
140 Group:          X11/Libraries
141 Requires:       %{name} = %{version}-%{release}
142
143 %description -n wxBase
144 wxBase is a collection of C++ classes providing basic data structures
145 (strings, lists, arrays), powerful wxDateTime class for date
146 manipulations, portable wrappers around many OS-specific functions
147 allowing to build the same program under all supported folders,
148 wxThread class for writing multithreaded programs using either Win32
149 or POSIX threads and much more. wxBase currently supports the
150 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
151 HP-UX, ...) and BeOS.
152
153 %description -n wxBase -l pl
154 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
155 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
156 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
157 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
158 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
159 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
160 platformy: Win32, Unix i BeOS.
161
162 %package -n wxBase-devel
163 Summary:        wxBase headers needed for developping with wxBase
164 Summary(pl):    Pliki nag³ówkowe do wxBase
165 Group:          X11/Development/Libraries
166 Requires:       %{name}-devel = %{version}-%{release}
167 Requires:       wxBase = %{version}-%{release}
168
169 %description -n wxBase-devel
170 Header files for wxBase. You need them to develop programs using
171 wxBase.
172
173 %description -n wxBase-devel -l pl
174 Pliki nag³ówkowe do biblioteki wxBase.
175
176 %package -n wxBase-unicode
177 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
178 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
179 Group:          X11/Libraries
180 Requires:       %{name} = %{version}-%{release}
181
182 %description -n wxBase-unicode
183 wxBase is a collection of C++ classes providing basic data structures
184 (strings, lists, arrays), powerful wxDateTime class for date
185 manipulations, portable wrappers around many OS-specific functions
186 allowing to build the same program under all supported folders,
187 wxThread class for writing multithreaded programs using either Win32
188 or POSIX threads and much more. wxBase currently supports the
189 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
190 HP-UX, ...) and BeOS. This version is build with UNICODE support.
191
192 %description -n wxBase-unicode -l pl
193 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
194 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
195 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
196 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
197 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
198 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
199 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
200 UNICODE.
201
202 %package -n wxBase-unicode-devel
203 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
204 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
205 Group:          X11/Development/Libraries
206 Requires:       %{name}-devel = %{version}-%{release}
207 Requires:       wxBase-unicode = %{version}-%{release}
208
209 %description -n wxBase-unicode-devel
210 Header files for wxBase. You need them to develop programs using
211 UNICODE-enabled wxBase.
212
213 %description -n wxBase-unicode-devel -l pl
214 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
215
216 %package -n wxGTK2
217 Summary:        wxGTK2 library
218 Summary(pl):    Biblioteka wxGTK2
219 Group:          X11/Libraries
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       %{name}-afm = %{version}-%{release}
222 Obsoletes:      wxGTK2-univ
223
224 %description -n wxGTK2
225 wxWidgets library using GTK2 widgets.
226
227 %description -n wxGTK2 -l pl
228 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
229
230 %package -n wxGTK2-devel
231 Summary:        Header files for wxGTK2 library
232 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
233 Group:          X11/Development/Libraries
234 Requires:       wxBase-devel = %{version}-%{release}
235 Requires:       wxGTK2 = %{version}-%{release}
236 Obsoletes:      wxGTK2-univ-devel
237
238 %description -n wxGTK2-devel
239 Header files for wxWidgets library using GTK2 widgets.
240
241 %description -n wxGTK2-devel -l pl
242 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
243
244 %package -n wxGTK2-gl
245 Summary:        GL canvas library for wxGTK2
246 Summary(pl):    Biblioteka GL dla wxGTK2
247 Group:          X11/Libraries
248 Requires:       wxGTK2 = %{version}-%{release}
249 Requires:       OpenGL
250 Obsoletes:      wxGTK2-univ-gl
251
252 %description -n wxGTK2-gl
253 wxGTK2 GL canvas library.
254
255 %description -n wxGTK2-gl -l pl
256 Biblioteka GL dla wxGTK2.
257
258 %package -n wxGTK2-gl-devel
259 Summary:        Development files for GL canvas library for wxGTK2
260 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
261 Group:          X11/Development/Libraries
262 Requires:       wxGTK2-devel = %{version}-%{release}
263 Requires:       wxGTK2-gl = %{version}-%{release}
264 Requires:       OpenGL-devel
265 Obsoletes:      wxGTK2-univ-gl-devel
266
267 %description -n wxGTK2-gl-devel
268 Development files for wxGTK2 GL canvas library.
269
270 %description -n wxGTK2-gl-devel -l pl
271 Pliki programistyczne biblioteki GL dla wxGTK2.
272
273 %package -n wxGTK2-unicode
274 Summary:        wxGTK2 library with UNICODE support
275 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
276 Group:          X11/Libraries
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       %{name}-afm = %{version}-%{release}
279 Obsoletes:      wxGTK2-univ-unicode
280
281 %description -n wxGTK2-unicode
282 wxWidgets library using GTK2 widgets with UNICODE support.
283
284 %description -n wxGTK2-unicode -l pl
285 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
286
287 %package -n wxGTK2-unicode-devel
288 Summary:        Header files for wxGTK2 library with UNICODE support
289 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
290 Group:          X11/Development/Libraries
291 Requires:       wxBase-unicode-devel = %{version}-%{release}
292 Requires:       wxGTK2-unicode = %{version}-%{release}
293 Obsoletes:      wxGTK2-univ-unicode-devel
294
295 %description -n wxGTK2-unicode-devel
296 Header files for wxWidgets library using GTK2 widgets with UNICODE
297 support.
298
299 %description -n wxGTK2-unicode-devel -l pl
300 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
301 obs³ug± UNICODE.
302
303 %package -n wxGTK2-unicode-gl
304 Summary:        GL canvas library for wxGTK2 with UNICODE support
305 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
306 Group:          X11/Libraries
307 Requires:       wxGTK2-unicode = %{version}-%{release}
308 Requires:       OpenGL
309 Obsoletes:      wxGTK2-univ-unicode-gl
310
311 %description -n wxGTK2-unicode-gl
312 GL canvas library for wxGTK2 with UNICODE support.
313
314 %description -n wxGTK2-unicode-gl -l pl
315 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
316
317 %package -n wxGTK2-unicode-gl-devel
318 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
319 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
320 Group:          X11/Development/Libraries
321 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
322 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
323 Requires:       OpenGL-devel
324 Obsoletes:      wxGTK2-univ-unicode-gl-devel
325
326 %description -n wxGTK2-unicode-gl-devel
327 Development files for GL canvas library for wxGTK2 with UNICODE
328 support.
329
330 %description -n wxGTK2-unicode-gl-devel -l pl
331 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
332
333 %package utils
334 Summary:        Misc utils from wxWidgets project
335 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
336 Group:          X11/Development/Tools
337 Requires:       wxX11 = %{version}-%{release}
338 Obsoletes:      wxWindows-utils
339
340 %description utils
341 Misc utils from wxWidgets project: helpviewer, makegen, etc.
342
343 %description utils -l pl
344 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
345
346 %package -n wxX11
347 Summary:        wxUniversal-based wxX11 library
348 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
349 Group:          X11/Libraries
350 Requires:       %{name} = %{version}-%{release}
351 Requires:       %{name}-afm = %{version}-%{release}
352 Obsoletes:      wxX11-univ
353
354 %description -n wxX11
355 wxUniversal-based wxX11 library.
356
357 %description -n wxX11 -l pl
358 Oparta na wxUniversal biblioteka wxX11.
359
360 %package -n wxX11-devel
361 Summary:        Header files for wxUniversal-based wxX11 library
362 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
363 Group:          X11/Libraries
364 Requires:       %{name}-devel = %{version}-%{release}
365 Requires:       wxX11 = %{version}-%{release}
366 Obsoletes:      wxX11-univ-devel
367
368 %description -n wxX11-devel
369 Header files for wxUniversal-based wxX11 library.
370
371 %description -n wxX11-devel -l pl
372 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
373
374 %package -n wxX11-gl
375 Summary:        GL canvas library for wxUniversal-based wxX11
376 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
377 Group:          X11/Libraries
378 Requires:       wxX11 = %{version}-%{release}
379 Requires:       OpenGL
380 Obsoletes:      wxX11-univ-gl
381
382 %description -n wxX11-gl
383 GL canvas library for wxUniversal-based wxX11.
384
385 %description -n wxX11-gl -l pl
386 Biblioteka GL dla opartej na wxUniversal wxX11.
387
388 %package -n wxX11-gl-devel
389 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
390 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
391 Group:          X11/Development/Libraries
392 Requires:       wxX11-gl = %{version}-%{release}
393 Requires:       wxX11-devel = %{version}-%{release}
394 Requires:       OpenGL-devel
395 Obsoletes:      wxX11-univ-gl-devel
396
397 %description -n wxX11-gl-devel
398 Development files for GL canvas library for wxUniversal-based wxX11.
399
400 %description -n wxX11-gl-devel -l pl
401 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
402
403 %package -n wxX11-unicode
404 Summary:        wxUniversal-based wxX11 library with UNICODE support
405 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
406 Group:          X11/Libraries
407 Requires:       %{name} = %{version}-%{release}
408 Requires:       %{name}-afm = %{version}-%{release}
409 Obsoletes:      wxX11-univ-unicode
410
411 %description -n wxX11-unicode
412 wxUniversal-based wxX11 library with UNICODE support.
413
414 %description -n wxX11-unicode -l pl
415 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
416
417 %package -n wxX11-unicode-devel
418 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
419 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
420 Group:          X11/Development/Libraries
421 Requires:       %{name}-devel = %{version}-%{release}
422 Requires:       wxX11-unicode = %{version}-%{release}
423 Obsoletes:      wxX11-univ-unicode-devel
424
425 %description -n wxX11-unicode-devel
426 Header files for wxUniversal-based wxX11 library with UNICODE support.
427
428 %description -n wxX11-unicode-devel -l pl
429 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
430
431 %package -n wxX11-unicode-gl
432 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
433 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
434 Group:          X11/Libraries
435 Requires:       wxX11-unicode = %{version}-%{release}
436 Requires:       OpenGL
437 Obsoletes:      wxX11-univ-unicode-gl
438
439 %description -n wxX11-unicode-gl
440 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
441
442 %description -n wxX11-unicode-gl -l pl
443 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
444
445 %package -n wxX11-unicode-gl-devel
446 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
447 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
448 Group:          X11/Development/Libraries
449 Requires:       wxX11-unicode-gl = %{version}-%{release}
450 Requires:       wxX11-unicode-devel = %{version}-%{release}
451 Requires:       OpenGL-devel
452 Obsoletes:      wxX11-univ-unicode-gl-devel
453
454 %description -n wxX11-unicode-gl-devel
455 Development files for GL canvas library for wxUniversal-based wxX11
456 with UNICODE support.
457
458 %description -n wxX11-unicode-gl-devel -l pl
459 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
460 obs³ug± UNICODE.
461
462 %prep
463 %setup -q
464 %patch0 -p1
465 %patch1 -p1
466 %patch2 -p1
467 %patch3 -p1
468 %patch4 -p1
469
470 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
471
472 # bakefile.m4 from 0.1.4
473 tail -n +1277 aclocal.m4 | head -n 1289 > bakefile.m4
474
475 %build
476 # if bakefiles rebuild is needed:
477 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.4"
478 #cd build/bakefiles
479 #bakefile_gen -f autoconf
480 #cd ../..
481 #%endif
482 cp -f /usr/share/automake/config.sub .
483 %{__aclocal} -I .
484 %{__autoconf}
485
486 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
487 # avoid adding -s to LDFLAGS
488 LDFLAGS=" "; export LDFLAGS
489 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
490         --enable-plugins \
491         --enable-std_iostreams \
492         --with-sdl \
493         --with-opengl \
494         --enable-calendar \
495         --enable-controls \
496         --enable-tabdialog"
497
498 gui='--with-gtk --enable-gtk2'
499 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
500         '--enable-unicode' ; do
501         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
502         mkdir $objdir
503         cd $objdir
504         ../%configure \
505                 ${args} \
506                 ${gui} \
507                 --disable-universal \
508                 ${unicode}
509         %{__make}
510         %{__make} -C contrib/src
511         cd ..
512 done
513
514 %if %{with x11}
515 gui='--with-x11'
516 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
517         '--enable-unicode' ; do
518         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
519         mkdir $objdir
520         cd $objdir
521         ../%configure \
522                 ${args} \
523                 ${gui} \
524                 --enable-universal \
525                 ${unicode}
526         %{__make}
527         %{__make} -C contrib/src
528         if echo $objdir| grep -q disable-unicode ; then
529                 %{__make} -C utils
530                 %{__make} -C utils/emulator
531                 %{__make} -C utils/hhp2cached
532                 %{__make} -C contrib/utils
533         fi
534         cd ..
535 done
536 %endif
537
538 cd locale
539 %{__make} allmo
540
541 %install
542 rm -rf $RPM_BUILD_ROOT
543 install -d $RPM_BUILD_ROOT%{_bindir}
544
545 gui='--with-gtk --enable-gtk2'
546 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
547         '--enable-unicode' ; do
548         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
549         cd $objdir
550         %{__make} install \
551                 prefix=$RPM_BUILD_ROOT%{_prefix} \
552                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
553                 bindir=$RPM_BUILD_ROOT%{_bindir} \
554                 datadir=$RPM_BUILD_ROOT%{_datadir} \
555                 libdir=$RPM_BUILD_ROOT%{_libdir} \
556                 mandir=$RPM_BUILD_ROOT%{_mandir} \
557                 includedir=$RPM_BUILD_ROOT%{_includedir}
558
559         %{__make} -C contrib/src install \
560                 prefix=$RPM_BUILD_ROOT%{_prefix} \
561                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
562                 bindir=$RPM_BUILD_ROOT%{_bindir} \
563                 datadir=$RPM_BUILD_ROOT%{_datadir} \
564                 libdir=$RPM_BUILD_ROOT%{_libdir} \
565                 mandir=$RPM_BUILD_ROOT%{_mandir} \
566                 includedir=$RPM_BUILD_ROOT%{_includedir}
567         cd ..
568 done
569
570 %if %{with x11}
571 gui='--with-x11'
572 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
573         '--enable-unicode' ; do
574         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
575         cd $objdir
576         %{__make} install \
577                 prefix=$RPM_BUILD_ROOT%{_prefix} \
578                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
579                 bindir=$RPM_BUILD_ROOT%{_bindir} \
580                 datadir=$RPM_BUILD_ROOT%{_datadir} \
581                 libdir=$RPM_BUILD_ROOT%{_libdir} \
582                 mandir=$RPM_BUILD_ROOT%{_mandir} \
583                 includedir=$RPM_BUILD_ROOT%{_includedir}
584         if echo $objdir| grep -q disable-unicode ; then
585 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
586                 # TODO: install default config files and default backgrouds
587                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
588                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
589                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
590                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
591 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
592                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
593 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
594 #               install -m644 utils/makegen/templates/* \
595 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
596 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
597 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
598 #               install contrib/utils/wxrcedit/df/* \
599 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
600         fi
601
602         %{__make} -C contrib/src install \
603                 prefix=$RPM_BUILD_ROOT%{_prefix} \
604                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
605                 bindir=$RPM_BUILD_ROOT%{_bindir} \
606                 datadir=$RPM_BUILD_ROOT%{_datadir} \
607                 libdir=$RPM_BUILD_ROOT%{_libdir} \
608                 mandir=$RPM_BUILD_ROOT%{_mandir} \
609                 includedir=$RPM_BUILD_ROOT%{_includedir}
610
611         cd ..
612 done
613 %endif
614
615 set -x
616
617 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
618 do
619         b=`basename $i`
620         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
621 done
622
623 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
624 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
625 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
626
627 %find_lang wxstd
628
629 %clean
630 rm -rf $RPM_BUILD_ROOT
631
632 %post   -n wxBase -p /sbin/ldconfig
633 %postun -n wxBase -p /sbin/ldconfig
634
635 %post   -n wxBase-unicode -p /sbin/ldconfig
636 %postun -n wxBase-unicode -p /sbin/ldconfig
637
638 %post   -n wxGTK2 -p /sbin/ldconfig
639 %postun -n wxGTK2 -p /sbin/ldconfig
640
641 %post   -n wxGTK2-gl -p /sbin/ldconfig
642 %postun -n wxGTK2-gl -p /sbin/ldconfig
643
644 %post   -n wxGTK2-unicode -p /sbin/ldconfig
645 %postun -n wxGTK2-unicode -p /sbin/ldconfig
646
647 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
648 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
649
650 %post   -n wxX11 -p /sbin/ldconfig
651 %postun -n wxX11 -p /sbin/ldconfig
652
653 %post   -n wxX11-unicode -p /sbin/ldconfig
654 %postun -n wxX11-unicode -p /sbin/ldconfig
655
656 %files -f wxstd.lang
657 %defattr(644,root,root,755)
658 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
659 %dir %{_datadir}/wx
660 %dir %{_datadir}/wx/2.5
661
662 %files -n wxWidgets-afm
663 %defattr(644,root,root,755)
664 %{_datadir}/wx/2.5/afm
665 %{_datadir}/wx/2.5/gs_afm
666
667 %files devel
668 %defattr(644,root,root,755)
669 %doc docs/html
670 %doc docs/tech docs/univ
671 %{_includedir}/wx*
672 %dir %{_libdir}/wx
673 %dir %{_libdir}/wx/include
674 %dir %{_libdir}/wx/config
675 %{_aclocaldir}/*.m4
676
677 %files examples
678 %defattr(644,root,root,755)
679 %{_examplesdir}/%{name}-%{version}
680
681 %if %{with x11}
682 %files HelpGen
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_bindir}/HelpGen
685 %endif
686
687 %if %{with ansi}
688 %files -n wxBase
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/libwx_base-*.so.*.*
691 %attr(755,root,root) %{_libdir}/libwx_base_*.so.*.*
692 %attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
693
694 %files -n wxBase-devel
695 %defattr(644,root,root,755)
696 %{_libdir}/libwx_base-*.so
697 %{_libdir}/libwx_base_*.so
698 %endif
699
700 %files -n wxBase-unicode
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/libwx_baseu-*.so.*.*
703 %attr(755,root,root) %{_libdir}/libwx_baseu_*.so.*.*
704 %attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
705
706 %files -n wxBase-unicode-devel
707 %defattr(644,root,root,755)
708 %{_libdir}/libwx_baseu-*.so
709 %{_libdir}/libwx_baseu_*.so
710
711 %if %{with ansi}
712 %files -n wxGTK2
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/libwx_gtk2_*.so.*.*
715 %exclude %{_libdir}/libwx_gtk2_ogl-*.so.*.*
716
717 %files -n wxGTK2-devel
718 %defattr(644,root,root,755)
719 %{_libdir}/libwx_gtk2_*-*.so
720 %exclude %{_libdir}/libwx_gtk2_ogl-*.so
721 %{_libdir}/wx/config/gtk2-ansi-*
722 %{_libdir}/wx/include/gtk2-ansi-*
723 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi-config
724
725 %files -n wxGTK2-gl
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/libwx_gtk2_ogl-*.so.*.*
728
729 %files -n wxGTK2-gl-devel
730 %defattr(644,root,root,755)
731 %{_libdir}/libwx_gtk2_ogl-*.so
732 %endif
733
734 %files -n wxGTK2-unicode
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/libwx_gtk2u_*-*.so.*.*
737 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
738
739 %files -n wxGTK2-unicode-devel
740 %defattr(644,root,root,755)
741 %{_libdir}/libwx_gtk2u_*-*.so
742 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so
743 %{_libdir}/wx/config/gtk2-unicode-*
744 %{_libdir}/wx/include/gtk2-unicode-*
745 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode-config
746
747 %files -n wxGTK2-unicode-gl
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
750
751 %files -n wxGTK2-unicode-gl-devel
752 %defattr(644,root,root,755)
753 %{_libdir}/libwx_gtk2u_ogl-*.so
754
755 %if %{with x11}
756 %if %{with ansi}
757 %files utils
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_bindir}/*
760 %exclude %{_bindir}/HelpGen
761 %exclude %{_bindir}/wx*-config
762 #%{_datadir}/wx/makegen
763 #%{_datadir}/wx/wxrcedit
764
765 %files -n wxX11
766 %defattr(644,root,root,755)
767 %doc docs/wxX11-readme.txt
768 %attr(755,root,root) %{_libdir}/libwx_x11univ_*-*.so.*.*
769 %exclude %{_libdir}/libwx_x11univ_ogl-*.so.*.*
770
771 %files -n wxX11-devel
772 %defattr(644,root,root,755)
773 %{_libdir}/libwx_x11univ_*-*.so
774 %exclude %{_libdir}/libwx_x11univ_ogl-*.so
775 %{_libdir}/wx/config/x11univ-ansi-*
776 %{_libdir}/wx/include/x11univ-ansi-*
777 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi-config
778
779 %files -n wxX11-gl
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libwx_x11univ_ogl-*.so.*.*
782
783 %files -n wxX11-gl-devel
784 %defattr(644,root,root,755)
785 %{_libdir}/libwx_x11univ_ogl-*.so
786 %endif
787
788 %files -n wxX11-unicode
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_libdir}/libwx_x11univu_*-*.so.*.*
791 %exclude %{_libdir}/libwx_x11univu_ogl-*.so.*.*
792
793 %files -n wxX11-unicode-devel
794 %defattr(644,root,root,755)
795 %{_libdir}/libwx_x11univu_*-*.so
796 %exclude %{_libdir}/libwx_x11univu_ogl-*.so
797 %{_libdir}/wx/config/x11univ-unicode-*
798 %{_libdir}/wx/include/x11univ-unicode-*
799 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode-config
800
801 %files -n wxX11-unicode-gl
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_libdir}/libwx_x11univu_ogl-*.so.*.*
804
805 %files -n wxX11-unicode-gl-devel
806 %defattr(644,root,root,755)
807 %{_libdir}/libwx_x11univu_ogl-*.so
808 %endif
This page took 0.114669 seconds and 4 git commands to generate.