]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- Reverted; BR: autoconf >= 2.59-9 (tx qboosh)
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8 #
9 # Unpackaged files:
10 #  /usr/bin/wxrc-2.6
11 #  /usr/share/bakefile/presets/wx.bkl
12 #  /usr/share/bakefile/presets/wx_unix.bkl
13 #  /usr/share/bakefile/presets/wx_win32.bkl
14 #  /usr/share/locale/it/LC_MESSAGES/wxmsw.mo
15 #
16
17 Summary:        wxWidgets library
18 Summary(pl):    Biblioteka wxWidgets
19 Name:           wxWidgets
20 Version:        2.6.3
21 Release:        1
22 License:        wxWidgets Licence (LGPL with exception)
23 Group:          X11/Libraries
24 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}.tar.bz2
25 # Source0-md5:  183a1fe136d7caacb60c717bbbef9788
26 Patch0:         %{name}-samples.patch
27 Patch1:         %{name}-ogl.patch
28 Patch2:         %{name}-ac.patch
29 Patch3:         %{name}-gif0delay.patch
30 Patch4:         %{name}-x11unicode.patch
31 Patch5:         %{name}-gcc4.patch
32 URL:            http://www.wxWidgets.org/
33 BuildRequires:  OpenGL-GLU-devel
34 #BuildRequires: SDL-devel
35 BuildRequires:  autoconf >= 2.59-9
36 BuildRequires:  automake
37 #BuildRequires: bakefile >= 0.1.9
38 BuildRequires:  cppunit-devel
39 BuildRequires:  esound-devel
40 BuildRequires:  expat-devel
41 BuildRequires:  flex
42 BuildRequires:  gettext-devel
43 BuildRequires:  gtk+2-devel >= 2.0.0
44 BuildRequires:  libjpeg-devel
45 BuildRequires:  libmng-devel
46 BuildRequires:  libmspack-devel
47 BuildRequires:  libpng-devel
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libtiff-devel
50 BuildRequires:  libtool
51 BuildRequires:  pkgconfig
52 %{?with_x11:BuildRequires:      xorg-lib-libXext-devel}
53 # these are not supported by wxWidgets
54 Obsoletes:      LDAPExplorerTool <= 0.6-1
55 Obsoletes:      abridge <= 0.4.0-1
56 # and these are replaced
57 Obsoletes:      wxGTK
58 Obsoletes:      wxGTK-devel
59 Obsoletes:      wxGTK-gl
60 Obsoletes:      wxGTK-gl-devel
61 Obsoletes:      wxGTK-univ
62 Obsoletes:      wxGTK-univ-devel
63 Obsoletes:      wxGTK-univ-gl
64 Obsoletes:      wxGTK-univ-gl-devel
65 Obsoletes:      wxGTK2-univ
66 Obsoletes:      wxGTK2-univ-devel
67 Obsoletes:      wxGTK2-univ-gl
68 Obsoletes:      wxGTK2-univ-gl-devel
69 Obsoletes:      wxGTK2-univ-unicode
70 Obsoletes:      wxGTK2-univ-unicode-devel
71 Obsoletes:      wxGTK2-univ-unicode-gl
72 Obsoletes:      wxGTK2-univ-unicode-gl-devel
73 Obsoletes:      wxMotif
74 Obsoletes:      wxMotif-devel
75 Obsoletes:      wxMotif-gl
76 Obsoletes:      wxMotif-gl-devel
77 Obsoletes:      wxWidgets-afm
78 Obsoletes:      wxWindows
79 Obsoletes:      wxWindows-afm
80 Obsoletes:      wxwin-afm
81 Obsoletes:      wxwin-common
82 Conflicts:      wxGTK2 < 2.6.0
83 Conflicts:      wxGTK2-unicode < 2.6.0
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         _sysconfdir     %{_datadir}
87
88 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
89
90 %description
91 wxWidgets is a free C++ library for cross-platform GUI development.
92 With wxWidgets, you can create applications for different GUIs (GTK+,
93 Motif/LessTif, MS Windows, Mac) from the same source code.
94
95 %description -l pl
96 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
97 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
98 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
99 Windows, Mac) z tego samego kodu ¼ród³owego.
100
101 %package devel
102 Summary:        wxWidgets header files and development documentation
103 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
104 Group:          X11/Development/Libraries
105 Requires:       libstdc++-devel
106 Obsoletes:      wxWindows-devel
107
108 %description devel
109 Header files and development documentation for the wxWidgets
110 libraries.
111
112 %description devel -l pl
113 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
114
115 %package examples
116 Summary:        wxWidgets example programs
117 Summary(pl):    Przyk³adowe programy wxWidgets
118 Group:          X11/Development/Libraries
119 Requires:       %{name}-devel = %{version}-%{release}
120 Obsoletes:      wxWindows-examples
121
122 %description examples
123 wxWidgets example programs.
124
125 %description examples -l pl
126 Przyk³adowe programy wxWidgets.
127
128 %package HelpGen
129 Summary:        Help file generator for wxWidgets programs
130 Summary(pl):    Generator plików pomocy dla programów wxWidgets
131 Group:          Development/Tools
132 Requires:       wxBase = %{version}-%{release}
133 Obsoletes:      wxWindows-HelpGen
134
135 %description HelpGen
136 Help file generator for wxWidgets programs.
137
138 %description HelpGen -l pl
139 Generator plików pomocy dla programów wxWidgets.
140
141 %package -n wxBase
142 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
143 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
144 Group:          X11/Libraries
145 Requires:       %{name} = %{version}-%{release}
146
147 %description -n wxBase
148 wxBase is a collection of C++ classes providing basic data structures
149 (strings, lists, arrays), powerful wxDateTime class for date
150 manipulations, portable wrappers around many OS-specific functions
151 allowing to build the same program under all supported folders,
152 wxThread class for writing multithreaded programs using either Win32
153 or POSIX threads and much more. wxBase currently supports the
154 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
155 HP-UX, ...) and BeOS.
156
157 %description -n wxBase -l pl
158 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
159 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
160 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
161 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
162 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
163 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
164 platformy: Win32, Unix i BeOS.
165
166 %package -n wxBase-devel
167 Summary:        wxBase headers needed for developping with wxBase
168 Summary(pl):    Pliki nag³ówkowe do wxBase
169 Group:          X11/Development/Libraries
170 Requires:       %{name}-devel = %{version}-%{release}
171 Requires:       wxBase = %{version}-%{release}
172
173 %description -n wxBase-devel
174 Header files for wxBase. You need them to develop programs using
175 wxBase.
176
177 %description -n wxBase-devel -l pl
178 Pliki nag³ówkowe do biblioteki wxBase.
179
180 %package -n wxBase-unicode
181 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
182 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
183 Group:          X11/Libraries
184 Requires:       %{name} = %{version}-%{release}
185
186 %description -n wxBase-unicode
187 wxBase is a collection of C++ classes providing basic data structures
188 (strings, lists, arrays), powerful wxDateTime class for date
189 manipulations, portable wrappers around many OS-specific functions
190 allowing to build the same program under all supported folders,
191 wxThread class for writing multithreaded programs using either Win32
192 or POSIX threads and much more. wxBase currently supports the
193 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
194 HP-UX, ...) and BeOS. This version is build with UNICODE support.
195
196 %description -n wxBase-unicode -l pl
197 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
198 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
199 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
200 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
201 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
202 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
203 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
204 UNICODE.
205
206 %package -n wxBase-unicode-devel
207 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
208 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
209 Group:          X11/Development/Libraries
210 Requires:       %{name}-devel = %{version}-%{release}
211 Requires:       wxBase-unicode = %{version}-%{release}
212
213 %description -n wxBase-unicode-devel
214 Header files for wxBase. You need them to develop programs using
215 UNICODE-enabled wxBase.
216
217 %description -n wxBase-unicode-devel -l pl
218 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
219
220 %package -n wxGTK2
221 Summary:        wxGTK2 library
222 Summary(pl):    Biblioteka wxGTK2
223 Group:          X11/Libraries
224 Requires:       %{name} = %{version}-%{release}
225 Obsoletes:      wxGTK2-univ
226
227 %description -n wxGTK2
228 wxWidgets library using GTK2 widgets.
229
230 %description -n wxGTK2 -l pl
231 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
232
233 %package -n wxGTK2-devel
234 Summary:        Header files for wxGTK2 library
235 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
236 Group:          X11/Development/Libraries
237 Requires:       wxBase-devel = %{version}-%{release}
238 Requires:       wxGTK2 = %{version}-%{release}
239 Obsoletes:      wxGTK2-univ-devel
240
241 %description -n wxGTK2-devel
242 Header files for wxWidgets library using GTK2 widgets.
243
244 %description -n wxGTK2-devel -l pl
245 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
246
247 %package -n wxGTK2-gl
248 Summary:        GL canvas library for wxGTK2
249 Summary(pl):    Biblioteka GL dla wxGTK2
250 Group:          X11/Libraries
251 Requires:       wxGTK2 = %{version}-%{release}
252 Obsoletes:      wxGTK2-univ-gl
253
254 %description -n wxGTK2-gl
255 wxGTK2 GL canvas library.
256
257 %description -n wxGTK2-gl -l pl
258 Biblioteka GL dla wxGTK2.
259
260 %package -n wxGTK2-gl-devel
261 Summary:        Development files for GL canvas library for wxGTK2
262 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
263 Group:          X11/Development/Libraries
264 Requires:       wxGTK2-devel = %{version}-%{release}
265 Requires:       wxGTK2-gl = %{version}-%{release}
266 Requires:       OpenGL-GLU-devel
267 Obsoletes:      wxGTK2-univ-gl-devel
268
269 %description -n wxGTK2-gl-devel
270 Development files for wxGTK2 GL canvas library.
271
272 %description -n wxGTK2-gl-devel -l pl
273 Pliki programistyczne biblioteki GL dla wxGTK2.
274
275 %package -n wxGTK2-unicode
276 Summary:        wxGTK2 library with UNICODE support
277 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
278 Group:          X11/Libraries
279 Requires:       %{name} = %{version}-%{release}
280 Obsoletes:      wxGTK2-univ-unicode
281
282 %description -n wxGTK2-unicode
283 wxWidgets library using GTK2 widgets with UNICODE support.
284
285 %description -n wxGTK2-unicode -l pl
286 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
287
288 %package -n wxGTK2-unicode-devel
289 Summary:        Header files for wxGTK2 library with UNICODE support
290 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
291 Group:          X11/Development/Libraries
292 Requires:       wxBase-unicode-devel = %{version}-%{release}
293 Requires:       wxGTK2-unicode = %{version}-%{release}
294 Obsoletes:      wxGTK2-univ-unicode-devel
295
296 %description -n wxGTK2-unicode-devel
297 Header files for wxWidgets library using GTK2 widgets with UNICODE
298 support.
299
300 %description -n wxGTK2-unicode-devel -l pl
301 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
302 obs³ug± UNICODE.
303
304 %package -n wxGTK2-unicode-gl
305 Summary:        GL canvas library for wxGTK2 with UNICODE support
306 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
307 Group:          X11/Libraries
308 Requires:       wxGTK2-unicode = %{version}-%{release}
309 Obsoletes:      wxGTK2-univ-unicode-gl
310
311 %description -n wxGTK2-unicode-gl
312 GL canvas library for wxGTK2 with UNICODE support.
313
314 %description -n wxGTK2-unicode-gl -l pl
315 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
316
317 %package -n wxGTK2-unicode-gl-devel
318 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
319 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
320 Group:          X11/Development/Libraries
321 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
322 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
323 Requires:       OpenGL-GLU-devel
324 Obsoletes:      wxGTK2-univ-unicode-gl-devel
325
326 %description -n wxGTK2-unicode-gl-devel
327 Development files for GL canvas library for wxGTK2 with UNICODE
328 support.
329
330 %description -n wxGTK2-unicode-gl-devel -l pl
331 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
332
333 %package utils
334 Summary:        Misc utils from wxWidgets project
335 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
336 Group:          X11/Development/Tools
337 Requires:       wxX11 = %{version}-%{release}
338 Obsoletes:      wxWindows-utils
339
340 %description utils
341 Misc utils from wxWidgets project: helpviewer, makegen, etc.
342
343 %description utils -l pl
344 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
345
346 %package -n wxX11
347 Summary:        wxUniversal-based wxX11 library
348 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
349 Group:          X11/Libraries
350 Requires:       %{name} = %{version}-%{release}
351 Obsoletes:      wxX11-univ
352
353 %description -n wxX11
354 wxUniversal-based wxX11 library.
355
356 %description -n wxX11 -l pl
357 Oparta na wxUniversal biblioteka wxX11.
358
359 %package -n wxX11-devel
360 Summary:        Header files for wxUniversal-based wxX11 library
361 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
362 Group:          X11/Libraries
363 Requires:       %{name}-devel = %{version}-%{release}
364 Requires:       wxX11 = %{version}-%{release}
365 Obsoletes:      wxX11-univ-devel
366
367 %description -n wxX11-devel
368 Header files for wxUniversal-based wxX11 library.
369
370 %description -n wxX11-devel -l pl
371 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
372
373 %package -n wxX11-gl
374 Summary:        GL canvas library for wxUniversal-based wxX11
375 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
376 Group:          X11/Libraries
377 Requires:       wxX11 = %{version}-%{release}
378 Obsoletes:      wxX11-univ-gl
379
380 %description -n wxX11-gl
381 GL canvas library for wxUniversal-based wxX11.
382
383 %description -n wxX11-gl -l pl
384 Biblioteka GL dla opartej na wxUniversal wxX11.
385
386 %package -n wxX11-gl-devel
387 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
388 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
389 Group:          X11/Development/Libraries
390 Requires:       wxX11-gl = %{version}-%{release}
391 Requires:       wxX11-devel = %{version}-%{release}
392 Requires:       OpenGL-GLU-devel
393 Obsoletes:      wxX11-univ-gl-devel
394
395 %description -n wxX11-gl-devel
396 Development files for GL canvas library for wxUniversal-based wxX11.
397
398 %description -n wxX11-gl-devel -l pl
399 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
400
401 %package -n wxX11-unicode
402 Summary:        wxUniversal-based wxX11 library with UNICODE support
403 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
404 Group:          X11/Libraries
405 Requires:       %{name} = %{version}-%{release}
406 Obsoletes:      wxX11-univ-unicode
407
408 %description -n wxX11-unicode
409 wxUniversal-based wxX11 library with UNICODE support.
410
411 %description -n wxX11-unicode -l pl
412 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
413
414 %package -n wxX11-unicode-devel
415 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
416 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
417 Group:          X11/Development/Libraries
418 Requires:       %{name}-devel = %{version}-%{release}
419 Requires:       wxX11-unicode = %{version}-%{release}
420 Obsoletes:      wxX11-univ-unicode-devel
421
422 %description -n wxX11-unicode-devel
423 Header files for wxUniversal-based wxX11 library with UNICODE support.
424
425 %description -n wxX11-unicode-devel -l pl
426 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
427
428 %package -n wxX11-unicode-gl
429 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
430 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
431 Group:          X11/Libraries
432 Requires:       wxX11-unicode = %{version}-%{release}
433 Obsoletes:      wxX11-univ-unicode-gl
434
435 %description -n wxX11-unicode-gl
436 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
437
438 %description -n wxX11-unicode-gl -l pl
439 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
440
441 %package -n wxX11-unicode-gl-devel
442 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
443 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
444 Group:          X11/Development/Libraries
445 Requires:       wxX11-unicode-gl = %{version}-%{release}
446 Requires:       wxX11-unicode-devel = %{version}-%{release}
447 Requires:       OpenGL-GLU-devel
448 Obsoletes:      wxX11-univ-unicode-gl-devel
449
450 %description -n wxX11-unicode-gl-devel
451 Development files for GL canvas library for wxUniversal-based wxX11
452 with UNICODE support.
453
454 %description -n wxX11-unicode-gl-devel -l pl
455 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
456 obs³ug± UNICODE.
457
458 %prep
459 %setup -q
460 %patch0 -p1
461 %patch1 -p1
462 %patch2 -p1
463 %patch3 -p1
464 %patch4 -p1
465 %patch5 -p1
466
467 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
468
469 %build
470 # if bakefiles rebuild is needed:
471 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.9"
472 #cd build/bakefiles
473 #bakefile_gen -f autoconf
474 #cd ../..
475 #%endif
476 cp -f /usr/share/automake/config.sub .
477 %{__aclocal} -I build/aclocal
478 %{__autoconf}
479
480 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
481 # avoid adding -s to LDFLAGS
482 LDFLAGS=" "; export LDFLAGS
483 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
484         --enable-plugins \
485         --enable-std_iostreams \
486         --without-sdl \
487         --with-opengl \
488         --enable-calendar \
489         --enable-controls \
490         --enable-tabdialog"
491
492 gui='--with-gtk'
493 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
494         '--enable-unicode' ; do
495         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
496         mkdir $objdir
497         cd $objdir
498         ../%configure \
499                 ${args} \
500                 ${gui} \
501                 --disable-universal \
502                 ${unicode}
503         %{__make}
504         %{__make} -C contrib/src
505         cd ..
506 done
507
508 %if %{with x11}
509 gui='--with-x11'
510 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
511         '--enable-unicode' ; do
512         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
513         mkdir $objdir
514         cd $objdir
515         ../%configure \
516                 ${args} \
517                 ${gui} \
518                 --enable-universal \
519                 ${unicode}
520         %{__make}
521         %{__make} -C contrib/src
522         if echo $objdir| grep -q disable-unicode ; then
523                 %{__make} -C utils
524                 %{__make} -C utils/emulator
525                 %{__make} -C utils/hhp2cached
526                 %{__make} -C contrib/utils
527         fi
528         cd ..
529 done
530 %endif
531
532 cd locale
533 %{__make} allmo
534
535 %install
536 rm -rf $RPM_BUILD_ROOT
537 install -d $RPM_BUILD_ROOT%{_bindir}
538
539 gui='--with-gtk'
540 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
541         '--enable-unicode' ; do
542         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
543         cd $objdir
544         %{__make} install \
545                 prefix=$RPM_BUILD_ROOT%{_prefix} \
546                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
547                 bindir=$RPM_BUILD_ROOT%{_bindir} \
548                 datadir=$RPM_BUILD_ROOT%{_datadir} \
549                 libdir=$RPM_BUILD_ROOT%{_libdir} \
550                 mandir=$RPM_BUILD_ROOT%{_mandir} \
551                 includedir=$RPM_BUILD_ROOT%{_includedir}
552
553         %{__make} -C contrib/src install \
554                 prefix=$RPM_BUILD_ROOT%{_prefix} \
555                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
556                 bindir=$RPM_BUILD_ROOT%{_bindir} \
557                 datadir=$RPM_BUILD_ROOT%{_datadir} \
558                 libdir=$RPM_BUILD_ROOT%{_libdir} \
559                 mandir=$RPM_BUILD_ROOT%{_mandir} \
560                 includedir=$RPM_BUILD_ROOT%{_includedir}
561         cd ..
562 done
563
564 %if %{with x11}
565 gui='--with-x11'
566 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
567         '--enable-unicode' ; do
568         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
569         cd $objdir
570         %{__make} install \
571                 prefix=$RPM_BUILD_ROOT%{_prefix} \
572                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
573                 bindir=$RPM_BUILD_ROOT%{_bindir} \
574                 datadir=$RPM_BUILD_ROOT%{_datadir} \
575                 libdir=$RPM_BUILD_ROOT%{_libdir} \
576                 mandir=$RPM_BUILD_ROOT%{_mandir} \
577                 includedir=$RPM_BUILD_ROOT%{_includedir}
578         if echo $objdir| grep -q disable-unicode ; then
579 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
580                 # TODO: install default config files and default backgrouds
581                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
582                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
583                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
584                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
585 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
586                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
587 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
588 #               install -m644 utils/makegen/templates/* \
589 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
590 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
591 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
592 #               install contrib/utils/wxrcedit/df/* \
593 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
594         fi
595
596         %{__make} -C contrib/src install \
597                 prefix=$RPM_BUILD_ROOT%{_prefix} \
598                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
599                 bindir=$RPM_BUILD_ROOT%{_bindir} \
600                 datadir=$RPM_BUILD_ROOT%{_datadir} \
601                 libdir=$RPM_BUILD_ROOT%{_libdir} \
602                 mandir=$RPM_BUILD_ROOT%{_mandir} \
603                 includedir=$RPM_BUILD_ROOT%{_includedir}
604
605         cd ..
606 done
607 %endif
608
609 set -x
610
611 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
612 do
613         b=`basename $i`
614         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
615 done
616
617 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
618 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
619 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
620
621 %find_lang wxstd
622
623 %clean
624 rm -rf $RPM_BUILD_ROOT
625
626 %post   -n wxBase -p /sbin/ldconfig
627 %postun -n wxBase -p /sbin/ldconfig
628
629 %post   -n wxBase-unicode -p /sbin/ldconfig
630 %postun -n wxBase-unicode -p /sbin/ldconfig
631
632 %post   -n wxGTK2 -p /sbin/ldconfig
633 %postun -n wxGTK2 -p /sbin/ldconfig
634
635 %post   -n wxGTK2-gl -p /sbin/ldconfig
636 %postun -n wxGTK2-gl -p /sbin/ldconfig
637
638 %post   -n wxGTK2-unicode -p /sbin/ldconfig
639 %postun -n wxGTK2-unicode -p /sbin/ldconfig
640
641 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
642 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
643
644 %post   -n wxX11 -p /sbin/ldconfig
645 %postun -n wxX11 -p /sbin/ldconfig
646
647 %post   -n wxX11-unicode -p /sbin/ldconfig
648 %postun -n wxX11-unicode -p /sbin/ldconfig
649
650 %define _libf %{?with_debug:d}
651 %define _configf %{?with_debug:-debug-2.6}
652
653 %files -f wxstd.lang
654 %defattr(644,root,root,755)
655 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
656
657 %files devel
658 %defattr(644,root,root,755)
659 %doc docs/html
660 %doc docs/tech docs/univ
661 %{_includedir}/wx*
662 %dir %{_libdir}/wx
663 %dir %{_libdir}/wx/include
664 %dir %{_libdir}/wx/config
665 %{_aclocaldir}/*.m4
666
667 %files examples
668 %defattr(644,root,root,755)
669 %{_examplesdir}/%{name}-%{version}
670
671 %if %{with x11}
672 %files HelpGen
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_bindir}/HelpGen
675 %endif
676
677 %if %{with ansi}
678 %files -n wxBase
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
681 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
682 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
683
684 %files -n wxBase-devel
685 %defattr(644,root,root,755)
686 %{_libdir}/libwx_base%{_libf}-*.so
687 %{_libdir}/libwx_base%{_libf}_*.so
688 %endif
689
690 %files -n wxBase-unicode
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
693 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
694 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
695
696 %files -n wxBase-unicode-devel
697 %defattr(644,root,root,755)
698 %{_libdir}/libwx_baseu%{_libf}-*.so
699 %{_libdir}/libwx_baseu%{_libf}_*.so
700
701 %if %{with ansi}
702 %files -n wxGTK2
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
705 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
706
707 %files -n wxGTK2-devel
708 %defattr(644,root,root,755)
709 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
710 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
711 %{_libdir}/wx/config/gtk2-ansi-*
712 %{_libdir}/wx/include/gtk2-ansi-*
713 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
714
715 %files -n wxGTK2-gl
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
718
719 %files -n wxGTK2-gl-devel
720 %defattr(644,root,root,755)
721 %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
722 %endif
723
724 %files -n wxGTK2-unicode
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
727 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
728
729 %files -n wxGTK2-unicode-devel
730 %defattr(644,root,root,755)
731 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
732 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
733 %{_libdir}/wx/config/gtk2-unicode-*
734 %{_libdir}/wx/include/gtk2-unicode-*
735 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
736
737 %files -n wxGTK2-unicode-gl
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
740
741 %files -n wxGTK2-unicode-gl-devel
742 %defattr(644,root,root,755)
743 %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
744
745 %if %{with x11}
746 %if %{with ansi}
747 %files utils
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_bindir}/*
750 %exclude %{_bindir}/HelpGen
751 %exclude %{_bindir}/wx*-config
752
753 %files -n wxX11
754 %defattr(644,root,root,755)
755 %doc docs/wxX11-readme.txt
756 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
757 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
758
759 %files -n wxX11-devel
760 %defattr(644,root,root,755)
761 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
762 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
763 %{_libdir}/wx/config/x11univ-ansi-*
764 %{_libdir}/wx/include/x11univ-ansi-*
765 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
766
767 %files -n wxX11-gl
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
770
771 %files -n wxX11-gl-devel
772 %defattr(644,root,root,755)
773 %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
774 %endif
775
776 %files -n wxX11-unicode
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
779 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
780
781 %files -n wxX11-unicode-devel
782 %defattr(644,root,root,755)
783 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
784 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
785 %{_libdir}/wx/config/x11univ-unicode-*
786 %{_libdir}/wx/include/x11univ-unicode-*
787 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
788
789 %files -n wxX11-unicode-gl
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
792
793 %files -n wxX11-unicode-gl-devel
794 %defattr(644,root,root,755)
795 %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
796 %endif
This page took 0.163865 seconds and 4 git commands to generate.