]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- rel 1, STBR
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     gnomeprint              # GNOME print support
7 %bcond_with     debug                   # build with \--enable-debug
8                                         # (binary incompatible with non-debug)
9 #
10 # Unpackaged files:
11 #  /usr/bin/wxrc-2.8
12 #  /usr/share/locale/it/LC_MESSAGES/wxmsw.mo
13 #
14
15 Summary:        wxWidgets library
16 Summary(pl):    Biblioteka wxWidgets
17 Name:           wxWidgets
18 Version:        2.8.1
19 Release:        1
20 License:        wxWidgets Licence (LGPL with exception)
21 Group:          X11/Libraries
22 Source0:        http://ftp.wxwidgets.org/pub/%{version}/%{name}-%{version}.tar.bz2
23 # Source0-md5:  fe01afe1c055bc82875682e5905c7378
24 Patch0:         %{name}-samples.patch
25 Patch1:         %{name}-ogl.patch
26 Patch2:         %{name}-ac.patch
27 Patch3:         %{name}-gif0delay.patch
28 Patch4:         %{name}-x11unicode.patch
29 Patch5:         %{name}-gcc4.patch
30 URL:            http://www.wxWidgets.org/
31 BuildRequires:  OpenGL-GLU-devel
32 #BuildRequires: SDL-devel
33 BuildRequires:  autoconf >= 2.59-9
34 BuildRequires:  automake
35 #BuildRequires: bakefile >= 0.2.1
36 BuildRequires:  cppunit-devel
37 BuildRequires:  esound-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  flex
40 BuildRequires:  gettext-devel
41 BuildRequires:  gtk+2-devel >= 2.0.0
42 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.8.0}
43 BuildRequires:  libjpeg-devel
44 BuildRequires:  libmng-devel
45 BuildRequires:  libmspack-devel
46 BuildRequires:  libpng-devel
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  libtiff-devel
49 BuildRequires:  libtool
50 BuildRequires:  pkgconfig
51 %{?with_x11:BuildRequires:      xorg-lib-libXext-devel}
52 # these are not supported by wxWidgets
53 Obsoletes:      LDAPExplorerTool <= 0.6-1
54 Obsoletes:      abridge <= 0.4.0-1
55 # and these are replaced
56 Obsoletes:      wxGTK
57 Obsoletes:      wxGTK-devel
58 Obsoletes:      wxGTK-gl
59 Obsoletes:      wxGTK-gl-devel
60 Obsoletes:      wxGTK-univ
61 Obsoletes:      wxGTK-univ-devel
62 Obsoletes:      wxGTK-univ-gl
63 Obsoletes:      wxGTK-univ-gl-devel
64 Obsoletes:      wxGTK2-univ
65 Obsoletes:      wxGTK2-univ-devel
66 Obsoletes:      wxGTK2-univ-gl
67 Obsoletes:      wxGTK2-univ-gl-devel
68 Obsoletes:      wxGTK2-univ-unicode
69 Obsoletes:      wxGTK2-univ-unicode-devel
70 Obsoletes:      wxGTK2-univ-unicode-gl
71 Obsoletes:      wxGTK2-univ-unicode-gl-devel
72 Obsoletes:      wxMotif
73 Obsoletes:      wxMotif-devel
74 Obsoletes:      wxMotif-gl
75 Obsoletes:      wxMotif-gl-devel
76 Obsoletes:      wxWidgets-afm
77 Obsoletes:      wxWindows
78 Obsoletes:      wxWindows-afm
79 Obsoletes:      wxwin-afm
80 Obsoletes:      wxwin-common
81 Conflicts:      wxGTK2 < 2.6.0
82 Conflicts:      wxGTK2-unicode < 2.6.0
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _sysconfdir     %{_datadir}
86
87 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
88
89 %description
90 wxWidgets is a free C++ library for cross-platform GUI development.
91 With wxWidgets, you can create applications for different GUIs (GTK+,
92 Motif/LessTif, MS Windows, Mac) from the same source code.
93
94 %description -l pl
95 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
96 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
97 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
98 Windows, Mac) z tego samego kodu ¼ród³owego.
99
100 %package devel
101 Summary:        wxWidgets header files and development documentation
102 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
103 Group:          X11/Development/Libraries
104 Requires:       libstdc++-devel
105 Obsoletes:      wxWindows-devel
106
107 %description devel
108 Header files and development documentation for the wxWidgets
109 libraries.
110
111 %description devel -l pl
112 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
113
114 %package -n bakefile-wxWidgets
115 Summary:        Files for Bakefile to generate wxWidgets project files
116 Summary(pl):    Pliki dla Bakefile generuj±ce pliki projektów wxWidgets
117 Group:          Development/Tools
118 Requires:       bakefile
119
120 %description -n bakefile-wxWidgets
121 Additional files for Bakefile to generate wxWidgets project files.
122
123 %description -n bakefile-wxWidgets -l pl
124 Dodatkowe pliki dla programu Bakefile umo¿liwiaj±ce wygenerowanie
125 projektów opartych na bibliotece wxWidgets.
126
127 %package examples
128 Summary:        wxWidgets example programs
129 Summary(pl):    Przyk³adowe programy wxWidgets
130 Group:          X11/Development/Libraries
131 Requires:       %{name}-devel = %{version}-%{release}
132 Obsoletes:      wxWindows-examples
133
134 %description examples
135 wxWidgets example programs.
136
137 %description examples -l pl
138 Przyk³adowe programy wxWidgets.
139
140 %package HelpGen
141 Summary:        Help file generator for wxWidgets programs
142 Summary(pl):    Generator plików pomocy dla programów wxWidgets
143 Group:          Development/Tools
144 Requires:       wxBase = %{version}-%{release}
145 Obsoletes:      wxWindows-HelpGen
146
147 %description HelpGen
148 Help file generator for wxWidgets programs.
149
150 %description HelpGen -l pl
151 Generator plików pomocy dla programów wxWidgets.
152
153 %package -n wxBase
154 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
155 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
156 Group:          X11/Libraries
157 Requires:       %{name} = %{version}-%{release}
158
159 %description -n wxBase
160 wxBase is a collection of C++ classes providing basic data structures
161 (strings, lists, arrays), powerful wxDateTime class for date
162 manipulations, portable wrappers around many OS-specific functions
163 allowing to build the same program under all supported folders,
164 wxThread class for writing multithreaded programs using either Win32
165 or POSIX threads and much more. wxBase currently supports the
166 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
167 HP-UX, ...) and BeOS.
168
169 %description -n wxBase -l pl
170 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
171 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
172 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
173 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
174 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
175 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
176 platformy: Win32, Unix i BeOS.
177
178 %package -n wxBase-devel
179 Summary:        wxBase headers needed for developping with wxBase
180 Summary(pl):    Pliki nag³ówkowe do wxBase
181 Group:          X11/Development/Libraries
182 Requires:       %{name}-devel = %{version}-%{release}
183 Requires:       wxBase = %{version}-%{release}
184
185 %description -n wxBase-devel
186 Header files for wxBase. You need them to develop programs using
187 wxBase.
188
189 %description -n wxBase-devel -l pl
190 Pliki nag³ówkowe do biblioteki wxBase.
191
192 %package -n wxBase-unicode
193 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
194 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
195 Group:          X11/Libraries
196 Requires:       %{name} = %{version}-%{release}
197
198 %description -n wxBase-unicode
199 wxBase is a collection of C++ classes providing basic data structures
200 (strings, lists, arrays), powerful wxDateTime class for date
201 manipulations, portable wrappers around many OS-specific functions
202 allowing to build the same program under all supported folders,
203 wxThread class for writing multithreaded programs using either Win32
204 or POSIX threads and much more. wxBase currently supports the
205 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
206 HP-UX, ...) and BeOS. This version is build with UNICODE support.
207
208 %description -n wxBase-unicode -l pl
209 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
210 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
211 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
212 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
213 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
214 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
215 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
216 UNICODE.
217
218 %package -n wxBase-unicode-devel
219 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
220 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
221 Group:          X11/Development/Libraries
222 Requires:       %{name}-devel = %{version}-%{release}
223 Requires:       wxBase-unicode = %{version}-%{release}
224
225 %description -n wxBase-unicode-devel
226 Header files for wxBase. You need them to develop programs using
227 UNICODE-enabled wxBase.
228
229 %description -n wxBase-unicode-devel -l pl
230 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
231
232 %package -n wxGTK2
233 Summary:        wxGTK2 library
234 Summary(pl):    Biblioteka wxGTK2
235 Group:          X11/Libraries
236 Requires:       %{name} = %{version}-%{release}
237 Obsoletes:      wxGTK2-univ
238
239 %description -n wxGTK2
240 wxWidgets library using GTK2 widgets.
241
242 %description -n wxGTK2 -l pl
243 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
244
245 %package -n wxGTK2-devel
246 Summary:        Header files for wxGTK2 library
247 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
248 Group:          X11/Development/Libraries
249 Requires:       wxBase-devel = %{version}-%{release}
250 Requires:       wxGTK2 = %{version}-%{release}
251 Obsoletes:      wxGTK2-univ-devel
252
253 %description -n wxGTK2-devel
254 Header files for wxWidgets library using GTK2 widgets.
255
256 %description -n wxGTK2-devel -l pl
257 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
258
259 %package -n wxGTK2-gl
260 Summary:        GL canvas library for wxGTK2
261 Summary(pl):    Biblioteka GL dla wxGTK2
262 Group:          X11/Libraries
263 Requires:       wxGTK2 = %{version}-%{release}
264 Obsoletes:      wxGTK2-univ-gl
265
266 %description -n wxGTK2-gl
267 wxGTK2 GL canvas library.
268
269 %description -n wxGTK2-gl -l pl
270 Biblioteka GL dla wxGTK2.
271
272 %package -n wxGTK2-gl-devel
273 Summary:        Development files for GL canvas library for wxGTK2
274 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
275 Group:          X11/Development/Libraries
276 Requires:       OpenGL-GLU-devel
277 Requires:       wxGTK2-devel = %{version}-%{release}
278 Requires:       wxGTK2-gl = %{version}-%{release}
279 Obsoletes:      wxGTK2-univ-gl-devel
280
281 %description -n wxGTK2-gl-devel
282 Development files for wxGTK2 GL canvas library.
283
284 %description -n wxGTK2-gl-devel -l pl
285 Pliki programistyczne biblioteki GL dla wxGTK2.
286
287 %package -n wxGTK2-unicode
288 Summary:        wxGTK2 library with UNICODE support
289 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
290 Group:          X11/Libraries
291 Requires:       %{name} = %{version}-%{release}
292 Obsoletes:      wxGTK2-univ-unicode
293
294 %description -n wxGTK2-unicode
295 wxWidgets library using GTK2 widgets with UNICODE support.
296
297 %description -n wxGTK2-unicode -l pl
298 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
299
300 %package -n wxGTK2-unicode-devel
301 Summary:        Header files for wxGTK2 library with UNICODE support
302 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
303 Group:          X11/Development/Libraries
304 Requires:       wxBase-unicode-devel = %{version}-%{release}
305 Requires:       wxGTK2-unicode = %{version}-%{release}
306 Obsoletes:      wxGTK2-univ-unicode-devel
307
308 %description -n wxGTK2-unicode-devel
309 Header files for wxWidgets library using GTK2 widgets with UNICODE
310 support.
311
312 %description -n wxGTK2-unicode-devel -l pl
313 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
314 obs³ug± UNICODE.
315
316 %package -n wxGTK2-unicode-gl
317 Summary:        GL canvas library for wxGTK2 with UNICODE support
318 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
319 Group:          X11/Libraries
320 Requires:       wxGTK2-unicode = %{version}-%{release}
321 Obsoletes:      wxGTK2-univ-unicode-gl
322
323 %description -n wxGTK2-unicode-gl
324 GL canvas library for wxGTK2 with UNICODE support.
325
326 %description -n wxGTK2-unicode-gl -l pl
327 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
328
329 %package -n wxGTK2-unicode-gl-devel
330 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
331 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
332 Group:          X11/Development/Libraries
333 Requires:       OpenGL-GLU-devel
334 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
335 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
336 Obsoletes:      wxGTK2-univ-unicode-gl-devel
337
338 %description -n wxGTK2-unicode-gl-devel
339 Development files for GL canvas library for wxGTK2 with UNICODE
340 support.
341
342 %description -n wxGTK2-unicode-gl-devel -l pl
343 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
344
345 %package utils
346 Summary:        Misc utils from wxWidgets project
347 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
348 Group:          X11/Development/Tools
349 Requires:       wxX11 = %{version}-%{release}
350 Obsoletes:      wxWindows-utils
351
352 %description utils
353 Misc utils from wxWidgets project: helpviewer, makegen, etc.
354
355 %description utils -l pl
356 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
357
358 %package -n wxX11
359 Summary:        wxUniversal-based wxX11 library
360 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
361 Group:          X11/Libraries
362 Requires:       %{name} = %{version}-%{release}
363 Obsoletes:      wxX11-univ
364
365 %description -n wxX11
366 wxUniversal-based wxX11 library.
367
368 %description -n wxX11 -l pl
369 Oparta na wxUniversal biblioteka wxX11.
370
371 %package -n wxX11-devel
372 Summary:        Header files for wxUniversal-based wxX11 library
373 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
374 Group:          X11/Libraries
375 Requires:       %{name}-devel = %{version}-%{release}
376 Requires:       wxX11 = %{version}-%{release}
377 Obsoletes:      wxX11-univ-devel
378
379 %description -n wxX11-devel
380 Header files for wxUniversal-based wxX11 library.
381
382 %description -n wxX11-devel -l pl
383 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
384
385 %package -n wxX11-gl
386 Summary:        GL canvas library for wxUniversal-based wxX11
387 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
388 Group:          X11/Libraries
389 Requires:       wxX11 = %{version}-%{release}
390 Obsoletes:      wxX11-univ-gl
391
392 %description -n wxX11-gl
393 GL canvas library for wxUniversal-based wxX11.
394
395 %description -n wxX11-gl -l pl
396 Biblioteka GL dla opartej na wxUniversal wxX11.
397
398 %package -n wxX11-gl-devel
399 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
400 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
401 Group:          X11/Development/Libraries
402 Requires:       OpenGL-GLU-devel
403 Requires:       wxX11-devel = %{version}-%{release}
404 Requires:       wxX11-gl = %{version}-%{release}
405 Obsoletes:      wxX11-univ-gl-devel
406
407 %description -n wxX11-gl-devel
408 Development files for GL canvas library for wxUniversal-based wxX11.
409
410 %description -n wxX11-gl-devel -l pl
411 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
412
413 %package -n wxX11-unicode
414 Summary:        wxUniversal-based wxX11 library with UNICODE support
415 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
416 Group:          X11/Libraries
417 Requires:       %{name} = %{version}-%{release}
418 Obsoletes:      wxX11-univ-unicode
419
420 %description -n wxX11-unicode
421 wxUniversal-based wxX11 library with UNICODE support.
422
423 %description -n wxX11-unicode -l pl
424 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
425
426 %package -n wxX11-unicode-devel
427 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
428 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
429 Group:          X11/Development/Libraries
430 Requires:       %{name}-devel = %{version}-%{release}
431 Requires:       wxX11-unicode = %{version}-%{release}
432 Obsoletes:      wxX11-univ-unicode-devel
433
434 %description -n wxX11-unicode-devel
435 Header files for wxUniversal-based wxX11 library with UNICODE support.
436
437 %description -n wxX11-unicode-devel -l pl
438 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug±
439 UNICODE.
440
441 %package -n wxX11-unicode-gl
442 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
443 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
444 Group:          X11/Libraries
445 Requires:       wxX11-unicode = %{version}-%{release}
446 Obsoletes:      wxX11-univ-unicode-gl
447
448 %description -n wxX11-unicode-gl
449 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
450
451 %description -n wxX11-unicode-gl -l pl
452 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
453
454 %package -n wxX11-unicode-gl-devel
455 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
456 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
457 Group:          X11/Development/Libraries
458 Requires:       OpenGL-GLU-devel
459 Requires:       wxX11-unicode-devel = %{version}-%{release}
460 Requires:       wxX11-unicode-gl = %{version}-%{release}
461 Obsoletes:      wxX11-univ-unicode-gl-devel
462
463 %description -n wxX11-unicode-gl-devel
464 Development files for GL canvas library for wxUniversal-based wxX11
465 with UNICODE support.
466
467 %description -n wxX11-unicode-gl-devel -l pl
468 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
469 obs³ug± UNICODE.
470
471 %prep
472 %setup -q
473 %patch0 -p1
474 %patch1 -p1
475 %patch2 -p1
476 %patch3 -p1
477 %patch4 -p1
478 %patch5 -p1
479
480 %build
481 # if bakefiles rebuild is needed:
482 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.2.1"
483 #cd build/bakefiles
484 #bakefile_gen -f autoconf
485 #cd ../..
486 #%endif
487 cp -f /usr/share/automake/config.sub .
488 %{__aclocal} -I build/aclocal
489 %{__autoconf}
490
491 CPPFLAGS="%{rpmcflags} -I`pwd`/include"; export CPPFLAGS
492 # avoid adding -s to LDFLAGS
493 LDFLAGS=" "; export LDFLAGS
494 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
495         --enable-plugins \
496         --enable-std_iostreams \
497         --without-sdl \
498         --with-opengl \
499         --enable-calendar \
500         --enable-controls \
501         --enable-tabdialog"
502
503 gui='--with-gtk'
504 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
505         '--enable-unicode' ; do
506         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
507         mkdir $objdir
508         cd $objdir
509         ../%configure \
510                 ${args} \
511                 ${gui} \
512                 --disable-universal \
513                 ${unicode} \
514                 %{!?with_gnomeprint:--without-gnomeprint}
515         %{__make}
516         %{__make} -C contrib/src
517         cd ..
518 done
519
520 %if %{with x11}
521 gui='--with-x11'
522 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
523         '--enable-unicode' ; do
524         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
525         mkdir $objdir
526         cd $objdir
527         ../%configure \
528                 ${args} \
529                 ${gui} \
530                 --enable-universal \
531                 ${unicode}
532         %{__make}
533         %{__make} -C contrib/src
534         if echo $objdir| grep -q disable-unicode ; then
535                 %{__make} -C utils
536                 %{__make} -C utils/emulator
537                 %{__make} -C utils/hhp2cached
538                 # %{__make} -C contrib/utils
539         fi
540         cd ..
541 done
542 %endif
543
544 cd locale
545 %{__make} allmo
546
547 %install
548 rm -rf $RPM_BUILD_ROOT
549 install -d $RPM_BUILD_ROOT%{_bindir}
550
551 gui='--with-gtk'
552 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
553         '--enable-unicode' ; do
554         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
555         cd $objdir
556         %{__make} install \
557                 prefix=$RPM_BUILD_ROOT%{_prefix} \
558                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
559                 bindir=$RPM_BUILD_ROOT%{_bindir} \
560                 datadir=$RPM_BUILD_ROOT%{_datadir} \
561                 libdir=$RPM_BUILD_ROOT%{_libdir} \
562                 mandir=$RPM_BUILD_ROOT%{_mandir} \
563                 includedir=$RPM_BUILD_ROOT%{_includedir}
564
565         %{__make} -C contrib/src install \
566                 prefix=$RPM_BUILD_ROOT%{_prefix} \
567                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
568                 bindir=$RPM_BUILD_ROOT%{_bindir} \
569                 datadir=$RPM_BUILD_ROOT%{_datadir} \
570                 libdir=$RPM_BUILD_ROOT%{_libdir} \
571                 mandir=$RPM_BUILD_ROOT%{_mandir} \
572                 includedir=$RPM_BUILD_ROOT%{_includedir}
573         cd ..
574 done
575
576 %if %{with x11}
577 gui='--with-x11'
578 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
579         '--enable-unicode' ; do
580         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
581         cd $objdir
582         %{__make} install \
583                 prefix=$RPM_BUILD_ROOT%{_prefix} \
584                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
585                 bindir=$RPM_BUILD_ROOT%{_bindir} \
586                 datadir=$RPM_BUILD_ROOT%{_datadir} \
587                 libdir=$RPM_BUILD_ROOT%{_libdir} \
588                 mandir=$RPM_BUILD_ROOT%{_mandir} \
589                 includedir=$RPM_BUILD_ROOT%{_includedir}
590         if echo $objdir| grep -q disable-unicode ; then
591 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
592                 # TODO: install default config files and default backgrouds
593                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
594                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
595                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
596                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
597 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
598                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
599 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
600 #               install -m644 utils/makegen/templates/* \
601 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
602 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
603 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
604 #               install contrib/utils/wxrcedit/df/* \
605 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
606         fi
607
608         %{__make} -C contrib/src install \
609                 prefix=$RPM_BUILD_ROOT%{_prefix} \
610                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
611                 bindir=$RPM_BUILD_ROOT%{_bindir} \
612                 datadir=$RPM_BUILD_ROOT%{_datadir} \
613                 libdir=$RPM_BUILD_ROOT%{_libdir} \
614                 mandir=$RPM_BUILD_ROOT%{_mandir} \
615                 includedir=$RPM_BUILD_ROOT%{_includedir}
616
617         cd ..
618 done
619 %endif
620
621 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
622 do
623         b=`basename $i`
624         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
625 done
626
627 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
628 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
629 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
630
631 %find_lang wxstd
632
633 %clean
634 rm -rf $RPM_BUILD_ROOT
635
636 %post   -n wxBase -p /sbin/ldconfig
637 %postun -n wxBase -p /sbin/ldconfig
638
639 %post   -n wxBase-unicode -p /sbin/ldconfig
640 %postun -n wxBase-unicode -p /sbin/ldconfig
641
642 %post   -n wxGTK2 -p /sbin/ldconfig
643 %postun -n wxGTK2 -p /sbin/ldconfig
644
645 %post   -n wxGTK2-gl -p /sbin/ldconfig
646 %postun -n wxGTK2-gl -p /sbin/ldconfig
647
648 %post   -n wxGTK2-unicode -p /sbin/ldconfig
649 %postun -n wxGTK2-unicode -p /sbin/ldconfig
650
651 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
652 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
653
654 %post   -n wxX11 -p /sbin/ldconfig
655 %postun -n wxX11 -p /sbin/ldconfig
656
657 %post   -n wxX11-unicode -p /sbin/ldconfig
658 %postun -n wxX11-unicode -p /sbin/ldconfig
659
660 %define _libf %{?with_debug:d}
661 %define _configf %{?with_debug:-debug-2.8}
662
663 %files -f wxstd.lang
664 %defattr(644,root,root,755)
665 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
666
667 %files devel
668 %defattr(644,root,root,755)
669 %doc docs/html
670 %doc docs/tech docs/univ
671 %{_includedir}/wx*
672 %dir %{_libdir}/wx
673 %dir %{_libdir}/wx/include
674 %dir %{_libdir}/wx/config
675 %{_aclocaldir}/*.m4
676
677 %files -n bakefile-wxWidgets
678 %defattr(644,root,root,755)
679 %{_datadir}/bakefile/presets/*.bkl
680
681 %files examples
682 %defattr(644,root,root,755)
683 %{_examplesdir}/%{name}-%{version}
684
685 %if %{with x11}
686 %files HelpGen
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_bindir}/HelpGen
689 %endif
690
691 %if %{with ansi}
692 %files -n wxBase
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
695 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
696 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
697
698 %files -n wxBase-devel
699 %defattr(644,root,root,755)
700 %{_libdir}/libwx_base%{_libf}-*.so
701 %{_libdir}/libwx_base%{_libf}_*.so
702 %endif
703
704 %files -n wxBase-unicode
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
707 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
708 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
709
710 %files -n wxBase-unicode-devel
711 %defattr(644,root,root,755)
712 %{_libdir}/libwx_baseu%{_libf}-*.so
713 %{_libdir}/libwx_baseu%{_libf}_*.so
714
715 %if %{with ansi}
716 %files -n wxGTK2
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
719 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
720
721 %files -n wxGTK2-devel
722 %defattr(644,root,root,755)
723 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
724 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
725 %{_libdir}/wx/config/gtk2-ansi-*
726 %{_libdir}/wx/include/gtk2-ansi-*
727 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
728
729 %files -n wxGTK2-gl
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
732
733 %files -n wxGTK2-gl-devel
734 %defattr(644,root,root,755)
735 %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
736 %endif
737
738 %files -n wxGTK2-unicode
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
741 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
742
743 %files -n wxGTK2-unicode-devel
744 %defattr(644,root,root,755)
745 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
746 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
747 %{_libdir}/wx/config/gtk2-unicode-*
748 %{_libdir}/wx/include/gtk2-unicode-*
749 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
750
751 %files -n wxGTK2-unicode-gl
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
754
755 %files -n wxGTK2-unicode-gl-devel
756 %defattr(644,root,root,755)
757 %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
758
759 %if %{with x11}
760 %if %{with ansi}
761 %files utils
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_bindir}/*
764 %exclude %{_bindir}/HelpGen
765 %exclude %{_bindir}/wx*-config
766
767 %files -n wxX11
768 %defattr(644,root,root,755)
769 %doc docs/wxX11-readme.txt
770 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
771 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
772
773 %files -n wxX11-devel
774 %defattr(644,root,root,755)
775 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
776 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
777 %{_libdir}/wx/config/x11univ-ansi-*
778 %{_libdir}/wx/include/x11univ-ansi-*
779 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
780
781 %files -n wxX11-gl
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
784
785 %files -n wxX11-gl-devel
786 %defattr(644,root,root,755)
787 %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
788 %endif
789
790 %files -n wxX11-unicode
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
793 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
794
795 %files -n wxX11-unicode-devel
796 %defattr(644,root,root,755)
797 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
798 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
799 %{_libdir}/wx/config/x11univ-unicode-*
800 %{_libdir}/wx/include/x11univ-unicode-*
801 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
802
803 %files -n wxX11-unicode-gl
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
806
807 %files -n wxX11-unicode-gl-devel
808 %defattr(644,root,root,755)
809 %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
810 %endif
This page took 0.095856 seconds and 3 git commands to generate.