]> git.pld-linux.org Git - packages/wordpress.git/commitdiff
start uppdate to 3.5.1
authorElan Ruusamäe <glen@delfi.ee>
Wed, 6 Feb 2013 14:48:34 +0000 (16:48 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 6 Feb 2013 14:48:34 +0000 (16:48 +0200)
apache.conf
atomlib.patch [deleted file]
configpath.patch
multisite.patch
phpmailer.patch
swfobject.patch
wordpress.patch
wordpress.spec
wp-secure.sh [changed mode: 0644->0755]
wp-setup.sh [changed mode: 0644->0755]

index 0bc918fc9ca39a4bd700da981942fb0fa37da060..08cb4240301ca82d51d97e0d42568945b52b428a 100644 (file)
@@ -14,3 +14,13 @@ Alias /wordpress /usr/share/wordpress
                RewriteRule . /wordpress/index.php [L]
        </IfModule>
 </Directory>
+
+# integrate wp-content/plugins/akismet/.htaccess
+<Directory /usr/share/wordpress/wp-content/plugins/akismet>
+       Order deny,allow
+       Deny from all
+
+       <FilesMatch "^akismet\.(css|js)$">
+               Allow from all
+       </FilesMatch>
+</Directory>
diff --git a/atomlib.patch b/atomlib.patch
deleted file mode 100644 (file)
index 8508d00..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- wpmu/./wp-app.php~ 2010-05-20 12:45:13.000000000 +0300
-+++ wpmu/./wp-app.php  2010-05-20 13:08:50.963000632 +0300
-@@ -18,7 +18,7 @@
- require_once('./wp-load.php');
- /** Atom Publishing Protocol Class */
--require_once(ABSPATH . WPINC . '/atomlib.php');
-+require_once 'atomlib.php';
- /** Admin Image API for metadata updating */
- require_once(ABSPATH . '/wp-admin/includes/image.php');
index 0021eadc3a46451fd183ee45522fd7519f3631dc..44b928de4e74947aaf66500b473e240d3decef53 100644 (file)
@@ -1,11 +1,11 @@
---- wordpress/wp-admin/setup-config.php~       2010-09-08 12:29:43.000000000 +0300
-+++ wordpress/wp-admin/setup-config.php        2010-09-08 15:01:48.112464938 +0300
-@@ -51,7 +51,7 @@
- $configFile = file(ABSPATH . 'wp-config-sample.php');
+--- wordpress-3.5.1/wp-admin/setup-config.php~ 2013-02-06 16:10:02.000000000 +0200
++++ wordpress-3.5.1/wp-admin/setup-config.php  2013-02-06 16:11:57.583090884 +0200
+@@ -68,7 +68,7 @@
+ $config_file = file(ABSPATH . 'wp-config-sample.php');
  
  // Check if wp-config.php has been created
--if (file_exists(ABSPATH . 'wp-config.php'))
-+if (file_exists(ABSPATH . 'wp-config.php') && filesize(ABSPATH . 'wp-config.php'))
-       wp_die("<p>The file 'wp-config.php' already exists. If you need to reset any of the configuration items in this file, please delete it first. You may try <a href='install.php'>installing now</a>.</p>");
+-if ( file_exists( ABSPATH . 'wp-config.php' ) )
++if ( file_exists( ABSPATH . 'wp-config.php' ) && filesize( ABSPATH . 'wp-config.php' ) )
+       wp_die( '<p>' . sprintf( __( "The file 'wp-config.php' already exists. If you need to reset any of the configuration items in this file, please delete it first. You may try <a href='%s'>installing now</a>." ), 'install.php' ) . '</p>' );
  
  // Check if wp-config.php exists above the root directory but is not part of another install
index ed364c0acff4de0f4f3371f0ca3a0c57de88f35a..e61151afe987030b1443fdf70864be1e90ae57ee 100644 (file)
  /* That's all, stop editing! Happy blogging. */
  
  /** Absolute path to the WordPress directory. */
---- wordpress-3.0.1/wp-includes/ms-default-constants.php~      2010-09-08 18:37:37.000000000 +0300
-+++ wordpress-3.0.1/wp-includes/ms-default-constants.php       2010-09-08 18:37:39.450725426 +0300
-@@ -18,14 +18,14 @@
-       /** @since 3.0.0 */
+--- wordpress-3.5.1/wp-includes/ms-default-constants.php~      2013-02-06 16:12:50.000000000 +0200
++++ wordpress-3.5.1/wp-includes/ms-default-constants.php       2013-02-06 16:14:43.844078357 +0200
+@@ -26,7 +26,7 @@
        // Base uploads dir relative to ABSPATH
        if ( !defined( 'UPLOADBLOGSDIR' ) )
 -              define( 'UPLOADBLOGSDIR', 'wp-content/blogs.dir' );
 +              define( 'UPLOADBLOGSDIR', '/var/lib/wordpress' );
  
-       /** @since 3.0.0 */
-       if ( !defined( 'UPLOADS' ) ) {
-               // Uploads dir relative to ABSPATH
+       // Note, the main site in a post-MU network uses wp-content/uploads.
+       // This is handled in wp_upload_dir() by ignoring UPLOADS for this case.
+@@ -34,8 +34,8 @@
                define( 'UPLOADS', UPLOADBLOGSDIR . "/{$wpdb->blogid}/files/" );
-               if ( 'wp-content/blogs.dir' == UPLOADBLOGSDIR )
+               // Uploads dir relative to ABSPATH
+-              if ( 'wp-content/blogs.dir' == UPLOADBLOGSDIR && ! defined( 'BLOGUPLOADDIR' ) )
 -                      define( 'BLOGUPLOADDIR', WP_CONTENT_DIR . "/blogs.dir/{$wpdb->blogid}/files/" );
++              if ( ('wp-content/blogs.dir' == UPLOADBLOGSDIR  || '/var/lib/wordpress' == UPLOADBLOGSDIR) && ! defined( 'BLOGUPLOADDIR' ) )
 +                      define( 'BLOGUPLOADDIR', "/var/lib/wordpress/{$wpdb->blogid}/files/" );
        }
  }
  
---- wordpress-3.0.1/wp-admin/includes/ms.php~  2010-09-08 18:39:08.000000000 +0300
-+++ wordpress-3.0.1/wp-admin/includes/ms.php   2010-09-08 18:40:25.993923701 +0300
-@@ -88,7 +88,7 @@
-                       $wpdb->query( "DROP TABLE IF EXISTS ". current( $drop_table ) ."" );
-               }
-               $wpdb->query( $wpdb->prepare( "DELETE FROM $wpdb->blogs WHERE blog_id = %d", $blog_id ) );
--              $dir = apply_filters( 'wpmu_delete_blog_upload_dir', WP_CONTENT_DIR . "/blogs.dir/{$blog_id}/files/", $blog_id );
-+              $dir = apply_filters( 'wpmu_delete_blog_upload_dir', UPLOADBLOGSDIR . "/{$blog_id}/files/", $blog_id );
-               $dir = rtrim( $dir, DIRECTORY_SEPARATOR );
-               $top_dir = $dir;
-               $stack = array($dir);
---- wordpress-3.0.1/wp-admin/network.php       2010-09-08 18:41:39.993826475 +0300
-+++ wordpress-3.0.1/wp-admin/network.php       2010-09-08 18:48:16.814203165 +0300
-@@ -96,7 +96,7 @@
-       '<p>' . __('This screen allows you to configure a network as having subdomains (<code>site1.example.com</code>) or subdirectories (<code>example.com/site1</code>). Subdomains require wildcard subdomains to be enabled in Apache and DNS records, if your host allows it.') . '</p>' .
-       '<p>' . __('Choose subdomains or subdirectories; this can only be switched afterwards by reconfiguring your install. Fill out the network details, and click install. If this does not work, you may have to add a wildcard DNS record (for subdomains) or change to another setting in Permalinks (for subdirectories).') . '</p>' .
-       '<p>' . __('The next screen for Network will give you individually-generated lines of code to add to your wp-config.php and .htaccess files. Make sure the settings of your FTP client make files starting with a dot visible, so that you can find .htaccess; you may have to create this file if it really is not there. Make backup copies of those two files.') . '</p>' .
--      '<p>' . __('Add a <code>blogs.dir</code> directory under <code>/wp-content</code> and add the designated lines of code to wp-config.php (just before <code>/*...stop editing...*/</code>) and <code>.htaccess</code> (replacing the existing WordPress rules).') . '</p>' .
-+      '<p>' . __('Add the designated lines of code to wp-config.php (just before <code>/*...stop editing...*/</code>) and <code>.htaccess</code> (replacing the existing WordPress rules).') . '</p>' .
-       '<p>' . __('Refreshing your browser will take you to a screen with an archive of those added lines of code. A set of six links under Super Admin will appear at the top of the main left navigation menu. The multisite network is now enabled.') . '</p>' .
-       '<p>' . __('The choice of subdirectory sites is disabled if this setup is more than a month old because of permalink problems with &#8220;/blog/&#8221; from the main site. This disabling will be addressed soon in a future version.') . '</p>' .
-       '<p><strong>' . __('For more information:') . '</strong></p>' .
-@@ -323,11 +323,12 @@
-       }
- ?>
-               <ol>
--                      <li><p><?php
--                              printf( __( 'Create a <code>blogs.dir</code> directory in <code>%s</code>. This directory is used to stored uploaded media for your additional sites and must be writeable by the web server.' ), WP_CONTENT_DIR );
-+                      <?php
-                               if ( WP_CONTENT_DIR != ABSPATH . 'wp-content' )
-+                                      echo '<li><p>';
-                                       echo ' <strong>' . __('Warning:') . ' ' . __( 'Networks may not be fully compatible with custom wp-content directories.' ) . '</strong';
--                      ?></p></li>
-+                                      echo '</p></li>';
-+                      ?>
-                       <li><p><?php printf( __( 'Add the following to your <code>wp-config.php</code> file in <code>%s</code> <strong>above</strong> the line reading <code>/* That&#8217;s all, stop editing! Happy blogging. */</code>:' ), ABSPATH ); ?></p>
-                               <textarea class="code" readonly="readonly" cols="100" rows="7">
- define( 'MULTISITE', true );
---- wordpress-3.0.1/wp-includes/ms-functions.php~      2010-09-08 18:39:08.000000000 +0300
-+++ wordpress-3.0.1/wp-includes/ms-functions.php       2010-09-08 18:43:02.557151530 +0300
-@@ -902,7 +902,7 @@
-       update_option('siteurl', $url);
-       update_option('home', $url);
-       update_option('fileupload_url', $url . "files" );
--      update_option('upload_path', "wp-content/blogs.dir/" . $blog_id . "/files");
-+      update_option('upload_path', UPLOADBLOGSDIR . "/" . $blog_id . "/files");
-       update_option('blogname', stripslashes( $blog_title ) );
-       update_option('admin_email', '');
-       $wpdb->update( $wpdb->options, array('option_value' => ''), array('option_name' => 'admin_email') );
index c496dc73c156de7330043d0c28331f7d2625c095..af2ebaaf1de0b99a5ac8f7e3a352097a843b2fbe 100644 (file)
@@ -1,12 +1,12 @@
---- wordpress/wp-includes/pluggable.php~       2010-09-09 16:45:23.000000000 +0300
-+++ wordpress/wp-includes/pluggable.php        2010-09-09 18:51:10.849503438 +0300
-@@ -279,8 +279,7 @@
+--- wordpress-3.5.1/wp-includes/pluggable.php~ 2013-02-06 16:24:28.000000000 +0200
++++ wordpress-3.5.1/wp-includes/pluggable.php  2013-02-06 16:24:59.242270976 +0200
+@@ -222,8 +222,7 @@
  
        // (Re)create it, if it's gone missing
        if ( !is_object( $phpmailer ) || !is_a( $phpmailer, 'PHPMailer' ) ) {
 -              require_once ABSPATH . WPINC . '/class-phpmailer.php';
 -              require_once ABSPATH . WPINC . '/class-smtp.php';
 +              require_once 'class.phpmailer.php';
-               $phpmailer = new PHPMailer();
+               $phpmailer = new PHPMailer( true );
        }
  
index 03ea540e833ad28e4a728a293e58b3d393c24bba..e009c1430c5815fe4485f6c1f595a8e0f7c79e5f 100644 (file)
@@ -1,11 +1,11 @@
---- wordpress-3.0.1/wp-includes/script-loader.php~     2010-09-09 16:21:19.000000000 +0300
-+++ wordpress-3.0.1/wp-includes/script-loader.php      2010-09-09 16:26:18.913290221 +0300
-@@ -176,7 +176,7 @@
+--- wordpress-3.5.1/wp-includes/script-loader.php~     2013-02-06 16:23:21.000000000 +0200
++++ wordpress-3.5.1/wp-includes/script-loader.php      2013-02-06 16:24:06.019821611 +0200
+@@ -192,7 +192,7 @@
  
-       $scripts->add( 'jcrop', "/wp-includes/js/jcrop/jquery.Jcrop$suffix.js", array('jquery'), '0.9.8');
+       $scripts->add( 'jcrop', "/wp-includes/js/jcrop/jquery.Jcrop.min.js", array('jquery'), '0.9.10');
  
--      $scripts->add( 'swfobject', "/wp-includes/js/swfobject.js", false, '2.2');
-+      $scripts->add( 'swfobject', "/js/swfobject.js", false, '2.2');
+-      $scripts->add( 'swfobject', "/wp-includes/js/swfobject.js", array(), '2.2-20120417');
++      $scripts->add( 'swfobject', "/js/swfobject.js", array(), '2.2-20120417');
  
-       $scripts->add( 'swfupload', '/wp-includes/js/swfupload/swfupload.js', false, '2201');
-       $scripts->add( 'swfupload-swfobject', '/wp-includes/js/swfupload/plugins/swfupload.swfobject.js', array('swfupload', 'swfobject'), '2201');
+       // common bits for both uploaders
+       $max_upload_size = ( (int) ( $max_up = @ini_get('upload_max_filesize') ) < (int) ( $max_post = @ini_get('post_max_size') ) ) ? $max_up : $max_post;
index 11e1ec24c44d556386a7341f2c3f2c652e8249f9..72208e2a6083e4942ca7b91b9ee185f957bf3a1b 100644 (file)
  
        /** The config file resides in ABSPATH */
        require_once( ABSPATH . 'wp-config.php' );
---- wordpress/wp-admin/setup-config.php.orig   2009-11-20 05:11:01.000000000 +0100
-+++ wordpress/wp-admin/setup-config.php        2010-01-23 19:09:28.000000000 +0100
-@@ -199,7 +199,7 @@
- <p class="step"><a href="install.php" class="button">Run the install</a></p>
+--- wordpress-3.5.1/wp-admin/setup-config.php~ 2013-02-06 16:21:34.000000000 +0200
++++ wordpress-3.5.1/wp-admin/setup-config.php  2013-02-06 16:22:14.098004158 +0200
+@@ -275,7 +275,7 @@
+ </script>
  <?php
        else :
 -              $handle = fopen(ABSPATH . 'wp-config.php', 'w');
 +              $handle = fopen(ABSPATH . '/etc/webapps/wordpress/wp-config.php', 'w');
-               foreach( $configFile as $line ) {
+               foreach( $config_file as $line ) {
                        fwrite($handle, $line);
                }
 --- wordpress-3.0.1/wp-config.php~     2010-09-08 12:02:37.000000000 +0300
index d76e93ef4091126b959fdab1f0dc79f58376b71f..f5df2fb0c6491bed19ba9d94fb3db45313130e36 100644 (file)
@@ -6,35 +6,37 @@
 Summary:       Personal publishing system
 Summary(pl.UTF-8):     Osobisty system publikacji
 Name:          wordpress
-Version:       3.0.4
-Release:       3
+Version:       3.5.1
+Release:       0.1
 License:       GPL v2
 Group:         Applications/Publishing
 Source0:       http://wordpress.org/%{name}-%{version}.tar.gz
-# Source0-md5: a455e0834eb2c8994c35acf3c13ddc11
+# Source0-md5: 409889c98b13cbdbb9fd121df859ae3e
 Source1:       wp-secure.sh
 Source2:       wp-setup.sh
 Source3:       wp-setup.txt
 Source4:       apache.conf
 Source5:       lighttpd.conf
-Source6:       http://svn.automattic.com/wordpress-i18n/et/tags/%{version}/messages/et.po
-# Source6-md5: faccf42481d5bf742b019c24a3c6251a
-Source7:       http://svn.automattic.com/wordpress-i18n/pl_PL/tags/%{version}/messages/pl_PL.po
-# Source7-md5: 8c9038410b596f9c705cc006dcdd5960
+# no 3.5.1 tag
+Source6:       http://svn.automattic.com/wordpress-i18n/et/tags/3.5/messages/et.po
+# Source6-md5: e6fbcf1940701ce6f1f91c0ad4ed5a99
+# no messages under 3.5 tag
+Source7:       http://svn.automattic.com/wordpress-i18n/pl_PL/tags/3.2.1/messages/pl_PL.po
+# Source7-md5: a0f5d65b7d4e5d53209edc595a19ff49
 Patch0:                configpath.patch
 Patch1:                multisite.patch
 Patch2:                %{name}.patch
 Patch3:                simplepie.patch
 Patch4:                pear-text-diff.patch
-Patch5:                atomlib.patch
 Patch6:                swfobject.patch
 Patch7:                phpmailer.patch
 URL:           http://www.wordpress.org/
 BuildRequires: gettext-devel
 BuildRequires: rpm-php-pearprov
 BuildRequires: rpmbuild(macros) >= 1.553
-Requires:      js-swfobject >= 2.1
+Requires:      js-swfobject >= 2.2
 Requires:      php(core) >= %{php_min_version}
+Requires:      php(date)
 Requires:      php(dom)
 Requires:      php(gettext)
 Requires:      php(hash)
@@ -46,8 +48,6 @@ Requires:     php(pcre)
 Requires:      php(spl)
 Requires:      php(tokenizer)
 Requires:      php(xml)
-Requires:      php-atomlib >= 0.4
-Requires:      php-date
 Requires:      php-pear-Text_Diff
 Requires:      php-phpmailer >= 2.0.4
 Requires:      php-simplepie >= 1.2
@@ -89,8 +89,8 @@ WordPress jest nowym oprogramowaniem, ale jego korzenie i rozwój
 sięgają 2001 roku.
 
 %package setup
-Summary:       Wordpress setup package
-Summary(pl.UTF-8):     Pakiet do wstępnej konfiguracji Wordpress
+Summary:       WordPress setup package
+Summary(pl.UTF-8):     Pakiet do wstępnej konfiguracji WordPress
 Group:         Applications/WWW
 Requires:      %{name} = %{version}-%{release}
 
@@ -105,7 +105,7 @@ po pierwszej instalacji. Potem należy go odinstalować, jako że
 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
 
 %package plugin-akismet
-Summary:       Wordpress Akismet Plugin
+Summary:       WordPress Akismet Plugin
 Group:         Applications/WWW
 Requires:      %{name} = %{version}-%{release}
 
@@ -114,23 +114,42 @@ Akismet checks your comments against the Akismet web service to see if
 they look like spam or not and lets you review the spam it catches
 under your blog's "Comments" admin screen.
 
-%package theme-twentyten
-Summary:       Wordpress MU default theme
+%package theme-twentyeleven
+Summary:       WordPress Twenty Eleven theme
 Group:         Applications/WWW
-URL:           http://wordpress.org/extend/themes/twentyten
+URL:           http://wordpress.org/extend/themes/twentyeleven
 Requires:      %{name} = %{version}-%{release}
 
-%description theme-twentyten
-The 2010 theme for WordPress is stylish, customizable, simple, and
-readable.
+%description theme-twentyeleven
+The 2011 theme for WordPress is sophisticated, lightweight, and
+adaptable.
+
+Make it yours with a custom menu, header image, and background -- then
+go further with available theme options for light or dark color
+scheme, custom link colors, and three layout choices. Twenty Eleven
+comes equipped with a Showcase page template that transforms your
+front page into a showcase to show off your best content, widget
+support galore (sidebar, three footer areas, and a Showcase page
+widget area), and a custom "Ephemera" widget to display your Aside,
+Link, Quote, or Status posts. Included are styles for print and for
+the admin editor, support for featured images (as custom header images
+on posts and pages and as large images on featured "sticky" posts),
+and special styles for six different post formats.
+
+%package theme-twentytwelve
+Summary:       WordPress Twenty Twelve theme
+Group:         Applications/WWW
+URL:           http://wordpress.org/extend/themes/twentytwelve
+Requires:      %{name} = %{version}-%{release}
+
+%description theme-twentytwelve
+The 2012 theme for WordPress is a fully responsive theme that looks
+great on any device.
 
-Make it yours with a custom menu, header image, and background. Twenty
-Ten supports six widgetized areas (two in the sidebar, four in the
-footer) and featured images (thumbnails for gallery posts and custom
-header images for posts and pages). It includes stylesheets for print
-and the admin Visual Editor, special styles for posts in the "Asides"
-and "Gallery" categories, and has an optional one-column page template
-that removes the sidebar.
+Features include a front page template with its own widgets, an
+optional display font, styling for post formats on both index and
+single views, and an optional no-sidebar page template. Make it yours
+with a custom menu, header image, and background.
 
 %prep
 %setup -qc
@@ -138,46 +157,54 @@ mv %{name}/* . && rmdir %{name}
 %undos -f php,js,html
 %patch0 -p1
 %patch1 -p1
-cp -a wp-config{-sample,}.php
+cp -p wp-config{-sample,}.php
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 %patch6 -p1
 %patch7 -p1
-cp -a %{SOURCE3} .
+cp -p %{SOURCE3} .
 
-rm license.txt
-rm wp-content/themes/index.php
-rm wp-content/plugins/index.php
-rm wp-content/index.php
+%{__rm} license.txt
+%{__rm} wp-content/themes/index.php
+%{__rm} wp-content/plugins/index.php
+%{__rm} wp-content/index.php
 
-# remove *.dev js/.css
-find -name *.dev.js | xargs rm -v
-find -name *.dev.css | xargs rm -v
+# remove .js/.css with matching minified file
+find -name '*.min.js' | while read min; do
+       js=${min%.min.js}.js
+       test -e $js && echo $js
+done | xargs rm -v
+
+find -name '*.min.css' | while read min; do
+       css=${min%.min.css}.css
+       test -e $css && echo $css
+done | xargs rm -v
 
 # sample plugin
-rm wp-content/plugins/hello.php
+%{__rm} wp-content/plugins/hello.php
 
 # system swfobject
-rm wp-includes/js/swfobject.js
+%{__rm} wp-includes/js/swfobject.js
 
 # system simplepie
-rm wp-includes/class-simplepie.php
+%{__rm} wp-includes/class-simplepie.php
 
 # system php-pear-Text_Diff
-rm -r wp-includes/Text/Diff*
+%{__rm} -r wp-includes/Text/Diff*
 rmdir wp-includes/Text
 
 # system atomlib
-rm wp-includes/atomlib.php
+%{__rm} wp-includes/atomlib.php
 
 # system phpmailer
-rm wp-includes/class-phpmailer.php
-rm wp-includes/class-smtp.php
+%{__rm} wp-includes/class-phpmailer.php
+%{__rm} wp-includes/class-smtp.php
 
 # php 5.2 + json ext satisfies this compat
-rm wp-includes/class-json.php
+%{__rm} wp-includes/class-json.php
+
+%{__rm} wp-content/plugins/akismet/.htaccess
 
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
@@ -200,9 +227,9 @@ install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/wp-setup
 ln -s %{_bindir}/wp-setup $RPM_BUILD_ROOT%{_appdir}/wp-setup.sh
 ln -s %{_bindir}/wp-secure $RPM_BUILD_ROOT%{_appdir}/wp-secure.sh
 
-cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
-cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -284,9 +311,15 @@ fi
 %defattr(644,root,root,755)
 %dir %{_appdir}/wp-content/plugins/akismet
 %doc %{_appdir}/wp-content/plugins/akismet/readme.txt
-%{_appdir}/wp-content/plugins/akismet/*.php
+%{_appdir}/wp-content/plugins/akismet/*.css
 %{_appdir}/wp-content/plugins/akismet/*.gif
+%{_appdir}/wp-content/plugins/akismet/*.js
+%{_appdir}/wp-content/plugins/akismet/*.php
+
+%files theme-twentyeleven
+%defattr(644,root,root,755)
+%{_appdir}/wp-content/themes/twentyeleven
 
-%files theme-twentyten
+%files theme-twentytwelve
 %defattr(644,root,root,755)
-%{_appdir}/wp-content/themes/twentyten
+%{_appdir}/wp-content/themes/twentytwelve
old mode 100644 (file)
new mode 100755 (executable)
old mode 100644 (file)
new mode 100755 (executable)
This page took 0.114512 seconds and 4 git commands to generate.