]> git.pld-linux.org Git - packages/wordpress.git/blob - wordpress.spec
- upgraded to 2.3.3 (sec fixes),
[packages/wordpress.git] / wordpress.spec
1 # TODO
2 # - put config files to %{_sysconfdir}!
3 # - switch to versioned url: ftp://ftp.openpkg.org/sources/CPY/VERSIONED/00README
4 Summary:        Personal publishing system
5 Summary(pl.UTF-8):      Osobisty system publikacji
6 Name:           wordpress
7 Version:        2.3.3
8 Release:        1
9 License:        GPL
10 Group:          Applications/Publishing
11 Source0:        http://wordpress.org/latest.tar.gz
12 # Source0-md5:  19518de1117aa68f0c3de84b6858efc3
13 Source1:        wp-secure.sh
14 Source2:        wp-setup.sh
15 Source3:        wp-setup.txt
16 Source4:        %{name}.conf
17 Source5:        %{name}-lighttpd.conf
18 Source6:        http://wordpress-polska.org/system/files/pl_PL_0.po
19 # Source6-md5:  0b1d193435065c98e12ac188232f190f
20 Source7:        http://wordpress-polska.org/system/files/pl_PL_0.mo
21 # Source7-md5:  4ec7fff754ce3cbdccfde7fc58d98af6
22 URL:            http://wordpress.org/
23 Requires:       php(gettext)
24 Requires:       php(mysql)
25 Requires:       php(pcre)
26 Requires:       php(xml)
27 Requires:       php(xmlrpc)
28 Requires:       webapps
29 Requires:       webserver(php) >= 5.0
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _appdir         %{_datadir}/%{name}
34 %define         _webapps        /etc/webapps
35 %define         _webapp         %{name}
36 %define         _sysconfdir     %{_webapps}/%{_webapp}
37
38 %description
39 WordPress is a state-of-the-art semantic personal publishing platform
40 with a focus on aesthetics, web standards, and usability. WordPress
41 was born out of a desire for an elegant, well-architectured personal
42 publishing system (also called blog or weblog) built on PHP and MySQL
43 and licensed under the GPL. It is the official successor of
44 b2/cafelog. WordPress is fresh software, but its roots and development
45 go back to 2001.
46
47 %description -l pl.UTF-8
48 WordPress jest technologicznie dopracowaną, semantyczną, osobistą
49 platformą do publikacji kładącą nacisk na standardy WWW oraz
50 użyteczność. WordPress został stworzony w wyniku potrzeby
51 eleganckiego, dobrze zaprojektowanego, osobistego systemu publikacji
52 (nazywanego również blogiem czy weblogiem). Jest to system oparty o
53 PHP i MySQL oraz na licencji GPL. Jest oficjalnym następcą b2/cafelog.
54 WordPress jest nowym oprogramowaniem, ale jego korzenie i rozwój
55 sięgają 2001 roku.
56
57 %prep
58 %setup -q -n %{name}
59 cp %{SOURCE1} %{SOURCE2} %{SOURCE3} .
60 rm -f license.txt
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_sysconfdir},%{_appdir}/wp-content/languages}
65
66 cp -R * $RPM_BUILD_ROOT%{_appdir}
67 rm -f $RPM_BUILD_ROOT%{_appdir}/readme.html
68 rm -f $RPM_BUILD_ROOT%{_appdir}/wp-setup.txt
69 ln -sf %{_appdir}/wp-setup.sh $RPM_BUILD_ROOT%{_bindir}/wp-setup
70 ln -sf %{_appdir}/wp-secure.sh $RPM_BUILD_ROOT%{_bindir}/wp-secure
71
72 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
73 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
74 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
75 install %{SOURCE6} $RPM_BUILD_ROOT%{_appdir}/wp-content/languages/pl_PL.po
76 install %{SOURCE7} $RPM_BUILD_ROOT%{_appdir}/wp-content/languages/pl_PL.mo
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post
82 if [ ! -f %{_appdir}/wp-config.php ]; then
83         install -oroot -ghttp -m640 %{_appdir}/wp-config-sample.php %{_appdir}/wp-config.php
84
85         %banner -e %{name} <<-EOF
86         To finish your configuration DO NOT FORGET to:
87
88         1) Create some MySQL database owned by some user
89         2) Edit the file: %{_appdir}/wp-config.php
90         3) Run a browser and visit: http://`hostname`/wordpress/wp-admin/install.php
91 EOF
92 fi
93
94 %triggerin -- apache1 < 1.3.37-3, apache1-base
95 %webapp_register apache %{_webapp}
96
97 %triggerin -- lighttpd
98 %webapp_register lighttpd %{_webapp}
99
100 %triggerun -- apache1 < 1.3.37-3, apache1-base
101 %webapp_unregister apache %{_webapp}
102
103 %triggerin -- apache < 2.2.0, apache-base
104 %webapp_register httpd %{_webapp}
105
106 %triggerun -- apache < 2.2.0, apache-base
107 %webapp_unregister httpd %{_webapp}
108
109 %triggerun -- lighttpd
110 %webapp_unregister lighttpd %{_webapp}
111
112 %files
113 %defattr(644,root,root,755)
114 %doc readme.html wp-setup.txt
115 %dir %attr(750,root,http) %{_sysconfdir}
116 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
117 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
118 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
119
120 %dir %{_appdir}
121 %dir %attr(750,root,http) %{_appdir}/wp-content
122 %dir %attr(750,root,http) %{_appdir}/wp-content/plugins
123 %dir %attr(750,root,http) %{_appdir}/wp-content/themes
124 %dir %attr(750,root,http) %{_appdir}/wp-content/themes/classic
125 %dir %attr(750,root,http) %{_appdir}/wp-content/themes/default
126 %dir %attr(750,root,http) %{_appdir}/wp-content/themes/default/images
127 %attr(640,root,http) %{_appdir}/wp-content/plugins/*.php
128 %attr(640,root,http) %{_appdir}/wp-content/plugins/akismet
129 %attr(640,root,http) %{_appdir}/wp-content/themes/classic/*
130 %attr(640,root,http) %{_appdir}/wp-content/themes/default/*.php
131 %attr(640,root,http) %{_appdir}/wp-content/themes/default/*.css
132 %attr(640,root,http) %{_appdir}/wp-content/themes/default/images/*
133 %{_appdir}/wp-content/index.php
134 %{_appdir}/wp-content/languages
135 %{_appdir}/wp-content/themes/default/screenshot.png
136 %{_appdir}/wp-admin
137 %{_appdir}/wp-includes
138 %{_appdir}/*.php
139 %{_appdir}/wp-secure.sh
140 %{_appdir}/wp-setup.sh
141 %attr(755,root,root) %{_bindir}/wp-secure
142 %attr(755,root,root) %{_bindir}/wp-setup
This page took 0.36739 seconds and 4 git commands to generate.