]> git.pld-linux.org Git - packages/wl.git/commitdiff
- fix building with kernel 6.1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 17 Dec 2022 18:28:51 +0000 (19:28 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 17 Dec 2022 18:28:51 +0000 (19:28 +0100)
kernel-6.1.patch [new file with mode: 0644]
wl.spec

diff --git a/kernel-6.1.patch b/kernel-6.1.patch
new file mode 100644 (file)
index 0000000..d1bd482
--- /dev/null
@@ -0,0 +1,104 @@
+--- wl-6.30.223.271/wl/src/wl/sys/wl_cfg80211_hybrid.c~        2022-12-17 19:19:31.000000000 +0100
++++ wl-6.30.223.271/wl/src/wl/sys/wl_cfg80211_hybrid.c 2022-12-17 19:25:07.419529697 +0100
+@@ -112,13 +112,27 @@
+ #endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 38)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 1, 0)
++static s32 wl_cfg80211_config_default_key(struct wiphy *wiphy,
++           struct net_device *dev, int link_id, u8 key_idx, bool unicast, bool multicast);
++#else
+ static s32 wl_cfg80211_config_default_key(struct wiphy *wiphy,
+            struct net_device *dev, u8 key_idx, bool unicast, bool multicast);
++#endif
+ #else
+ static s32 wl_cfg80211_config_default_key(struct wiphy *wiphy,
+            struct net_device *dev, u8 key_idx);
+ #endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 37)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 1, 0)
++static s32 wl_cfg80211_add_key(struct wiphy *wiphy, struct net_device *dev, int link_id,
++           u8 key_idx, bool pairwise, const u8 *mac_addr, struct key_params *params);
++static s32 wl_cfg80211_del_key(struct wiphy *wiphy, struct net_device *dev, int link_id,
++           u8 key_idx, bool pairwise, const u8 *mac_addr);
++static s32 wl_cfg80211_get_key(struct wiphy *wiphy, struct net_device *dev, int link_id,
++           u8 key_idx, bool pairwise, const u8 *mac_addr,
++           void *cookie, void (*callback) (void *cookie, struct key_params *params));
++#else
+ static s32 wl_cfg80211_add_key(struct wiphy *wiphy, struct net_device *dev,
+            u8 key_idx, bool pairwise, const u8 *mac_addr, struct key_params *params);
+ static s32 wl_cfg80211_del_key(struct wiphy *wiphy, struct net_device *dev,
+@@ -126,6 +140,7 @@
+ static s32 wl_cfg80211_get_key(struct wiphy *wiphy, struct net_device *dev,
+            u8 key_idx, bool pairwise, const u8 *mac_addr,
+            void *cookie, void (*callback) (void *cookie, struct key_params *params));
++#endif
+ #else
+ static s32 wl_cfg80211_add_key(struct wiphy *wiphy, struct net_device *dev,
+            u8 key_idx, const u8 *mac_addr, struct key_params *params);
+@@ -1185,9 +1185,15 @@
+ }
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 38)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 1, 0)
++static s32
++wl_cfg80211_config_default_key(struct wiphy *wiphy,
++      struct net_device *dev, int link_id, u8 key_idx, bool unicast, bool multicast)
++#else
+ static s32
+ wl_cfg80211_config_default_key(struct wiphy *wiphy,
+       struct net_device *dev, u8 key_idx, bool unicast, bool multicast)
++#endif
+ #else
+ static s32
+ wl_cfg80211_config_default_key(struct wiphy *wiphy,
+@@ -1210,9 +1216,15 @@
+ }
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 37)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 1, 0)
++static s32
++wl_cfg80211_add_key(struct wiphy *wiphy, struct net_device *dev, int link_id,
++                    u8 key_idx, bool pairwise, const u8 *mac_addr, struct key_params *params)
++#else
+ static s32
+ wl_cfg80211_add_key(struct wiphy *wiphy, struct net_device *dev,
+                     u8 key_idx, bool pairwise, const u8 *mac_addr, struct key_params *params)
++#endif
+ #else
+ static s32
+ wl_cfg80211_add_key(struct wiphy *wiphy, struct net_device *dev,
+@@ -1331,9 +1343,15 @@
+ }
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 37)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 1, 0)
++static s32
++wl_cfg80211_del_key(struct wiphy *wiphy, struct net_device *dev, int link_id,
++                    u8 key_idx, bool pairwise, const u8 *mac_addr)
++#else
+ static s32
+ wl_cfg80211_del_key(struct wiphy *wiphy, struct net_device *dev,
+                     u8 key_idx, bool pairwise, const u8 *mac_addr)
++#endif
+ #else
+ static s32
+ wl_cfg80211_del_key(struct wiphy *wiphy, struct net_device *dev,
+@@ -1374,10 +1392,17 @@
+ }
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 37)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 1, 0)
++static s32
++wl_cfg80211_get_key(struct wiphy *wiphy, struct net_device *dev, int link_id,
++                    u8 key_idx, bool pairwise, const u8 *mac_addr, void *cookie,
++                    void (*callback) (void *cookie, struct key_params * params))
++#else
+ static s32
+ wl_cfg80211_get_key(struct wiphy *wiphy, struct net_device *dev,
+                     u8 key_idx, bool pairwise, const u8 *mac_addr, void *cookie,
+                     void (*callback) (void *cookie, struct key_params * params))
++#endif
+ #else
+ static s32
+ wl_cfg80211_get_key(struct wiphy *wiphy, struct net_device *dev,
diff --git a/wl.spec b/wl.spec
index 3feac88c4732e6d29a270fc50219ce8808155011..0cc6fa2c1e1fba520567cc9eff9c87869e86b6f8 100644 (file)
--- a/wl.spec
+++ b/wl.spec
@@ -50,6 +50,7 @@ Patch11:      kernel-5.10.patch
 Patch12:       kernel-5.17.patch
 Patch13:       kernel-5.18.patch
 Patch14:       kernel-6.0.patch
+Patch15:       kernel-6.1.patch
 URL:           http://www.broadcom.com/support/802.11
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -143,6 +144,7 @@ EOF\
 %patch12 -p2
 %patch13 -p2
 %patch14 -p2
+%patch15 -p2
 
 mkdir wl
 mv lib src Makefile wl/
This page took 0.102002 seconds and 4 git commands to generate.