]> git.pld-linux.org Git - packages/wireshark.git/commitdiff
- updated to 1.2.0
authorAdam Gołębiowski <adamg@pld-linux.org>
Tue, 23 Jun 2009 20:50:18 +0000 (20:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    wireshark-0.99.5-hip-base05.patch -> 1.5
    wireshark-as_needed.patch -> 1.6
    wireshark.spec -> 1.208

wireshark-0.99.5-hip-base05.patch
wireshark-as_needed.patch
wireshark.spec

index 3b1a9195be592c6e90f5b68550ea131eab7ba689..74ed01bc52bc3ad0330fd73c7ea75ebf60200771 100644 (file)
@@ -1264,7 +1264,7 @@ diff -urN wireshark-0.99.7.orig/epan/dissectors/register.c wireshark-0.99.7/epan
    {extern void proto_reg_handoff_dcerpc_frsrpc (void); if(cb) (*cb)(RA_HANDOFF, "proto_reg_handoff_dcerpc_frsrpc", client_data); proto_reg_handoff_dcerpc_frsrpc ();}
    {extern void proto_reg_handoff_dcerpc_initshutdown (void); if(cb) (*cb)(RA_HANDOFF, "proto_reg_handoff_dcerpc_initshutdown", client_data); proto_reg_handoff_dcerpc_initshutdown ();}
 +  {extern void proto_reg_handoff_hip (void); proto_reg_handoff_hip ();}
-   {extern void proto_reg_handoff_dcerpc_lsa (void); if(cb) (*cb)(RA_HANDOFF, "proto_reg_handoff_dcerpc_lsa", client_data); proto_reg_handoff_dcerpc_lsa ();}
+   {extern void proto_reg_handoff_dcerpc_lsarpc (void); if(cb) (*cb)(RA_HANDOFF, "proto_reg_handoff_dcerpc_lsarpc", client_data); proto_reg_handoff_dcerpc_lsarpc ();}
    {extern void proto_reg_handoff_dcerpc_mapi (void); if(cb) (*cb)(RA_HANDOFF, "proto_reg_handoff_dcerpc_mapi", client_data); proto_reg_handoff_dcerpc_mapi ();}
    {extern void proto_reg_handoff_dcerpc_messenger (void); if(cb) (*cb)(RA_HANDOFF, "proto_reg_handoff_dcerpc_messenger", client_data); proto_reg_handoff_dcerpc_messenger ();}
 diff -urN wireshark-0.99.7.orig/epan/ipproto.h wireshark-0.99.7/epan/ipproto.h
@@ -1284,11 +1284,11 @@ diff -urN wireshark-0.99.7.orig/epan/prefs.c wireshark-0.99.7/epan/prefs.c
 @@ -2172,6 +2172,10 @@
          /* Handle old names for UDP preferences. */
          if (strcmp(dotp, "udp_summary_in_tree") == 0)
-           pref = find_preference(module, "summary_in_tree");
+           pref = prefs_find_preference(module, "summary_in_tree");
 +      } else if (strcmp(module->name, "hip") == 0) {
 +        /* Handle old names for HIP preferences. */
 +        if (strcmp(dotp, "hip_summary_in_tree") == 0)
-+          pref = find_preference(module, "summary_in_tree");
++          pref = prefs_find_preference(module, "summary_in_tree");
        } else if (strcmp(module->name, "ndps") == 0) {
          /* Handle old names for NDPS preferences. */
          if (strcmp(dotp, "desegment_ndps") == 0)
index d3caae90c1757b975110f54e0694d316107a9a52..7ac4699fdb05a4eb26789d74dae228d1e2e810c5 100644 (file)
@@ -1,34 +1,23 @@
---- wireshark-1.0.0/epan/Makefile.am.orig      2008-04-01 05:57:15.796355855 +0200
-+++ wireshark-1.0.0/epan/Makefile.am   2008-04-01 05:59:06.288761964 +0200
-@@ -129,15 +129,17 @@
-       libwireshark_asmopt.la crypt/libairpdcap.la ftypes/libftypes.la \
-       dfilter/libdfilter.la dissectors/libcleandissectors.la \
-       dissectors/libdissectors.la dissectors/libasndissectors.la \
--      dissectors/libpidldissectors.la $(wslua_lib) @SOCKET_LIBS@ @NSL_LIBS@ \
-+      dissectors/libpidldissectors.la ${top_builddir}/wiretap/libwiretap.la \
+--- wireshark-1.2.0/epan/Makefile.am~  2009-06-16 06:03:39.000000000 +0200
++++ wireshark-1.2.0/epan/Makefile.am   2009-06-23 01:19:15.746887934 +0200
+@@ -127,16 +127,17 @@
+       @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ libwireshark_generated.la \
+       libwireshark_asmopt.la crc/libcrc.la crypt/libairpdcap.la \
+       ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
+-      dissectors/libdirtydissectors.la $(wslua_lib) @SOCKET_LIBS@ @NSL_LIBS@ \
++      dissectors/libdirtydissectors.la ${top_builddir}/wiretap/libwiretap.la \
 +      $(wslua_lib) @SOCKET_LIBS@ @NSL_LIBS@ \
-       @ADNS_LIBS@ @LIBGCRYPT_LIBS@ @LIBGNUTLS_LIBS@ @LIBICONV@ @KRB5_LIBS@ \
--      @SSL_LIBS@ @LIBSMI_LDFLAGS@ -lm
-+      @SSL_LIBS@ @LIBSMI_LDFLAGS@ -lm -lgmodule-2.0
- libwireshark_la_DEPENDENCIES = @G_ASCII_STRCASECMP_LO@ @G_ASCII_STRTOULL_LO@ \
-       @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ libwireshark_generated.la \
-       libwireshark_asmopt.la crypt/libairpdcap.la ftypes/libftypes.la \
-       dfilter/libdfilter.la dissectors/libcleandissectors.la \
-       dissectors/libdissectors.la dissectors/libasndissectors.la \
--      dissectors/libpidldissectors.la $(wslua_lib)
-+      dissectors/libpidldissectors.la ${top_builddir}/wiretap/libwiretap.la \
-+      $(wslua_lib)
+       @C_ARES_LIBS@ @ADNS_LIBS@ @LIBGCRYPT_LIBS@ @LIBGNUTLS_LIBS@ \
+       @KRB5_LIBS@ @SSL_LIBS@ @LIBSMI_LDFLAGS@ @GEOIP_LIBS@ \
+-      ${top_builddir}/wsutil/libwsutil.la -lm
++      ${top_builddir}/wsutil/libwsutil.la -lm -lgmodule-2.0
  
- #EXTRA_PROGRAMS = reassemble_test
- #reassemble_test_LDADD = $(GLIB_LIBS)
---- wireshark-1.0.0/wiretap/Makefile.am.orig   2008-04-01 05:56:08.300994660 +0200
-+++ wireshark-1.0.0/wiretap/Makefile.am        2008-04-01 05:56:47.298314463 +0200
-@@ -67,7 +67,7 @@
-       $(GENERATOR_FILES)      \
-       $(GENERATED_FILES)
--libwiretap_la_LIBADD = libwiretap_generated.la
-+libwiretap_la_LIBADD = libwiretap_generated.la -lglib-2.0
- libwiretap_la_DEPENDENCIES = libwiretap_generated.la
+ libwireshark_la_DEPENDENCIES = \
+       @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ libwireshark_generated.la \
+       libwireshark_asmopt.la crc/libcrc.la crypt/libairpdcap.la \
+       ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
+-      dissectors/libdirtydissectors.la $(wslua_lib) \
++      dissectors/libdirtydissectors.la $(wslua_lib) ${top_builddir}/wiretap/libwiretap.la \
+       ${top_builddir}/wsutil/libwsutil.la
  
- RUNLEX = $(top_srcdir)/tools/runlex.sh
+ #EXTRA_PROGRAMS = reassemble_test
index e49f5edfbc56ae3bead85ba2b8f96679fb7b67dd..ba9982e5cfe0ebd8d4c321dd792aab148ac106c9 100644 (file)
@@ -11,17 +11,19 @@ Summary(pt_BR.UTF-8):       Analisador de tráfego de rede
 Summary(ru.UTF-8):     Анализатор сетевого траффика
 Summary(uk.UTF-8):     Аналізатор мережевого трафіку
 Name:          wireshark
-Version:       1.0.8
+Version:       1.2.0
 Release:       1
 License:       GPL
 Group:         Networking
 Source0:       http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
-# Source0-md5: 09d895f111ee768cc0d7c7e2c427c496
+# Source0-md5: d3f799e0ae7953cd3426d9e0b6e2708d
 Source1:       %{name}.desktop
 Source2:       %{name}.su-start-script
 Patch0:                %{name}-0.99.5-hip-base05.patch
 Patch1:                %{name}-as_needed.patch
 Patch2:                %{name}-Werror.patch
+Patch3:                %{name}-gcc43.patch
+Patch4:                %{name}-ac.patch
 URL:           http://www.wireshark.org/
 # http://milw0rm.com/exploits/8308:
 #BuildRequires:        security(milw0rm.com/exploits/8308)
@@ -218,6 +220,8 @@ pakietów.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
 perl -pi -e 's/lua5\.1/lua51/g' acinclude.m4
 find -name Makefile.am | xargs perl -pi -e 's/-Werror//g'
 
@@ -285,7 +289,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files common
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog FAQ NEWS README{,.[lv]*} doc/{randpkt.txt,README.*}
+%doc AUTHORS* ChangeLog NEWS README{,.[lv]*} doc/{randpkt.txt,README.*}
 %attr(755,root,root) %{_bindir}/capinfos
 %attr(755,root,root) %{_bindir}/dftest
 %attr(755,root,root) %{_bindir}/dumpcap
@@ -297,6 +301,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/text2pcap
 %attr(755,root,root) %{_libdir}/libwireshark.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libwireshark.so.0
+%attr(755,root,root) %{_libdir}/libwsutil.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libwsutil.so.0
 %{_mandir}/man1/capinfos.1*
 %{_mandir}/man1/dumpcap.1*
 %{_mandir}/man1/editcap.1*
This page took 0.246442 seconds and 4 git commands to generate.