]> git.pld-linux.org Git - packages/winswitch.git/blob - winswitch.spec
gst and avahi optional
[packages/winswitch.git] / winswitch.spec
1 # TODO
2 # - minimize deps, use more suggests
3 Summary:        Front end for controlling remote desktop sessions
4 Name:           winswitch
5 Version:        0.12.20
6 Release:        2
7 License:        GPL v3
8 Group:          Networking
9 #Source0:       http://winswitch.org/src/%{name}-%{version}.tar.gz
10 Source0:        %{name}-%{version}.tar.gz
11 # Source0-md5:  b2814b2fd6274408ff9820d8fb519a85
12 URL:            http://winswitch.org/
13 BuildRequires:  python
14 BuildRequires:  python-distribute
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.672
17 BuildRequires:  sed >= 4.0
18
19 Suggests:       avahi
20 Suggests:       avahi-ui
21
22 Suggests:       gstreamer
23
24 #Requires:      gnome-python2-rsvg
25 #Requires:      nautilus-python
26 Requires:       python-utmp
27
28 Requires:       python-Crypto
29 Requires:       python-PIL
30 Requires:       python-TwistedConch
31 Requires:       python-TwistedCore
32 #Requires:      python-ctypes
33 #Requires:      python-hashlib
34 Requires:       python-pygtk-gtk
35 #Requires:      python-uuid
36 #Requires:      python-xlib
37
38 Requires:       python
39
40 Requires:       python-pyasn1
41
42 #Requires:      xorg-x11-server-utils
43
44 Requires:       openssh-clients
45 #Requires:      tigervnc-server >= 1.0.90
46 Requires:       xpra >= 0.7
47 Suggests:       nx
48 Suggests:       rdesktop
49
50 Suggests:       ImageMagick
51 Suggests:       dbus-x11
52 #Suggests:      devilspie
53 Suggests:       gnome-menus
54 #Suggests:      gnome-python2
55 Suggests:       tigervnc
56 Suggests:       xfreerdp
57 #Suggests:      xloadimage
58
59 Obsoletes:      shifter
60 BuildArch:      noarch
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _libexecdir     %{_prefix}/lib
64
65 %define         _noautoreq_java ClassDataVersion
66
67 %description
68 Start and control remote GUI sessions via xpra, NX, VNC, RDP or plain
69 ssh X11 forwarding. You can start, suspend, resume and send supported
70 sessions to other clients.
71
72 %prep
73 %setup -q
74
75 # TODO: bashism:
76 # skel/libexec/winswitch/firewall
77 # skel/libexec/winswitch/kill_parent
78
79 grep -rl '/usr/bin/env python' winswitch skel | xargs %{__sed} -i -e '1s,^#!.*python,#!%{__python},'
80
81 %build
82 %{__python} setup.py build
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 %{__python} setup.py install \
87         --skip-build \
88         --optimize=2 \
89         --root=$RPM_BUILD_ROOT
90
91 %py_postclean
92
93 # nautilus 2.x (no gnome 2 in pld)
94 rm $RPM_BUILD_ROOT%{_libexecdir}/nautilus/extensions-2.0/python/nautilus_winswitch.py
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %doc COPYING
102 %dir %{_sysconfdir}/winswitch
103 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/winswitch/firewall
104 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/winswitch/ports.conf
105 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/winswitch/server_defaults.conf
106 %attr(755,root,root) %{_bindir}/wcw
107 %attr(755,root,root) %{_bindir}/winswitch_applet
108 %attr(755,root,root) %{_bindir}/winswitch_away
109 %attr(755,root,root) %{_bindir}/winswitch_back
110 %attr(755,root,root) %{_bindir}/winswitch_client
111 %attr(755,root,root) %{_bindir}/winswitch_command_wrapper
112 %attr(755,root,root) %{_bindir}/winswitch_open_remotely
113 %attr(755,root,root) %{_bindir}/winswitch_server
114 %attr(755,root,root) %{_bindir}/winswitch_ssh_Xnest
115 %attr(755,root,root) %{_bindir}/winswitch_ssh_session
116 %attr(755,root,root) %{_bindir}/winswitch_stdio_socket
117 %attr(755,root,root) %{_bindir}/winswitch_stdio_tcp
118 %{_mandir}/man1/wcw.1*
119 %{_mandir}/man1/winswitch_*.1*
120 %{_desktopdir}/winswitch.desktop
121 %{_iconsdir}/hicolor/*/apps/winswitch*.png
122 %{_iconsdir}/winswitch_applet.png
123 %{_datadir}/mime/packages/winswitch.xml
124
125 %{_datadir}/winswitch
126 %{py_sitescriptdir}/winswitch
127 %{py_sitescriptdir}/winswitch-%{version}-py*.egg-info
128
129 %dir %{_libexecdir}/winswitch
130 %dir %{_libexecdir}/winswitch/bin-override
131 %attr(755,root,root) %{_libexecdir}/winswitch/bin-override/xdg-open
132 %attr(755,root,root) %{_libexecdir}/winswitch/delayed_start
133 %attr(755,root,root) %{_libexecdir}/winswitch/firewall
134 %attr(755,root,root) %{_libexecdir}/winswitch/gst_capture
135 %attr(755,root,root) %{_libexecdir}/winswitch/gst_playback
136 %attr(755,root,root) %{_libexecdir}/winswitch/kill_parent
137 %attr(755,root,root) %{_libexecdir}/winswitch/mime_open
138 %attr(755,root,root) %{_libexecdir}/winswitch/server_monitor
139 %attr(755,root,root) %{_libexecdir}/winswitch/server_portinfo
140 %attr(755,root,root) %{_libexecdir}/winswitch/virt_server_daemonizer
141
142 # thunar
143 %{_datadir}/Thunar/sendto/thunar-winswitch.desktop
144
145 # Vash - https://github.com/thevash/vash
146 # .jar to make screenshots
147 # TODO: package as java-vash and suggest it
148 %{_datadir}/Vash
This page took 0.128126 seconds and 4 git commands to generate.