]> git.pld-linux.org Git - packages/wine.git/commitdiff
Merge commit 'a26a38' from DEVEL branch
authorJacek Konieczny <jajcus@jajcus.net>
Sat, 9 Jan 2016 16:23:42 +0000 (17:23 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Sat, 9 Jan 2016 16:23:42 +0000 (17:23 +0100)
(skipping the compholio patches on DEVEL)

1  2 
wine.spec

diff --cc wine.spec
index 2d28a0a83a043fd4aa4e179aefb287af2ee9e585,94b4f84e68da4230df7309855db358cf44453119..b079ea5ffc6663b42ed3542206f9b2e76bff61f4
+++ b/wine.spec
@@@ -1,32 -1,22 +1,33 @@@
  #
  # Conditional build:
- %bcond_without        alsa            # ALSA mm driver
- %bcond_without        capi            # CAPI 2.0 (ISDN) support
- %bcond_without        gstreamer       # GStreamer filters support
- %bcond_without        sane            # TWAIN DLL with scanning support (through SANE)
+ %bcond_without        alsa            # don't build ALSA mm driver
+ %bcond_without        capi            # don't build CAPI 2.0 (ISDN) support
+ %bcond_without        gstreamer       # don't build GStreamer filters support
+ %bcond_without        sane            # don't build TWAIN DLL with scanning support (through SANE)
 +%bcond_with   hal             # HAL dynamic device support [deprecated]
- %bcond_without        ldap            # LDAP DLL
- %bcond_without        cups            # CUPS printing support in winspool,wineps DLLs
+ %bcond_without        ldap            # don't build LDAP DLL
+ %bcond_without        cups            # without CUPS printing support in winspool,wineps DLLs
+ %bcond_without        netapi          # don't use the Samba NetAPI library
  #
  # NOTE: wine detects the following SONAMES for dlopen at build time:
 -#   libcrypto,libssl (wininet.dll)
 -#   libcups (winspool.dll.so,wineps.dll.so)
 -#   libcurses/libncurses (wineconsole program)
 +#   libGL (winex11.drv.so)
 +#   libOSMesa (gdi32.dll.so)
 +#   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
 +#   libcapi20 (capi2032.dll.so)
 +#   libcups (winspool.drv.so)
 +#   libdbus (mountmgr.sys.so)
  #   libfontconfig (gdi32.dll.so)
 -#   libfreetype (wineps.dll.so,gdi32.dll.so)
 -#   libGL (x11drv.dll.so,ddraw.dll.so)
 -#   libX11, libXext, libXi, libXrender (x11drv.dll.so)
 -#   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
 +#   libfreetype (gdi32.dll.so)
 +#   libgnutls (secur32.dll.so)
 +#   libhal (mountmgr.sys.so)
 +#   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
 +#   libncurses (kernel32.dll.so)
 +#   libodbc (odbc32.dll.so)
 +#   libpng (windowscodecs.dll.so)
 +#   libsane (sane.ds.so)
 +#   libtiff (windowscodecs.dll.so)
 +#   libv4l1 (qcap.dll.so)
 +#   libxslt (msxml3.dll.so)
  # thus requires rebuild after change of any of the above.
  
  # library qualifier in rpm generated deps
@@@ -61,18 -51,16 +62,18 @@@ Patch1:            %{name}-makedep.patc
  Patch2:               %{name}-ncurses.patch
  Patch4:               %{name}-disable-valgrind.patch
  Patch5:               %{name}-ca_certificates.patch
- Patch6:               %{name}-manpaths.patch
- Patch7:               desktop.patch
- Patch8:               %{name}-wine64_man.patch
+ Patch6:               desktop.patch
+ Patch7:               %{name}-wine64_man.patch
  URL:          http://www.winehq.org/
 +BuildRequires:        Mesa-libOSMesa-devel
  BuildRequires:        OpenAL-devel >= 1.1
 -BuildRequires:        ocl-icd-libOpenCL-devel
 +BuildRequires:        OpenCL-devel
  BuildRequires:        OpenGL-GLU-devel
 +BuildRequires:        OpenGL-GLX-devel
+ BuildRequires:        Mesa-libOSMesa-devel
  %{?with_alsa:BuildRequires:   alsa-lib-devel}
  %{?with_arts:BuildRequires:   artsc-devel}
 -BuildRequires:        autoconf
 +BuildRequires:        autoconf >= 2.62
  BuildRequires:        automake
  BuildRequires:        bison
  %{?with_capi:BuildRequires:   capi4k-utils-devel}
@@@ -113,8 -91,11 +114,9 @@@ BuildRequires:     ncurses-deve
  BuildRequires:        openjade >= 1:1.3.3-0.pre1
  %{?with_ldap:BuildRequires:   openldap-devel}
  BuildRequires:        opensp >= 1:1.5.1
 -BuildRequires:        openssl-devel >= 0.9.7d
  BuildRequires:        pkgconfig
  BuildRequires:        prelink
+ BuildRequires:        samba-devel
  %{?with_sane:BuildRequires:   sane-backends-devel}
  BuildRequires:        unixODBC-devel >= 2.2.12-2
  #BuildRequires:       valgrind
@@@ -310,24 -287,30 +311,30 @@@ mv -f oic_winlogo_*.png %{name}.pn
  %ifarch %{x8664}
        --enable-win64 \
  %endif
 -      --with%{!?with_alsa:out}-alsa \
 -      --with%{!?with_capi:out}-capi \
 +      --with-alsa%{!?with_alsa:=no} \
 +      --with-capi%{!?with_capi:=no} \
        --with-cms \
        --with-coreaudio \
 -      --with%{!?with_cups:out}-cups \
 +      --with-cups%{!?with_cups:=no} \
        --with-curses \
+       --with-dbus \
        --with-fontconfig \
        --with-freetype \
+       --with-gphoto \
        --with-glu \
        --with-gnutls \
-       --with-gphoto \
        --with-gsm \
-       --with-gstreamer%{!?with_gstreamer:=no} \
-       --with-hal%{!?with_hal:=no} \
 -      --with%{!?with_gstreamer:out}-gstreamer \
 -      --without-hal \
++      %{__with_without gstreamer} \
++      %{__with_without hal} \
        --with-jpeg \
 -      --with%{!?with_ldap:out}-ldap \
 +      --with-ldap%{!?with_ldap:=no} \
        --with-mpg123 \
+       --with%{!?with_netapi:out}-netapi \
+       --with-openal \
+       --with-opencl \
        --with-opengl \
+       --with-openssl \
+       --with-osmesa \
        --with-oss \
        --with-png \
        --with-pthread \
This page took 0.14972 seconds and 4 git commands to generate.