]> git.pld-linux.org Git - packages/wimlib.git/blob - wimlib.spec
rebuild with openssl 3.0.0
[packages/wimlib.git] / wimlib.spec
1 # Conditional build:
2 %bcond_without  ntfs_3g         # build without ntfs-3g (avoid GPLv2 dependency)
3
4 Summary:        Open source Windows Imaging (WIM) library
5 Name:           wimlib
6 Version:        1.13.4
7 Release:        2
8 License:        GPL v3+ or LGPL v3+
9 Group:          Libraries
10 Source0:        https://wimlib.net/downloads/%{name}-%{version}.tar.gz
11 # Source0-md5:  3e73d06fd78d6541ba98478ac9cc295e
12 URL:            https://wimlib.net/
13 BuildRequires:  libfuse-devel
14 BuildRequires:  libxml2-devel
15 %{?with_ntfs_3g:BuildRequires:  ntfs-3g-devel >= 1:2011.4.12}
16 BuildRequires:  openssl-devel
17 BuildRequires:  pkgconfig
18 Requires:       libfuse-tools
19 %{?with_ntfs_3g:Requires:       ntfs-3g-libs >= 1:2011.4.12}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 wimlib is an open source, cross-platform library for creating,
24 extracting, and modifying Windows Imaging (WIM) archives. WIM is a
25 file archiving format, somewhat comparable to ZIP (and many other file
26 archiving formats); but unlike ZIP, it allows storing various
27 Windows-specific metadata, allows storing multiple "images" in a
28 single archive, automatically deduplicates all file contents, and
29 supports optional solid compression to get a better compression ratio.
30 wimlib and its command-line frontend wimlib-imagex provide a free and
31 cross-platform alternative to Microsoft's WIMGAPI, ImageX, and DISM.
32
33 %package devel
34 Summary:        Development files for wimlib
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Development files for wimlib.
40
41 %package static
42 Summary:        Static wimlib library
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static wimlib library.
48
49 %package tools
50 Summary:        Tools for creating, modifying, extracting, and mounting WIM files
51 Group:          Applications/System
52 Requires:       %{name} = %{version}-%{release}
53 Suggests:       mkisofs
54
55 %description tools
56 Tools for creating, modifying, extracting, and mounting WIM files.
57
58 %prep
59 %setup -q
60
61 %{__sed} -i -e '1s,/usr/bin/env bash,%{__bash},' programs/mkwinpeimg.in
62
63 %build
64 %configure \
65         --disable-silent-rules \
66         %{!?with_ntfs_3g:--without-ntfs-3g}
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwim.la
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc COPYING NEWS README
86 %attr(755,root,root) %{_libdir}/libwim.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libwim.so.15
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libwim.so
92 %{_includedir}/wimlib.h
93 %{_pkgconfigdir}/wimlib.pc
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libwim.a
98
99 %files tools
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_bindir}/mkwinpeimg
102 %attr(755,root,root) %{_bindir}/wimappend
103 %attr(755,root,root) %{_bindir}/wimapply
104 %attr(755,root,root) %{_bindir}/wimcapture
105 %attr(755,root,root) %{_bindir}/wimdelete
106 %attr(755,root,root) %{_bindir}/wimdir
107 %attr(755,root,root) %{_bindir}/wimexport
108 %attr(755,root,root) %{_bindir}/wimextract
109 %attr(755,root,root) %{_bindir}/wiminfo
110 %attr(755,root,root) %{_bindir}/wimjoin
111 %attr(755,root,root) %{_bindir}/wimlib-imagex
112 %attr(755,root,root) %{_bindir}/wimmount
113 %attr(755,root,root) %{_bindir}/wimmountrw
114 %attr(755,root,root) %{_bindir}/wimoptimize
115 %attr(755,root,root) %{_bindir}/wimsplit
116 %attr(755,root,root) %{_bindir}/wimunmount
117 %attr(755,root,root) %{_bindir}/wimupdate
118 %attr(755,root,root) %{_bindir}/wimverify
119 %{_mandir}/man1/mkwinpeimg.1*
120 %{_mandir}/man1/wimappend.1*
121 %{_mandir}/man1/wimapply.1*
122 %{_mandir}/man1/wimcapture.1*
123 %{_mandir}/man1/wimdelete.1*
124 %{_mandir}/man1/wimdir.1*
125 %{_mandir}/man1/wimexport.1*
126 %{_mandir}/man1/wimextract.1*
127 %{_mandir}/man1/wiminfo.1*
128 %{_mandir}/man1/wimjoin.1*
129 %{_mandir}/man1/wimlib-imagex-append.1*
130 %{_mandir}/man1/wimlib-imagex-apply.1*
131 %{_mandir}/man1/wimlib-imagex-capture.1*
132 %{_mandir}/man1/wimlib-imagex-delete.1*
133 %{_mandir}/man1/wimlib-imagex-dir.1*
134 %{_mandir}/man1/wimlib-imagex-export.1*
135 %{_mandir}/man1/wimlib-imagex-extract.1*
136 %{_mandir}/man1/wimlib-imagex-info.1*
137 %{_mandir}/man1/wimlib-imagex-join.1*
138 %{_mandir}/man1/wimlib-imagex-mount.1*
139 %{_mandir}/man1/wimlib-imagex-mountrw.1*
140 %{_mandir}/man1/wimlib-imagex-optimize.1*
141 %{_mandir}/man1/wimlib-imagex-split.1*
142 %{_mandir}/man1/wimlib-imagex-unmount.1*
143 %{_mandir}/man1/wimlib-imagex-update.1*
144 %{_mandir}/man1/wimlib-imagex-verify.1*
145 %{_mandir}/man1/wimlib-imagex.1*
146 %{_mandir}/man1/wimmount.1*
147 %{_mandir}/man1/wimmountrw.1*
148 %{_mandir}/man1/wimoptimize.1*
149 %{_mandir}/man1/wimsplit.1*
150 %{_mandir}/man1/wimunmount.1*
151 %{_mandir}/man1/wimupdate.1*
152 %{_mandir}/man1/wimverify.1*
This page took 0.090258 seconds and 4 git commands to generate.