]> git.pld-linux.org Git - packages/wimlib.git/blob - wimlib.spec
new (version 1.13.2)
[packages/wimlib.git] / wimlib.spec
1 Summary:        Open source Windows Imaging (WIM) library
2 Name:           wimlib
3 Version:        1.13.2
4 Release:        1
5 License:        GPL v3+ or LGPL v2.1+
6 Group:          Libraries
7 Source0:        https://wimlib.net/downloads/%{name}-%{version}.tar.gz
8 # Source0-md5:  617ffc718a8f57ff2fc4316cc1feee8e
9 URL:            https://wimlib.net/
10 BuildRequires:  libfuse-devel
11 BuildRequires:  libxml2-devel
12 BuildRequires:  ntfs-3g-devel >= 1:2011.4.12
13 BuildRequires:  openssl-devel
14 BuildRequires:  pkgconfig
15 Requires:       libfuse-tools
16 Requires:       ntfs-3g-libs >= 1:2011.4.12
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 wimlib is an open source, cross-platform library for creating,
21 extracting, and modifying Windows Imaging (WIM) archives. WIM is a
22 file archiving format, somewhat comparable to ZIP (and many other file
23 archiving formats); but unlike ZIP, it allows storing various
24 Windows-specific metadata, allows storing multiple "images" in a
25 single archive, automatically deduplicates all file contents, and
26 supports optional solid compression to get a better compression ratio.
27 wimlib and its command-line frontend wimlib-imagex provide a free and
28 cross-platform alternative to Microsoft's WIMGAPI, ImageX, and DISM.
29
30 %package devel
31 Summary:        Development files for wimlib
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Development files for wimlib.
37
38 %package static
39 Summary:        Static wimlib library
40 Group:          Development/Libraries
41 Requires:       %{name}-devel = %{version}-%{release}
42
43 %description static
44 Static wimlib library.
45
46 %package tools
47 Summary:        Tools for creating, modifying, extracting, and mounting WIM files
48 Group:          Applications/System
49 Requires:       %{name} = %{version}-%{release}
50
51 %description tools
52 Tools for creating, modifying, extracting, and mounting WIM files.
53
54 %prep
55 %setup -q
56
57 %{__sed} -i -e '1s,/usr/bin/env bash,%{__bash},' programs/mkwinpeimg.in
58
59 %build
60 %configure \
61         --disable-silent-rules
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwim.la
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %doc COPYING NEWS README
81 %attr(755,root,root) %{_libdir}/libwim.so.*.*.*
82 %attr(755,root,root) %ghost %{_libdir}/libwim.so.15
83
84 %files devel
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/libwim.so
87 %{_includedir}/wimlib.h
88 %{_pkgconfigdir}/wimlib.pc
89
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/libwim.a
93
94 %files tools
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_bindir}/mkwinpeimg
97 %attr(755,root,root) %{_bindir}/wimappend
98 %attr(755,root,root) %{_bindir}/wimapply
99 %attr(755,root,root) %{_bindir}/wimcapture
100 %attr(755,root,root) %{_bindir}/wimdelete
101 %attr(755,root,root) %{_bindir}/wimdir
102 %attr(755,root,root) %{_bindir}/wimexport
103 %attr(755,root,root) %{_bindir}/wimextract
104 %attr(755,root,root) %{_bindir}/wiminfo
105 %attr(755,root,root) %{_bindir}/wimjoin
106 %attr(755,root,root) %{_bindir}/wimlib-imagex
107 %attr(755,root,root) %{_bindir}/wimmount
108 %attr(755,root,root) %{_bindir}/wimmountrw
109 %attr(755,root,root) %{_bindir}/wimoptimize
110 %attr(755,root,root) %{_bindir}/wimsplit
111 %attr(755,root,root) %{_bindir}/wimunmount
112 %attr(755,root,root) %{_bindir}/wimupdate
113 %attr(755,root,root) %{_bindir}/wimverify
114 %{_mandir}/man1/mkwinpeimg.1*
115 %{_mandir}/man1/wimappend.1*
116 %{_mandir}/man1/wimapply.1*
117 %{_mandir}/man1/wimcapture.1*
118 %{_mandir}/man1/wimdelete.1*
119 %{_mandir}/man1/wimdir.1*
120 %{_mandir}/man1/wimexport.1*
121 %{_mandir}/man1/wimextract.1*
122 %{_mandir}/man1/wiminfo.1*
123 %{_mandir}/man1/wimjoin.1*
124 %{_mandir}/man1/wimlib-imagex-append.1*
125 %{_mandir}/man1/wimlib-imagex-apply.1*
126 %{_mandir}/man1/wimlib-imagex-capture.1*
127 %{_mandir}/man1/wimlib-imagex-delete.1*
128 %{_mandir}/man1/wimlib-imagex-dir.1*
129 %{_mandir}/man1/wimlib-imagex-export.1*
130 %{_mandir}/man1/wimlib-imagex-extract.1*
131 %{_mandir}/man1/wimlib-imagex-info.1*
132 %{_mandir}/man1/wimlib-imagex-join.1*
133 %{_mandir}/man1/wimlib-imagex-mount.1*
134 %{_mandir}/man1/wimlib-imagex-mountrw.1*
135 %{_mandir}/man1/wimlib-imagex-optimize.1*
136 %{_mandir}/man1/wimlib-imagex-split.1*
137 %{_mandir}/man1/wimlib-imagex-unmount.1*
138 %{_mandir}/man1/wimlib-imagex-update.1*
139 %{_mandir}/man1/wimlib-imagex-verify.1*
140 %{_mandir}/man1/wimlib-imagex.1*
141 %{_mandir}/man1/wimmount.1*
142 %{_mandir}/man1/wimmountrw.1*
143 %{_mandir}/man1/wimoptimize.1*
144 %{_mandir}/man1/wimsplit.1*
145 %{_mandir}/man1/wimunmount.1*
146 %{_mandir}/man1/wimupdate.1*
147 %{_mandir}/man1/wimverify.1*
This page took 0.07975 seconds and 4 git commands to generate.