]> git.pld-linux.org Git - packages/wicd.git/commitdiff
- fix parsing unicode strings from dbus auto/th/wicd-1.7.2.4-3
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 20 Mar 2013 16:56:36 +0000 (17:56 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 20 Mar 2013 16:56:36 +0000 (17:56 +0100)
- rel 3

dbus-unicode.patch [new file with mode: 0644]
wicd.spec

diff --git a/dbus-unicode.patch b/dbus-unicode.patch
new file mode 100644 (file)
index 0000000..2fddc9a
--- /dev/null
@@ -0,0 +1,16 @@
+=== modified file 'wicd/misc.py'
+--- wicd/misc.py       2012-04-30 19:20:47 +0000
++++ wicd/misc.py       2012-05-03 16:01:49 +0000
+@@ -430,7 +430,10 @@
+     """ Sanitize property names to be used in config-files. """
+     allowed = string.ascii_letters + '_' + string.digits
+     table = string.maketrans(allowed, ' ' * len(allowed))
+-    return s.translate(None, table)
++
++    # s is a dbus.String -- since we don't allow unicode property keys,
++    # make it simple.
++    return str(s).translate(None, table)
+ def sanitize_escaped(s):
+     """ Sanitize double-escaped unicode strings. """
+
index 9ca919751d886223f78a05914806e234159894f6..d543dbafce4c016acc76aaa4857df5d34afb3d58 100644 (file)
--- a/wicd.spec
+++ b/wicd.spec
@@ -10,7 +10,7 @@ Summary(hu.UTF-8):    Vezeték és vezeték néklküli hálózati menedzser
 Summary(pl.UTF-8):     Zarządca sieci przewodowych i bezprzewodowych
 Name:          wicd
 Version:       1.7.2.4
-Release:       2
+Release:       3
 License:       GPL v2+
 Group:         X11/Applications/Networking
 Source0:       https://launchpad.net/wicd/1.7/%{version}/+download/wicd-%{version}.tar.gz
@@ -24,6 +24,7 @@ Patch2:               %{name}-desktop.patch
 Patch3:                install_kde.patch
 Patch4:                urwid-fix1.patch
 Patch5:                urwid-fix2.patch
+Patch6:                dbus-unicode.patch
 URL:           http://www.wicd.net/
 BuildRequires: gettext-devel
 # /etc/pld-release used to detect platform
@@ -153,6 +154,7 @@ Skrypt wicd dla pm-utils.
 %patch3 -p0
 %patch4 -p0
 %patch5 -p0
+%patch6 -p0
 
 mv po/{ar_EG,ar}.po
 rm po/ast.po
This page took 0.035193 seconds and 4 git commands to generate.