]> git.pld-linux.org Git - packages/wicd.git/blob - wicd.spec
- cp ../BUILD/wicd-1.6.2.2/init/pld/wicd
[packages/wicd.git] / wicd.spec
1 Summary:        wired and wireless network manager
2 Summary(pl.UTF-8):      Zarządca sieci przewodowych i bezprzewodowych
3 Name:           wicd
4 Version:        1.6.2.2
5 Release:        2
6 License:        GPL v2
7 Group:          X11/Applications/Networking
8 Source0:        http://dl.sourceforge.net/wicd/%{name}-%{version}.tar.gz
9 # Source0-md5:  acbbe695abf7ff83161c62317dfc7509
10 Patch0:         %{name}-init_status.patch
11 URL:            http://wicd.net/
12 # /etc/pld-release used to detect platform
13 BuildRequires:  issue
14 BuildRequires:  libiw-devel
15 BuildRequires:  python-devel
16 BuildRequires:  python-modules
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.228
19 Requires(post,preun):   /sbin/chkconfig
20 Requires:       dbus(org.freedesktop.Notifications)
21 Requires:       python-dbus
22 Requires:       python-pygobject
23 Requires:       python-pygtk-glade >= 2:2.0
24 Requires:       python-pygtk-gtk >= 2:2.0
25 Obsoletes:      wicd < 1.6.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Wicd is an open source wired and wireless network manager for Linux
30 which aims to provide a simple interface to connect to networks with a
31 wide variety of settings.
32
33 %description -l pl.UTF-8
34 Wicd jest zarządcą sieci przewodowych i bezprzewodowych dla Linuksa,
35 mającym zapewnić prosty interfejs do podłączania do sieci z
36 różnorakimi opcjami.
37
38 %package client-curses
39 Summary:        wicd console client
40 Summary(pl.UTF-8):      klient wicd dla konsoli
41 Group:          Applications/System
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       python-urwid
44
45 %description client-curses
46 wicd curses client.
47
48 %description client-curses -l pl.UTF-8
49 Klient wicd dla konsoli.
50
51 %package -n pm-utils-wicd
52 Summary:        wicd script for pm-utils
53 Summary(pl.UTF-8):      Skrypt wicd dla pm-utils
54 Group:          Applications/System
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       pm-utils
57
58 %description -n pm-utils-wicd
59 wicd script for pm-utils.
60
61 %description -n pm-utils-wicd -l pl.UTF-8
62 Skrypt wicd dla pm-utils.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 mv -f translations/{ar_EG,ar}
69 mv -f translations/{de_DE,de}
70 mv -f translations/{es_ES,es}
71 mv -f translations/{it_IT,it}
72 mv -f translations/{nl_NL,nl}
73 mv -f translations/{no,nb}
74 mv -f translations/{ru_RU,ru}
75
76 %{__python} setup.py configure \
77         --backends %{_libdir}/%{name}/backends \
78         --lib %{_libdir}/%{name} \
79         --pidfile /var/run/wicd.pid \
80         --pmutils %{_libdir}/pm-utils/sleep.d
81
82 %build
83 %{__python} setup.py build
84
85 cd depends/python-iwscan
86 %{__python} setup.py build
87 cd ../python-wpactrl
88 %{__python} setup.py build
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__python} setup.py install \
94         --optimize=2 \
95         --root=$RPM_BUILD_ROOT
96
97 cd depends/python-iwscan
98 %{__python} setup.py install \
99         --optimize=2 \
100         --root=$RPM_BUILD_ROOT
101
102 cd ../python-wpactrl
103 %{__python} setup.py install \
104         --optimize=2 \
105         --root=$RPM_BUILD_ROOT
106
107 cd ../..
108
109 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
110 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
111 %py_postclean
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post
119 /sbin/chkconfig --add %{name}
120 %service %{name} restart
121
122 %preun
123 if [ "$1" = "0" ]; then
124         %service -q %{name} stop
125         /sbin/chkconfig --del %{name}
126 fi
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc AUTHORS CHANGES INSTALL README 
131 %attr(755,root,root) %{_bindir}/wicd-client
132 %attr(755,root,root) %{_sbindir}/wicd
133 #% {_sysconfdir}/acpi/resume.d/80-wicd-connect.sh
134 #% {_sysconfdir}/acpi/suspend.d/50-wicd-suspend.sh
135
136 %{_sysconfdir}/dbus-1/system.d/wicd.conf
137 %{_sysconfdir}/wicd
138 %{_sysconfdir}/xdg/autostart/wicd-tray.desktop
139 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
140
141 %dir %{_libdir}/%{name}
142 %dir %{_libdir}/%{name}/backends
143 %attr(755,root,root) %{_libdir}/%{name}/*.py
144 %attr(755,root,root) %{_libdir}/%{name}/backends/*.py
145 %exclude %{_libdir}/%{name}/*curses*.py
146
147 %dir %{py_sitescriptdir}/wicd
148 %{py_sitescriptdir}/wicd/*.py[co]
149 %{py_sitescriptdir}/Wicd-*.egg-info
150
151 %if "%{py_ver}" > "2.4"
152 %{py_sitedir}/iwscan-*.egg-info
153 %endif
154 %{py_sitedir}/iwscan.so
155 %if "%{py_ver}" > "2.4"
156 %{py_sitedir}/wpactrl-*.egg-info
157 %endif
158 %{py_sitedir}/wpactrl.so
159
160 %{_datadir}/%{name}
161 %{_datadir}/autostart/wicd-tray.desktop
162
163 %{_desktopdir}/wicd.desktop
164 %{_iconsdir}/hicolor/*/apps/wicd-client.*
165 %{_pixmapsdir}/%{name}
166
167 /var/lib/%{name}
168 /var/log/%{name}
169
170 %{_mandir}/man1/wicd-client.1*
171 %{_mandir}/man5/wicd-manager-settings.conf.5*
172 %{_mandir}/man5/wicd-wired-settings.conf.5*
173 %{_mandir}/man5/wicd-wireless-settings.conf.5*
174 %{_mandir}/man8/wicd.8*
175
176 %files client-curses
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_bindir}/wicd-curses
179 %attr(755,root,root) %{_libdir}/%{name}/*curses*.py
180 %{_mandir}/man8/wicd-curses.8*
181
182 %files -n pm-utils-wicd
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/pm-utils/sleep.d/*wicd
This page took 0.033959 seconds and 3 git commands to generate.