]> git.pld-linux.org Git - packages/wicd.git/blob - wicd.spec
b61c9080a7f2c8b860c1337fe7a179a07cf36375
[packages/wicd.git] / wicd.spec
1 # TODO
2 # - fix pm-utils to store addons in non-arch dependant path so we could make this pkg noarch
3 # - package (acpid-XXX):
4 #   /etc/acpi/resume.d/80-wicd-connect.sh
5 #   /etc/acpi/suspend.d/50-wicd-suspend.sh
6 # - notes about translations:
7 #   - duplicate fr and fr_FR exist, we prefer fr_FR
8 #   - ar_PS (Palestine) isn't in glibc yet.
9 #   - ar_EG (Egypt) isn't in glibc yet. using ar instead
10 Summary:        wired and wireless network manager
11 Summary(pl.UTF-8):      Zarządca sieci przewodowych i bezprzewodowych
12 Name:           wicd
13 Version:        1.7.0
14 Release:        2
15 License:        GPL v2
16 Group:          X11/Applications/Networking
17 Source0:        http://dl.sourceforge.net/wicd/%{name}-%{version}.tar.gz
18 # Source0-md5:  003d2e67240989db55934553437ba32a
19 Source1:        %{name}.init
20 Patch0:         %{name}-init_status.patch
21 Patch1:         bashism.patch
22 Patch2:         %{name}-desktop.patch
23 URL:            http://www.wicd.net/
24 # /etc/pld-release used to detect platform
25 BuildRequires:  issue
26 BuildRequires:  python-devel
27 BuildRequires:  python-modules
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.228
30 BuildRequires:  sed >= 4.0
31 Requires(post,preun):   /sbin/chkconfig
32 Requires:       dbus(org.freedesktop.Notifications)
33 Requires:       python-dbus
34 Requires:       python-iwscan
35 Requires:       python-pygobject
36 Requires:       python-pygtk-glade >= 2:2.0
37 Requires:       python-pygtk-gtk >= 2:2.0
38 Requires:       python-wpactrl
39 # not noarch due pm-utils packaging stupidity
40 #BuildArch:     noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Wicd is an open source wired and wireless network manager for Linux
45 which aims to provide a simple interface to connect to networks with a
46 wide variety of settings.
47
48 %description -l pl.UTF-8
49 Wicd jest zarządcą sieci przewodowych i bezprzewodowych dla Linuksa,
50 mającym zapewnić prosty interfejs do podłączania do sieci z
51 różnorakimi opcjami.
52
53 %package client-cli
54 Summary:        wicd CLI client
55 Summary(pl.UTF-8):      klient wicd CLI
56 Group:          Applications/System
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       python-urwid
59
60 %description client-cli
61 Wicd command line interface (ncurses) client.
62
63 %description client-cli -l pl.UTF-8
64 Klient wicd z międzymordziem wiersza poleceń (ncurses).
65
66 %package client-curses
67 Summary:        wicd TUI client
68 Summary(pl.UTF-8):      klient wicd z TUI
69 Group:          Applications/System
70 Requires:       %{name} = %{version}-%{release}
71
72 %description client-curses
73 Wicd text user interface (ncurses) client.
74
75 %description client-curses -l pl.UTF-8
76 Klient Wicd z tesktowym międzymordziem uzytkownika (ncurses).
77
78 %package client-gtk
79 Summary:        wicd GUI client
80 Summary(pl.UTF-8):      klient wicd z GUI
81 Group:          Applications/System
82 Requires:       %{name} = %{version}-%{release}
83
84 %description client-gtk
85 Wicd graphical user interface (GTK+2) client.
86
87 %description client-gtk -l pl.UTF-8
88 Klient Wicd z graficznym międzymordziem użytkownika (GTK+2).
89
90 %package -n pm-utils-wicd
91 Summary:        wicd script for pm-utils
92 Summary(pl.UTF-8):      Skrypt wicd dla pm-utils
93 Group:          Applications/System
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       pm-utils
96
97 %description -n pm-utils-wicd
98 Wicd script for pm-utils.
99
100 %description -n pm-utils-wicd -l pl.UTF-8
101 Skrypt wicd dla pm-utils.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108
109 mv translations/{ar_EG,ar}
110 rm -rf translations/ar_PS
111 mv translations/{de_DE,de}
112 mv translations/{es_ES,es}
113 rm -rf translations/fr
114 mv translations/{fr_FR,fr}
115 mv translations/{hr_HR,hr}
116 mv translations/{it_IT,it}
117 mv translations/{nl_NL,nl}
118 mv translations/{no,nb}
119 mv translations/{ru_RU,ru}
120
121 grep -r bin/env.*python -l . | xargs sed -i -e '1s,^#!.*env python,#!%{__python},'
122
123 %build
124 %{__python} setup.py configure \
125         --pidfile /var/run/wicd.pid \
126         --pmutils %{_libdir}/pm-utils/sleep.d
127
128 %{__python} setup.py build
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 %{__python} setup.py install \
133         --optimize=2 \
134         --root=$RPM_BUILD_ROOT
135
136 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wicd
137
138 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
139 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
140 %py_postclean
141
142 %find_lang %{name}
143
144 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
145 rm -f $RPM_BUILD_ROOT/var/lib/%{name}/configurations/.empty_on_purpose
146 rm -f $RPM_BUILD_ROOT/var/log/%{name}/.empty_on_purpose
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post
152 /sbin/chkconfig --add %{name}
153 %service %{name} restart
154
155 %preun
156 if [ "$1" = "0" ]; then
157         %service -q %{name} stop
158         /sbin/chkconfig --del %{name}
159 fi
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS CHANGES INSTALL README
164 %attr(755,root,root) %{_bindir}/wicd-client
165 %attr(755,root,root) %{_sbindir}/wicd
166 %attr(754,root,root) /etc/rc.d/init.d/%{name}
167 %{_mandir}/man5/wicd-manager-settings.conf.5*
168 %lang(nl) %{_mandir}/nl/man5/wicd-manager-settings.conf.5*
169 %{_mandir}/man5/wicd-wired-settings.conf.5*
170 %lang(nl) %{_mandir}/nl/man5/wicd-wired-settings.conf.5*
171 %{_mandir}/man5/wicd-wireless-settings.conf.5*
172 %lang(nl) %{_mandir}/nl/man5/wicd-wireless-settings.conf.5*
173 %{_mandir}/man8/wicd.8*
174 %lang(nl) %{_mandir}/nl/man8/wicd.8*
175 /etc/dbus-1/system.d/wicd.conf
176 %{_sysconfdir}/wicd
177 %dir %{_datadir}/%{name}
178 %dir %{_datadir}/%{name}/backends
179 %attr(755,root,root) %{_datadir}/%{name}/backends/*.py
180 %dir %{_datadir}/%{name}/daemon
181 %attr(755,root,root) %{_datadir}/%{name}/daemon/*.py
182 %dir %{py_sitescriptdir}/wicd
183 %{py_sitescriptdir}/wicd/*.py[co]
184 %{py_sitescriptdir}/Wicd-*.egg-info
185 %dir /var/lib/%{name}
186 %dir /var/lib/%{name}/configurations
187 /var/lib/%{name}/WHEREAREMYFILES
188 %dir /var/log/%{name}
189
190 %files client-cli
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_bindir}/wicd-cli
193 %dir %{_datadir}/%{name}/cli
194 %attr(755,root,root) %{_datadir}/%{name}/cli/*.py
195 %{_mandir}/man8/wicd-cli.8*
196
197 %files client-curses
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_bindir}/wicd-curses
200 %dir %{_datadir}/%{name}/curses
201 %attr(755,root,root) %{_datadir}/%{name}/curses/*.py
202 %{_mandir}/man8/wicd-curses.8*
203 %lang(nl) %{_mandir}/nl/man8/wicd-curses.8*
204
205 %files client-gtk
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_bindir}/wicd-gtk
208 %{_sysconfdir}/xdg/autostart/wicd-tray.desktop
209 %dir %{_datadir}/%{name}/gtk
210 %{_datadir}/%{name}/gtk/%{name}.glade
211 %attr(755,root,root) %{_datadir}/%{name}/gtk/*.py
212 %{_datadir}/autostart/wicd-tray.desktop
213 %{_desktopdir}/wicd.desktop
214 %{_iconsdir}/hicolor/*/apps/wicd-gtk.*
215 %{_pixmapsdir}/%{name}
216 %{_pixmapsdir}/wicd-gtk.xpm
217 %{_mandir}/man1/wicd-client.1*
218 %lang(nl) %{_mandir}/nl/man1/wicd-client.1*
219
220 %files -n pm-utils-wicd
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/pm-utils/sleep.d/*wicd
This page took 0.086815 seconds and 2 git commands to generate.