]> git.pld-linux.org Git - packages/wicd.git/blob - wicd.spec
b0855ca003200580e580041f99835f6c5a710a43
[packages/wicd.git] / wicd.spec
1 Summary:        wired and wireless network manager
2 Summary(pl.UTF-8):      Zarządca sieci przewodowych i bezprzewodowych
3 Name:           wicd
4 Version:        1.6.2.2
5 Release:        5
6 License:        GPL v2
7 Group:          X11/Applications/Networking
8 Source0:        http://dl.sourceforge.net/wicd/%{name}-%{version}.tar.gz
9 # Source0-md5:  acbbe695abf7ff83161c62317dfc7509
10 Source1:        %{name}.init
11 Patch0:         %{name}-init_status.patch
12 Patch1:         bashism.patch
13 URL:            http://www.wicd.net/
14 # /etc/pld-release used to detect platform
15 BuildRequires:  issue
16 BuildRequires:  python-devel
17 BuildRequires:  python-modules
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  sed >= 4.0
20 BuildRequires:  rpmbuild(macros) >= 1.228
21 Requires(post,preun):   /sbin/chkconfig
22 Requires:       dbus(org.freedesktop.Notifications)
23 Requires:       python-dbus
24 Requires:       python-iwscan
25 Requires:       python-pygobject
26 Requires:       python-pygtk-glade >= 2:2.0
27 Requires:       python-pygtk-gtk >= 2:2.0
28 Requires:       python-wpactrl
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Wicd is an open source wired and wireless network manager for Linux
34 which aims to provide a simple interface to connect to networks with a
35 wide variety of settings.
36
37 %description -l pl.UTF-8
38 Wicd jest zarządcą sieci przewodowych i bezprzewodowych dla Linuksa,
39 mającym zapewnić prosty interfejs do podłączania do sieci z
40 różnorakimi opcjami.
41
42 %package client-curses
43 Summary:        wicd console client
44 Summary(pl.UTF-8):      klient wicd dla konsoli
45 Group:          Applications/System
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       python-urwid
48
49 %description client-curses
50 wicd curses client.
51
52 %description client-curses -l pl.UTF-8
53 Klient wicd dla konsoli.
54
55 %package -n pm-utils-wicd
56 Summary:        wicd script for pm-utils
57 Summary(pl.UTF-8):      Skrypt wicd dla pm-utils
58 Group:          Applications/System
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       pm-utils
61
62 %description -n pm-utils-wicd
63 wicd script for pm-utils.
64
65 %description -n pm-utils-wicd -l pl.UTF-8
66 Skrypt wicd dla pm-utils.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72
73 mv translations/{ar_EG,ar}
74 mv translations/{de_DE,de}
75 mv translations/{es_ES,es}
76 mv translations/{it_IT,it}
77 mv translations/{nl_NL,nl}
78 mv translations/{no,nb}
79 mv translations/{ru_RU,ru}
80
81 grep -r bin/env.*python -l . | xargs sed -i -e '1s,^#!.*env python,#!%{__python},'
82
83 %build
84 %{__python} setup.py configure \
85         --backends %{_libdir}/%{name}/backends \
86         --lib %{_libdir}/%{name} \
87         --pidfile /var/run/wicd.pid \
88         --pmutils %{_libdir}/pm-utils/sleep.d
89
90 %{__python} setup.py build
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %{__python} setup.py install \
95         --optimize=2 \
96         --root=$RPM_BUILD_ROOT
97
98 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wicd
99
100 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
101 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
102 %py_postclean
103
104 %find_lang %{name}
105
106 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 /sbin/chkconfig --add %{name}
113 %service %{name} restart
114
115 %preun
116 if [ "$1" = "0" ]; then
117         %service -q %{name} stop
118         /sbin/chkconfig --del %{name}
119 fi
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %doc AUTHORS CHANGES INSTALL README
124 %attr(755,root,root) %{_bindir}/wicd-client
125 %attr(755,root,root) %{_sbindir}/wicd
126 %attr(754,root,root) /etc/rc.d/init.d/%{name}
127 %{_mandir}/man1/wicd-client.1*
128 %{_mandir}/man5/wicd-manager-settings.conf.5*
129 %{_mandir}/man5/wicd-wired-settings.conf.5*
130 %{_mandir}/man5/wicd-wireless-settings.conf.5*
131 %{_mandir}/man8/wicd.8*
132 /etc/dbus-1/system.d/wicd.conf
133 %{_sysconfdir}/wicd
134 %{_sysconfdir}/xdg/autostart/wicd-tray.desktop
135
136 %dir %{_libdir}/%{name}
137 %dir %{_libdir}/%{name}/backends
138 %attr(755,root,root) %{_libdir}/%{name}/*.py
139 %attr(755,root,root) %{_libdir}/%{name}/backends/*.py
140 %exclude %{_libdir}/%{name}/*curses*.py
141
142 %{_datadir}/%{name}
143 %{_datadir}/autostart/wicd-tray.desktop
144
145 %{_desktopdir}/wicd.desktop
146 %{_iconsdir}/hicolor/*/apps/wicd-client.*
147 %{_pixmapsdir}/%{name}
148
149 %dir %{py_sitescriptdir}/wicd
150 %{py_sitescriptdir}/wicd/*.py[co]
151 %{py_sitescriptdir}/Wicd-*.egg-info
152
153 %dir /var/lib/%{name}
154 /var/lib/%{name}/WHEREAREMYFILES
155
156 %dir /var/log/%{name}
157
158 %files client-curses
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/wicd-curses
161 %attr(755,root,root) %{_libdir}/%{name}/*curses*.py
162 %{_mandir}/man8/wicd-curses.8*
163
164 %files -n pm-utils-wicd
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/pm-utils/sleep.d/*wicd
This page took 0.062939 seconds and 2 git commands to generate.