]> git.pld-linux.org Git - packages/wget.git/blob - wget.spec
fix build with gnupg >= 2.4.1; rel 2
[packages/wget.git] / wget.spec
1 # TODO
2 # - add --delete-remote patches:
3 #  - http://wget-bugs.ferrara.linux.it/issue9
4 #  - or http://osdir.com/ml/web.wget.patches/2005-09/msg00006.html
5 # - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
6 #
7 # Conditional build:
8 %bcond_without  tests   # check target
9 %bcond_without  metalink # build without metalink support
10 %bcond_with     gnutls  # use GnuTLS (wget default) instead of OpenSSL
11
12 Summary:        A utility for retrieving files using the HTTP or FTP protocols
13 Summary(es.UTF-8):      Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
14 Summary(fr.UTF-8):      Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
15 Summary(pl.UTF-8):      Wsadowy klient HTTP/FTP
16 Summary(pt_BR.UTF-8):   Cliente na linha de comando para baixar arquivos WWW/FTP com recursão opcional
17 Summary(ru.UTF-8):      Утилита для получения файлов по протоколам HTTP и FTP
18 Summary(uk.UTF-8):      Утиліта для отримання файлів по протоколам HTTP та FTP
19 Summary(zh_CN.UTF-8):   [通讯]功能强大的下载程序,支持断点续传
20 Name:           wget
21 Version:        1.21.4
22 Release:        2
23 License:        GPL v3+ with OpenSSL exception
24 Group:          Networking/Utilities
25 Source0:        http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.lz
26 # Source0-md5:  6d4ab603f1b905b6856a111c61078740
27 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
28 # Source1-md5:  d8b2b56ec7461606c22edbafaf8a418f
29 Patch0:         %{name}-info.patch
30 Patch1:         %{name}-wgetrc_path.patch
31 Patch2:         %{name}-home_etc.patch
32 Patch3:         %{name}-ssl-certs.patch
33 Patch4:         user.xdg.origin.url.patch
34 Patch5:         gnupg-2.4.1-tests.patch
35 URL:            http://www.gnu.org/software/wget/
36 BuildRequires:  autoconf >= 2.64
37 BuildRequires:  autoconf-archive
38 BuildRequires:  automake >= 1:1.9
39 BuildRequires:  gettext-tools >= 0.21
40 # >= 3.6.3 for TLSv1.3
41 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.0.16}
42 %{?with_metalink:BuildRequires: gpgme-devel >= 0.4.2}
43 BuildRequires:  libidn2-devel >= 0.14.0
44 %{?with_metalink:BuildRequires: libmetalink-devel}
45 BuildRequires:  libpsl-devel >= 0.16.0
46 BuildRequires:  libuuid-devel
47 BuildRequires:  lzip
48 # >= 1.1.0 for TLSv1.3
49 %{!?with_gnutls:BuildRequires:  openssl-devel >= 1.0.1}
50 BuildRequires:  pcre2-8-devel
51 BuildRequires:  perl-devel
52 BuildRequires:  pkgconfig
53 BuildRequires:  tar >= 1:1.22
54 BuildRequires:  texinfo
55 BuildRequires:  zlib-devel
56 %if %{with tests}
57 BuildRequires:  perl-HTTP-Daemon
58 BuildRequires:  perl-HTTP-Message
59 BuildRequires:  perl-IO-Socket-SSL
60 BuildRequires:  python3-modules >= 1:3.0
61 %endif
62 Provides:       webclient
63 %{?with_gnutls:Requires:        gnutls-libs >= 3.0.16}
64 %{!?with_gnutls:Requires:       openssl >= 1.0.1}
65 Requires:       libidn2 >= 0.14.0
66 Requires:       libpsl >= 0.16.0
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _noautoreqfiles         %{_bindir}/rmold
70
71 %description
72 GNU Wget is a file retrieval utility which can use either the HTTP or
73 FTP protocols. Wget features include the ability to work in the
74 background while you're logged out, recursive retrieval of
75 directories, file name wildcard matching, remote file timestamp
76 storage and comparison, use of Rest with FTP servers and Range with
77 HTTP servers to retrieve files over slow or unstable connections,
78 support for Proxy servers, and configurability.
79
80 %description -l es.UTF-8
81 GNU wget es una herramienta de red para bajar archivos usando HTTP y
82 FTP. Funciona en modo no interactivo, pudiendo trabajar en background.
83 Funciona muy bien, incluso en conexiones lentas o inestables, bajando
84 el archivo hasta que sea completamente recibido.
85
86 %description -l fr.UTF-8
87 GNU Wget est un utilitaire pour récupérer des fichiers qui peut
88 utiliser indifféremment les protocoles HTTP ou FTP. Parmi les
89 caractéristiques de Wget, citons la capacité à récupérer des fichiers
90 en arrière-plan alors que vous n'êtes pas connecté, la récupération
91 récursive de répertoires, la capacité de récupérer des fichiers en
92 appliquant un filtre sur le nom ou sur la date, la gestion de Rest
93 avec les serveurs FTP et de Range avec les serveurs HTTP pour
94 récupérer des fichiers avec une connexion lente ou instable, le
95 support des serveurs Proxy... Wget est particulièrement configurable.
96
97 %description -l ja.UTF-8
98 GNU wget は HTTP か FTP プロトコルのどちらかを使用することができる
99 ファイルを取得するユーティリティです。wget はログアウトしている
100 間にバックグラウンドで働く特徴をもっていること、ディレクトリの再帰的
101 取得、ファイルネームのワイルドカードマッチング、ファイルのタイムスタンプの
102 保存と比較、遅く不安定な接続で FTP サーバの Rest と HTTP サーバの
103 Range の使用、プロキシーサーバのサポートと設定の容易さを含んだ特徴を
104 もっています。
105
106 %description -l pl.UTF-8
107 Wget jest klientem FTP/HTTP przeznaczonym do ściągania zasobów
108 wsadowo. Umożliwia ściąganie zasobów z podkatalogami, a także ma opcje
109 umożliwiające wykonanie lokalnej kopii zasobów (mirror). W razie
110 niemożności dostania się do zasobów lub gdy połączenie z serwerem
111 FTP/HTTP zostanie zerwane, może automatycznie ponawiać próby
112 kopiowania. Jest także dobrze przystosowany do tego, żeby uruchamiać
113 go jako zadanie z crona.
114
115 %description -l pt_BR.UTF-8
116 O GNU wget é uma ferramenta de rede para baixar arquivos usando HTTP e
117 FTP. Ele funciona em modo não interativo, podendo trabalhar em
118 background. Funciona muito bem, mesmo em conexões lentas ou instáveis,
119 baixando o arquivo até que ele seja completamente recebido.
120
121 %description -l ru.UTF-8
122 GNU Wget - это утилита командной строки для получения файлов по
123 протоколам FTP и HTTP. Среди возможностей Wget - работа в фоновом
124 режиме когда вы выходите из системы, рекурсивное извлечение каталогов,
125 выбор файлов по шаблону, сравнение времени удаленных и локальных
126 файлов, сохранение времени удаленных файлов при загрузке,
127 использование REST с FTP серверами и Range с HTTP серверами для
128 загрузки файлов по медленным или нестабильным каналам, поддержка Proxy
129 серверов, конфигурируемость.
130
131 %description -l uk.UTF-8
132 GNU Wget - це утиліта командного рядка для отримання файлів по
133 протоколам FTP та HTTP. Серед можливостей Wget - робота в фоновому
134 режимі коли ви виходите із системи, рекурсивне отримання каталогів,
135 вибір файлів по шаблону, порівняння часу віддалених та локальних
136 файлів, збереження часу віддалених файлів при завантаженні,
137 використання REST з FTP серверами та Range з HTTP серверами для
138 завантаження файлів по повільним чи нестабільним каналам, підтримка
139 Proxy серверів, настроюваність.
140
141 %prep
142 %setup -q
143 %patch0 -p1
144 %patch1 -p1
145 %patch2 -p1
146 %patch3 -p1
147 %patch4 -p1
148 %patch5 -p1
149
150 %{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion po/stamp-po
151
152 # temp hack for 1.13.4
153 test -e build-aux/bzr-version-gen || cat <<EOF > build-aux/bzr-version-gen
154 #!/bin/sh
155 echo -n %{version}
156 EOF
157 chmod +x build-aux/bzr-version-gen
158
159 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' util/rmold.pl
160
161 %build
162 %{__gettextize}
163 %{__aclocal} -I m4
164 %{__autoheader}
165 %{__autoconf}
166 %{__automake}
167 %configure \
168         --enable-digest \
169         --enable-ipv6 \
170         --enable-iri \
171         --enable-largefile \
172         --enable-nls \
173         --enable-ntlm \
174         --enable-opie \
175         --enable-pcre \
176         --disable-silent-rules \
177         --disable-year2038 \
178         --with-libpsl \
179         %{__with_without metalink} \
180         --with-ssl%{!?with_gnutls:=openssl} \
181         --with-zlib \
182         %{nil}
183 %{__make}
184 tail -n 6 util/README >rmold.README
185
186 # 1.13.4 tarball was buggy and produced empty version.
187 grep %{version} src/version.c
188
189 %{?with_tests:%{__make} check}
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193 install -d $RPM_BUILD_ROOT%{_sysconfdir}
194
195 %{__make} install \
196         DESTDIR=$RPM_BUILD_ROOT \
197         GETTEXT_PACKAGE=wget
198
199 install -p util/rmold.pl $RPM_BUILD_ROOT%{_bindir}/rmold
200 cp -a doc/sample.wgetrc $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
201
202 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
203 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README*
204 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
205
206 # "wget" and "wget-gnulib" domains
207 %find_lang %{name} --all-name
208
209 %clean
210 rm -rf $RPM_BUILD_ROOT
211
212 %post   -p /sbin/postshell
213 -/usr/sbin/fix-info-dir -c %{_infodir}
214
215 %postun -p /sbin/postshell
216 -/usr/sbin/fix-info-dir -c %{_infodir}
217
218 %files -f %{name}.lang
219 %defattr(644,root,root,755)
220 %doc AUTHORS ChangeLog NEWS README MAILING-LIST rmold.README
221 %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/wgetrc
222 %attr(755,root,root) %{_bindir}/rmold
223 %attr(755,root,root) %{_bindir}/wget
224 %{_mandir}/man1/wget.1*
225 %{_mandir}/hu/man1/wget.1*
226 %{_mandir}/pl/man1/wget.1*
227 %{_infodir}/wget.info*
This page took 0.165624 seconds and 4 git commands to generate.