]> git.pld-linux.org Git - packages/websocketpp.git/commitdiff
- updated to 0.8.2 master auto/th/websocketpp-0.8.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 9 Apr 2023 13:19:50 +0000 (15:19 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 9 Apr 2023 13:19:50 +0000 (15:19 +0200)
websocketpp-boost.patch [deleted file]
websocketpp-fix_version.patch [deleted file]
websocketpp.pc
websocketpp.spec

diff --git a/websocketpp-boost.patch b/websocketpp-boost.patch
deleted file mode 100644 (file)
index cfdcf9b..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-From c769c9238ad62178f506038178714a1c35aa2769 Mon Sep 17 00:00:00 2001
-From: Stefan Floeren <42731906+stefan-floeren@users.noreply.github.com>
-Date: Tue, 16 Apr 2019 08:38:01 +0200
-Subject: [PATCH] Replace make_shared with new in some cases
-
-Replace make_shared for asio types that take a lib::ref as a parameter.
-This should fix the ASIO change (boostorg/asio@59066d8) for 1.70,
-while keeping it backwards compatible to older boost versions.
----
- websocketpp/transport/asio/connection.hpp    | 7 ++++---
- websocketpp/transport/asio/endpoint.hpp      | 3 +--
- websocketpp/transport/asio/security/none.hpp | 3 +--
- websocketpp/transport/asio/security/tls.hpp  | 3 +--
- 4 files changed, 7 insertions(+), 9 deletions(-)
-
-diff --git a/websocketpp/transport/asio/connection.hpp b/websocketpp/transport/asio/connection.hpp
-index 60f88a79..1ccda8f3 100644
---- a/websocketpp/transport/asio/connection.hpp
-+++ b/websocketpp/transport/asio/connection.hpp
-@@ -311,9 +311,10 @@ class connection : public config::socket_type::socket_con_type {
-      * needed.
-      */
-     timer_ptr set_timer(long duration, timer_handler callback) {
--        timer_ptr new_timer = lib::make_shared<lib::asio::steady_timer>(
--            lib::ref(*m_io_service),
--            lib::asio::milliseconds(duration)
-+        timer_ptr new_timer(
-+            new lib::asio::steady_timer(
-+                *m_io_service,
-+                lib::asio::milliseconds(duration))
-         );
-         if (config::enable_multithreading) {
-diff --git a/websocketpp/transport/asio/endpoint.hpp b/websocketpp/transport/asio/endpoint.hpp
-index ddab2c74..4b719a97 100644
---- a/websocketpp/transport/asio/endpoint.hpp
-+++ b/websocketpp/transport/asio/endpoint.hpp
-@@ -195,8 +195,7 @@ class endpoint : public config::socket_type {
-         m_io_service = ptr;
-         m_external_io_service = true;
--        m_acceptor = lib::make_shared<lib::asio::ip::tcp::acceptor>(
--            lib::ref(*m_io_service));
-+        m_acceptor.reset(new lib::asio::ip::tcp::acceptor(*m_io_service));
-         m_state = READY;
-         ec = lib::error_code();
-diff --git a/websocketpp/transport/asio/security/none.hpp b/websocketpp/transport/asio/security/none.hpp
-index 5c8293db..6c7d3524 100644
---- a/websocketpp/transport/asio/security/none.hpp
-+++ b/websocketpp/transport/asio/security/none.hpp
-@@ -168,8 +168,7 @@ class connection : public lib::enable_shared_from_this<connection> {
-             return socket::make_error_code(socket::error::invalid_state);
-         }
--        m_socket = lib::make_shared<lib::asio::ip::tcp::socket>(
--            lib::ref(*service));
-+        m_socket.reset(new lib::asio::ip::tcp::socket(*service));
-         if (m_socket_init_handler) {
-             m_socket_init_handler(m_hdl, *m_socket);
-diff --git a/websocketpp/transport/asio/security/tls.hpp b/websocketpp/transport/asio/security/tls.hpp
-index c76fd9aa..04ac3790 100644
---- a/websocketpp/transport/asio/security/tls.hpp
-+++ b/websocketpp/transport/asio/security/tls.hpp
-@@ -193,8 +193,7 @@ class connection : public lib::enable_shared_from_this<connection> {
-         if (!m_context) {
-             return socket::make_error_code(socket::error::invalid_tls_context);
-         }
--        m_socket = lib::make_shared<socket_type>(
--            _WEBSOCKETPP_REF(*service),lib::ref(*m_context));
-+        m_socket.reset(new socket_type(*service, *m_context));
-         if (m_socket_init_handler) {
-             m_socket_init_handler(m_hdl, get_socket());
diff --git a/websocketpp-fix_version.patch b/websocketpp-fix_version.patch
deleted file mode 100644 (file)
index bc65efb..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-From 4bccfb04a264704ec9b80ba332ee1cf113ce7f1b Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Wolfgang=20St=C3=B6ggl?= <c72578@yahoo.de>
-Date: Thu, 1 Nov 2018 20:58:10 +0100
-Subject: [PATCH] Update version number in CMakeLists.txt to 0.8.1
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2786aba9..2d13117b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -24,7 +24,7 @@ endif ()
- ############ Project name and version
- set (WEBSOCKETPP_MAJOR_VERSION 0)
- set (WEBSOCKETPP_MINOR_VERSION 8)
--set (WEBSOCKETPP_PATCH_VERSION 0)
-+set (WEBSOCKETPP_PATCH_VERSION 1)
- set (WEBSOCKETPP_VERSION ${WEBSOCKETPP_MAJOR_VERSION}.${WEBSOCKETPP_MINOR_VERSION}.${WEBSOCKETPP_PATCH_VERSION})
- if(POLICY CMP0048)
index 58f754840a2f51bf6ea922683bb0d62e03b46ab3..9148efcdb362495a126cbdf8197da91101253c3f 100644 (file)
@@ -4,6 +4,6 @@ includedir=${prefix}/include
 
 Name: websocketpp
 Description: WebSocket API
-Version: 0.8.1
+Version: @version@
 URL: https://www.zaphoyd.com/websocketpp/
 Cflags: -I${includedir}/
index 676618b65d44433bc0d1d1b29d5f69c4674f1e58..c8dc6d6c4c24b823626924fb1a18e08b81a55715 100644 (file)
@@ -5,20 +5,17 @@
 Summary:       C++ WebSocket Protocol Library
 Summary(pl.UTF-8):     Biblioteka C++ do obsługi protokołu WebSocket
 Name:          websocketpp
-Version:       0.8.1
+Version:       0.8.2
 Release:       1
 License:       BSD
 Group:         Development/Libraries
 #Source0Download: https://github.com/zaphoyd/websocketpp/releases
 Source0:       https://github.com/zaphoyd/websocketpp/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 75e96b15ba1cb3b37175d58352c3a7fb
+# Source0-md5: 261e977d69fdcb8fdaacb46b7c9e2258
 Source1:       websocketpp.pc
 Patch0:                %{name}-cmake_noarch.patch
 Patch1:                %{name}-cmake-configversion-compatibility.patch
 Patch2:                %{name}-tests.patch
-Patch3:                %{name}-fix_version.patch
-# from https://github.com/zaphoyd/websocketpp/pull/814/commits/c769c9238ad62178f506038178714a1c35aa2769.patch
-Patch4:                %{name}-boost.patch
 URL:           https://www.zaphoyd.com/websocketpp/
 BuildRequires: boost-devel >= 1.39
 BuildRequires: cmake >= 2.8.8
@@ -71,8 +68,6 @@ oparty o Boost Asio.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
 install -d build
@@ -93,7 +88,7 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{_npkgconfigdir}
-cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_npkgconfigdir}/websocketpp.pc
+%{__sed} -e 's/@version@/%{version}/' %{SOURCE1} >$RPM_BUILD_ROOT%{_npkgconfigdir}/websocketpp.pc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.04838 seconds and 4 git commands to generate.