]> git.pld-linux.org Git - packages/wayland.git/commitdiff
- updated to 1.0.0 auto/th/wayland-1.0.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 2 Nov 2012 18:13:40 +0000 (19:13 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 2 Nov 2012 18:13:40 +0000 (19:13 +0100)
- added publican patch to allow build using publican 3.0.0

wayland-publican.patch [new file with mode: 0644]
wayland.spec

diff --git a/wayland-publican.patch b/wayland-publican.patch
new file mode 100644 (file)
index 0000000..6536a33
--- /dev/null
@@ -0,0 +1,40 @@
+--- wayland-1.0.0/doc/Wayland/Makefile.am.orig 2012-10-16 02:51:00.000000000 +0200
++++ wayland-1.0.0/doc/Wayland/Makefile.am      2012-11-02 18:38:24.312376554 +0100
+@@ -52,7 +52,7 @@
+       $(AM_V_GEN)$(PUBLICAN) rename --name Wayland \
+               --version "$(WAYLAND_VERSION_MAJOR).$(WAYLAND_VERSION_MINOR)" \
+               --config $(builddir)/publican-copy.cfg
+-      $(AM_V_GEN)$(PUBLICAN) build --lang en-US --format html,pdf \
++      $(AM_V_GEN)$(PUBLICAN) build --langs en-US --formats html \
+               --config $(builddir)/publican-copy.cfg
+       @touch Wayland
+--- wayland-1.0.0/doc/Wayland/en-US/Revision_History.xml.orig  1970-01-01 01:00:00.000000000 +0100
++++ wayland-1.0.0/doc/Wayland/en-US/Revision_History.xml       2012-11-02 17:51:40.432494222 +0100
+@@ -0,0 +1,26 @@
++<?xml version='1.0' encoding='utf-8' ?>
++<!DOCTYPE appendix PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN" "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
++<!ENTITY % BOOK_ENTITIES SYSTEM "Wayland.ent">
++%BOOK_ENTITIES;
++]>
++<appendix id="appe-Wayland-Revision_History">
++      <title>Revision History</title>
++      <simpara>
++              <revhistory>
++                      <revision>
++                              <revnumber>0-0</revnumber>
++                              <date>Thu Feb 23 2012</date>
++                              <author>
++                                      <firstname>Dude</firstname>
++                                      <surname>McPants</surname>
++                                      <email>Dude.McPants@example.com</email>
++                              </author>
++                              <revdescription>
++                                      <simplelist>
++                                              <member>Initial creation of book by publican</member>
++                                      </simplelist>
++                              </revdescription>
++                      </revision>
++              </revhistory>
++      </simpara>
++</appendix>
index c8300d1aac23ecd33c5f8d97bd954c4b3eaa128a..c3ad894f3e7eefcb1e7c9588519a84a9a59e88e4 100644 (file)
@@ -1,21 +1,29 @@
 #
 # Conditional build:
+%bcond_without apidocs         # don't build API documentation
 %bcond_without static_libs     # don't build static libraries
 #
 Summary:       Wayland - protocol for a compositor to talk to its clients
 Summary(pl.UTF-8):     Wayland - protokół między serwerem składającym a klientami
 Name:          wayland
-Version:       0.95.0
+Version:       1.0.0
 Release:       1
 License:       MIT
 Group:         Libraries
 Source0:       http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
-# Source0-md5: 23d6bcd500db9d1bb13e9b89722331dc
+# Source0-md5: d7449ebe3b62c8a956d77a52a19c73a6
+Patch0:                %{name}-publican.patch
 URL:           http://wayland.freedesktop.org/
+BuildRequires: autoconf >= 2.64
+BuildRequires: automake >= 1:1.11
+BuildRequires: doxygen
 BuildRequires: expat-devel
 BuildRequires: libffi-devel
+BuildRequires: libtool >= 2:2.2
+BuildRequires: libxslt-progs
 BuildRequires: pkgconfig
 BuildRequires: pkgconfig(libffi)
+%{?with_apidocs:BuildRequires: publican >= 3}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -60,10 +68,31 @@ Static Wayland libraries.
 %description static -l pl.UTF-8
 Statyczne biblioteki Wayland.
 
+%package apidocs
+Summary:       Wayland API and protocol documentation
+Summary(pl.UTF-8):     Dokumentacja API biblioteki oraz protokołu Wayland
+Group:         Documentation
+
+%description apidocs
+Wayland API and protocol documentation.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki oraz protokołu Wayland.
+
 %prep
 %setup -q
 
+# this file is required by publican 3.0; publican patch adds it in en-US dir
+test ! -f doc/Wayland/en_US/Revision_History.xml
+
+%patch0 -p1
+
 %build
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
        --disable-silent-rules \
        %{!?with_static_libs:--disable-static}
@@ -109,6 +138,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/wayland-server.pc
 %{_aclocaldir}/wayland-scanner.m4
 %{_aclocaldir}/wayland-scanner.mk
+%{_mandir}/man3/wl_display_connect.3*
+%{_mandir}/man3/wl_display_connect_to_fd*
 
 %if %{with static_libs}
 %files static
@@ -117,3 +148,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libwayland-cursor.a
 %{_libdir}/libwayland-server.a
 %endif
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/Wayland/Wayland/en-US/html/*
+%endif
This page took 0.540584 seconds and 4 git commands to generate.