]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- updated to 1.18.0
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.18.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://wayland.freedesktop.org/releases.html
14 Source0:        https://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
15 # Source0-md5:  23317697b6e3ff2e1ac8c5ba3ed57b65
16 Patch0:         %{name}-missing.patch
17 Patch1:         %{name}-man.patch
18 URL:            https://wayland.freedesktop.org/
19 BuildRequires:  autoconf >= 2.64
20 BuildRequires:  automake >= 1:1.11
21 BuildRequires:  expat-devel >= 1.95
22 BuildRequires:  libffi-devel >= 3
23 BuildRequires:  libtool >= 2:2.2
24 # for DTD valudation
25 BuildRequires:  libxml2-devel >= 2.0
26 BuildRequires:  pkgconfig
27 %if %{with apidocs}
28 BuildRequires:  docbook-style-xsl-nons
29 BuildRequires:  doxygen >= 1.6.0
30 BuildRequires:  graphviz >= 2.26.0
31 BuildRequires:  libxslt-progs
32 BuildRequires:  xmlto
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Wayland is a project to define a protocol for a compositor to talk to
38 its clients as well as a library implementation of the protocol. The
39 compositor can be a standalone display server running on Linux kernel
40 modesetting and evdev input devices, an X application, or a Wayland
41 client itself. The clients can be traditional applications, X servers
42 (rootless or fullscreen) or other display servers.
43
44 %description -l pl.UTF-8
45 Wayland to projekt definiujący protokół między serwerem składającym a
46 klientami, a także biblioteki implementujące ten protokół. Serwer
47 składający może być samodzielnym serwerem wyświetlającym działającym
48 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
49 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
50 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
51 wyświetlające.
52
53 %package devel
54 Summary:        Header files for Wayland libraries
55 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       libffi-devel
59
60 %description devel
61 Header files for Wayland libraries.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe bibliotek Wayland.
65
66 %package static
67 Summary:        Static Wayland libraries
68 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static Wayland libraries.
74
75 %description static -l pl.UTF-8
76 Statyczne biblioteki Wayland.
77
78 %package egl
79 Summary:        Wayland EGL library
80 Summary(pl.UTF-8):      Biblioteka Wayland EGL
81 Group:          Libraries
82 Obsoletes:      Mesa-libwayland-egl
83
84 %description egl
85 Wayland EGL library.
86
87 %description egl -l pl.UTF-8
88 Biblioteka Wayland EGL.
89
90 %package egl-devel
91 Summary:        Header files for Wayland EGL library
92 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Wayland EGL
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95 Requires:       %{name}-egl = %{version}-%{release}
96 Obsoletes:      Mesa-libwayland-egl-devel
97
98 %description egl-devel
99 Header files for Wayland EGL library.
100
101 %description egl-devel -l pl.UTF-8
102 Pliki nagłówkowe biblioteki Wayland EGL.
103
104 %package egl-static
105 Summary:        Static Wayland EGL library
106 Summary(pl.UTF-8):      Statyczna biblioteka Wayland EGL
107 Group:          Development/Libraries
108 Requires:       %{name}-egl-devel = %{version}-%{release}
109
110 %description egl-static
111 Static Wayland EGL library.
112
113 %description egl-static -l pl.UTF-8
114 Statyczna biblioteka Wayland EGL.
115
116 %package apidocs
117 Summary:        Wayland API and protocol documentation
118 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
119 Group:          Documentation
120 %if "%{_rpmversion}" >= "5"
121 BuildArch:      noarch
122 %endif
123
124 %description apidocs
125 Wayland API and protocol documentation.
126
127 %description apidocs -l pl.UTF-8
128 Dokumentacja API biblioteki oraz protokołu Wayland.
129
130 %prep
131 %setup -q
132 %patch0 -p1
133 %patch1 -p1
134
135 # force regeneration (.so link is broken, double man3/)
136 %{__rm} doc/man/*.3
137
138 %build
139 %{__libtoolize}
140 %{__aclocal} -I m4
141 %{__autoconf}
142 %{__autoheader}
143 %{__automake}
144 %configure \
145         %{!?with_apidocs:--disable-documentation} \
146         --disable-silent-rules \
147         %{?with_static_libs:--enable-static}
148
149 %{__make}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 %if %{with apidocs}
158 # referenced by some installed wl_*.3 man pages
159 cp -p doc/doxygen/man/man3/wayland-{client,client-core,server,server-core,util}.h.3 \
160         doc/doxygen/man/man3/wayland-{client,server,shm,util}.c.3 $RPM_BUILD_ROOT%{_mandir}/man3
161 %endif
162
163 # obsoleted by pkg-config
164 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
165 %if %{with apidocs}
166 # packaged as %doc in -devel
167 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
168 %endif
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files
177 %defattr(644,root,root,755)
178 %doc COPYING README TODO
179 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
181 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
183 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
185
186 %files devel
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/wayland-scanner
189 %attr(755,root,root) %{_libdir}/libwayland-client.so
190 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
191 %attr(755,root,root) %{_libdir}/libwayland-server.so
192 %{_includedir}/wayland-client*.h
193 %{_includedir}/wayland-cursor.h
194 %{_includedir}/wayland-server*.h
195 %{_includedir}/wayland-util.h
196 %{_includedir}/wayland-version.h
197 %dir %{_datadir}/wayland
198 %{_datadir}/wayland/wayland.dtd
199 %{_datadir}/wayland/wayland.xml
200 %{_datadir}/wayland/wayland-scanner.mk
201 %{_pkgconfigdir}/wayland-client.pc
202 %{_pkgconfigdir}/wayland-cursor.pc
203 %{_pkgconfigdir}/wayland-scanner.pc
204 %{_pkgconfigdir}/wayland-server.pc
205 %{_aclocaldir}/wayland-scanner.m4
206 %if %{with apidocs}
207 %{_mandir}/man3/wayland-*.c.3*
208 %{_mandir}/man3/wayland-*.h.3*
209 %{_mandir}/man3/wl_*.3*
210 %endif
211 # NOTE: temporarily here because they're used but not included in Mesa 18.1.x
212 # TODO: move to -egl-devel after transition to Mesa 18.2.x
213 %{_includedir}/wayland-egl.h
214 %{_includedir}/wayland-egl-core.h
215
216 %if %{with static_libs}
217 %files static
218 %defattr(644,root,root,755)
219 %{_libdir}/libwayland-client.a
220 %{_libdir}/libwayland-cursor.a
221 %{_libdir}/libwayland-server.a
222 %endif
223
224 %if %{with apidocs}
225 %files apidocs
226 %defattr(644,root,root,755)
227 %doc doc/publican/Wayland/en-US/html/*
228 %endif
229
230 %files egl
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*.*
233 %attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
234
235 %files egl-devel
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_libdir}/libwayland-egl.so
238 %{_includedir}/wayland-egl-backend.h
239 %{_pkgconfigdir}/wayland-egl.pc
240 %{_pkgconfigdir}/wayland-egl-backend.pc
241
242 %if %{with static_libs}
243 %files egl-static
244 %defattr(644,root,root,755)
245 %{_libdir}/libwayland-egl.a
246 %endif
This page took 0.14507 seconds and 4 git commands to generate.