]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- rm %{_docdir}/wayland no longer needed (no such directory)
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.0.6
10 Release:        2
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  936a2590aea69fa3c0cf234d54b9137c
15 Patch0:         %{name}-publican.patch
16 Patch1:         %{name}-man.patch
17 URL:            http://wayland.freedesktop.org/
18 BuildRequires:  autoconf >= 2.64
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  docbook-style-xsl
21 BuildRequires:  doxygen
22 BuildRequires:  expat-devel
23 BuildRequires:  libffi-devel
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  libxslt-progs
26 BuildRequires:  pkgconfig
27 BuildRequires:  pkgconfig(libffi)
28 %{?with_apidocs:BuildRequires:  publican >= 3}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Wayland is a project to define a protocol for a compositor to talk to
33 its clients as well as a library implementation of the protocol. The
34 compositor can be a standalone display server running on Linux kernel
35 modesetting and evdev input devices, an X application, or a Wayland
36 client itself. The clients can be traditional applications, X servers
37 (rootless or fullscreen) or other display servers.
38
39 %description -l pl.UTF-8
40 Wayland to projekt definiujący protokół między serwerem składającym a
41 klientami, a także biblioteki implementujące ten protokół. Serwer
42 składający może być samodzielnym serwerem wyświetlającym działającym
43 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
44 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
45 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
46 wyświetlające.
47
48 %package devel
49 Summary:        Header files for Wayland libraries
50 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       libffi-devel
54
55 %description devel
56 Header files for Wayland libraries.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe bibliotek Wayland.
60
61 %package static
62 Summary:        Static Wayland libraries
63 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static Wayland libraries.
69
70 %description static -l pl.UTF-8
71 Statyczne biblioteki Wayland.
72
73 %package apidocs
74 Summary:        Wayland API and protocol documentation
75 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
76 Group:          Documentation
77
78 %description apidocs
79 Wayland API and protocol documentation.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki oraz protokołu Wayland.
83
84 %prep
85 %setup -q
86
87 # this file is required by publican 3.0; publican patch adds it in en-US dir
88 test ! -f doc/Wayland/en_US/Revision_History.xml
89
90 %patch0 -p1
91 %patch1 -p1
92
93 # force regeneration (.so link is broken, double man3/)
94 %{__rm} doc/man/*.3
95
96 %build
97 %{__libtoolize}
98 %{__aclocal} -I m4
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         --disable-silent-rules \
104         %{!?with_static_libs:--disable-static}
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 # obsoleted by pkg-config
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc COPYING README TODO
126 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
128 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
130 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/wayland-scanner
136 %attr(755,root,root) %{_libdir}/libwayland-client.so
137 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
138 %attr(755,root,root) %{_libdir}/libwayland-server.so
139 %{_includedir}/wayland-*.h
140 %{_pkgconfigdir}/wayland-client.pc
141 %{_pkgconfigdir}/wayland-cursor.pc
142 %{_pkgconfigdir}/wayland-server.pc
143 %{_aclocaldir}/wayland-scanner.m4
144 %{_aclocaldir}/wayland-scanner.mk
145 %{_mandir}/man3/wl_display_connect.3*
146 %{_mandir}/man3/wl_display_connect_to_fd*
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libwayland-client.a
152 %{_libdir}/libwayland-cursor.a
153 %{_libdir}/libwayland-server.a
154 %endif
155
156 %if %{with apidocs}
157 %files apidocs
158 %defattr(644,root,root,755)
159 %doc doc/Wayland/Wayland/en-US/html/*
160 %endif
This page took 0.081249 seconds and 3 git commands to generate.