]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
up to 1.22.0
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.22.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://gitlab.freedesktop.org/wayland/wayland/-/releases/
14 Source0:        https://gitlab.freedesktop.org/wayland/wayland/-/releases/%{version}/downloads/%{name}-%{version}.tar.xz
15 # Source0-md5:  7410ab549e3928fce9381455b17b0803
16 URL:            https://wayland.freedesktop.org/
17 BuildRequires:  automake
18 BuildRequires:  expat-devel >= 1.95
19 BuildRequires:  libffi-devel >= 3
20 # for DTD valudation
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  meson >= 0.56.0
23 BuildRequires:  ninja
24 BuildRequires:  pkgconfig
25 %if %{with apidocs}
26 BuildRequires:  docbook-style-xsl-nons
27 BuildRequires:  doxygen >= 1.6.0
28 BuildRequires:  graphviz >= 2.26.0
29 BuildRequires:  libxslt-progs
30 BuildRequires:  rpm-build >= 4.6
31 BuildRequires:  rpmbuild(macros) >= 1.752
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xmlto
34 BuildRequires:  xz
35 %endif
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Wayland is a project to define a protocol for a compositor to talk to
40 its clients as well as a library implementation of the protocol. The
41 compositor can be a standalone display server running on Linux kernel
42 modesetting and evdev input devices, an X application, or a Wayland
43 client itself. The clients can be traditional applications, X servers
44 (rootless or fullscreen) or other display servers.
45
46 %description -l pl.UTF-8
47 Wayland to projekt definiujący protokół między serwerem składającym a
48 klientami, a także biblioteki implementujące ten protokół. Serwer
49 składający może być samodzielnym serwerem wyświetlającym działającym
50 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
51 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
52 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
53 wyświetlające.
54
55 %package devel
56 Summary:        Header files for Wayland libraries
57 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       libffi-devel
61
62 %description devel
63 Header files for Wayland libraries.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe bibliotek Wayland.
67
68 %package static
69 Summary:        Static Wayland libraries
70 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Wayland libraries.
76
77 %description static -l pl.UTF-8
78 Statyczne biblioteki Wayland.
79
80 %package egl
81 Summary:        Wayland EGL library
82 Summary(pl.UTF-8):      Biblioteka Wayland EGL
83 Group:          Libraries
84 Obsoletes:      Mesa-libwayland-egl < 18.2
85
86 %description egl
87 Wayland EGL library.
88
89 %description egl -l pl.UTF-8
90 Biblioteka Wayland EGL.
91
92 %package egl-devel
93 Summary:        Header files for Wayland EGL library
94 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Wayland EGL
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97 Requires:       %{name}-egl = %{version}-%{release}
98 Obsoletes:      Mesa-libwayland-egl-devel < 18.2
99
100 %description egl-devel
101 Header files for Wayland EGL library.
102
103 %description egl-devel -l pl.UTF-8
104 Pliki nagłówkowe biblioteki Wayland EGL.
105
106 %package egl-static
107 Summary:        Static Wayland EGL library
108 Summary(pl.UTF-8):      Statyczna biblioteka Wayland EGL
109 Group:          Development/Libraries
110 Requires:       %{name}-egl-devel = %{version}-%{release}
111
112 %description egl-static
113 Static Wayland EGL library.
114
115 %description egl-static -l pl.UTF-8
116 Statyczna biblioteka Wayland EGL.
117
118 %package apidocs
119 Summary:        Wayland API and protocol documentation
120 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
121 Group:          Documentation
122 BuildArch:      noarch
123
124 %description apidocs
125 Wayland API and protocol documentation.
126
127 %description apidocs -l pl.UTF-8
128 Dokumentacja API biblioteki oraz protokołu Wayland.
129
130 %prep
131 %setup -q
132
133 %build
134 %meson build \
135         %{!?with_apidocs:-Ddocumentation=false} \
136         %{!?with_static_libs:--default-library=shared}
137
138 %ninja_build -C build
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %ninja_install -C build
144
145 %if %{with apidocs}
146 # packaged as %doc in -devel
147 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
148 %endif
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %post   egl -p /sbin/ldconfig
157 %postun egl -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc COPYING CONTRIBUTING.md README.md
162 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
164 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
166 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/wayland-scanner
172 %attr(755,root,root) %{_libdir}/libwayland-client.so
173 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
174 %attr(755,root,root) %{_libdir}/libwayland-server.so
175 %{_includedir}/wayland-client*.h
176 %{_includedir}/wayland-cursor.h
177 %{_includedir}/wayland-server*.h
178 %{_includedir}/wayland-util.h
179 %{_includedir}/wayland-version.h
180 %dir %{_datadir}/wayland
181 %{_datadir}/wayland/wayland.dtd
182 %{_datadir}/wayland/wayland.xml
183 %{_datadir}/wayland/wayland-scanner.mk
184 %{_pkgconfigdir}/wayland-client.pc
185 %{_pkgconfigdir}/wayland-cursor.pc
186 %{_pkgconfigdir}/wayland-scanner.pc
187 %{_pkgconfigdir}/wayland-server.pc
188 %{_aclocaldir}/wayland-scanner.m4
189 %if %{with apidocs}
190 %{_mandir}/man3/wl_*.3*
191 %endif
192 # NOTE: temporarily here because they're used but not included in Mesa 18.1.x
193 # TODO: move to -egl-devel after transition to Mesa 18.2.x
194 %{_includedir}/wayland-egl.h
195 %{_includedir}/wayland-egl-core.h
196
197 %if %{with static_libs}
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/libwayland-client.a
201 %{_libdir}/libwayland-cursor.a
202 %{_libdir}/libwayland-server.a
203 %endif
204
205 %if %{with apidocs}
206 %files apidocs
207 %defattr(644,root,root,755)
208 %doc build/doc/publican/html/* doc/publican/sources/{css,images}
209 %endif
210
211 %files egl
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*.*
214 %attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
215
216 %files egl-devel
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/libwayland-egl.so
219 %{_includedir}/wayland-egl-backend.h
220 %{_pkgconfigdir}/wayland-egl.pc
221 %{_pkgconfigdir}/wayland-egl-backend.pc
222
223 %if %{with static_libs}
224 %files egl-static
225 %defattr(644,root,root,755)
226 %{_libdir}/libwayland-egl.a
227 %endif
This page took 0.161162 seconds and 3 git commands to generate.