]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
87d1aa843992435a73fc7cf412692e56094002b8
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.19.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://wayland.freedesktop.org/releases.html
14 Source0:        https://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
15 # Source0-md5:  5d59ac3d8a8f4e42de2ceb8bb19dfca9
16 URL:            https://wayland.freedesktop.org/
17 BuildRequires:  expat-devel >= 1.95
18 BuildRequires:  libffi-devel >= 3
19 # for DTD valudation
20 BuildRequires:  libxml2-devel >= 2.0
21 BuildRequires:  meson >= 0.52.1
22 BuildRequires:  ninja
23 BuildRequires:  pkgconfig
24 %if %{with apidocs}
25 BuildRequires:  docbook-style-xsl-nons
26 BuildRequires:  doxygen >= 1.6.0
27 BuildRequires:  graphviz >= 2.26.0
28 BuildRequires:  libxslt-progs
29 BuildRequires:  rpmbuild(macros) >= 1.736
30 BuildRequires:  xmlto
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Wayland is a project to define a protocol for a compositor to talk to
36 its clients as well as a library implementation of the protocol. The
37 compositor can be a standalone display server running on Linux kernel
38 modesetting and evdev input devices, an X application, or a Wayland
39 client itself. The clients can be traditional applications, X servers
40 (rootless or fullscreen) or other display servers.
41
42 %description -l pl.UTF-8
43 Wayland to projekt definiujący protokół między serwerem składającym a
44 klientami, a także biblioteki implementujące ten protokół. Serwer
45 składający może być samodzielnym serwerem wyświetlającym działającym
46 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
47 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
48 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
49 wyświetlające.
50
51 %package devel
52 Summary:        Header files for Wayland libraries
53 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       libffi-devel
57
58 %description devel
59 Header files for Wayland libraries.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe bibliotek Wayland.
63
64 %package static
65 Summary:        Static Wayland libraries
66 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static Wayland libraries.
72
73 %description static -l pl.UTF-8
74 Statyczne biblioteki Wayland.
75
76 %package egl
77 Summary:        Wayland EGL library
78 Summary(pl.UTF-8):      Biblioteka Wayland EGL
79 Group:          Libraries
80 Obsoletes:      Mesa-libwayland-egl
81
82 %description egl
83 Wayland EGL library.
84
85 %description egl -l pl.UTF-8
86 Biblioteka Wayland EGL.
87
88 %package egl-devel
89 Summary:        Header files for Wayland EGL library
90 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Wayland EGL
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93 Requires:       %{name}-egl = %{version}-%{release}
94 Obsoletes:      Mesa-libwayland-egl-devel
95
96 %description egl-devel
97 Header files for Wayland EGL library.
98
99 %description egl-devel -l pl.UTF-8
100 Pliki nagłówkowe biblioteki Wayland EGL.
101
102 %package egl-static
103 Summary:        Static Wayland EGL library
104 Summary(pl.UTF-8):      Statyczna biblioteka Wayland EGL
105 Group:          Development/Libraries
106 Requires:       %{name}-egl-devel = %{version}-%{release}
107
108 %description egl-static
109 Static Wayland EGL library.
110
111 %description egl-static -l pl.UTF-8
112 Statyczna biblioteka Wayland EGL.
113
114 %package apidocs
115 Summary:        Wayland API and protocol documentation
116 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
117 Group:          Documentation
118 %if "%{_rpmversion}" >= "5"
119 BuildArch:      noarch
120 %endif
121
122 %description apidocs
123 Wayland API and protocol documentation.
124
125 %description apidocs -l pl.UTF-8
126 Dokumentacja API biblioteki oraz protokołu Wayland.
127
128 %prep
129 %setup -q
130
131 %build
132 %meson build \
133         %{!?with_apidocs:-Ddocumentation=false} \
134         %{!?with_static_libs:--default-library=shared}
135
136 %ninja_build -C build
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %ninja_install -C build
142
143 %if %{with apidocs}
144 # packaged as %doc in -devel
145 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
146 %endif
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc COPYING CONTRIBUTING.md README
157 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
159 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
161 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/wayland-scanner
167 %attr(755,root,root) %{_libdir}/libwayland-client.so
168 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
169 %attr(755,root,root) %{_libdir}/libwayland-server.so
170 %{_includedir}/wayland-client*.h
171 %{_includedir}/wayland-cursor.h
172 %{_includedir}/wayland-server*.h
173 %{_includedir}/wayland-util.h
174 %{_includedir}/wayland-version.h
175 %dir %{_datadir}/wayland
176 %{_datadir}/wayland/wayland.dtd
177 %{_datadir}/wayland/wayland.xml
178 %{_datadir}/wayland/wayland-scanner.mk
179 %{_pkgconfigdir}/wayland-client.pc
180 %{_pkgconfigdir}/wayland-cursor.pc
181 %{_pkgconfigdir}/wayland-scanner.pc
182 %{_pkgconfigdir}/wayland-server.pc
183 %{_aclocaldir}/wayland-scanner.m4
184 %if %{with apidocs}
185 %{_mandir}/man3/wl_*.3*
186 %endif
187 # NOTE: temporarily here because they're used but not included in Mesa 18.1.x
188 # TODO: move to -egl-devel after transition to Mesa 18.2.x
189 %{_includedir}/wayland-egl.h
190 %{_includedir}/wayland-egl-core.h
191
192 %if %{with static_libs}
193 %files static
194 %defattr(644,root,root,755)
195 %{_libdir}/libwayland-client.a
196 %{_libdir}/libwayland-cursor.a
197 %{_libdir}/libwayland-server.a
198 %endif
199
200 %if %{with apidocs}
201 %files apidocs
202 %defattr(644,root,root,755)
203 %doc build/doc/publican/html/* doc/publican/sources/{css,images}
204 %endif
205
206 %files egl
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*.*
209 %attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
210
211 %files egl-devel
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_libdir}/libwayland-egl.so
214 %{_includedir}/wayland-egl-backend.h
215 %{_pkgconfigdir}/wayland-egl.pc
216 %{_pkgconfigdir}/wayland-egl-backend.pc
217
218 %if %{with static_libs}
219 %files egl-static
220 %defattr(644,root,root,755)
221 %{_libdir}/libwayland-egl.a
222 %endif
This page took 0.100964 seconds and 3 git commands to generate.