]> git.pld-linux.org Git - packages/wavpack.git/blob - wavpack.spec
up to 5.7.0
[packages/wavpack.git] / wavpack.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs
4
5 Summary:        Open audio compression codec
6 Summary(pl.UTF-8):      Otwarty kodek kompresji dźwięku
7 Name:           wavpack
8 Version:        5.7.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://www.wavpack.com/downloads.html
13 Source0:        https://www.wavpack.com/%{name}-%{version}.tar.xz
14 # Source0-md5:  92f6d76e6e3d620aff296983792eab9f
15 URL:            https://www.wavpack.com/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1:1.15
18 BuildRequires:  gettext-tools
19 BuildRequires:  libtool >= 2:2
20 BuildRequires:  rpm-build >= 4.6
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       %{name}-libs = %{version}-%{release}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 WavPack is a completely open audio compression format providing
28 lossless, high-quality lossy, and a unique hybrid compression mode.
29
30 Although the technology is loosely based on previous versions of
31 WavPack, the new version 4 format has been designed from the ground up
32 to offer unparalleled performance and functionality. In the default
33 lossless mode WavPack acts just like a WinZip compressor for audio
34 files. However, unlike MP3 or WMA encoding which can affect the sound
35 quality, not a single bit of the original information is lost, so
36 there's no chance of degradation. This makes lossless mode ideal for
37 archiving audio material or any other situation where quality is
38 paramount. The compression ratio depends on the source material, but
39 generally is between 30% and 70%.
40
41 The hybrid mode provides all the advantages of lossless compression
42 with an additional bonus. Instead of creating a single file, this mode
43 creates both a relatively small, high-quality lossy file that can be
44 used all by itself, and a "correction" file that (when combined with
45 the lossy file) provides full lossless restoration. For some users
46 this means never having to choose between lossless and lossy
47 compression!
48
49 %description -l pl.UTF-8
50 WavPack to całkowicie otwarty format kompresji dźwięku dostarczający
51 tryby kompresji: bezstratny, stratny wysokiej jakości oraz unikalny
52 hybrydowy.
53
54 Chociaż technologia jest luźno oparta na poprzednich wersjach
55 WavPacka, format nowej wersji 4 został zaprojektowany od nowa, aby
56 zaoferować niezrównaną wydajność i funkcjonalność. W domyślnym trybie
57 bezstratnym WavPack zachowuje się tak jak kompresor WinZip dla plików
58 dźwiękowych. Jednak w przeciwieństwie do kodowań MP3 czy WMA, które
59 wpływają na jakość dźwięku, żaden bit oryginalnej informacji nie jest
60 tracony, więc nie ma żadnych szans na degradację. Czyni to tryb
61 bezstratny idealnym do archiwizowania materiałów dźwiękowych oraz w
62 innych sytuacjach, gdzie jakość jest najważniejsza. Współczynnik
63 kompresji zależy od materiału źródłowego, ale zwykle jest pomiędzy
64 30% a 70%.
65
66 Tryb hybrydowy udostępnia wszystkie zalety kompresji bezstratnej z
67 dodatkowym ulepszeniem. Zamiast tworzenia pojedynczego pliku tryb ten
68 tworzy zarówno stosunkowo mały, wysokiej jakości plik stratny, który
69 może być używany jako taki oraz plik "poprawek", który (w połączeniu z
70 plikiem stratnym) odtwarza pełną jakość bez strat. Dla niektórych
71 użytkowników oznacza to, że nie muszą wybierać pomiędzy kompresją
72 bezstratną a stratną.
73
74 %package libs
75 Summary:        Wavpack library
76 Summary(pl.UTF-8):      Biblioteka Wavpack
77 Group:          Libraries
78 Requires:       %{name}-libs = %{version}-%{release}
79
80 %description libs
81 Wavpack library.
82
83 %description libs -l pl.UTF-8
84 Biblioteka Wavpack.
85
86 %package devel
87 Summary:        Header files for Wavpack
88 Summary(pl.UTF-8):      Pliki nagłówkowe Wavpack
89 Group:          Development/Libraries
90 Requires:       %{name}-libs = %{version}-%{release}
91
92 %description devel
93 Header files for Wavpack.
94
95 %description devel -l pl.UTF-8
96 Pliki nagłówkowe biblioteki Wavpack.
97
98 %package static
99 Summary:        Static Wavpack library
100 Summary(pl.UTF-8):      Statyczna biblioteka Wavpack
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103
104 %description static
105 Static Wavpack library.
106
107 %description static -l pl.UTF-8
108 Statyczna biblioteka Wavpack.
109
110 %package apidocs
111 Summary:        API documentation for Wavpack library
112 Summary(pl.UTF-8):      Dokumentacja API biblioteki Wavpack
113 Group:          Documentation
114 BuildArch:      noarch
115
116 %description apidocs
117 API documentation for Wavpack library.
118
119 %description apidocs -l pl.UTF-8
120 Dokumentacja API biblioteki Wavpack.
121
122 %prep
123 %setup -q
124
125 %build
126 %{__libtoolize}
127 %{__aclocal}
128 %{__autoconf}
129 %{__automake}
130 %configure \
131         --enable-legacy \
132         %{?with_static_libs:--enable-static}
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 # packaged as %doc
142 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wavpack
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   libs -p /sbin/ldconfig
148 %postun libs -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/wavpack
153 %attr(755,root,root) %{_bindir}/wvgain
154 %attr(755,root,root) %{_bindir}/wvtag
155 %attr(755,root,root) %{_bindir}/wvunpack
156 %{_mandir}/man1/wavpack.1*
157 %{_mandir}/man1/wvgain.1*
158 %{_mandir}/man1/wvtag.1*
159 %{_mandir}/man1/wvunpack.1*
160
161 %files libs
162 %defattr(644,root,root,755)
163 %doc AUTHORS COPYING ChangeLog README.md
164 %attr(755,root,root) %{_libdir}/libwavpack.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libwavpack.so.1
166
167 %files devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libwavpack.so
170 %{_libdir}/libwavpack.la
171 %{_includedir}/wavpack
172 %{_pkgconfigdir}/wavpack.pc
173
174 %if %{with static_libs}
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/libwavpack.a
178 %endif
179
180 %files apidocs
181 %defattr(644,root,root,755)
182 %doc doc/{WavPack*.pdf,wavpack_doc.html,style.css}
This page took 0.107307 seconds and 4 git commands to generate.